Errore installazione Spotify 1.0.77.336-2

Segnalazioni di pacchetti utili, richieste di creazione pacchetti e supporto tecnico
Rispondi
Avatar utente
morii
Newbie
Messaggi: 15
Iscritto il: 23 aprile 2012, 22:07

Errore installazione Spotify 1.0.77.336-2

Messaggio da morii » 31 marzo 2018, 2:36

Visto che ancora non viene aggiornato Spotify, su Aur ancora c'è la versione " 1.0.77.336-2 " e non si riesce ad installarla, posto il PKGBUIld già modificato per la versione 1.0.77.338 cosi da poterlo installare subito ed aiutare persone come me che non sono maghi del computer.. :D

Codice: Seleziona tutto

# Maintainer: Ashley Whetter <(firstname) @ awhetter.co.uk>
# Contributor: Eothred <yngve.levinsen@gmail.com>

pkgname=spotify
pkgver=1.0.77.338
_i386_pkgver=1.0.72.117
_anotherpkgver=.g758ebd78
_i386_anotherpkgver=.g6bd7cc73
_amd64_pkgrel=41
_i386_pkgrel=35
pkgrel=2
pkgdesc="A proprietary music streaming service"
arch=('x86_64' 'i686')
license=('custom:"Copyright (c) 2006-2010 Spotify Ltd"')
url="http://www.spotify.com"
#options=('!strip' '!upx')

source=('spotify'
'spotify.protocol'
'LICENSE')
sha256sums=('989920e9360cadc1a8103b8c04acf0c87cb7911eb9a09dddb0cf4708d6249d34'
            'af54f3b90cac46fa100b3f919a9225d10d847617d24aa9af3d832e7689f482c3'
            '4e8bea31ca27e16cac9c9dcd8f6ec27e1f82b45de86d6fee7a1e77e23f884b92')
sha256sums_x86_64=('0698d2dbda43f2866d2a6f6ed9816bf8022aa8cf67d0dba347f486410093e1a4')
sha256sums_i686=('f5ac29e8374901ce7401825d13471c03bcf6ec8106f8c210c710b0a8d7b22ca9')

source_x86_64=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.77.338.g758ebd78-41_amd64.deb'")

source_i686=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${_i386_pkgver}${_i386_anotherpkgver}-${_i386_pkgrel}_i386.deb")

depends=("alsa-lib>=1.0.14" "gconf" "gtk2" "glib2" "nss" "libsystemd" "libxtst" "libx11" "libxss" "openssl-1.0" "desktop-file-utils" "rtmpdump")
depends_x86_64=('libcurl-gnutls')
depends_i686=('libcurl-compat')
optdepends=('ffmpeg-compat-54: Adds support for playback of local files'
'zenity: Adds support for importing local files'
'libnotify: Desktop notifications'
)

package() {
    cd "${srcdir}"

    tar -xzf data.tar.gz -C "${pkgdir}"

    install -D "${pkgdir}"/usr/share/spotify/spotify.desktop "${pkgdir}"/usr/share/applications/spotify.desktop
    install -D "${pkgdir}"/usr/share/spotify/icons/spotify-linux-512.png "${pkgdir}"/usr/share/pixmaps/spotify-client.png

    for size in 22 24 32 48 64 128 256 512; do
        install -D "${pkgdir}/usr/share/spotify/icons/spotify-linux-$size.png" \
            "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/spotify.png"
    done

    chmod -R go-w "${pkgdir}"/usr

    # Bin Script
    rm "${pkgdir}"/usr/bin/spotify
    install -Dm755 "${srcdir}/spotify" "${pkgdir}/usr/bin/spotify"

    # Copy protocol file for KDE
    install -Dm644 "${srcdir}/spotify.protocol" "${pkgdir}/usr/share/kservices5/spotify.protocol"

    # License
    install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
OS: ArchLabs-x86_64
Description: Archlabs i3wm, bspwm, awesome, openbox, xfce
Release: 2018-03
Codename: Minimo
Immagine

Avatar utente
TheSaint
Robin Hood
Messaggi: 7937
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Errore installazione Spotify 1.0.77.336-2

Messaggio da TheSaint » 31 marzo 2018, 7:16

È da dire che l' architettura i686 è stata abbandonata da Archlinux.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Rispondi