[Risolto] Come disabilitare Plymouth

Nuovo di Arch Linux? Nessun problema, fai qui le tue domande
Rispondi
JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

[Risolto] Come disabilitare Plymouth

Messaggio da JacopoMolteni » 9 marzo 2015, 18:53

Come faccio a disabilitare il Plymout? Ho seguito la guida della wiki per installarlo, ma adesso anche se lo ho rimosso e ho disabilitato tutti i cambiamenti continua a non farmi vedere la sfilza di messaggi che stampa a schermo di solito e lascia una stampa con "starting version 288"... Ho già modificato il grub e ricostruito la configurazione. Come posso fare?
Ultima modifica di JacopoMolteni il 18 marzo 2015, 17:12, modificato 1 volta in totale.
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7918
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Come disabilitare Plymouth

Messaggio da TheSaint » 10 marzo 2015, 12:46

Visto wiki ?
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Come disabilitare Plymouth

Messaggio da JacopoMolteni » 10 marzo 2015, 15:05

Sulla wiki non dicono come disabilitarlo.
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Come disabilitare Plymouth

Messaggio da JacopoMolteni » 10 marzo 2015, 17:10

Da quando l'ho disinstallato ho perfino notato un rallentamento nell'avvio del sistema... Come è possibile?
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7918
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Come disabilitare Plymouth

Messaggio da TheSaint » 11 marzo 2015, 1:11

Vedi cosa dice il journal

Codice: Seleziona tutto

sudo journalctl -b

Attento che è abbastanza lungo, se lo vuoi pubblicare meglio lo indirizzi su file hosting.
Altrimenti proviamo a grepparlo

Codice: Seleziona tutto

sudo journalctl -b |grep -i error
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Come disabilitare Plymouth

Messaggio da JacopoMolteni » 11 marzo 2015, 15:40

Codice: Seleziona tutto

mar 11 15:35:48 archlaptop pulseaudio[927]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service files
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7918
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Come disabilitare Plymouth

Messaggio da TheSaint » 11 marzo 2015, 20:45

Prova un

Codice: Seleziona tutto

systemd-analyze blame

E magari la man page
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Come disabilitare Plymouth

Messaggio da JacopoMolteni » 12 marzo 2015, 15:13

Ecco l'output, non si parla di playmouth

Codice: Seleziona tutto

]$ systemd-analyze blame
         18.987s netctl@rete_wireless.service
         16.613s man-db.service
          6.482s systemd-journald.service
          4.701s NetworkManager.service
          2.496s accounts-daemon.service
          2.315s lightdm.service
          1.757s systemd-journal-flush.service
          1.303s logrotate.service
          1.240s systemd-logind.service
          1.228s systemd-user-sessions.service
          1.224s systemd-rfkill@rfkill1.service
          1.187s udisks2.service
          1.060s polkit.service
          1.027s systemd-binfmt.service
          1.020s systemd-vconsole-setup.service
          1.003s systemd-sysctl.service
           838ms shadow.service
           784ms dev-mqueue.mount
           743ms systemd-udev-trigger.service
         18.987s netctl@rete_wireless.service
         16.613s man-db.service
          6.482s systemd-journald.service
          4.701s NetworkManager.service
          2.496s accounts-daemon.service
          2.315s lightdm.service
          1.757s systemd-journal-flush.service
          1.303s logrotate.service
          1.240s systemd-logind.service
          1.228s systemd-user-sessions.service
          1.224s systemd-rfkill@rfkill1.service
          1.187s udisks2.service
          1.060s polkit.service
          1.027s systemd-binfmt.service
          1.020s systemd-vconsole-setup.service
          1.003s systemd-sysctl.service
           838ms shadow.service
           784ms dev-mqueue.mount
           743ms systemd-udev-trigger.service
           723ms tmp.mount
           723ms sys-kernel-config.mount
           696ms kmod-static-nodes.service
           696ms systemd-remount-fs.service
           694ms dev-hugepages.mount
           694ms sys-kernel-debug.mount
           687ms systemd-udevd.service
           571ms upower.service
           456ms systemd-tmpfiles-setup-dev.service
           316ms systemd-backlight@backlight:acpi_video0.service
           303ms systemd-rfkill@rfkill0.service
           282ms user@620.service
           242ms systemd-random-seed.service
           217ms systemd-rfkill@rfkill2.service
           153ms proc-sys-fs-binfmt_misc.mount
            85ms rtkit-daemon.service
            81ms dev-disk-by\x2duuid-fefb158c\x2df45c\x2d41d3\x2dafb4\x2d714b73a
            64ms systemd-tmpfiles-setup.service
            43ms user@1000.service
            30ms systemd-update-utmp.service
             4ms alsa-restore.service
             4ms wpa_supplicant.service
             1ms sys-fs-fuse-connections.mount
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7918
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Come disabilitare Plymouth

Messaggio da TheSaint » 12 marzo 2015, 18:29

Il peggiore è netctl, come vedi.
Però non capisco che ce lo tieni a fare se hai NetworkManager. Sono in conflitto. Direi che dovresti dare

Codice: Seleziona tutto

# netctl disable rete_wireless
.
Poi vediamo cosa ti risulta.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Come disabilitare Plymouth

Messaggio da JacopoMolteni » 12 marzo 2015, 18:36

Mi restituisce:

Codice: Seleziona tutto

No regular unit file found for profile 'rete_wireless'
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7918
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Come disabilitare Plymouth

Messaggio da TheSaint » 13 marzo 2015, 0:46

Avresti potuto inquisire qualcosa in più in merito.
Vedi se hai

Codice: Seleziona tutto

# systemctl is-active netctl ### quindi disabilita con
# systemctl disable netctl
##### oppure
# systemctl is-active netctl-auto ### quindi disabilita con
# systemctl disable netctl-auto
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Come disabilitare Plymouth

Messaggio da JacopoMolteni » 13 marzo 2015, 15:30

Con il primo comando mi dice che è disabilitato, il secondo mi dice unknown
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7918
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Come disabilitare Plymouth

Messaggio da TheSaint » 14 marzo 2015, 1:19

Rimuovi il pacchetto ?

Codice: Seleziona tutto

$ pacman -Qs netctl
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Come disabilitare Plymouth

Messaggio da JacopoMolteni » 15 marzo 2015, 12:52

Rimosso, il tempo di boot si è praticamente dimezzato XD

Comunque, per il problema di plymouth?
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7918
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Come disabilitare Plymouth

Messaggio da TheSaint » 16 marzo 2015, 0:46

Stessa procedura, cerca cosa implica tale comportamento.
Magari cerca quale pacchetto ha come dipendenza (opzionale) il plymouth.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Come disabilitare Plymouth

Messaggio da JacopoMolteni » 16 marzo 2015, 13:59

Ho usato il comando per disinstallare le dipendenze non più richieste sudo pacman -Rs $(pacman -Qtdq), non dovrebbe bastare?
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7918
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Come disabilitare Plymouth

Messaggio da TheSaint » 16 marzo 2015, 15:52

Vedi col journal o con analyze cosa ti risulta.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Come disabilitare Plymouth

Messaggio da JacopoMolteni » 16 marzo 2015, 17:22

L'output è enorme, con che parametri posso filtrarlo?
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7918
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Come disabilitare Plymouth

Messaggio da TheSaint » 17 marzo 2015, 4:31

Codice: Seleziona tutto

$ man journalctl
o wiki o sul forum oppure motori di ricerca ?
Nessuno ti da la risposta ?
Eppure al momento che accendi il computer puoi avere tutte le informazioni che cerchi, forse anche troppe.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Come disabilitare Plymouth

Messaggio da JacopoMolteni » 17 marzo 2015, 13:19

Codice: Seleziona tutto

-- Logs begin at mer 2015-02-11 13:38:20 CET. --
mar 17 13:02:45 archlaptop sudo[3156]: jacopo : TTY=pts/1 ; PWD=/home/jacopo ; USER=root ; COMMAND=/usr/bin/pacman --color auto -Sy
mar 17 13:02:45 archlaptop sudo[3156]: pam_unix(sudo:session): session opened for user root by jacopo(uid=0)
mar 17 13:02:54 archlaptop sudo[3156]: pam_unix(sudo:session): session closed for user root
mar 17 13:03:00 archlaptop sudo[3273]: jacopo : TTY=pts/1 ; PWD=/home/jacopo ; USER=root ; COMMAND=list /usr/bin/pacman --color auto -S -u
mar 17 13:03:00 archlaptop sudo[3274]: jacopo : TTY=pts/1 ; PWD=/home/jacopo ; USER=root ; COMMAND=/usr/bin/pacman --color auto -S -u
mar 17 13:03:00 archlaptop sudo[3274]: pam_unix(sudo:session): session opened for user root by jacopo(uid=0)
mar 17 13:03:10 archlaptop sudo[3274]: pam_unix(sudo:session): session closed for user root
mar 17 13:18:28 archlaptop org.freedesktop.thumbnails.Cache1[2248]: (tumblerd:4033): tumbler-WARNING **: Failed to load plugin "tumbler-raw-thumbnailer.so": libopenrawgnome.so.1: cannot open shared object file: No such file or directory
mar 17 13:18:28 archlaptop org.freedesktop.thumbnails.Cache1[2248]: (tumblerd:4033): tumbler-WARNING **: Failed to load plugin "tumbler-odf-thumbnailer.so": libgsf-1.so.114: cannot open shared object file: No such file or directory
mar 17 13:18:28 archlaptop org.freedesktop.thumbnails.Cache1[2248]: (tumblerd:4033): tumbler-WARNING **: Failed to load plugin "tumbler-ffmpeg-thumbnailer.so": libffmpegthumbnailer.so.4: cannot open shared object file: No such file or directory
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7918
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Come disabilitare Plymouth

Messaggio da TheSaint » 17 marzo 2015, 15:21

Non c'è plymouth. Forse un piccolo problema con tumbler.
Mettiamo [Risolto] ?
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Come disabilitare Plymouth

Messaggio da JacopoMolteni » 17 marzo 2015, 18:22

Il fatto è che io volevo vedere all'avvio del sistema i messaggi che vengono stampati a schermo prima dell'avio del log in manager
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7918
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Come disabilitare Plymouth

Messaggio da TheSaint » 18 marzo 2015, 1:08

Togli il quiet dalla linea del kernel, nella configurazione del boot loader.
Durante l' avvio se vuoi vedere a lungo premi CTRL+S (XOFF) per sospendere il processo e CTRL+Q (XON) per riprendere.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: [Risolto] Come disabilitare Plymouth

Messaggio da JacopoMolteni » 18 marzo 2015, 17:13

Problema risolto, grazie mille per l'aiuto :)
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

Rispondi