[Risolto]Errore Virtualbox - Manjaro Linux

Tutto ciò che altrimenti sarebbe OT
Rispondi
Avatar utente
-Killer-Psicotico-
Novello Arciere
Messaggi: 29
Iscritto il: 2 settembre 2014, 18:13
Architettura: x86 (32Bit)
Località: Savignano sul Panaro, Modena

[Risolto]Errore Virtualbox - Manjaro Linux

Messaggio da -Killer-Psicotico- » 12 settembre 2014, 13:08

Ciao a tutti :lol:
quando apro virtualbox da terminale mi da questo errore:

Codice: Seleziona tutto

WARNING: The vboxdrv kernel module is not loaded. Either there is no module
             available for the current kernel (3.12.27-1-MANJARO) or it failed to
             load. Please reinstall the kernel module virtualbox-host-modules or
             if you don't use our stock kernel compile the modules with

               sudo dkms autoinstall

             You will not be able to start VMs until this problem is fixed.
Ho provato pure a dare il comando in questione, ma mi da

Codice: Seleziona tutto

Error! echo
    Your kernel headers for kernel 3.12.27-1-MANJARO cannot be found at
    /usr/lib/modules/3.12.27-1-MANJARO/build or /usr/lib/modules/3.12.27-1-MANJARO/source.
so che si devono avviare i kernel prima di avviare virtualbox, ho seguito diverse guide pure quelle della wiki https://wiki.archlinux.org/index.php/Vi ... VirtualBox
ma gia al secondo passaggio mi da

Codice: Seleziona tutto

[enriklapi1015@paperoassassino ~]$ vboxbuild
bash: vboxbuild: comando non trovato
Grazie a tutti! :mrgreen:
Ps= chi e l'amministratore?
Ultima modifica di -Killer-Psicotico- il 12 settembre 2014, 15:52, modificato 1 volta in totale.

Avatar utente
ambro
Robin Hood
Messaggi: 1933
Iscritto il: 27 agosto 2009, 21:37
Località: Verona

Re: Errore Virtualbox - Manjaro Linux

Messaggio da ambro » 12 settembre 2014, 13:47

Dopo l'aggiornamento di virtualbox devi reinstallare i moduli nel kernel.
Prova a dare

Codice: Seleziona tutto

dkms install vboxhost/$(pacman -Q virtualbox-bin|awk {'print $2'}|sed 's/\-.\+//') -k $(uname -rm|sed 's/\ /\//')
Comunque ne parlano qui
PC: Amd FX-6100-Nvidia GT630-SSD- 64bit - kernel 4.3-ck - KDE Plasma 5
Mediacenter: Asrock Q2900 Itx - VGA Intel - 64bit - kernel 4.3-ck - lxde - Kodi - isengard
Netbook: Asus eeepc1001 - i686 - kernel 4.3 - lxde

Avatar utente
-Killer-Psicotico-
Novello Arciere
Messaggi: 29
Iscritto il: 2 settembre 2014, 18:13
Architettura: x86 (32Bit)
Località: Savignano sul Panaro, Modena

Re: Errore Virtualbox - Manjaro Linux

Messaggio da -Killer-Psicotico- » 12 settembre 2014, 13:54

mmm...

Codice: Seleziona tutto

[enriklapi1015@paperoassassino ~]$ dkms install vboxhost/$(pacman -Q virtualbox-bin|awk {'print $2'}|sed 's/\-.\+//') -k $(uname -rm|sed 's/\ /\//')
errore: impossibile trovare il pacchetto 'virtualbox-bin'
Error! You must be root to use this command.
[enriklapi1015@paperoassassino ~]$ sudo dkms install vboxhost/$(pacman -Q virtualbox-bin|awk {'print $2'}|sed 's/\-.\+//') -k $(uname -rm|sed 's/\ /\//')
errore: impossibile trovare il pacchetto 'virtualbox-bin'
Error! Invalid number of arguments passed.
Usage: add <module>/<module-version> or
       add -m <module>/<module-version> or
       add -m <module> -v <module-version>
:cry:
Ora vedo un po la wiki :|
dimenticavo...

Avatar utente
ambro
Robin Hood
Messaggi: 1933
Iscritto il: 27 agosto 2009, 21:37
Località: Verona

Re: Errore Virtualbox - Manjaro Linux

Messaggio da ambro » 12 settembre 2014, 13:58

Io ho un altro tipo di virtualbox installato
dai

Codice: Seleziona tutto

dkms install vboxhost/$(pacman -Q virtualbox|awk {'print $2'}|sed 's/\-.\+//') -k $(uname -rm|sed 's/\ /\//')
ti avevo incollato il comado che lancio io anziché quello di default della wiki

Che kernel usi?
PC: Amd FX-6100-Nvidia GT630-SSD- 64bit - kernel 4.3-ck - KDE Plasma 5
Mediacenter: Asrock Q2900 Itx - VGA Intel - 64bit - kernel 4.3-ck - lxde - Kodi - isengard
Netbook: Asus eeepc1001 - i686 - kernel 4.3 - lxde

Avatar utente
-Killer-Psicotico-
Novello Arciere
Messaggi: 29
Iscritto il: 2 settembre 2014, 18:13
Architettura: x86 (32Bit)
Località: Savignano sul Panaro, Modena

Re: Errore Virtualbox - Manjaro Linux

Messaggio da -Killer-Psicotico- » 12 settembre 2014, 14:01

Codice: Seleziona tutto

[enriklapi1015@paperoassassino ~]$ sudo dkms install vboxhost/$(pacman -Q virtualbox|awk {'print $2'}|sed 's/\-.\+//') -k $(uname -rm|sed 's/\ /\//')
Error! echo
Your kernel headers for kernel 3.12.27-1-MANJARO cannot be found at
/usr/lib/modules/3.12.27-1-MANJARO/build or /usr/lib/modules/3.12.27-1-MANJARO/source.
penso che sia un problema di versione :cry:

Avatar utente
ambro
Robin Hood
Messaggi: 1933
Iscritto il: 27 agosto 2009, 21:37
Località: Verona

Re: Errore Virtualbox - Manjaro Linux

Messaggio da ambro » 12 settembre 2014, 14:07

ok io non uso Manjaro comunque il tuo problema è che non hai gli header installati
Nei tuoi repo devi installare un pacchetto che si dovrebbe chiamare

Codice: Seleziona tutto

linux....-manjaro-headers
Prova a postare

Codice: Seleziona tutto

pacman -Ss headers
PC: Amd FX-6100-Nvidia GT630-SSD- 64bit - kernel 4.3-ck - KDE Plasma 5
Mediacenter: Asrock Q2900 Itx - VGA Intel - 64bit - kernel 4.3-ck - lxde - Kodi - isengard
Netbook: Asus eeepc1001 - i686 - kernel 4.3 - lxde

Avatar utente
-Killer-Psicotico-
Novello Arciere
Messaggi: 29
Iscritto il: 2 settembre 2014, 18:13
Architettura: x86 (32Bit)
Località: Savignano sul Panaro, Modena

Re: Errore Virtualbox - Manjaro Linux

Messaggio da -Killer-Psicotico- » 12 settembre 2014, 14:12

eccolo

Codice: Seleziona tutto

[enriklapi1015@paperoassassino ~]$ pacman -Ss headers
core/acl 2.2.52-2 [installato]
    Access control list utilities, libraries and headers
core/linux-api-headers 3.14.1-1 [installato]
    Kernel headers sanitized for use in userspace
core/linux310-headers 3.10.53-1 [installato]
    Header files and scripts for building modules for Linux310 kernel
core/linux311-headers 3.11.10.15-1
    Header files and scripts for building modules for Linux311 kernel
core/linux312-headers 3.12.27-1
    Header files and scripts for building modules for Linux312 kernel
core/linux313-headers 3.13.11.6-1
    Header files and scripts for building modules for Linux313 kernel
core/linux314-headers 3.14.17-1
    Header files and scripts for building modules for Linux314 kernel
core/linux315-headers 3.15.10-1
    Header files and scripts for building modules for Linux315 kernel
core/linux316-headers 3.16.1-1
    Header files and scripts for building modules for Linux316 kernel
core/linux38-headers 3.8.13.28-1
    Header files and scripts for building modules for Linux38 kernel
extra/libcups 1.7.5-1 [installato]
    The CUPS Printing System - client libraries and headers
extra/nx-headers 3.5.0.27-1
    NX headers
extra/spice-protocol 0.12.7-1
    Headers for SPICE protocol
extra/xproto 7.0.26-1 [installato]
    X11 core wire protocol and auxiliary headers
community/gnubiff 2.2.15-2
    Mail notification program that checks for mail and displays headers when new mail has arrived
community/gnubiff-gtk 2.2.15-2
    Mail notification program that checks for mail and displays headers when new mail has arrived. GTK version.
community/mingw-w64-headers 3.2.0-1 (mingw-w64-toolchain mingw-w64)
    MinGW-w64 headers for Windows
community/mingw-w64-headers-bootstrap 3.2.0-1 (mingw-w64-bootstrap mingw-w64)
    MinGW-w64 headers for Windows (bootstrap)
community/mingw-w64-winpthreads 3.2.0-1 (mingw-w64-toolchain mingw-w64)
    MinGW-w64 winpthreads library
community/opencl-headers 2:1.1.20110526-1
    OpenCL (Open Computing Language) header files
community/perl-email-simple 2.203-1
    simple parsing of RFC2822 message format and headers
community/pyopencl-headers 1:2013.2-4
    A complete, object-oriented language binding of OpenCL to Python
community/qt4-private-headers 4.8.6-1
    Qt4 private headers for development
cmq grazie per il tuo sostegno :)
ah il primo comando mi ha dato

Codice: Seleziona tutto

[enriklapi1015@paperoassassino ~]$ sudo pacman -S linux....-manjaro-headers
[sudo] password for enriklapi1015: 
errore: il seguente pacchetto non è stato trovato: linux....-manjaro-headers

Avatar utente
ambro
Robin Hood
Messaggi: 1933
Iscritto il: 27 agosto 2009, 21:37
Località: Verona

Re: Errore Virtualbox - Manjaro Linux

Messaggio da ambro » 12 settembre 2014, 14:22

Nei puntini dovevi metterci tu qualcosa che mancava. Io non conosco come manjaro chiama i pacchetti.
Comunque prova a installare il pacchetto

Codice: Seleziona tutto

linux312-headers 3.12.27-1
Sto andando a tentativi come ti ripeto perchè non so come chiama i pacchetti la tua distribuzione.
Io per esempio ho installato il kernel linux-ck-bulldozer e gli headers linux-ck-bulldozer-headers
Però probabilmente in manjaro non è così
PC: Amd FX-6100-Nvidia GT630-SSD- 64bit - kernel 4.3-ck - KDE Plasma 5
Mediacenter: Asrock Q2900 Itx - VGA Intel - 64bit - kernel 4.3-ck - lxde - Kodi - isengard
Netbook: Asus eeepc1001 - i686 - kernel 4.3 - lxde

Avatar utente
-Killer-Psicotico-
Novello Arciere
Messaggi: 29
Iscritto il: 2 settembre 2014, 18:13
Architettura: x86 (32Bit)
Località: Savignano sul Panaro, Modena

Re: Errore Virtualbox - Manjaro Linux

Messaggio da -Killer-Psicotico- » 12 settembre 2014, 14:26

Codice: Seleziona tutto

[root@paperoassassino enriklapi1015]# pacman -S linux312-headers 3.12.27-1
errore: il seguente pacchetto non è stato trovato: 3.12.27-1
mi toccare fare una ricerca, puoi aiutarmi? :oops:

Avatar utente
ambro
Robin Hood
Messaggi: 1933
Iscritto il: 27 agosto 2009, 21:37
Località: Verona

Re: Errore Virtualbox - Manjaro Linux

Messaggio da ambro » 12 settembre 2014, 14:30

calma...
il comando che devi dare è

Codice: Seleziona tutto

pacman -S linux312-headers
il numero di versione non deve essere indicato.
pacman installa quella che trova nei repo
PC: Amd FX-6100-Nvidia GT630-SSD- 64bit - kernel 4.3-ck - KDE Plasma 5
Mediacenter: Asrock Q2900 Itx - VGA Intel - 64bit - kernel 4.3-ck - lxde - Kodi - isengard
Netbook: Asus eeepc1001 - i686 - kernel 4.3 - lxde

Avatar utente
-Killer-Psicotico-
Novello Arciere
Messaggi: 29
Iscritto il: 2 settembre 2014, 18:13
Architettura: x86 (32Bit)
Località: Savignano sul Panaro, Modena

Re: Errore Virtualbox - Manjaro Linux

Messaggio da -Killer-Psicotico- » 12 settembre 2014, 14:34

ok sta scaricando quindi

Codice: Seleziona tutto

pacman -S linux312-headers
poi

Codice: Seleziona tutto

sudo dkms install vboxhost/$(pacman -Q virtualbox|awk {'print $2'}|sed 's/\-.\+//') -k $(uname -rm|sed 's/\ /\//')
faccio tutto e vi dico grazie

Avatar utente
-Killer-Psicotico-
Novello Arciere
Messaggi: 29
Iscritto il: 2 settembre 2014, 18:13
Architettura: x86 (32Bit)
Località: Savignano sul Panaro, Modena

Re: Errore Virtualbox - Manjaro Linux

Messaggio da -Killer-Psicotico- » 12 settembre 2014, 15:14

ho fatto tutto ma mi esce sempre il problema, devo fare qualcos'altro?

Avatar utente
tecnopado
Arciere Provetto
Messaggi: 376
Iscritto il: 16 maggio 2014, 22:15
Architettura: x86_64 (64bit)
Località: /src

Re: Errore Virtualbox - Manjaro Linux

Messaggio da tecnopado » 12 settembre 2014, 15:23

hai provato semplicemente a fare come ti suggerisce il terminale nel primo output?

Codice: Seleziona tutto

pacman -S virtualbox-host-modules
??
the BEST BOOT TIME! Intel core i5 4670+Crucial-M550 GPT+BTRFS+custom kernel 4.0
Startup finished in 1.145s (kernel) + 674ms (userspace) = 1.820s (cercasi sfidante ;) )
I'm happy :D :D :D

Avatar utente
-Killer-Psicotico-
Novello Arciere
Messaggi: 29
Iscritto il: 2 settembre 2014, 18:13
Architettura: x86 (32Bit)
Località: Savignano sul Panaro, Modena

Re: Errore Virtualbox - Manjaro Linux

Messaggio da -Killer-Psicotico- » 12 settembre 2014, 15:33

e gia installato

Codice: Seleziona tutto

[root@paperoassassino enriklapi1015]# pacman -S virtualbox-host-modules
attenzione: linux310-virtualbox-host-modules-4.3.14-2 è aggiornato ma sarà reinstallato

Avatar utente
tecnopado
Arciere Provetto
Messaggi: 376
Iscritto il: 16 maggio 2014, 22:15
Architettura: x86_64 (64bit)
Località: /src

Re: Errore Virtualbox - Manjaro Linux

Messaggio da tecnopado » 12 settembre 2014, 15:39

mhh.. guardato anche qui? https://wiki.manjaro.org/index.php?title=Virtualbox

seguendo la tua versione di kernel pero' eh

Codice: Seleziona tutto

uname -r
x sapere che kernel usi

edit: ho trovato questo,magari puo' tornarti utile,sono listati i passaggi..vedi la wiki comunque http://archlinuxtricks.blogspot.it/2013 ... albox.html
the BEST BOOT TIME! Intel core i5 4670+Crucial-M550 GPT+BTRFS+custom kernel 4.0
Startup finished in 1.145s (kernel) + 674ms (userspace) = 1.820s (cercasi sfidante ;) )
I'm happy :D :D :D

Avatar utente
-Killer-Psicotico-
Novello Arciere
Messaggi: 29
Iscritto il: 2 settembre 2014, 18:13
Architettura: x86 (32Bit)
Località: Savignano sul Panaro, Modena

Re: Errore Virtualbox - Manjaro Linux

Messaggio da -Killer-Psicotico- » 12 settembre 2014, 15:51

si ora funziona! dopo aver fatto

Codice: Seleziona tutto

sudo dkms install vboxhost/$(pacman -Q virtualbox|awk {'print $2'}|sed 's/\-.\+//') -k $(uname -rm|sed 's/\ /\//')
dovevo avviare i moduli con

Codice: Seleziona tutto

sudo modprobe vboxdrv
oppure riavviare :D
ora e tutto apposto

Codice: Seleziona tutto

[enriklapi1015@paperoassassino ~]$ virtualbox
/usr/share/themes/Murrina-Tangoesque/gtk-2.0/gtkrc:50: Murrine configuration option "gradients" is no longer supported and will be ignored.
/usr/share/themes/Murrina-Tangoesque/gtk-2.0/gtkrc:51: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
/usr/share/themes/Murrina-Tangoesque/gtk-2.0/gtkrc:63: Murrine configuration option "hilight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile
ringrazio ambro e tecnopado :oops: :mrgreen:

Rispondi