Installazione pacchetti

Segnalazioni di pacchetti utili, richieste di creazione pacchetti e supporto tecnico
Rispondi
Avatar utente
CielitoLindo
Arciere
Messaggi: 275
Iscritto il: 1 marzo 2013, 16:16

Installazione pacchetti

Messaggio da CielitoLindo » 25 novembre 2017, 11:47

Buongiorno a tutti. Ho un problema con yaourt. Quando vado ad aggiornare i pacchetti installati con yaourt mi da dei problemi in particolare con drftsight (ho provato ad installarlo scaricandolo dome siongolo pacchetto direttamente da aur ma non ne vuole sapere).
Ho provato ad installare gli altri pacchetti, in attesa di capire come risolvere il problema dratsight, ma pur mostrandomeli come prseenti, se li installo come singoli pacchetti mi dice che nn ci sono in aur. Non capisco.
Credo che farvi vedere l'output del terminale sia meglio di ogni spiegazione

Codice: Seleziona tutto

[giacomob@arch ~]$ yaourt -Syua exclude=draftsight
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community è aggiornato
 multilib è aggiornato
 archlinuxfr è aggiornato
  gstreamer0.10-bad : Orfano 
  gstreamer0.10-bad-plugins : Orfano 
  gstreamer0.10-ffmpeg : Orfano 
 Altri pacchetti: / 93 / 93

==> Solo aggiornamenti dei pacchetti (nuova release):
aur/goocanvas1                           1.0.0-4      4 -> 5
aur/gstreamer0.10                        0.10.36-16   16 -> 17
aur/gstreamer0.10-base                   0.10.36-10   10 -> 11
aur/gstreamer0.10-base-plugins           0.10.36-10   10 -> 11
aur/gstreamer0.10-good                   0.10.31-28   28 -> 29
aur/gstreamer0.10-good-plugins           0.10.31-28   28 -> 29
aur/lib32-qt4                            4.8.7-6      6 -> 13
aur/libgnome                             2.32.1-6     6 -> 7
aur/libgnome-data                        2.32.1-6     6 -> 7
aur/libgnomeui                           2.24.5-2     2 -> 3
aur/otf-tex-gyre-ib                      2.005-7      7 -> 8
aur/qtwebkit                             2.3.4-5      5 -> 6
aur/ttf-courier-prime-ib                 1.203-6      6 -> 9

==> Aggiornamenti del software (nuova versione):
aur/draftsight                           2017SP0-2    -> 2018SP0-1
aur/fontconfig-infinality-ultimate       2.12.1-4     -> 2.12.6-1
aur/lib32-fontconfig-infinality-ultimate 2.12.3-1     -> 2.12.6-1
aur/plymouth                             0.9.2-13     -> 0.9.3-3
aur/python-path                          10.1-1       -> 10.4-1
aur/python2-path                         10.1-1       -> 10.4-1
aur/realvnc-vnc-server                   6.1.1-1      -> 6.2.0-1
aur/realvnc-vnc-viewer                   6.1.1-1      -> 6.17.731-1
aur/teamviewer                           12.0.76279-6 -> 12.0.85001-7
aur/ttf-caladea-ib                       20130214-6   -> 20140817-1
aur/ttf-carlito-ib                       20130920-7   -> 20140820-1

==> Continuare l'aggiornamento? [S/n]
==> [V]edi i dettagli dei pacchetti   Seleziona [M]anualmente i pacchetti
==> ---------------------------------------------------------------------
==> n
[giacomob@arch ~]$ yaourt -S goocanvas1 

==> Scaricamento del PKGBUILD di goocanvas1 da AUR...
(23) Failed writing body
==> ERRORE: goocanvas1 non trovato in AUR.
[giacomob@arch ~]$ 
Quest'ultimo errore avviene con tutti i pacchetti evidenziati in yaourt -Syua
Suggerimenti?
Grazie in anticipo.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7957
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Installazione pacchetti

Messaggio da TheSaint » 25 novembre 2017, 12:00

I pacchetti di AUR li dovresti escludere durante la rischiesta di installazione. Non penso sia da usare l' opzione exclude=
Per goocanvas1

Codice: Seleziona tutto

 yaourt -Ss goocanvas1
aur/goocanvas1 1.0.0-5 (27) (3,94)
    A cairo canvas widget for GTK+
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Installazione pacchetti

Messaggio da 4javier » 25 novembre 2017, 12:48

Prova a svuotare la /tmp
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Avatar utente
CielitoLindo
Arciere
Messaggi: 275
Iscritto il: 1 marzo 2013, 16:16

Re: Installazione pacchetti

Messaggio da CielitoLindo » 4 dicembre 2017, 11:20

Salve a tutti.
Sono riuscito ad andare avanti istallando molti pacchetti singolarmente. Poi ho fatto un po' di pulizia con pacman -R (pacman -Qtdq) e yaourt -R (yaourt -Qtdq) togliendo circa un giga di roba (900 MB da pacman il restante da yaourt).
Adesso mi rimane da installare solo le lib32-qt4 e draftsight. Cominciando dalle prime, ad un certo punto si blocca con i seguenti errori e non so come risolvere:

Codice: Seleziona tutto

compiling tools/qstringbuilder.cpp
compiling tools/qstringlist.cpp
compiling tools/qtextboundaryfinder.cpp
compiling tools/qtimeline.cpp
compiling tools/qvector.cpp
compiling tools/qvsnprintf.cpp
compiling tools/qelapsedtimer_unix.cpp
compiling tools/qlocale_unix.cpp
compiling tools/qlocale_icu.cpp
In file included from /usr/include/unicode/unorm2.h:34:0,
                 from /usr/include/unicode/unorm.h:25,
                 from /usr/include/unicode/ucol.h:17,
                 from tools/qlocale_icu.cpp:49:
/usr/include/unicode/localpointer.h:221:34: error: expected ‘,’ or ‘...’ before ‘&&’ token
     LocalPointer(LocalPointer<T> &&src) U_NOEXCEPT : LocalPointerBase<T>(src.ptr) {
                                  ^~
/usr/include/unicode/localpointer.h:221:39: error: invalid constructor; you probably meant ‘icu_60::LocalPointer<T> (const icu_60::LocalPointer<T>&)’
     LocalPointer(LocalPointer<T> &&src) U_NOEXCEPT : LocalPointerBase<T>(src.ptr) {
                                       ^
/usr/include/unicode/localpointer.h:238:48: error: expected ‘,’ or ‘...’ before ‘&&’ token
     LocalPointer<T> &operator=(LocalPointer<T> &&src) U_NOEXCEPT {
                                                ^~
/usr/include/unicode/localpointer.h: In member function ‘icu_60::LocalPointer<T>& icu_60::LocalPointer<T>::operator=(icu_60::LocalPointer<T>)’:
/usr/include/unicode/localpointer.h:239:25: error: ‘src’ was not declared in this scope
         return moveFrom(src);
                         ^~~
/usr/include/unicode/localpointer.h: At global scope:
/usr/include/unicode/localpointer.h:366:30: error: expected ‘,’ or ‘...’ before ‘&&’ token
     LocalArray(LocalArray<T> &&src) U_NOEXCEPT : LocalPointerBase<T>(src.ptr) {
                              ^~
/usr/include/unicode/localpointer.h:366:35: error: invalid constructor; you probably meant ‘icu_60::LocalArray<T> (const icu_60::LocalArray<T>&)’
     LocalArray(LocalArray<T> &&src) U_NOEXCEPT : LocalPointerBase<T>(src.ptr) {
                                   ^
/usr/include/unicode/localpointer.h:383:44: error: expected ‘,’ or ‘...’ before ‘&&’ token
     LocalArray<T> &operator=(LocalArray<T> &&src) U_NOEXCEPT {
                                            ^~
/usr/include/unicode/localpointer.h: In member function ‘icu_60::LocalArray<T>& icu_60::LocalArray<T>::operator=(icu_60::LocalArray<T>)’:
/usr/include/unicode/localpointer.h:384:25: error: ‘src’ was not declared in this scope
         return moveFrom(src);
                         ^~~
/usr/include/unicode/uset.h: At global scope:
/usr/include/unicode/uset.h:326:1: error: expected ‘,’ or ‘...’ before ‘&&’ token
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUSetPointer, USet, uset_close);
 ^
/usr/include/unicode/uset.h:326:1: error: invalid constructor; you probably meant ‘icu_60::LocalUSetPointer (const icu_60::LocalUSetPointer&)’
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUSetPointer, USet, uset_close);
 ^
/usr/include/unicode/uset.h:326:1: error: expected ‘,’ or ‘...’ before ‘&&’ token
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUSetPointer, USet, uset_close);
 ^
/usr/include/unicode/uset.h: In member function ‘icu_60::LocalUSetPointer& icu_60::LocalUSetPointer::operator=(icu_60::LocalUSetPointer)’:
/usr/include/unicode/uset.h:326:1: error: ‘src’ was not declared in this scope
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUSetPointer, USet, uset_close);
 ^
/usr/include/unicode/unorm2.h: At global scope:
/usr/include/unicode/unorm2.h:261:1: error: expected ‘,’ or ‘...’ before ‘&&’ token
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUNormalizer2Pointer, UNormalizer2, unorm2_close);
 ^
/usr/include/unicode/unorm2.h:261:1: error: invalid constructor; you probably meant ‘icu_60::LocalUNormalizer2Pointer (const icu_60::LocalUNormalizer2Pointer&)’
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUNormalizer2Pointer, UNormalizer2, unorm2_close);
 ^
/usr/include/unicode/unorm2.h:261:1: error: expected ‘,’ or ‘...’ before ‘&&’ token
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUNormalizer2Pointer, UNormalizer2, unorm2_close);
 ^
/usr/include/unicode/unorm2.h: In member function ‘icu_60::LocalUNormalizer2Pointer& icu_60::LocalUNormalizer2Pointer::operator=(icu_60::LocalUNormalizer2Pointer)’:
/usr/include/unicode/unorm2.h:261:1: error: ‘src’ was not declared in this scope
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUNormalizer2Pointer, UNormalizer2, unorm2_close);
 ^
/usr/include/unicode/uenum.h: At global scope:
/usr/include/unicode/uenum.h:68:1: error: expected ‘,’ or ‘...’ before ‘&&’ token
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUEnumerationPointer, UEnumeration, uenum_close);
 ^
/usr/include/unicode/uenum.h:68:1: error: invalid constructor; you probably meant ‘icu_60::LocalUEnumerationPointer (const icu_60::LocalUEnumerationPointer&)’
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUEnumerationPointer, UEnumeration, uenum_close);
 ^
/usr/include/unicode/uenum.h:68:1: error: expected ‘,’ or ‘...’ before ‘&&’ token
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUEnumerationPointer, UEnumeration, uenum_close);
 ^
/usr/include/unicode/uenum.h: In member function ‘icu_60::LocalUEnumerationPointer& icu_60::LocalUEnumerationPointer::operator=(icu_60::LocalUEnumerationPointer)’:
/usr/include/unicode/uenum.h:68:1: error: ‘src’ was not declared in this scope
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUEnumerationPointer, UEnumeration, uenum_close);
 ^
/usr/include/unicode/ucol.h: At global scope:
/usr/include/unicode/ucol.h:538:1: error: expected ‘,’ or ‘...’ before ‘&&’ token
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUCollatorPointer, UCollator, ucol_close);
 ^
/usr/include/unicode/ucol.h:538:1: error: invalid constructor; you probably meant ‘icu_60::LocalUCollatorPointer (const icu_60::LocalUCollatorPointer&)’
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUCollatorPointer, UCollator, ucol_close);
 ^
/usr/include/unicode/ucol.h:538:1: error: expected ‘,’ or ‘...’ before ‘&&’ token
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUCollatorPointer, UCollator, ucol_close);
 ^
/usr/include/unicode/ucol.h: In member function ‘icu_60::LocalUCollatorPointer& icu_60::LocalUCollatorPointer::operator=(icu_60::LocalUCollatorPointer)’:
/usr/include/unicode/ucol.h:538:1: error: ‘src’ was not declared in this scope
 U_DEFINE_LOCAL_OPEN_POINTER(LocalUCollatorPointer, UCollator, ucol_close);
 ^
make[1]: *** [Makefile:14643: .obj/release-shared/qlocale_icu.o] Error 1
make[1]: uscita dalla directory "/tmp/yaourt-tmp-giacomob/aur-lib32-qt4/src/qt-everywhere-opensource-src-4.8.7/src/corelib"
make: *** [Makefile:206: sub-corelib-make_default-ordered] Error 2
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
==> ERRORE: Makepkg non è riuscito a compilare lib32-qt4.
==> Riavviare la compilazione di lib32-qt4 [s/N]
==> --------------------------------------------
==> 

Avatar utente
CielitoLindo
Arciere
Messaggi: 275
Iscritto il: 1 marzo 2013, 16:16

Re: Installazione pacchetti

Messaggio da CielitoLindo » 4 dicembre 2017, 12:20

Questo invece il risultato di draftight installato scaricando lo snapshot da aur

Codice: Seleziona tutto

[giacomob@arch draftsight]$ makepkg
==> Creazione del pacchetto: draftsight 2018SP0-1 (lun  4 dic 2017, 12.06.42, CET)
==> Controllo delle dipendenze durante l'avvio in corso...
==> Controllo delle dipendenze durante la compilazione in corso...
==> Download dei sorgenti in corso...
  -> Download di draftsight-2018SP0 in corso...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  589M  100  589M    0     0   878k      0  0:11:27  0:11:27 --:--:-- 1121k
  -> È stato trovato draftsight.desktop
==> Validazione di source file con md5sums...
    draftsight-2018SP0 ... Verificato
    draftsight.desktop ... Verificato
==> Estrazione dei sorgenti in corso...
  -> Estrazione di draftsight-2018SP0 usando bsdtar in corso...
==> Entro nell'ambiente fakeroot...
==> Avvio di package() in corso...
/home/giacomob/Scaricati/draftsight (2)/draftsight/PKGBUILD: riga 41: $pkgdir/usr/bin/$pkgname: redirezione ambigua
==> ERRORE: Si è verificato un errore in package().
    L'operazione sta per essere interrotta...
[giacomob@arch draftsight]$ 

Rispondi