Systemd: Curiosità - Domande - Problemi

Problemi e suggerimenti legati all'installazione di Arch Linux
Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Systemd: Curiosità - Domande - Problemi

Messaggio da dieghen89 » 2 maggio 2010, 16:14

Discussione dedicata ai vari problemi, informazioni e domande su sytemd.
Ricordo che il wiki a riguardo è il seguente. https://wiki.archlinux.org/index.php/Sy ... taliano%29
Per i servizi non disponibili si veda la pagina https://wiki.archlinux.org/index.php/Systemd/Services
Per le FAQ https://wiki.archlinux.org/index.php/Sy ... (Italiano)

Veleno77



Da qualche giorno ho letto sul forum internazionale dell'esistenza di questa nuova concezione di init del mondo linux, ho dato una letta veloce alla spiegazione di cos'è e cosa si predispone di fare, e sembra essere un metodo interessante...

Poi oggi leggo l'articolo su Ossblog, quindi qualcosa si sta muovendo....Qualcuno ha già avuto modo di provarlo?

Appena ho tempo vorrei farmi una installazione di arch in macchina virtuale e provare se almeno funziona....
Ultima modifica di veleno77 il 4 novembre 2012, 14:01, modificato 4 volte in totale.
Motivazione: Messa in rilevo discussione per unificare eventuali richieste e discussioni
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

dren
Novello Arciere
Messaggi: 66
Iscritto il: 14 aprile 2009, 21:48

Messaggio da dren » 2 maggio 2010, 17:21

Non mi sembra tanto differente da initng, che e' davvero una bomba.

franz1789
Arciere Provetto
Messaggi: 410
Iscritto il: 23 giugno 2008, 14:58

Messaggio da franz1789 » 4 maggio 2010, 20:16

a quanto pare sta guadagnando consensi...

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 4 maggio 2010, 20:21

Io l'ho provato in macchina virtuale ma non boota niente....Non ho voglia di andare a guardarmi i sorgenti che tra l'altro se ho capito bene sono in C e io ho solo conoscenze base di questo linguaggio....Aspetto qualcuno più competente di me per il porting...
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 5 maggio 2010, 23:51

Qualcosa si sta muovendo....
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

franz1789
Arciere Provetto
Messaggi: 410
Iscritto il: 23 giugno 2008, 14:58

Messaggio da franz1789 » 5 maggio 2010, 23:58

mmm, aspetterò un po' prima di distruggere la mia arch, in genere quando faccio 'ste cose c'è sempre qualcosa che non mi va e che son troppo nabbo per risolvere...

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 6 maggio 2010, 0:05

È ancora fuori discussione provare su una installazione reale...per fortuna che esiste virtualbox ;)
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 6 maggio 2010, 0:43

Leggete la pagina di AUR che è stata aggiornata proprio oggi (anzi ieri vista l'ora), qualche utente con il nuovo supporto ad Arch è riuscito a bootare con systemd....Ora mi sto ricompilando il kernel (i686) -ARCH aggiungendo il supporto a DEVTMPFS, poi per i volenterosi lo upperò da qualche parte...

p.s. perchè mi segna 23.43 quando invece sono le 00.43??
Ultima modifica di dieghen89 il 6 maggio 2010, 0:44, modificato 1 volta in totale.
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 25 giugno 2010, 10:44

Sembrerebbe che fedora adotterà systemd con la prossima versione :)
Ultima modifica di dieghen89 il 25 giugno 2010, 10:44, modificato 1 volta in totale.
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

Avatar utente
Berseker
Amministratore
Messaggi: 4432
Iscritto il: 27 settembre 2007, 10:18
Architettura: x86_64 (64bit)
Località: Lecco (provincia)

Messaggio da Berseker » 25 giugno 2010, 11:11

il tuo esperimento di inizio maggio com'era andato? :)
Leggete il Regolamento e cercate sempre su googleforumwiki prima di chiedere.
Tag x thread risolti: [Risolto] + Spazio messo all'inizio del titolo. Grazie

ArchWiki / Board Internazionale / Blog

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 25 giugno 2010, 11:23

Non partiva proprio niente :) Avevo provato a ricompilare qualche giorno fa ma falliva...Qualcuno su aur ha proposto una patch e applicando quella la compilzione va a buon fine, ma il mainteiner l'ha rifiutata perchè da quello che ho capito era un problema di un altro pacchetto (sua dipendenza)...

Ho provato a farlo partire con quella patch ma ancora si blocca nei primi momenti del boot...Però sto usando il kernel-netbook che non ha attiva l'opzione CGROUP anche se mi pare di aver capito che non serve più...

p.s. ora non uso più la macchina virtuale perchè non va a intaccare nessun file di sistema....Quindi se qualcuno vuole provare questo pacchetto può farlo liberamente sulla sua installazione reale, basta poi aggiungere a grub init=/bin/systemd....

EDIT: col kernel26 parte, ma va a sostituire solo il preboot, ossia quello che c'è prima che vengano stampate le scritte Arch Linux bla bla Aaron Griffin ecc....Poi partono gli initscripts tradizionali...

Cmq avvia in init 3 e non c'è la possibilità di avviare la sessione grafica....
Ultima modifica di dieghen89 il 25 giugno 2010, 11:30, modificato 1 volta in totale.
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 25 giugno 2010, 12:02

Ho scoperto una cosa nuova...C'è anche il pacchetto systemd-initscripts-git...Installando quello (non va a sovrascrivere niente) e avviando il kernel26 passandogli l'init in grub, parte e funziona...

Il boot è rapidissimo ma, come detto sopra, mi ritrovo in init3 senza la possibilità di sessione grafica...che dire, promette bene questo progetto :)

Se siete interessati, provatelo anche voi, basta installare quei 2 pacchetti che non intaccano niente :D
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

Avatar utente
Berseker
Amministratore
Messaggi: 4432
Iscritto il: 27 settembre 2007, 10:18
Architettura: x86_64 (64bit)
Località: Lecco (provincia)

Messaggio da Berseker » 25 giugno 2010, 13:18

ok ma se parti in init3 poi facendo startx non ti parte X?
Leggete il Regolamento e cercate sempre su googleforumwiki prima di chiedere.
Tag x thread risolti: [Risolto] + Spazio messo all'inizio del titolo. Grazie

ArchWiki / Board Internazionale / Blog

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 25 giugno 2010, 15:13

No non funziona...Init 3 era per farti capire dove arrivo col boot poi ancora non ho ben capito come gestisce i runlevel ammesso che usi quelli classici...
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 7 luglio 2010, 8:56

Dalla mailing list scopro che la versione 1 è uscita, ora sono fuori casa e non ho tempo per provarla, spero di darvi qualche notizia questo weekend :)
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

franz1789
Arciere Provetto
Messaggi: 410
Iscritto il: 23 giugno 2008, 14:58

Messaggio da franz1789 » 7 luglio 2010, 17:51

beh, speriamo bene, un boot più veloce dei 40 secondi di oggi non sarebbe male...

fabioamd87
Arciere Provetto
Messaggi: 390
Iscritto il: 4 novembre 2007, 23:33
Località: Cassino
Contatta:

Messaggio da fabioamd87 » 22 novembre 2010, 13:46

dieghen89 ha scritto:Se siete interessati, provatelo anche voi, basta installare quei 2 pacchetti che non intaccano niente :D
però come far capire al sistema di non usare il vecchio metodo di avvio?

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 22 novembre 2010, 13:51

Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

fabioamd87
Arciere Provetto
Messaggi: 390
Iscritto il: 4 novembre 2007, 23:33
Località: Cassino
Contatta:

Messaggio da fabioamd87 » 25 novembre 2010, 18:31

per adesso aspetto il kernel 2.6.36

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 29 aprile 2011, 14:50

Riesumo la discussione :) SystemD ora funziona veramente bene, vi consiglio di testarlo...Neanche con readahead-fedora avevo un boot così rapido :lol:

EDIT: leggete questo articoletto di paragone con gli altri sistemi di init :)
Ultima modifica di dieghen89 il 29 aprile 2011, 14:55, modificato 1 volta in totale.
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

Ossk

Messaggio da Ossk » 30 aprile 2011, 17:25

E infatti è uno spettacolo. Oltre ad essere decisamente moderno come concezione e funzionalità. Proporlo di default in arch?

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 30 aprile 2011, 17:29

Non credo verrà mai accettato come sistema di init di default...Già averlo in community è una bella cosa, il passaggio in extra sarebbe il massimo che mi potrei aspettare :)

p.s. Oggi è un anno che systemd esiste ;)
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

franz1789
Arciere Provetto
Messaggi: 410
Iscritto il: 23 giugno 2008, 14:58

Messaggio da franz1789 » 30 aprile 2011, 17:29

Splendido, davvero splendido, devo ancora capire bene la configurazione, ma ora come ora è ottimo.
Di default no, preferisco poter tornare indietro se le cose non mi "suonassero" bene.. Inoltre necessita ancora di molto testing..

franz1789
Arciere Provetto
Messaggi: 410
Iscritto il: 23 giugno 2008, 14:58

Messaggio da franz1789 » 15 maggio 2011, 17:30

Per attivare il readahead di systemd il wiki da:
# systemctl enable systemd-readahead-collect.service
# systemctl enable systemd-readahead-replay.service
Ma poi posso dimenticarmene o devo bloccarli dopo qualche reboot?

Avatar utente
dieghen89
Little John
Messaggi: 1310
Iscritto il: 28 novembre 2008, 17:53
Località: Provincia di Udine
Contatta:

Messaggio da dieghen89 » 15 maggio 2011, 19:32

No devi lasciarli...poi è systemd che se ne occupa :)
XPS 13 Developer Edition i7-4650U/hd5000 + KDE
Eeepc 1015PEM Black + KDE Minimal + kernel-netbook + acpi-eeepc-1015pem --> GUIDA

Rispondi