[Risolto] Problemi di aggiornamento

Problemi e suggerimenti legati all'installazione di Arch Linux
Rispondi
Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

[Risolto] Problemi di aggiornamento

Messaggio da vda » 29 maggio 2018, 17:56

Bentrovati tutti,

oggi,provando a fare un aggiornamento di sistema, ho ottenuto il seguente errore

Codice: Seleziona tutto

$ sudo pacman -Syu

:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community è aggiornato
 multilib è aggiornato
:: Aggiornamento del sistema in corso...
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: installing x265 (2.8-1) breaks dependency 'libx265.so=151-64' required by ffmpeg2.8
Ho così provato a disinstallare (speravo temporaneamente) l'incriminato ffmpeg2.8

Codice: Seleziona tutto

$ sudo pacman -Rs ffmpeg2.8
e sono in effetti riuscito ad aggiornare il sistema senza ulteriori difficoltà. Anzi, ho notato che anche il pacchetto ffmpeg è stato aggiornato.

Il problema è che ora, volendo ripristinare ffmpeg2.8, la cosa mi risulta impossibile

Codice: Seleziona tutto

$ sudo pacman -S ffmpeg2.8
errore: il seguente pacchetto non è stato trovato: ffmpeg2.8


Voi, amanti dei codec (sicuramente più di me) sapete se ffmpeg2.8 è ancora indispensabile? Posso ignorare la cosa senza ulteriori problemi?

Grazie in anticipo,

8)
Ultima modifica di vda il 29 maggio 2018, 20:04, modificato 1 volta in totale.
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
Dusty
Little John
Messaggi: 888
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: Problemi di aggiornamento

Messaggio da Dusty » 29 maggio 2018, 18:39

ffmpeg2.8 è servito fino a poco tempo fa perchè alcuni programmi che usano ffmpeg non si erano ancora adeguati alla versione più recente.
Per esempio, vlc.
Poi, col tempo, si sono adeguati tutti; quindi non serve più ed è stato rimosso.
Senza assillo, ma con costanza, dovresti fare periodici controlli sul sistema per rilevare pacchetti sconoscuti:

Codice: Seleziona tutto

pacman -Qm

Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Re: Problemi di aggiornamento

Messaggio da vda » 29 maggio 2018, 20:00

Grazie mille Dusty. Chiarissimo.

8)
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Problemi di aggiornamento

Messaggio da TheSaint » 30 maggio 2018, 4:55

Dusty ha scritto:
29 maggio 2018, 18:39
per rilevare pacchetti sconoscuti:
Direi pacchetti disconosciuti. Mi son trovato con paccache sparito :)
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

pipep
Novello Arciere
Messaggi: 70
Iscritto il: 27 novembre 2016, 20:07
Architettura: x86_64 (64bit)

Re: Problemi di aggiornamento

Messaggio da pipep » 5 luglio 2018, 11:21

TheSaint ha scritto:
30 maggio 2018, 4:55
Mi son trovato con paccache sparito :)
$ pacman -Fs paccache
community/pacman-contrib 1.0.0-2

Rispondi