[Risolto] LXDE (installazione) tasto tilde ~

Problemi e suggerimenti legati all'installazione di Arch Linux
Bloccato
geopardo
Novello Arciere
Messaggi: 48
Iscritto il: 10 dicembre 2017, 13:20

[Risolto] LXDE (installazione) tasto tilde ~

Messaggio da geopardo » 14 dicembre 2017, 18:56

Sono sempre sul portatile A200 Toshiba
Mentre installavo LXDE sono arrivato ad un certo punto dove chiede di copiare tre file:

Codice: Seleziona tutto

# cp /etc/xdg/openbox/menu.xml /etc/xdg/openbox/rc.xml /etc/xdg/openbox/autostart ~/.config/openbox
Sulla precedente installazione (con desk gnome) Da terminale riuscivo a fare la tilde ~ e credo la combinazione fosse: ALT gr + ì
Ho provato varie combinazioni dei tasti proposte in rete, cercato abbastanza da arrendermi quando ho trovato Tilda. (che non centra nulla..)
attivato il tastierino numerico e provato qualche combinazione senza successo.

Ora leggendo anche nel forum che:
~/. significa che sei nella tua home ovvero /home/utente

Nell'installazione ho già creato l'utente, ho provato a loggarmi per accedere alla home, ma se provo a copiare con:

Codice: Seleziona tutto

sudo cp /etc/xdg/openbox/menu.xml /etc/xdg/openbox/rc.xml /etc/xdg/openbox/autostart /home/utente/.config/openbox

mi dice: cp: l'obbiettivo '/home/utente/.config/openbox' non è una directory

se provo con:

Codice: Seleziona tutto

sudo cp /etc/xdg/openbox/menu.xml /etc/xdg/openbox/rc.xml /etc/xdg/openbox/autostart /home/utente/config/openbox
mide ancora: cp: l'obbiettivo '/home/utente/.config/openbox' non è una directory

devo creare la directory? oppure mi sono perso qualcosa..
Ho letto:
https://wiki.archlinux.org/index.php/Xinitrc_(Italiano)
https://wiki.archlinux.org/index.php/Locale_(Italiano)
https://foros.archlinux-es.org/viewtopic.php?t=5749
https://www.archlinux.it/forum/viewtopi ... =4&t=11530
https://www.archlinux.it/forum/viewtopic.php?f=4&t=7004

Durante l'installazione di xorg non ho installato tutti i pacchetti.. xorg-docs e font utils, pensando che servono ad altro, io sono su un'ambiente d'installazione. Sembrano possibili più strade ma non so dove andare ..
un ringraziamento e Saluti
Ultima modifica di geopardo il 16 dicembre 2017, 13:52, modificato 1 volta in totale.

VenereNera
Little John
Messaggi: 952
Iscritto il: 20 dicembre 2012, 19:50

Re: LXDE (installazione) tasto tilde ~

Messaggio da VenereNera » 14 dicembre 2017, 20:10

Crei la cartella usando il comando mkdir con l' opzione -p (-p farà in modo di creare le cartelle mancanti) oppure puoi provare con cp -R <fonte> <destinazione> (l' opzione -R copia in modo ricorsivo l' intera cartella openbox).

Codice: Seleziona tutto

mkdir -p /home/utente/.config/openbox
# E poi copi i files.

## Oppure  
cp -R /etc/xdg/openbox /home/utente/.config
Usa la pagina wiki in inglese perché più aggiornata.
Per la tastiera non so aiutarti.

EDIT: Se le cartelle utente le crei da utente root, controlla i permessi delle cartelle e relativi contenuti perché tendono a prendere i permessi dell' utente creante. Le cartelle nella home dell' utente, appartengono all' utente, non a root.

geopardo
Novello Arciere
Messaggi: 48
Iscritto il: 10 dicembre 2017, 13:20

Re: LXDE (installazione) tasto tilde ~

Messaggio da geopardo » 14 dicembre 2017, 21:32

VenereNera ha scritto:
14 dicembre 2017, 20:10

EDIT: Se le cartelle utente le crei da utente root, controlla i permessi delle cartelle e relativi contenuti perché tendono a prendere i permessi dell' utente creante. Le cartelle nella home dell' utente, appartengono all' utente, non a root.
sarebbe sudo a delegare il permesso ad agire sui comandi
se eseguo i comandi senza sudo cambia qualcosa?

In pratica la directory intera, la posso creare sia da root che da utente, sostituendo alla tilde la directory /home/utente
Spero di aver capito bene..
Quindi è meglio stare su utente e poi finire eventualmente shell script.
Poi tornare root e fare un network manager, un login manager ed avviare il tutto.
Grazie per la risposta :)


:) al momento 0 errori, non ho usato sudo e sono loggato come utente.
Per la tastiera forse non ho scaricato i due pacchetti di xorg, uno riguarda font.
Non saprei installando quei pacchetti, quanto si possa fare su una tastiera da console.

se il SO si avvia siamo apposto.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: LXDE (installazione) tasto tilde ~

Messaggio da TheSaint » 15 dicembre 2017, 4:48

Metti [Risolto] ?
La tilde su una tastiera italiana è ALT-GR+ì, che si trova al secondo tasto dopo il tasto dello zero. Per una tastiera internazionale si dovrebbe trovare a sinistra del tasto dell'uno.
In alternativa alla tilde, si può usare la variabile globale $HOME, facendo attenzione che è riferita all' utente che è loggato al momento.
Infine, nomeutente non è quello del tuo utente, quello che hai impostato per l' accesso da utente normale ?
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

geopardo
Novello Arciere
Messaggi: 48
Iscritto il: 10 dicembre 2017, 13:20

Re: LXDE (installazione) tasto tilde ~

Messaggio da geopardo » 15 dicembre 2017, 13:48

Ci siamo quasi ciao a tutti.
TheSaint ha scritto:
15 dicembre 2017, 4:48
In alternativa alla tilde, si può usare la variabile globale $HOME, facendo attenzione che è riferita all' utente che è loggato al momento.
Infine, nomeutente non è quello del tuo utente, quello che hai impostato per l' accesso da utente normale ?
:)
Risolto per metà, il tasto tilde non funziona da console, da terminale andava con gnome con ALT-GR+ì.
Arch si è avviato e la cartella non è stata creata da root, l'ho creata da utente. Da root ho evitato seguendo il consiglio di VenereNera
https://www.archlinux.it/forum/viewtopi ... 13&t=11500 anche qui dicono che la cartella va creata da utente e non da root.
Il sistema si avvia, non ha programmi ed è molto scarno, sembra quasi apposto.
Ora ogni comando lanciato da terminale mi da questo errore:

Codice: Seleziona tutto

Couldn't get a file descriptor referring to the console

Inoltre la tastiera non è impostata in italiano e ci sono errori sui font sul terminale, rendendomi impossibile il resto da farsi. Sul terminale le lettere sono accavallate o poco distanti, mentre sul desktop ed esplorazione file tutto normale.
Per il momento ho usato CTRL+ALT+F1 e sono ritornato sulla console ed ho scaricato ed installato i pacchetti di xorg mancanti. Qui il codice nei file me lo fa modificare solo da root, eventualmente userò sudo -s per diventare root. Se torno su consolle.. tutto su tastiera è ok

Entrambe concordano su due cose.
https://wiki.archlinux.org/index.php/Installation_guide
https://wiki.archlinux.org/index.php/In ... (Italiano)


Decommentare en_US.UTF-8 UTF-8 e altre localizzazioni necessarie in /etc/locale.gen Localizzazione necessaria se ho capito bene sarebbe:

Codice: Seleziona tutto

it_IT.UTF-8 UTF-8 

e generare con:

Codice: Seleziona tutto

# locale-gen
Settare la variabile LANG in locale.conf, ad esempio:

Codice: Seleziona tutto

LANG=it_IT.UTF-8
questo file /etc/locale.conf

wiki.archlinux su locale.conf dice questo:

Codice: Seleziona tutto

# localectl set-locale LANG="it_IT.UTF8"
Non so se si dovrebbe riavviare X oppure semplicemente il sistema con un reboot.
sulla wikiarchlinux da xorg riavviare X dice:

Codice: Seleziona tutto

$ setxkbmap fr
quindi sarebbe al caso:

Codice: Seleziona tutto

$ setxkbmap it
Molti tutorial dicono di inserire nel file: /etc/vconsole.conf

Codice: Seleziona tutto

 KEYMAP=it
mentre altri dicono:

Codice: Seleziona tutto

KEYMAP=it
LANG=it
Sulla wiki in inglese dice di aggiungere dentro il file: /etc/vconsole.conf

Codice: Seleziona tutto

KEYMAP=de-latin1
mentre quella italiana dice:

Codice: Seleziona tutto

KEYMAP=us'
Seguendo la wiki.archlinux ora LXDE è impostato con lingua inglese US con disponibile imput italiano IT.
Su console la tastiera è italiana. Penso perchè ho lasciato l'impostazione in /etc/vconsole.conf con KEYMAP=it

https://bbs.archlinux.org/viewtopic.php?id=190157
qui mettono sul file vconsole.conf

Codice: Seleziona tutto

KEYMAP=pl
FONT=lat2-16
http://jlk.fjfi.cvut.cz/arch/manpages/m ... ole.conf.5

nei tutorial avevo trovato questi comandi per /etc/locale.conf

Codice: Seleziona tutto

# echo "LANG=it_IT.UTF-8" > /etc/locale.conf
# export LANG=it_IT.UTF-8
fine edit
per il momento non ho altro da aggiungere.

un ringraziamento e Saluti

geopardo
Novello Arciere
Messaggi: 48
Iscritto il: 10 dicembre 2017, 13:20

Re: LXDE (installazione) tasto tilde ~

Messaggio da geopardo » 15 dicembre 2017, 21:15

ho risolto installando un font

Codice: Seleziona tutto

ttf-dejavu
, il terminale ora funziona, ma non riesco a caricare loadkeys it dice

Codice: Seleziona tutto

Couldn't get a file descriptor referring to the console
linux è tutto americano!

http://jlk.fjfi.cvut.cz/arch/manpages/m ... ole.conf.5
https://bbs.archlinux.org/viewtopic.php?id=147339
https://bbs.archlinux.org/viewtopic.php?id=151233

Codice: Seleziona tutto

KEYMAP=us
FONT=ter-v12n
FONT_MAP=
Io oltre al KEYMAP= non saprei cosa inserire su FONT= e FONT_MAP=
magari?
/etc/vconsole.conf

Codice: Seleziona tutto

KEYMAP=it-latin1
FONT=eurlatgr
Se qualcuno gentilmente mi spiega :) poi vedrò questo tilde.. se funzia da console..

controllando non ho /etc/xorg.conf
l'ho creato ma non c'è il codice decommentato.
https://wiki.archlinux.org/index.php/Fonts_(Italiano)

Codice: Seleziona tutto

# Let Xorg know about the custom font directories
Section "Files"
    FontPath    "/usr/share/fonts/100dpi"
    FontPath    "/usr/share/fonts/75dpi"
    FontPath    "/usr/share/fonts/cantarell"
    FontPath    "/usr/share/fonts/cyrillic"
    FontPath    "/usr/share/fonts/encodings"
    FontPath    "/usr/share/fonts/local"
    FontPath    "/usr/share/fonts/misc"
    FontPath    "/usr/share/fonts/OTF"
    FontPath    "/usr/share/fonts/TTF"
    FontPath    "/usr/share/fonts/util"
EndSection
Saluti

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: LXDE (installazione) tasto tilde ~

Messaggio da TheSaint » 15 dicembre 2017, 22:56

Per la localizzazione metti in un altra discussione. Per la tilde dovresti usare la configurazione di difetto che è quella internazionale. Quindi sulla tastiera si trova a sinistra dell'uno.
In genere le TTY si avviano così. Per cambiare si deve dare

Codice: Seleziona tutto

# loadkey it
se per qualche ragione ti dà errore, allora ci sta che hai pasticciato con l'installazione.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

VenereNera
Little John
Messaggi: 952
Iscritto il: 20 dicembre 2012, 19:50

Re: LXDE (installazione) tasto tilde ~

Messaggio da VenereNera » 15 dicembre 2017, 23:37

@geopardo Nel nuovo topic servirebbe leggere il contenuto del file xorg.conf, il contenuto di /etc/vconsole.conf, /etc/locale.conf, sapere quali linguaggi son stati decomentati in /etc/locale.gen (quindi cosa ha generato lo script locale-gen), controllare le impostazioni di LxDe e infine è utile capire se tutto il sistema è in inglese o solo la console.
Il comando 'loadkeys it' si lancia da root (in alternativa con sudo), se lanciato da utente normale si riceve la risposta ''errore'' che hai riporato.

geopardo
Novello Arciere
Messaggi: 48
Iscritto il: 10 dicembre 2017, 13:20

Re: [Risolto] LXDE (installazione) tasto tilde ~

Messaggio da geopardo » 16 dicembre 2017, 13:57

Adesso formatto tutto reinstallo arch e seguo solo wiki.archlinux come indicazione. (ho provato alcuni componenti e non mi sono piaciuti..)
Poi se il problema si ripresenta vi faccio sapere, ma penso si riprensenterà perché capita spesso LXDE. Metto risolto perché alla fine il problema era più sulla HOME :)
Saluti

Avatar utente
smlb
Amministratore
Messaggi: 573
Iscritto il: 17 aprile 2013, 12:40
Architettura: x86_64 (64bit)
Località: /dev/null
Contatta:

Re: [Risolto] LXDE (installazione) tasto tilde ~

Messaggio da smlb » 16 dicembre 2017, 15:41

Non ha senso reinstallare, non e` windows e non funziona in questo modo.

Per quanto riguarda la tastiera in italiano, puoi anche usare

Codice: Seleziona tutto

# Funziona da utente 
setxkbmap it
per impostarlo solo per X. Il discorso e` che sono cose che dovevi configurare in fase di installazione (vconsole, locale,conf et similia).
Prima di aprire thread ed effettuare altre azioni sul forum, leggere attentamente: forum etiquette

Consultare la wiki prima di postare sul forum - inserire sempre informazioni attinenti alle problematiche riscontrate

geopardo
Novello Arciere
Messaggi: 48
Iscritto il: 10 dicembre 2017, 13:20

Re: [Risolto] LXDE (installazione) tasto tilde ~

Messaggio da geopardo » 17 dicembre 2017, 22:58

@smlb
@TheSaint
@VenereNera

Il tasto tilde da me equivale alla bisciolina alta ho provato e funziona la /home/utente/
grafema (~ o ˜) risulta con la combinazione ALT GR+0
Quindi direi tutto risolto, non saprei se è un problema di font.. è cosi' ˜ :)
Comunque faccio confusione sulla wiki, senza toccare nulla nell'installazione i file di .xinitrc li trovo su /etc/X11/xinit/.xinitrc
la wiki-it dice ~/.xinitrc ed ho trovato difficoltà anche con l'opzione di cp speciale per i file nascosti.

Installo e reinstallo perché devo imparare bene :P
ma con questa ultima installazione, mi sono accorto che ci sono solo rari casi di irreversibilità!
Questa volta ho avviato solo gnome senza un DE e stesso problema.

Come dicono entrambe le wiki en / it , ho editato esattamente solo tre file:
vconsole.conf, locale.conf, locale.gen

non ho questo file nano /etc/rc.conf
aprirò sull'angolo del Newbie una discussione..

anche questa volta.. (sono in fase di configurazione)
sistema operativo/file manager in italiano (anche console) ma terminale, leafpad, menu (le poche cose installate) sono in americano.
si parla di imput di tastiera.
:mrgreen: non ho pasticciato , mancano proprio i file.

VenereNera
Little John
Messaggi: 952
Iscritto il: 20 dicembre 2012, 19:50

Re: [Risolto] LXDE (installazione) tasto tilde ~

Messaggio da VenereNera » 17 dicembre 2017, 23:55

Usa le pagine del wiki in inglese perché i contenuti nelle pagine ITA sono spesso obsoleti. Puoi usare il wiki in ITA per sommi capi (tanto per essere indirizzato), ma le procedure, comandi eccecc rigorosamente dal wiki inglese.
Il file xinitrc non sta più in /etc/skel/.xinitrc ma in /etc/X11/xinit/xinitrc.
Il file /etc/rc.conf in Arch non si usa dal lontano Gennaio 2013 (Openrc a parte) da quando si è passati a Systemd, non so se rendo...

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: [Risolto] LXDE (installazione) tasto tilde ~

Messaggio da TheSaint » 18 dicembre 2017, 6:20

Chiudo
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Bloccato