Grub non aggiunge altre partizioni

Problemi e suggerimenti legati all'installazione di Arch Linux
Rispondi
Zar Marco
Arciere Provetto
Messaggi: 630
Iscritto il: 29 dicembre 2015, 11:34
Architettura: x86_64 (64bit)

Grub non aggiunge altre partizioni

Messaggio da Zar Marco » 25 novembre 2017, 11:35

Ciao ragazzi, apro questa discussione per un non-problema, mi spiego, la wiki recita così :https://imgur.com/xDDwxgm
Io l'ho letto dopo, quindi, purtroppo ho partizionato con cfdisk.
Ora, ho la Root su ssd ed ho grub2. In installazione ho avuto seri problemi con pacstrap, falliva l'installazione su new root, ma poi sono riuscito, ma credo che il problema derivi da quello.
Premetto che per ora funziona tutto bene, apparte che systemd non mi riconosce network manager, l'ho installato ma quando vado di systemctl enable NetworkManager mi dice servizio inesistente.
Il problema sorge quando ho provato ad installare gentoo in dualboot con arch. Completo l'installazione, ma poi non riesco ad aggiornare grub per fargli riconoscere entrambi i sistemi. Senza reinstallare non ho modo di ovviare a questo "problema" giusto?
Ultima modifica di Zar Marco il 25 novembre 2017, 12:12, modificato 1 volta in totale.
Lenovo Legion Y520 Intel i7 7700HQ 8Gb ram arch(x86_64)+plasma5+i3wm
Macbook pro intel core 2duo 8gb di ram arch(x86_64)+i3wm

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Usato cfdisk per il partizionamento

Messaggio da TheSaint » 25 novembre 2017, 11:54

Il titolo è ambiguo. Mi par di capire che il problema è con il dual boot. A dispetto della distro, per un buon risultato entrambe necessitano di os-probe.
Provalo e poi prova a generare il grub.cfg.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Zar Marco
Arciere Provetto
Messaggi: 630
Iscritto il: 29 dicembre 2015, 11:34
Architettura: x86_64 (64bit)

Re: Usato cfdisk per il partizionamento

Messaggio da Zar Marco » 25 novembre 2017, 12:11

Metto un titolo più specifico.
Comunque, chiaramente ho os prober su entrambi , lo lancio, riconosce entrambi gli OS, do mkconfig -o /boot/grub/grub.cfg, rileva tutte le partizioni, quindi in teoria le ha scritte, riavvio e nulla, presente solo arch.
Stavo pensando di sostituire grub, visto che da quello che ho capito, il problema lo dovrebbe fare solo con esso. Ma con cosa potrei sostituirlo?
Lenovo Legion Y520 Intel i7 7700HQ 8Gb ram arch(x86_64)+plasma5+i3wm
Macbook pro intel core 2duo 8gb di ram arch(x86_64)+i3wm

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Grub non aggiunge altre partizioni

Messaggio da 4javier » 25 novembre 2017, 12:43

Non è che stai modificando il grub.cfg di gentoo, ma poi lo stage1 lancia quello di arch?
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Zar Marco
Arciere Provetto
Messaggi: 630
Iscritto il: 29 dicembre 2015, 11:34
Architettura: x86_64 (64bit)

Re: Grub non aggiunge altre partizioni

Messaggio da Zar Marco » 25 novembre 2017, 13:03

Allora, io ho prima installato arch, poi da arch, tramite chroot ho provato ad installare gentoo, ho provato ad aggiornare il grub di arch, da un secondo terminale, e mi trova tutti e due, sempre da quel terminale, quindi in arch, provo a configurare grub, di arch, con grub-mkconfig, trova i due OS, dice di aver aggiornato il file grub.cfg, ma in realtà non lo fa, oppure successivamente grub se ne frega e mi fa vedere solo arch all'avvio. Per questo credo che il problema sia stato nell'usare cfdisk
Lenovo Legion Y520 Intel i7 7700HQ 8Gb ram arch(x86_64)+plasma5+i3wm
Macbook pro intel core 2duo 8gb di ram arch(x86_64)+i3wm

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Grub non aggiunge altre partizioni

Messaggio da TheSaint » 25 novembre 2017, 15:20

Mi par ovvio che sia da farsi da root.
Ad ogni modo posta le informazioni riguardo al risultato del grub-mkconfig che il /boot/grub/grub.cfg. Poi fare attenzione che se usi UEFI vada a finire nella ESP.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Zar Marco
Arciere Provetto
Messaggi: 630
Iscritto il: 29 dicembre 2015, 11:34
Architettura: x86_64 (64bit)

Re: Grub non aggiunge altre partizioni

Messaggio da Zar Marco » 25 novembre 2017, 17:04

Appena riesco, nei prossimi giorni proverò a reinstallare gentoo e posterò il risultato. Chiaramente lo faccio da Root. Sì, son in uefi e la partizione di boot ha il flag boot ed esp
Lenovo Legion Y520 Intel i7 7700HQ 8Gb ram arch(x86_64)+plasma5+i3wm
Macbook pro intel core 2duo 8gb di ram arch(x86_64)+i3wm

Rispondi