BIOS, GPT e GRUB non esegue il boot

Problemi e suggerimenti legati all'installazione di Arch Linux
Rispondi
mattia
Arciere
Messaggi: 170
Iscritto il: 10 febbraio 2010, 13:59
Località: Brescia

BIOS, GPT e GRUB non esegue il boot

Messaggio da mattia » 29 novembre 2013, 11:59

Ciao a tutti,
voglio installare Arch su una macchina virtuale VMware workstation.
Ho seguito i passi descritti nella guida https://wiki.archlinux.org/index.php/Gu ... incipianti che riassumo nella lista qui sotto.
Il succo della questione è questo: voglio installare in una VM con un disco da 20 GB arch con 3 partizioni per i Boot, Swap e Root utilizzando GPT al posto di MBR (perchè voglio provarlo).
Il fatto è che dopo aver installato grub alla fine riavvio e il boot non parte!
Questi sono i passi fatti (lo spazio lasciato a sinistra indica che ciò che segue è un comando! ):

- Caricare la mappa della tastiera in Italiano
loadkeys it
- In questo caso ho deciso di utilizzare GPT
gdisk /dev/sda
o
(linux boot) n -> partition number: 1 -> first sector: 2048 -> last sector(2048x128): 262143 -> ef02 ## tra i 100 e 200 MiB
(linux swap) n -> partition number: 2 -> first sector: 262144 -> last sector: 524287 -> 8200
(linux root dir) n -> partition number: 3 -> first sector: 524288 -> last sector: XXXX -> 8300
x -> 1 (selezionare boot partition) -> 2 (rendere la partizione bootable)
w
- formatto le partizioni
mkswap /dev/sda2
swapon /dev/sda2
mkfs.ext4 /dev/sda3
mkfs.ext3 /dev/sda1
- Monto le partizioni
mount /dev/sda3 /mnt
mkdir /mnt/boot
mount /dev/sda1 /mnt/boot
- Aggiorno la lista dei mirror /etc/pacman.d/mirrorlist
Come indicato, dopo ogni modifica dei mirror, forzo l'aggiornamento
pacman -Syy
- Verifico che l'orario del sistema sia corretto con
cal
- Procedo all'installazione dei pacchetti "base"
pacstrap -i /mnt base
- Terminata l'installazione avremo un sistema base. Passiamo alla creazione del file "fstab"
genfstab -U -p /mnt >> /mnt/etc/fstab
- Eseguo il chroot nel nuovo sistema
arch-chroot /mnt
- Impostare i "Locale" modificando il file /etc/locale.gen nel modo opportuno.
Nel nostro caso decommentare la riga
# it_IT.UTF-8 UTF-8
- Creare il file /etc/locale.conf per definire
# LANG="it_IT.UTF-8"
# LC_COLLATE="C"
- Inoltre per evitare che l'impostazione LC_COLLATE="C" venga sovrascritta da LC_ALL imposto
in /etc/profile il valore della variabile a LC_ALL=
Generare i locali con
locale-gen
- Definisco la mappatura della tastiera e lo stile del font in /etc/vconsole.conf
# loadkeys it
# setfont Lat2-Terminus16
- Impostare la Time Zone
ln -s /usr/share/zoneinfo/Europe/Rome /etc/localtime
- Installiamo NTP in modo da sincronizzare gli orologi
pacman -S ntp
aggiorniamo l'ora
ntpd -qg
- Imposto la password di root
passwd
- Passiamo ora all'installazione del boot loader (GRUB nel nostro caso)
pacman -S grub
grub-install --target=i386-pc --debug --force /dev/sda1
- Passiamo alla creazione del file di configurazione di grub
Editiamo i parametri del file /etc/default/grub
# GRUB_GFXMODE=auto ## oppure impostare =auto, oppure nel caso non funzioni lanciare il comando "hwinfo --framebuffer" o dal prompt di grub "vbeinfo", dopo aver caricato il modulo vbe.
# GRUB_GFXPAYLOAD_LINUX=keep
# GRUB_COLOR_NORMAL="light-blue/black"
# GRUB_COLOR_HIGHLIGHT="light-cyan/blue"
# GRUB_DEFAULT=saved
# GRUB_SAVEDEFAULT=true
Infine salviamo le modifiche
grub-mkconfig -o /boot/grub/grub.cfg
- Configuriamo l'hostname in /etc/hostname
archtest
- Usciamo dall'ambiente di chroot
exit
- Procediamo allo smontamento delle partizioni
umount /mnt /mnt/boot
- Riavviare il pc e smontare il supporto di installazione
reboot


Aiutatemi vi prego, non so dove sbattere la testa :|

Grazie

Avatar utente
TheSaint
Robin Hood
Messaggi: 7959
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: BIOS, GPT e GRUB non esegue il boot

Messaggio da TheSaint » 29 novembre 2013, 16:55

mattia ha scritto: - formatto le partizioni

Codice: Seleziona tutto

	mkswap /dev/sda2
	swapon /dev/sda2
	mkfs.ext4 /dev/sda3
	mkfs.ext3 /dev/sda1
Mi risulta che la partizione EFI è da formattare in FAT32/16/12 e non ext3. Altrimenti il BIOS (forse virtuale) non vede il programma grubx64.efi che serve per avviare il kernel.
Ci potrebbe una seconda opzione che non usa grub ed avvii il kernel immediatamente. Prova a leggere il wiki
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

mattia
Arciere
Messaggi: 170
Iscritto il: 10 febbraio 2010, 13:59
Località: Brescia

Re: BIOS, GPT e GRUB non esegue il boot

Messaggio da mattia » 29 novembre 2013, 17:09

Grazie per la risposta.

Solo una cosa volevo farti notare, il ho un laptop su cui ho installato VMware workstation e su cui sto facendo queste prove.
La tipologia di BIOS è Legacy non UEFI.

Sto cercando di utilizzare GPT con BIOS tradizionale

Vedo se il problema è la tipologia di filesystem con cui ho formattato la partizione di boot...

Avatar utente
TheSaint
Robin Hood
Messaggi: 7959
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: BIOS, GPT e GRUB non esegue il boot

Messaggio da TheSaint » 29 novembre 2013, 17:19

Scusa, non riesco a percepire una cosa. Se la tua installazione è o meno in virtuale.
Se l' installazione è virtuale non credo sia un vincolo quello che realmente è la formattazione dell' HD reale, importa solo il file immagine di HD virtuale.
Il BIOS virtuale dovrebbe comportarsi in maniera simile a quello reale, quindi con un tipo di avvio UEFI, la partizione che contiene i dati dei bootloaders deve essere di tipo FAT32 e col flag ef00. vedi il wiki
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

mattia
Arciere
Messaggi: 170
Iscritto il: 10 febbraio 2010, 13:59
Località: Brescia

Re: BIOS, GPT e GRUB non esegue il boot

Messaggio da mattia » 3 dicembre 2013, 17:09

Questo è quello che volevo fare
Se si dispone di una scheda madre BIOS (o si ha intenzione di avviare la macchina in modalità di compatibilità BIOS) e si desidera installare GRUB con partizionamento GPT, allora avete bisogno di creare una partizione extra (BIOS Boot Partition)) della grandezza di 1007 KiB e come tipo EF02. Si veda. Syslinux non ne ha bisogno.
Ed è descritto qui
https://wiki.archlinux.org/index.php/Gu ... zionamento

L'installazione è in virtuale grazie a VMware Workstation

Avatar utente
TheSaint
Robin Hood
Messaggi: 7959
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: BIOS, GPT e GRUB non esegue il boot

Messaggio da TheSaint » 3 dicembre 2013, 17:17

Posta

Codice: Seleziona tutto

 sudo gdisk -l  /dev/sda
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

mattia
Arciere
Messaggi: 170
Iscritto il: 10 febbraio 2010, 13:59
Località: Brescia

Re: BIOS, GPT e GRUB non esegue il boot

Messaggio da mattia » 3 dicembre 2013, 17:22

Eccoti in allegato il file
arch.png
arch.png (8.14 KiB) Visto 4491 volte
PS: Sto procedendo alla riformattazione della partizione di boot /dev/sda1 in fat32. Voglio vedere se cambia qualcosa..

Avatar utente
TheSaint
Robin Hood
Messaggi: 7959
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: BIOS, GPT e GRUB non esegue il boot

Messaggio da TheSaint » 6 dicembre 2013, 17:26

Di sicuro funzionerà e dovrai popolarla degli applicativi di avvio. A scelta un bootloader come grub o addirittura il kernel direttamente, che però è ostico aggiungere i comandi alla linea del kernel.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

mattia
Arciere
Messaggi: 170
Iscritto il: 10 febbraio 2010, 13:59
Località: Brescia

Re: BIOS, GPT e GRUB non esegue il boot

Messaggio da mattia » 9 dicembre 2013, 14:05

Bah..
Rimango perplesso.. Giorni fà avevo tentato di formattare in fat32 la partizione di boot ma avevo ricevuto l'errore che mi avvertiva che questa operazione non poteva essere effettuata perchè per formattare un disco in fat32 deve avere una dimensione minima di 512 MB (credo), mentre la mia era 200MB.
Così molto infastidito ho cancellato la VM.

Quello che ancora mi lascia di stucco è che più cerco di schiarirmi le idee, più si confondono!!
In questa guida https://wiki.archlinux.org/index.php/Pa ... _GPT_e_MBR addirittura si dice che la partizione di boot non deve essere formattata!
Nota:
Per eseguire l'avvio da un disco partizionato in GPT su un sistema basato su BIOS si deve creare, preferibilmente all'inizio del disco , una partizione BIOS di boot senza file system e con il tipo di partizione impostato come BIOS boot o come partizione bios_grub (codice gdisk di tipo EF02) per l'avvio da disco utilizzando GRUB. Per Syslinux, non è necessario creare questa partizione bios_grub, ma è necessario disporre della partizione /boot separata e abilitare l'attributo Legacy BIOS Bootable partition per quella partizione (usando gdisk).
Non ci capisco più nulla.. Quasi quasi torno a MBR

:(

mattia
Arciere
Messaggi: 170
Iscritto il: 10 febbraio 2010, 13:59
Località: Brescia

Re: BIOS, GPT e GRUB non esegue il boot

Messaggio da mattia » 10 dicembre 2013, 13:57

Ci sto provando ancora..
Questa volta non ho formattato la partizione di /boot e non l'ho montata sotto /mnt/boot in fase di installazione e questo è il risultato
arch2.png
arch2.png (10.76 KiB) Visto 4338 volte
Devo dire che però il sistema parte ( dopo aver ridenominato il file grub.cfg.examples.new in grub.cfg ), ma non sono convinto del fatto che la partizione di boot e anche quella di swap siano correttamente utilizzate/impostate.. (dato che non le trovo in df -h)
Credo che cosi com'è il boot è installato nella partizione di root /dev/sda2 e che quella di swap nemmeno sia configurata... o sbaglio?

Avatar utente
TheSaint
Robin Hood
Messaggi: 7959
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: BIOS, GPT e GRUB non esegue il boot

Messaggio da TheSaint » 10 dicembre 2013, 18:18

La swap la dovresti montare con la configurazione di /etc/fstab.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Rispondi