Kernel version 2.4.x requires old depmod

Problemi e discussioni inerenti al kernel e al supporto hardware in ambiente Linux
Rispondi
dren
Novello Arciere
Messaggi: 66
Iscritto il: 14 aprile 2009, 21:48

Messaggio da dren » 7 febbraio 2010, 17:36

Salve a tutti,
sono su un kernel 2.6.32 e sto cercando di compilare un vecchio 2.4.
Quando arrivo al make modules_install mi tira via l'errore in questione.
Cercando in rete pare che i nuovi kernel 2.6 utilizzino un depmod diverso e per i 2.4 c'e' bisogno di uno vecchio.
Alcuni hanno fixato creando un link simbolico da depmod a depmod.old o depmod.modutils ma non funge, credo sia proprio un problema di versioni.
Non ho trovato nei pacchetti archlinux (ne aur ne abs) una vecchia versione da poter installare.
Voi ne sapete qualcosa?

Rispondi