A stop job is running for Session 1 [pcmanfm]

Problemi e discussioni inerenti al kernel e al supporto hardware in ambiente Linux
Rispondi
gaglioffo
Arciere
Messaggi: 319
Iscritto il: 11 maggio 2016, 21:06

A stop job is running for Session 1 [pcmanfm]

Messaggio da gaglioffo » 25 marzo 2020, 12:58

ciao untori,
l'altro ieri ho aggiornato il sistema dopo un mese e ora si presenta un problema: spesso, ma non sempre, quando spengo il PC (con il comando "poweroff") mi dice "A stop job is running for Session 1" e per fermarsi ci mette un minuto e mezzo circa.

Come posso capire dov'è il problema?
Ultima modifica di gaglioffo il 8 aprile 2020, 19:14, modificato 1 volta in totale.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7919
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: A stop job is running for Session 1

Messaggio da TheSaint » 25 marzo 2020, 13:18

Non so se si può riparare, so che si può ridurre il tempo di attesa modificando in /etc/systemd/system.conf

Codice: Seleziona tutto

DefaultTimeoutStopSec=20s
Questo è il mio.
Magari lo puoi confrontare con un *.pacnew per capire le voci aggiunte.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

gaglioffo
Arciere
Messaggi: 319
Iscritto il: 11 maggio 2016, 21:06

Re: A stop job is running for Session 1

Messaggio da gaglioffo » 25 marzo 2020, 13:46

grazie, l'ho impostato a 5 secondi, vediamo se funziona.
non ho il "system.conf.pacnew" quindi era così anche prima.

Avatar utente
Dusty
Little John
Messaggi: 880
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: A stop job is running for Session 1

Messaggio da Dusty » 25 marzo 2020, 16:34

Io ho avuto per molto tempo questo problema.
Per me è stato risolutivo questo:
https://wiki.archlinux.org/index.php/Sy ... _on_logout

Avatar utente
TheSaint
Robin Hood
Messaggi: 7919
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: A stop job is running for Session 1

Messaggio da TheSaint » 28 marzo 2020, 1:20

@ Dusty,
Una bella informazione.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

ziomarco
Novello Arciere
Messaggi: 132
Iscritto il: 27 giugno 2009, 18:53

Re: A stop job is running for Session 1

Messaggio da ziomarco » 5 aprile 2020, 16:41

Ciao,
da qualche tempo ho anch'io lo stesso problema.
Ho ridotto il tempo di attesa con DefaultTimeoutStopSec, in questo modo l'attesa diventa accettabile... .
Ho anche provato la soluzione suggerita da Dusty, ma a me non ha funzionato, quindi mi e' venuto un dubbio: dopo aver decommentato e modificato la riga in /etc/systemd/logind.conf basta riavviare o bisogna fare qualche altra operazione?

Avatar utente
Dusty
Little John
Messaggi: 880
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: A stop job is running for Session 1

Messaggio da Dusty » 5 aprile 2020, 21:12

Sì, il riavvio è sufficiente.
Hai individuato il processo che ritarda?

ziomarco
Novello Arciere
Messaggi: 132
Iscritto il: 27 giugno 2009, 18:53

Re: A stop job is running for Session 1

Messaggio da ziomarco » 5 aprile 2020, 21:46

No, non ho idea di come identificarlo durante lo shutdown...
vedo solo il messaggio stop job is running for Session 1 of user marco
L'utente marco non e' privilegiato e la sessione che chiudo e' LXDE.
Se invece lo shutdown avviene con attivo solo root in text mode non c'è alcuno stop job

Avatar utente
Dusty
Little John
Messaggi: 880
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: A stop job is running for Session 1

Messaggio da Dusty » 5 aprile 2020, 23:54

Mi sembra uno scenario coerente.
Il processo appartiene all'utente connesso.
Se l'utente esce, tutti i suoi processi sono chiusi ordinatamente.
Se l'utenza è connessa quando parte lo shutdown, evidentemente la chiusura dei processi è meno ordinata e qualcuno resta appeso in attesa di un evento che non arriva mai.
Le indicazioni che abbiamo trovato servono a mitigare il problema ma non lo risolvono.

gaglioffo
Arciere
Messaggi: 319
Iscritto il: 11 maggio 2016, 21:06

Re: A stop job is running for Session 1

Messaggio da gaglioffo » 6 aprile 2020, 12:43

ho seguito i vostri consigli impostando "DefaultTimeoutStopSec=1s" in "/etc/systemd/system.conf" e
"KillUserProcesses=yes" in "/etc/systemd/logind.conf"

Ora il messaggio "A stop job is running for Session 1" c'è ancora ma si chiude subito.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7919
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: A stop job is running for Session 1

Messaggio da TheSaint » 7 aprile 2020, 7:33

Ma prova a vedere se hai qualche programma quando esci. Forse quelli non avviati da systemd. Oppure cerca un indizio nel journal.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

ziomarco
Novello Arciere
Messaggi: 132
Iscritto il: 27 giugno 2009, 18:53

Re: A stop job is running for Session 1

Messaggio da ziomarco » 7 aprile 2020, 19:45

Ho googlato parecchioe credo di aver trovato il colpevole...
riassumo il procedimento seguito, sperando di non dimenticare niente:

1) chiudere tutti i programmi aperti e aprire una console di root

2) modificare la voce "DefaultTimeoutStopSec" nel file "/etc/systemd/system.conf", impostandola ad un tempo molto lungo esempio a "600s".
in questo modo avremotempo per indagare...

3) abilitare una shell di emergenza con:

Codice: Seleziona tutto

# systemctl enable --now debug-shell
(nota: questa shell dovrà essere poi disattivata il prima possibile: otherwise your system has on tty9 an always enabled root shell without password, which might be considered as a vulnerability.)

4) eseguire:

Codice: Seleziona tutto

# systemctl list-jobs
che dovrebbe rispondere No jobs running

5) chiudere la console di root

6) spegnere come di consueto da utente normale

7) spostarsi su tty9 con Ctrl+Alt+F9 dove, anche se un po' disturbato dai messaggi dello shutdown, si possono eseguire comandi (purtroppo non e' bash ma sh)

8) eseguire nuovamente

Codice: Seleziona tutto

# systemctl list-jobs 
che adesso invece risponde:
session-1.scope running
che e' il nome del processo in attesa.

9) eseguire:

Codice: Seleziona tutto

# systemd-cgls -u session-1.scope
che elenca cosa c'e' di attivo in session-1: nel mio caso pcmanfm

10)eseguire :

Codice: Seleziona tutto

#  pkill --signal SIGKILL pcmanfm
appena eseguito pkill l'attesa termina e il pc si spegne....

A indagine terminata ricordarsi di disabilitare la console di emergenza con:

Codice: Seleziona tutto

# systemctl disable --now debug-shell
e riportare la voce "DefaultTimeoutStopSec" nel file "/etc/systemd/system.conf" a un valore accettabile

Avatar utente
TheSaint
Robin Hood
Messaggi: 7919
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: A stop job is running for Session 1

Messaggio da TheSaint » 8 aprile 2020, 5:47

Allora sto pcmanfm è sempre in background?
Hai magari una idea se ci sta per un determinato periodo e quindi si stacca?
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

enzolatina
Little John
Messaggi: 1149
Iscritto il: 6 ottobre 2007, 22:51
Architettura: x86_64 (64bit)
Località: belluno

Re: A stop job is running for Session 1

Messaggio da enzolatina » 8 aprile 2020, 7:25

io non ho mai installato pcmanfm eppure per un periodo pure io avevo quel messaggio e il tempo d'attesa prima che si spegnesse il pc...
Io non ho mai fatto alcunchè per risolvere, si è presentato ed è poi sparito per ritornare e sparire diverse volte, secondo me il problema sta nell'aggiornamento di qualche pacchetto che crea qualche tipo di interazione rognosa col sistema. Detto per inciso da circa 2 mesi da me non si presenta più....
noi siamo arch linux, ogni resistenza è inutile, sarete assimilati

gaglioffo
Arciere
Messaggi: 319
Iscritto il: 11 maggio 2016, 21:06

Re: A stop job is running for Session 1

Messaggio da gaglioffo » 8 aprile 2020, 13:09

ziomarco ha scritto:
7 aprile 2020, 19:45
Ho googlato parecchioe credo di aver trovato il colpevole...
riassumo il procedimento seguito, sperando di non dimenticare niente:
grazie ziomarco,
ho seguito la tua guida e anche da me il colpevole risulta pcmanfm! che in effetti uso spesso visto che è il mio file manager di default (non ho un DE, uso il solo openbox).
forse è un bug e dovremmo segnalarlo ai tipi di LXDE?

ziomarco
Novello Arciere
Messaggi: 132
Iscritto il: 27 giugno 2009, 18:53

Re: A stop job is running for Session 1

Messaggio da ziomarco » 8 aprile 2020, 14:21

il wiki spiega l'utilizzo di pcmanfm in modalita demone , credo per poter gestire montaggio/smontaggio per le unita esterne, tipo chiavette e dischi usb.
Dato che io uso LXDE pcmanfm e' anche il mio filemanager di default.
Ho escogitato un workaround che ha funzionato solo in parte:
per terminarlo al loguot ho messo in fondo al file ~/.xinitrc , dopo l'istruzione startlxde, una riga contenente:
pkill --signal SIGKILL pcmanfm
in questo modo finita l'esecuzione di startlxde (cioe quando viene dato il comando di logout) verra eseguito il pkill di pcmanfm e lo spegnimento avviene senza attesa.
Purtroppo pero', inspiegabilmente, il tutto funziona solo se lascio abilitata la "famosa" console di emergenza. Se la disabilito il trucco non funziona piu'...

Riguardo la segnalazione di bug: non ho la piu' pallida idea di come fare...

caruso spaonazzo
Arciere Provetto
Messaggi: 537
Iscritto il: 9 maggio 2017, 14:06

Re: A stop job is running for Session 1

Messaggio da caruso spaonazzo » 8 aprile 2020, 16:54

pcmanfm è buggato, tra l'altro non è aggiornato da anni
per me c'entra anche con questo problema che ho scritto qua: https://archlinux.it/forum/viewtopic.php?f=4&t=23047
peccato non esista un file manager migliore a mio avviso

gaglioffo
Arciere
Messaggi: 319
Iscritto il: 11 maggio 2016, 21:06

Re: A stop job is running for Session 1 [pcmanfm]

Messaggio da gaglioffo » 8 aprile 2020, 19:32

è vero, pcmanfm è pieno di bugs, spesso si chiude all'improvviso.
forse pcmanfm-qt è più aggiornato, però qt fa schifo:
https://github.com/lxqt/pcmanfm-qt

ziomarco
Novello Arciere
Messaggi: 132
Iscritto il: 27 giugno 2009, 18:53

Re: A stop job is running for Session 1 [pcmanfm]

Messaggio da ziomarco » 8 aprile 2020, 19:57

Correggo l'affermazione fatta nel mio post precedente: il workaround modificando xinitrc non funziona, ma ha funzionato rinominare xinitrc in xinitrc.bak, cioe' di fatto renderlo inefficace.
LXDE parte comunque, a tempo perso mi studiero' il wiki per capire da chi viene avviato se xinitrc non e' piu' disponibile, ma intanto la cosa importante e' che il ritardo nello shutdown e' sparito e il pc si spegne in un attimo,
come e' giusto che sia! :D
Mi sarebbe dispiaciuto rinunciare a pcmanfm perche a me ha sempre funzionato bene, diversamente, per chi non e' soddisfatto l'alternativa potrebbe essere thunar ;)

Rispondi