Errori ACPI al boot dopo installazione di linux-4.9.6-1

Problemi e discussioni inerenti al kernel e al supporto hardware in ambiente Linux
Rispondi
Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Errori ACPI al boot dopo installazione di linux-4.9.6-1

Messaggio da vda » 27 gennaio 2017, 18:54

Caio a tutti,

dopo aver installato il gruppo di pacchetti

Codice: Seleziona tutto

linux-4.9.6-1
linux-firmware-20161222.4b9559f-2  
linux-headers-4.9.6-1
linux-lts-headers-4.4.45-1
noto all'avvio dei messaggi di errore a carico di ACPI. In dettaglio:

Codice: Seleziona tutto

]$ dmesg | grep -i error
[    0.502736] ACPI Error: No handler for Region [RAM_] (ffff88015a0c0708) [EmbeddedControl] (20160831/evregion-166)
[    0.502745] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20160831/exfldio-299)
[    0.502751] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._REG] (Node ffff88015a0c1f78), AE_NOT_EXIST (20160831/psparse-543)
[    0.502888] ACPI Error: No handler for Region [RAM_] (ffff88015a0c0708) [EmbeddedControl] (20160831/evregion-166)
[    0.502893] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20160831/exfldio-299)
[    0.502897] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._REG] (Node ffff88015a0c1f78), AE_NOT_EXIST (20160831/psparse-543) 
Questi i messaggi del kernel per ACPI:

Codice: Seleziona tutto

$ dmesg | grep -i ACPI
[    0.000000] BIOS-e820: [mem 0x000000009cebf000-0x000000009cfbefff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x000000009cfbf000-0x000000009cffefff] ACPI data
[    0.000000] reserve setup_data: [mem 0x000000009cebf000-0x000000009cfbefff] ACPI NVS
[    0.000000] reserve setup_data: [mem 0x000000009cfbf000-0x000000009cffefff] ACPI data
[    0.000000] efi:  SMBIOS=0x9c743000  ESRT=0x9c84f018  ACPI 2.0=0x9cffe014 
[    0.000000] ACPI: Early table checksum verification disabled
[    0.000000] ACPI: RSDP 0x000000009CFFE014 000024 (v02 ACRSYS)
[    0.000000] ACPI: XSDT 0x000000009CFCD188 0000CC (v01 ACRSYS ACRPRDCT 00000001      01000013)
[    0.000000] ACPI: FACP 0x000000009CFF2000 00010C (v05 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: DSDT 0x000000009CFDA000 011529 (v02 ACRSYS ACRPRDCT 00000000 1025 00040000)
[    0.000000] ACPI: FACS 0x000000009CFB8000 000040
[    0.000000] ACPI: UEFI 0x000000009CFFD000 000236 (v01 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: UEFI 0x000000009CFFC000 000042 (v01 ACRSYS ACRPRDCT 00000000 1025 00040000)
[    0.000000] ACPI: SSDT 0x000000009CFF8000 0031AA (v01 ACRSYS ACRPRDCT 00001000 1025 00040000)
[    0.000000] ACPI: MSDM 0x000000009CFF7000 000055 (v03 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: ASF! 0x000000009CFF6000 0000A5 (v32 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: ASPT 0x000000009CFF5000 000034 (v07 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: BOOT 0x000000009CFF4000 000028 (v01 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: DBGP 0x000000009CFF3000 000034 (v01 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: HPET 0x000000009CFF1000 000038 (v01 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: LPIT 0x000000009CFF0000 000094 (v01 ACRSYS ACRPRDCT 00000000 1025 00040000)
[    0.000000] ACPI: APIC 0x000000009CFEF000 00008C (v03 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: MCFG 0x000000009CFEE000 00003C (v01 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: WDAT 0x000000009CFED000 000224 (v01 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: SSDT 0x000000009CFD8000 0013C4 (v02 ACRSYS ACRPRDCT 00001000 1025 00040000)
[    0.000000] ACPI: SSDT 0x000000009CFEC000 000539 (v02 ACRSYS ACRPRDCT 00003000 1025 00040000)
[    0.000000] ACPI: SSDT 0x000000009CFD7000 000B74 (v02 ACRSYS ACRPRDCT 00003000 1025 00040000)
[    0.000000] ACPI: SSDT 0x000000009CFD1000 005CEB (v02 ACRSYS ACRPRDCT 00003000 1025 00040000)
[    0.000000] ACPI: DMAR 0x000000009CFD0000 0000B0 (v01 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: FPDT 0x000000009CFCF000 000044 (v01 ACRSYS ACRPRDCT 00000002 1025 00040000)
[    0.000000] ACPI: BGRT 0x000000009CFCE000 000038 (v01 ACRSYS ACRPRDCT 00000001 1025 00040000)
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: PM-Timer IO Port: 0x1808
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    0.000000] ACPI: IRQ0 used by override.
[    0.000000] ACPI: IRQ9 used by override.
[    0.000000] Using ACPI (MADT) for SMP configuration information
[    0.000000] ACPI: HPET id: 0x8086a201 base: 0xfed00000
[    0.000037] ACPI: Core revision 20160831
[    0.018687] ACPI: 6 ACPI AML tables successfully acquired and loaded
[    0.449664] PM: Registering ACPI NVS region [mem 0x9cebf000-0x9cfbefff] (1048576 bytes)
[    0.480733] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
[    0.480734] ACPI: bus type PCI registered
[    0.480735] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[    0.497654] ACPI: Added _OSI(Module Device)
[    0.497655] ACPI: Added _OSI(Processor Device)
[    0.497656] ACPI: Added _OSI(3.0 _SCP Extensions)
[    0.497657] ACPI: Added _OSI(Processor Aggregator Device)
[    0.498269] ACPI: Executed 17 blocks of module-level executable AML code
[    0.502736] ACPI Error: No handler for Region [RAM_] (ffff88015a0c0708) [EmbeddedControl] (20160831/evregion-166)
[    0.502745] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20160831/exfldio-299)
[    0.502751] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._REG] (Node ffff88015a0c1f78), AE_NOT_EXIST (20160831/psparse-543)
[    0.502888] ACPI Error: No handler for Region [RAM_] (ffff88015a0c0708) [EmbeddedControl] (20160831/evregion-166)
[    0.502893] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20160831/exfldio-299)
[    0.502897] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._REG] (Node ffff88015a0c1f78), AE_NOT_EXIST (20160831/psparse-543)
[    0.505227] ACPI: Dynamic OEM Table Load:
[    0.505237] ACPI: SSDT 0xFFFF8801592A7000 0003D3 (v02 PmRef  Cpu0Cst  00003001 INTL 20130117)
[    0.505699] ACPI: Dynamic OEM Table Load:
[    0.505709] ACPI: SSDT 0xFFFF880159110800 0005AA (v02 PmRef  ApIst    00003000 INTL 20130117)
[    0.506185] ACPI: Dynamic OEM Table Load:
[    0.506193] ACPI: SSDT 0xFFFF880159230E00 000119 (v02 PmRef  ApCst    00003000 INTL 20130117)
[    0.507562] ACPI : EC: EC started
[    0.614278] ACPI: \_SB_.PCI0.LPCB.EC0_: Used as first EC
[    0.614280] ACPI: \_SB_.PCI0.LPCB.EC0_: GPE=0x2f, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.614281] ACPI: \_SB_.PCI0.LPCB.EC0_: Used as boot DSDT EC to handle transactions
[    0.614282] ACPI: Interpreter enabled
[    0.614325] ACPI: (supports S0 S3 S4 S5)
[    0.614326] ACPI: Using IOAPIC for interrupt routing
[    0.614363] PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
[    0.614428] ACPI: watchdog: Failed to create platform device
[    0.614970] ACPI: Power Resource [PG00] (on)
[    0.615444] ACPI: Power Resource [PG01] (on)
[    0.615896] ACPI: Power Resource [PG02] (on)
[    0.678839] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-fe])
[    0.678845] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
[    0.679819] acpi PNP0A08:00: _OSC: OS now controls [PCIeHotplug PME AER PCIeCapability]
[    0.679820] acpi PNP0A08:00: FADT indicates ASPM is unsupported, using BIOS configuration
[    0.681875] pci 0000:00:14.0: System wakeup disabled by ACPI
[    0.682622] pci 0000:00:1b.0: System wakeup disabled by ACPI
[    0.683004] pci 0000:00:1c.0: System wakeup disabled by ACPI
[    0.683387] pci 0000:00:1c.3: System wakeup disabled by ACPI
[    0.685198] pci 0000:00:1d.0: System wakeup disabled by ACPI
[    0.686961] pci 0000:01:00.0: System wakeup disabled by ACPI
[    0.695243] pci 0000:02:00.0: System wakeup disabled by ACPI
[    0.706030] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[    0.706080] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[    0.706128] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[    0.706174] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[    0.706221] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[    0.706268] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[    0.706314] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[    0.706360] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[    0.706653] ACPI: Enabled 6 GPEs in block 00 to 7F
[    0.706709] ACPI : EC: event unblocked
[    0.706716] ACPI: \_SB_.PCI0.LPCB.EC0_: GPE=0x2f, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.706717] ACPI: \_SB_.PCI0.LPCB.EC0_: Used as boot DSDT EC to handle transactions and events
[    0.738504] PCI: Using ACPI for IRQ routing
[    0.752581] pnp: PnP ACPI init
[    0.752801] system 00:00: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.752855] pnp 00:01: Plug and Play ACPI device, IDs PNP0b00 (active)
[    0.752899] system 00:02: Plug and Play ACPI device, IDs INT3f0d PNP0c02 (active)
[    0.752987] pnp 00:03: Plug and Play ACPI device, IDs PNP0303 (active)
[    0.753463] system 00:04: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.754056] system 00:05: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.754294] pnp: PnP ACPI: found 6 devices
[    0.760347] clocksource: acpi_pm: mask: 0xffffff max_cycles: 0xffffff, max_idle_ns: 2085701024 ns
[    0.938501] ACPI: bus type USB registered
[    2.849199] ACPI: Lid Switch [LID0]
[    2.849233] ACPI: Sleep Button [SLPB]
[    2.849262] ACPI: Power Button [PWRF]
[    2.919115] ACPI: Battery Slot [BAT0] (battery present)
[    2.923071] ACPI: AC Adapter [ADP1] (off-line)
[    2.928559] ACPI: Thermal Zone [TZS0] (30 C)
[    2.928695] ACPI: Thermal Zone [TZS1] (37 C)
[    2.971572] acer_wmi: Acer Laptop ACPI-WMI Extras
[    3.078768] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
E questi infine i moduli kernel caricati, sempre per ACPI

Codice: Seleziona tutto

$ lsmod | grep -i acpi
acpi_als               16384  0
kfifo_buf              16384  1 acpi_als
industrialio           53248  2 acpi_als,kfifo_buf
snd_soc_sst_acpi       16384  0
snd_soc_sst_match      16384  1 snd_soc_sst_acpi
acpi_pad               20480  0
sdhci_acpi             16384  0
sdhci                  40960  1 sdhci_acpi
mmc_core              122880  3 rtsx_usb_sdmmc,sdhci,sdhci_acpi
A regime però non noto particolari problemi e le prestazioni sembrano le stesse di sempre.

Avete idea di cosa possa trattarsi?

Grazie anticipatamente,

8)
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Re: Errori ACPI al boot dopo installazione di linux-4.9.6-1

Messaggio da vda » 27 gennaio 2017, 20:10

Ho provato a fare il downgrade del kernel alla precedente versione 4.8.8-2

Codice: Seleziona tutto

$ sudo pacman -U linux-4.8.8-2-x86_64.pkg.tar.xz
e gli errori in effetti scompaiono.

La responsabilità è quindi evidentemente del nuovo kernel.

D'altra parte ne parlano anche altrove (vd. https://bbs.archlinux.org/viewtopic.php?id=222410)

8)
Ultima modifica di vda il 29 gennaio 2017, 18:49, modificato 1 volta in totale.
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

zorro62
Arciere
Messaggi: 320
Iscritto il: 26 aprile 2011, 18:07

Re: Errori ACPI al boot dopo installazione di linux-4.9.6-1

Messaggio da zorro62 » 28 gennaio 2017, 14:17

ho lo stesso problema,ma in più non si avvia,quindi sono dovuto tornare al kernel 4.8.13-1,qualcuno sa si ci saranno correzioni o devo bloccare il kernel in pacman.conf
grazie!
succede sia xfce non uefi,sia in mate con system-boot!
archlinux-xfce,archlinux.mate

Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Re: Errori ACPI al boot dopo installazione di linux-4.9.6-1

Messaggio da vda » 28 gennaio 2017, 14:59

Ho dato una occhiata in giro, ma al momento non vedo soluzioni. Credo quindi che per ora sia opportuno fare il downgrade del kernel.

8)
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

allinone
Arciere
Messaggi: 176
Iscritto il: 5 aprile 2014, 12:16
Architettura: x86_64 (64bit)

Re: Errori ACPI al boot dopo installazione di linux-4.9.6-1

Messaggio da allinone » 29 gennaio 2017, 18:04

Anche a me è successo qualcosa dopo l'installazione del kernel 4.9.6-1.

Codice: Seleziona tutto

$ dmesg -l err
[    0.669948] platform wdat_wdt: failed to claim resource 4
[    0.670034] ACPI: watchdog: Failed to create platform device
[   12.387501] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
[  707.927536] pciehp 0000:00:1c.1:pcie004: Device 0000:02:00.0 already exists at 0000:02:00, cannot hot-add
[  707.927540] pciehp 0000:00:1c.1:pcie004: Cannot add device at 0000:02:00
[  708.550567] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
La macchina sembra non risentire di nulla, il bluetooth non l'ho mai usato.

Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Re: Errori ACPI al boot dopo installazione di linux-4.9.6-1

Messaggio da vda » 29 gennaio 2017, 19:00

In questa discussione https://bbs.archlinux.org/viewtopic.php?id=222409 si dice che il problema era già presente, ma non manifesto, nei precedenti rilasci e che sono comunque previste patch per le prossime versioni del kernel.

In ogni caso, a parte il disturbo di vedere al boot la segnalazione di errori, non noto problemi significativi nelle performance della macchina.

8)
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Re: Errori ACPI al boot dopo installazione di linux-4.9.6-1

Messaggio da vda » 7 febbraio 2017, 8:44

Ho appena aggiornato il kernel alla versione 4.9.7-1, ma ancora noto lo stesso problema.

8)
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

zorro62
Arciere
Messaggi: 320
Iscritto il: 26 aprile 2011, 18:07

Re: Errori ACPI al boot dopo installazione di linux-4.9.6-1

Messaggio da zorro62 » 7 febbraio 2017, 9:51

gli errori su acpi cerano anche prima solo che non li vedevi quando botavi!
almeno ora mi riparte tutto ,per lo meno xfce4,sabato vedro con mate!
archlinux-xfce,archlinux.mate

Rispondi