[Risolto] erore aggiornamenti nvidia-libgl

Problemi e discussioni inerenti al kernel e al supporto hardware in ambiente Linux
Rispondi
Avatar utente
toposodo
Novello Arciere
Messaggi: 52
Iscritto il: 30 gennaio 2013, 16:52

[Risolto] erore aggiornamenti nvidia-libgl

Messaggio da toposodo » 8 marzo 2014, 17:26

dando il comando pacman -Syu ho il seguente errore:

Codice: Seleziona tutto

 Vuoi procedere con l'installazione? [S/n] 
:: Download dei pacchetti in corso...
 linux-3.13.6-1-x86_64                                                                                 50,6 MiB   205K/s 04:13 [#############################################################################] 100%
(67/67) verifica delle chiavi presenti nel portachiavi                                                                         [#############################################################################] 100%
(67/67) verifica dell'integrità dei pacchetti                                                                                  [#############################################################################] 100%
(67/67) caricamento dei file dei pacchetti                                                                                     [#############################################################################] 100%
(67/67) controllo dei conflitti in corso                                                                                       [#############################################################################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
nvidia-libgl: /usr/lib/libEGL.so è già presente nel filesystem
nvidia-libgl: /usr/lib/libEGL.so.1 è già presente nel filesystem
nvidia-libgl: /usr/lib/libGLESv1_CM.so è già presente nel filesystem
nvidia-libgl: /usr/lib/libGLESv1_CM.so.1 è già presente nel filesystem
nvidia-libgl: /usr/lib/libGLESv2.so è già presente nel filesystem
nvidia-libgl: /usr/lib/libGLESv2.so.2 è già presente nel filesystem
libspnav: /usr/lib/libspnav.so.0 è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
Avete idee su come risolvere?
Grazie
Ultima modifica di veleno77 il 9 marzo 2014, 2:49, modificato 1 volta in totale.
Motivazione: Problema Risolto con aggiornamento del 8/3/2014

Avatar utente
francesco_dem
Arciere
Messaggi: 234
Iscritto il: 17 maggio 2013, 17:05
Architettura: x86_64 (64bit)

Impossibile aggiornare nvidia-libgl è gia presente

Messaggio da francesco_dem » 8 marzo 2014, 19:10

Scusate se sono nuovamente qui a chiedere, vi posto il mio nuovo problema

Codice: Seleziona tutto

[francesco@francescopc ~]$ sudo pacman -Syu
[sudo] password for francesco: 
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community-testing          7,7 KiB   638K/s 00:00 [######################] 100%
 community è aggiornato
 archlinuxfr è aggiornato
 multilib è aggiornato
:: Aggiornamento del sistema in corso...
attenzione: wine: l'aggiornamento del pacchetto è stato ignorato (1.7.12-2 => 1.7.14-1)
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...

Pacchetti (5): linux-3.13.6-1  linux-headers-3.13.6-1  nvidia-libgl-334.21-3
               nvidia-utils-334.21-3  python2-setuptools-3.1-1

Dimensione totale dei pacchetti da installare:   218,13 MiB
Dimensione netta dell'aggiornamento:             39,78 MiB

:: Vuoi procedere con l'installazione? [S/n] s
(5/5) verifica delle chiavi presenti nel porta...  [######################] 100%
(5/5) verifica dell'integrità dei pacchetti        [######################] 100%
(5/5) caricamento dei file dei pacchetti           [######################] 100%
(5/5) controllo dei conflitti in corso             [######################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
nvidia-libgl: /usr/lib/libEGL.so è già presente nel filesystem
nvidia-libgl: /usr/lib/libEGL.so.1 è già presente nel filesystem
nvidia-libgl: /usr/lib/libGLESv1_CM.so è già presente nel filesystem
nvidia-libgl: /usr/lib/libGLESv1_CM.so.1 è già presente nel filesystem
nvidia-libgl: /usr/lib/libGLESv2.so è già presente nel filesystem
nvidia-libgl: /usr/lib/libGLESv2.so.2 è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
Non ho il paccheto nvidia, ma nvidia-dmks

Codice: Seleziona tutto

[francesco@francescopc ~]$ sudo pacman -Qi nvidia-dkms
[sudo] password for francesco: 
Nome           : nvidia-dkms
Versione       : 334.21-1
Descrizione    : NVIDIA kernel module sources (DKMS)
Architettura   : x86_64
URL            : http://www.nvidia.com/
Licenze        : custom
Gruppi         : Nessuno
Fornisce       : nvidia=334.21  nvidia-uvm=334.21
Dipende da     : bash  dkms  nvidia-utils=334.21
Dip. opzionali : linux-headers: Build the module against Arch kernel[installato]
                 linux-lts-headers: Build the module against LTS Arch kernel
Richiesto da   : nvidia-hook
Opzionale per : Nessuno
Conflitti con  : nvidia  nvidia-304xx-dkms
Sostituisce    : Nessuno
Kb richiesti : 15142,00 KiB
Autore         : Unknown Packager
Creato il      : sab 08 mar 2014 18:35:00 CET
Installato il  : sab 08 mar 2014 18:35:26 CET
Motivo         : Installato come dipendenza di un altro pacchetto
Script install : Sì
Convalidato da : Nessuno


Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: erore aggiornamenti nvidia-libgl

Messaggio da 4javier » 8 marzo 2014, 19:27

https://bugs.archlinux.org/task/39219

EDIT
uniti i due thread.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Re: erore aggiornamenti nvidia-libgl

Messaggio da veleno77 » 8 marzo 2014, 20:59

dovrebbero aver risolto il problema oggi, provate a riaggiornare:

Codice: Seleziona tutto

:: Download dei pacchetti in corso...
 linux-3.13.6-1-i686                                                                                      49,5 MiB   910K/s 00:56 [------------------------------------------------------------------------------] 100%
 mesa-10.1.0-2-i686                                                                                        4,2 MiB  1162K/s 00:04 [------------------------------------------------------------------------------] 100%
 nvidia-utils-334.21-3-i686                                                                               21,4 MiB  1106K/s 00:20 [------------------------------------------------------------------------------] 100%
 nvidia-libgl-334.21-3-i686                                                                             1380,0   B  0,00B/s 00:00 [------------------------------------------------------------------------------] 100%
 python2-setuptools-3.1-1-any                                                                            311,8 KiB  1072K/s 00:00 [------------------------------------------------------------------------------] 100%
 kdeconnect-0.5.1-1-i686                                                                                 269,0 KiB   947K/s 00:00 [------------------------------------------------------------------------------] 100%
(12/12) verifica delle chiavi presenti nel portachiavi                                                                            [------------------------------------------------------------------------------] 100%
(12/12) verifica dell'integrità dei pacchetti                                                                                     [------------------------------------------------------------------------------] 100%
(12/12) caricamento dei file dei pacchetti                                                                                        [------------------------------------------------------------------------------] 100%
(12/12) controllo dei conflitti in corso                                                                                          [------------------------------------------------------------------------------] 100%
(12/12) controllo dello spazio disponibile sul disco                                                                              [------------------------------------------------------------------------------] 100%
( 1/12) aggiornamento in corso di libcups                                                                                         [------------------------------------------------------------------------------] 100%
( 2/12) aggiornamento in corso di systemd                                                                                         [------------------------------------------------------------------------------] 100%
( 3/12) aggiornamento in corso di cups                                                                                            [------------------------------------------------------------------------------] 100%
( 4/12) aggiornamento in corso di kdeconnect                                                                                      [------------------------------------------------------------------------------] 100%
( 5/12) aggiornamento in corso di linux                                                                                           [------------------------------------------------------------------------------] 100%
>>> Updating module dependencies. Please wait ...
>>> Generating initial ramdisk, using mkinitcpio.  Please wait...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 3.13.6-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 3.13.6-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: smsmdtv
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
( 6/12) aggiornamento in corso di mesa                                                                                            [------------------------------------------------------------------------------] 100%
( 7/12) aggiornamento in corso di nvidia-utils                                                                                    [------------------------------------------------------------------------------] 100%
( 8/12) aggiornamento in corso di nvidia-libgl                                                                                    [------------------------------------------------------------------------------] 100%
( 9/12) aggiornamento in corso di python2-setuptools                                                                              [------------------------------------------------------------------------------] 100%
(10/12) aggiornamento in corso di rekonq                                                                                          [------------------------------------------------------------------------------] 100%
(11/12) aggiornamento in corso di systemd-sysvcompat                                                                              [------------------------------------------------------------------------------] 100%
(12/12) aggiornamento in corso di xterm 
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
francesco_dem
Arciere
Messaggi: 234
Iscritto il: 17 maggio 2013, 17:05
Architettura: x86_64 (64bit)

Re: erore aggiornamenti nvidia-libgl

Messaggio da francesco_dem » 8 marzo 2014, 22:09

ho provato a riaggiornare, problema risolto per me :-)

Rispondi