Kernel panic all'avvio o all'inserimento cd e altri dispositivi

Problemi e discussioni inerenti al kernel e al supporto hardware in ambiente Linux
Senseoflife
Arciere Provetto
Messaggi: 467
Iscritto il: 24 ottobre 2008, 9:42

Messaggio da Senseoflife » 6 gennaio 2011, 22:40

Salve..
Leggevo di un utente che all'inserimento di un cd otteneva un kernel panic. Ha messo 'risolto' al post e dunque ne ho creato un altro.
A me accade lo stesso.
Dopo qualche ora però, il sistema ha iniziato ad andarmi in kernel panic ogni volta che accendo, più o meno prima di caricare gdm.
Se avvio con fallback, accade la stessa cosa a meno che non abbia inserito da prima del boot la chiavetta usb per il bluetooth.
Quindi, avendo inserito la chiavetta bluetooth e avendo fatto partire arch con la falback sono riuscito a far partire il sistema, e in rc.conf ho messo MOD_AUTOLOAD=no. Avrei poi inserito tutti i moduli nel campo MODULES, per poi escluderli uno ad uno come verifica, se non mi fosse mancata la corrente all'improvviso :(.

Ora ho un sistema che si avvia sempre, anche senza la bluetooth key, ma inutilizzabile! Non funziona neanche la tastiera nè riesco a collegarmi con ssh, penso poichè neanche il modulo della porta ethernet è inserito.
Sto scaricando una live per poter montare la root (ext4 su lvm :mad:) e sistemare in rc.conf.
La vedo pure male perchè sto su un netbook senza lettore cd per masterizzare la iso e il bios del pc 'bloccato' non supporta il boot da usb.

Intanto, perchè ho tutti questi problemi con i moduli? Tanto da provocare kernel panic ad ogni avvio o all'inserimento di cd!
You can be anything you want to be, just turn yourself into anything you think that you could ever be

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 7 gennaio 2011, 19:14

Bene bene anch'io sono stato vittima del masterizzatore... inserendo un cd il sistema si blocca inesorabilmente senza poter far nulla se non riavviare in modo drastico il pc...

posto quello che posso notare:

Codice: Seleziona tutto

Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: Buffer I/O error on device sr0, logical block 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: Buffer I/O error on device sr0, logical block 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: Buffer I/O error on device sr0, logical block 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: Buffer I/O error on device sr0, logical block 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: Buffer I/O error on device sr0, logical block 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: Buffer I/O error on device sr0, logical block 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: Buffer I/O error on device sr0, logical block 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: Buffer I/O error on device sr0, logical block 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: Buffer I/O error on device sr0, logical block 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: Buffer I/O error on device sr0, logical block 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 16
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 128
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 128
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 128
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 16
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 128
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 72
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 16
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 8
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 128
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 4096
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 0
Jan  7 12:53:36 isengard kernel: end_request: I/O error, dev sr0, sector 64
Jan  7 12:53:57 isengard kernel: end_request: I/O error, dev sr0, sector 64
Jan  7 12:53:57 isengard kernel: Buffer I/O error on device sr0, logical block 8
Jan  7 12:53:57 isengard kernel: end_request: I/O error, dev sr0, sector 64
Jan  7 12:53:57 isengard kernel: Buffer I/O error on device sr0, logical block 8
Jan  7 12:53:57 isengard kernel: end_request: I/O error, dev sr0, sector 64
Jan  7 12:53:57 isengard kernel: Buffer I/O error on device sr0, logical block 8
Jan  7 12:53:57 isengard kernel: end_request: I/O error, dev sr0, sector 64
Jan  7 12:53:57 isengard kernel: Buffer I/O error on device sr0, logical block 8
Jan  7 12:53:57 isengard kernel: end_request: I/O error, dev sr0, sector 64
Jan  7 12:53:57 isengard kernel: Buffer I/O error on device sr0, logical block 8
Jan  7 12:53:57 isengard kernel: end_request: I/O error, dev sr0, sector 64
Jan  7 12:53:57 isengard kernel: Buffer I/O error on device sr0, logical block 8
Jan  7 12:53:58 isengard kernel: end_request: I/O error, dev sr0, sector 64
Jan  7 12:53:58 isengard kernel: Buffer I/O error on device sr0, logical block 8
Jan  7 12:53:58 isengard kernel: end_request: I/O error, dev sr0, sector 64
Jan  7 12:53:58 isengard kernel: Buffer I/O error on device sr0, logical block 8
Jan  7 12:53:58 isengard kernel: end_request: I/O error, dev sr0, sector 64
Jan  7 12:53:58 isengard kernel: Buffer I/O error on device sr0, logical block 8
Jan  7 12:53:58 isengard kernel: end_request: I/O error, dev sr0, sector 64
Jan  7 12:53:58 isengard kernel: Buffer I/O error on device sr0, logical block 8
Jan  7 12:58:46 isengard kernel: sd 6:0:0:0: [sdd] Assuming drive cache: write through
Jan  7 12:58:46 isengard kernel: sd 6:0:0:0: [sdd] Assuming drive cache: write through
Jan  7 12:58:46 isengard kernel: sd 6:0:0:0: [sdd] Assuming drive cache: write through
Jan  7 12:58:46 isengard kernel: sd 7:0:0:0: [sde] Assuming drive cache: write through
Jan  7 12:58:46 isengard kernel: sd 7:0:0:0: [sde] Assuming drive cache: write through
Jan  7 12:58:46 isengard kernel: sd 7:0:0:0: [sde] Assuming drive cache: write through
Jan  7 12:58:46 isengard kernel: sd 8:0:0:0: [sdf] Assuming drive cache: write through
Jan  7 12:58:46 isengard kernel: sd 8:0:0:0: [sdf] Assuming drive cache: write through
Jan  7 12:58:46 isengard kernel: sd 8:0:0:0: [sdf] Assuming drive cache: write through
Jan  7 12:58:50 isengard NetworkManager[3994]: supplicant_interface_acquire: assertion `mgr_state == NM_SUPPLICANT_MANAGER_STATE_IDLE' failed
Jan  7 12:58:55 isengard kdm_greet[4056]: Cannot load /usr/share/apps/kdm/faces/.default.face: No such file or directory
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

morbin
Arciere Provetto
Messaggi: 546
Iscritto il: 20 gennaio 2010, 1:18
Località: Spagna

Messaggio da morbin » 7 gennaio 2011, 19:23

Ho provato un cd ed è successo anche a me. Blocco totale e riavvio forzato.
Ho riprovato svariate volte e non è più successo. Ho fatto la prova anche con un altro pc e tutto bene.
Con le pennette invece tutto ok.
Appena posso guardo i log

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 7 gennaio 2011, 19:38

mm quante volte ti è successo?....

comunque non saprei dove controllare eventuali errori
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
Hilinus
Moderatore
Messaggi: 5649
Iscritto il: 25 ottobre 2008, 19:28
Architettura: x86_64 (64bit)

Messaggio da Hilinus » 7 gennaio 2011, 19:42

In /var/log/kernel.log vi è traccia del kernel panic?
Q6600 @ 3.2 Ghz + Thermalright Ultra 120 Extreme | 6 GB DDR2 Ocz Gold
Asus P5K | Sapphire HD7850 2GB | E ovviamente... Arch Linux :)

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 7 gennaio 2011, 20:16

mmm no mi pare di no
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
Berseker
Amministratore
Messaggi: 4432
Iscritto il: 27 settembre 2007, 10:18
Architettura: x86_64 (64bit)
Località: Lecco (provincia)

Messaggio da Berseker » 8 gennaio 2011, 10:02

c'è un bug segnalato
https://bugs.archlinux.org/task/22343?p ... &sort=desc
https://bbs.archlinux.org/viewtopic.php?id=111197

provate a downgradare udev alla versione 164-3
Leggete il Regolamento e cercate sempre su googleforumwiki prima di chiedere.
Tag x thread risolti: [Risolto] + Spazio messo all'inizio del titolo. Grazie

ArchWiki / Board Internazionale / Blog

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 8 gennaio 2011, 10:33

mmm devoimparare ad usare la pagina dei bug, confermo solo che è random ieri sera con un dvd non lo ha fatto.
appena accendo il fisso vedo se con il donwgrade si risolve- grazie
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 8 gennaio 2011, 11:34

Aggiornamento
ok ho avuto un blocco al boot con DVD inserito.. §(con una serie di errori libdata, ho dovuto riavviare forzatamente, ad un altro tentativo udev al boot si bloccava..

Ora ho fatto il downgrade alla versione 164-3 e vediamo come va.. tra l'altro ho finalmente utilizzato la mia partizione var separata con tutti i miei pacchetti... avevo 4 versioni di udev... :D

EDIT: anche con la versione 164-3 al riavvio al bott udev è rimasto in busy per almeno una 20ina di secondi...
Ultima modifica di veleno77 il 8 gennaio 2011, 11:39, modificato 1 volta in totale.
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Il decoratore di scimmie
Novello Arciere
Messaggi: 33
Iscritto il: 2 dicembre 2010, 1:20

Messaggio da Il decoratore di scimmie » 9 gennaio 2011, 16:18

Aggiungo una problematica: Audacious messo in pausa per alcuni minuti, rimettendolo in esecuzione freeza, prima dell'aggiornamento di qualche giorno fa...
Running 'pacman -S -u'
[2011-01-06 12:48] starting full system upgrade
[2011-01-06 12:48] upgraded asunder (2.0-1 -> 2.1-1)
[2011-01-06 12:48] upgraded atkmm (2.22.1-1 -> 2.22.1-2)
[2011-01-06 12:48] upgraded cairo (1.10.0-2 -> 1.10.2-1)
[2011-01-06 12:48] upgraded cloog-ppl (0.15.10-1 -> 0.15.10-2)
[2011-01-06 12:48] upgraded pciutils (3.1.7-1 -> 3.1.7-2)
[2011-01-06 12:48] upgraded udev (164-3 -> 165-1)
[2011-01-06 12:48] upgraded device-mapper (2.02.78-1 -> 2.02.79-1)
[2011-01-06 12:48] upgraded cryptsetup (1.1.3-1 -> 1.2.0-1)
[2011-01-06 12:48] upgraded gcc (4.5.2-3 -> 4.5.2-4)
[2011-01-06 12:48] upgraded gcc-libs (4.5.2-3 -> 4.5.2-4)
[2011-01-06 12:48] upgraded groff (1.20.1-4 -> 1.21-1)
[2011-01-06 12:48] upgraded gtk-doc (1.15-2 -> 1.15-3)
[2011-01-06 12:48] upgraded libmysqlclient (5.1.51-1 -> 5.1.54-1)
[2011-01-06 12:48] upgraded lvm2 (2.02.78-1 -> 2.02.79-1)
[2011-01-06 12:49] upgraded pam (1.1.1-2 -> 1.1.3-1)
[2011-01-06 12:49] upgraded slim-themes (1.2.3-3 -> 1.2.3-4)
...non era mai capitato, forse è correlato

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 9 gennaio 2011, 16:27

qualcuno mi ha detto che forse è un problema legato anche a gcc.. io posso dire che tornando a udev 164-3 al boot rimane in basy per almeno 20-30 secondi... vediamo come si sviluppa la cosa.. dovrei provare se ho ancora blocchi con i cd dvd
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Il decoratore di scimmie
Novello Arciere
Messaggi: 33
Iscritto il: 2 dicembre 2010, 1:20

Messaggio da Il decoratore di scimmie » 9 gennaio 2011, 16:49

Da LinuxQuestions

Presunta incompatibilità tra kernel e nuovo uDev?

morbin
Arciere Provetto
Messaggi: 546
Iscritto il: 20 gennaio 2010, 1:18
Località: Spagna

Messaggio da morbin » 9 gennaio 2011, 17:01

A me è capitato solo una volta su un solo pc, all'inserimento del cd. Non è più capitato, quindi non ho neanche fatto il downgrade di udev come segnalato da berseker.
Per il momento attendo, poi se vedo altri strani comportamenti, procederò.
Dai vari log non ho notato nulla di strano.

Il decoratore di scimmie
Novello Arciere
Messaggi: 33
Iscritto il: 2 dicembre 2010, 1:20

Messaggio da Il decoratore di scimmie » 9 gennaio 2011, 17:40

Riuscite voi ad aggiornare? Sia Pacman che Yaourt mostrano connessione negata a mirrors.kernel.org

Edit: come non detto, su Firefox http://mirrors.kernel.org non si apre, ftp://mirrors.kernel.org invece si

Avatar utente
Berseker
Amministratore
Messaggi: 4432
Iscritto il: 27 settembre 2007, 10:18
Architettura: x86_64 (64bit)
Località: Lecco (provincia)

Messaggio da Berseker » 9 gennaio 2011, 17:50

decoratore, ci sono decine di mirror diversi quindi ha poco senso chiedere agli altri se riescono ad aggiornare non credi? dipende dal mirror selezionato da ognuno. Comunque il consiglio classico è quello di mettere come mirror 4 o 5 mirror diversi, così che se dal primo non si riesce a scaricare, pacman prima di bloccarsi proverà in sequenza tutti i mirror attivati successivi.
Leggete il Regolamento e cercate sempre su googleforumwiki prima di chiedere.
Tag x thread risolti: [Risolto] + Spazio messo all'inizio del titolo. Grazie

ArchWiki / Board Internazionale / Blog

Il decoratore di scimmie
Novello Arciere
Messaggi: 33
Iscritto il: 2 dicembre 2010, 1:20

Messaggio da Il decoratore di scimmie » 9 gennaio 2011, 17:54

Berseker ha scritto:decoratore, ci sono decine di mirror diversi quindi ha poco senso chiedere agli altri se riescono ad aggiornare non credi? dipende dal mirror selezionato da ognuno. Comunque il consiglio classico è quello di mettere come mirror 4 o 5 mirror diversi, così che se dal primo non si riesce a scaricare, pacman prima di bloccarsi proverà in sequenza tutti i mirror attivati successivi.
Aspetterò che ritorni up, mi sono capitati in passato problemi relativi al desync dei vari mirror (pacchetti di versioni diverse)
Qualcuno su Bbs afferma che con il kernel 2.6.37 per ora non gli si sono presentati problemi...

Avatar utente
Berseker
Amministratore
Messaggi: 4432
Iscritto il: 27 settembre 2007, 10:18
Architettura: x86_64 (64bit)
Località: Lecco (provincia)

Messaggio da Berseker » 9 gennaio 2011, 17:57

il kernel 2.6.37 per ora è in testing comunque, se volete provarlo...
Leggete il Regolamento e cercate sempre su googleforumwiki prima di chiedere.
Tag x thread risolti: [Risolto] + Spazio messo all'inizio del titolo. Grazie

ArchWiki / Board Internazionale / Blog

Il decoratore di scimmie
Novello Arciere
Messaggi: 33
Iscritto il: 2 dicembre 2010, 1:20

Messaggio da Il decoratore di scimmie » 9 gennaio 2011, 19:27

Berseker ha scritto:il kernel 2.6.37 per ora è in testing comunque, se volete provarlo...
E' appena uscito il 2.6.36.3, testo

Arlecchino
Novello Arciere
Messaggi: 80
Iscritto il: 16 ottobre 2009, 23:57
Architettura: x86_64 (64bit)
Località: Imperia
Contatta:

Messaggio da Arlecchino » 10 gennaio 2011, 13:40

Ho aggiornato il sistema ieri sera (dom 9/1/11) e da stamattina a me va in kernel panic addirittura all'avvio, dopo che escono le prime righe azzurre Arch Linux 2002/2010... e appaiono alcune righe che riportano udev. Il Fallback funziona (vi scrivo da qua) ma appena inserisco un dvd va di nuovo in kernel panic, o almeno caps lock e scroll back iniziano a lampeggiare e si blocca tutto. Lavorare posso lavorare, ma ovviamente fastidiosissimo dover stare sul Fallback e non sapere che succede. Mi consigliate di fare il downgrade di udev come ho letto più su?

Pacman -Q udev mi dà: udev 165-1.

Uname -a:
Linux arch 2.6.36-ARCH #1 SMP PREEMPT Fri Dec 10 20:01:53 UTC 2010 i686 AMD Sempron(tm) Processor 3000+ AuthenticAMD GNU/Linux

Guardando qua avrei solo l'imbarazzo della scelta:

Codice: Seleziona tutto

[gyrev@arch pkg]$ ls | grep udev
udev-160-1-i686.pkg.tar.xz
udev-161-1-i686.pkg.tar.xz
udev-162-1-i686.pkg.tar.xz
udev-163-1-i686.pkg.tar.xz
udev-164-1-i686.pkg.tar.xz
udev-164-2-i686.pkg.tar.xz
udev-164-3-i686.pkg.tar.xz
udev-165-1-i686.pkg.tar.xz
Immagino però che non sia scherzo retrocedere un pacchetto così importante. E poi è proprio udev che mi manda in kernel panic?

Con

Codice: Seleziona tutto

[gyrev@arch ~]$ sudo cat /var/log/kernel.log | grep udev
Jan  9 19:37:36 localhost kernel: udev[33]: starting version 164
Jan  9 19:37:36 localhost kernel: udev[604]: starting version 165
Jan 10 11:53:00 localhost kernel: udev[33]: starting version 164
Jan 10 11:53:00 localhost kernel: udev[600]: starting version 165
Jan 10 13:25:23 localhost kernel: udev[33]: starting version 164
Jan 10 13:25:23 localhost kernel: udev[604]: starting version 165
non ottengo niente di significativo, ma forse sbaglio a cercare e comunque sono sul Fallback.

Sullo stesso disco Win XP in dual boot si carica e va senza problemi, dunque credo proprio che dipenda dall'aggiornamento. A parte tutto, spero di aver usato i tag giusti, se ho sbagliato perdonatemi, è la prima volta che riporto del codice qui sul forum.

Grazie a tutti!
Marco

Avatar utente
Hilinus
Moderatore
Messaggi: 5649
Iscritto il: 25 ottobre 2008, 19:28
Architettura: x86_64 (64bit)

Messaggio da Hilinus » 10 gennaio 2011, 13:55

Immagini male, è proprio uno scherzo: Ho installato l'altro giorno udev-164-3 e tutto è ok da allora :D
Q6600 @ 3.2 Ghz + Thermalright Ultra 120 Extreme | 6 GB DDR2 Ocz Gold
Asus P5K | Sapphire HD7850 2GB | E ovviamente... Arch Linux :)

Avatar utente
cippaciong
Arciere Provetto
Messaggi: 513
Iscritto il: 21 giugno 2010, 10:55
Località: Pavia

Messaggio da cippaciong » 10 gennaio 2011, 15:28

Anch'io sot avendo lo stesso problema su due partizioni con arch nello stesso pc e anche sul portatile (sempre Arch). Il problema è che a me capita spesso anche senza inserire CD/DVD.
Farò un downgrade di udev o proverò il kernel 2.6.37 da testing.
Il mio wallpaper su arch-stuff.org: I Saw an Arch

Avatar utente
cippaciong
Arciere Provetto
Messaggi: 513
Iscritto il: 21 giugno 2010, 10:55
Località: Pavia

Messaggio da cippaciong » 10 gennaio 2011, 15:46

Appena effettuato il downgrade di udev alla versione 164-3 e ho ottenuto subito un kernel panic al riavvio
Il mio wallpaper su arch-stuff.org: I Saw an Arch

TheEnd
Novello Arciere
Messaggi: 117
Iscritto il: 24 dicembre 2010, 12:55

Messaggio da TheEnd » 10 gennaio 2011, 16:19

stà cosa del kernel panic ancora nn l'ho riscontrata,ma succede solo se si ha un cd/dvd inserito all'anncensione?

Avatar utente
cippaciong
Arciere Provetto
Messaggi: 513
Iscritto il: 21 giugno 2010, 10:55
Località: Pavia

Messaggio da cippaciong » 10 gennaio 2011, 16:20

No, a me succede anche senza.
Il mio wallpaper su arch-stuff.org: I Saw an Arch

Arlecchino
Novello Arciere
Messaggi: 80
Iscritto il: 16 ottobre 2009, 23:57
Architettura: x86_64 (64bit)
Località: Imperia
Contatta:

Messaggio da Arlecchino » 10 gennaio 2011, 19:59

Ciao! ho appena risolto facendo il downgrade di udev alla 164-3. Prima avevo provato a ridare pacman -Syu che mi aveva di nuovo aggiornato il kernel, senza però risolvere il problema del kernel panic all'inserimento dei dvd.

Ora invece mi pare che il sistema si sia leggerissimamente rallentato. Soprattutto all'avvio di Gnome 2.32.1 ci mette un po' a caricare tutto, molto più di prima. Me lo tengo così in speranzosa attesa del prossimo pacman -Syu o posso provare a fare qualcosa?

Grazie dell'incoraggiamento a fare il downgrad, che comunque ha dato i suoi frutti :-)

Domanda: se anche il Fallback mi fosse andato in kernel panic durante l'avvio, come avrei potuto fare il downgrade di udev? usando una live di Arch One? oppure?

Grazie!

Marco Vallarino

Rispondi