Problema riavvio dopo spegnimento forzato

Problemi e discussioni inerenti al kernel e al supporto hardware in ambiente Linux
Rispondi
fermat
Little John
Messaggi: 1072
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Problema riavvio dopo spegnimento forzato

Messaggio da fermat » 9 febbraio 2021, 19:50

ciao!

dopo un aggiornamento, durante il reboot, la corrente è andata via.

al riavvio:

Codice: Seleziona tutto

Loading linux core repo kernel...
error: premature end of file/vmlinuz.
Loading inital ramdisk ...
error: you need to load the kernel first.

Press any key to continue...
cosa posso fare??

fermat
Little John
Messaggi: 1072
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Re: Problema riavvio dopo spegnimento forzato

Messaggio da fermat » 9 febbraio 2021, 20:11

intanto ho avviato da live usb e fatto ik chroot.

è già ci stanno due cose che nn vanno:

Codice: Seleziona tutto

I have no name!@archiso /# ping google.it
ping: error while loading shared libraries: /usr/lib/libresolv.so.2: file toot short

Avatar utente
TheSaint
Robin Hood
Messaggi: 8052
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Problema riavvio dopo spegnimento forzato

Messaggio da TheSaint » 10 febbraio 2021, 4:19

Dovresti vedere se hai la connessione con internet. Ultimamente si usa iwctl per collegarsi a router.
Di seguito dovresti vedere si il pacchetto linux è installato.
Direi che, senza sapere né leggere né scrivere, di reinstallare tutto il gruppo base. Poi vedi se hai installato il boot loader.
F the saint 14 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

fermat
Little John
Messaggi: 1072
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Re: Problema riavvio dopo spegnimento forzato

Messaggio da fermat » 10 febbraio 2021, 7:28

ciao!

connessione c'è, solo che una volta fatto il chroot non mi fa eseguire nessun comando.
ad esempio su mi da:

Codice: Seleziona tutto

su: error while loading shared libraries: /usr/lib/libutil.so.1: file toot short
ma se provo ad eseguire pactstrap come da guida, mi dice che i file esistono già!

fermat
Little John
Messaggi: 1072
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Re: Problema riavvio dopo spegnimento forzato

Messaggio da fermat » 10 febbraio 2021, 7:39

ho eseguito questo comando prima di fare il chroot:

Codice: Seleziona tutto

# pacman -Sy --root /mnt --overwrite "*" base linux linux-firmware
..................
/usr/bin/systemd-tmpfiles: error while loading shared libraries: /usr/lib/librt.so.1: file toot short
error: command failed to execute correctly
..................
depmod: error while loading shared libraries: /usr/lib/libpthread.so.0: file toot short
error: command failed to execute correctly
==> ERROR: /proc must be mounted
error: command failed to execute correctly

fermat
Little John
Messaggi: 1072
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Re: Problema riavvio dopo spegnimento forzato

Messaggio da fermat » 10 febbraio 2021, 8:04

ho notato questo:

Codice: Seleziona tutto

# ls -l /usr/lib/libutil.so.1
lrwxrwxrwx 1 0 0 15 Feb 6 01:09 /usr/lib/libutil.so.1 -> libutil-2.33.so

# ls -l /usr/lib/libutil-2.33.so
-rwxr-xr-x 1 0 0 0 Feb 6 01:09 /usr/lib/libutil-2.33.so
non è che c'è un problema di permessi / utenze??

Avatar utente
Dusty
Little John
Messaggi: 945
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: Problema riavvio dopo spegnimento forzato

Messaggio da Dusty » 10 febbraio 2021, 15:36

A me sembra che ci sia un problema di corruzione del file system.
Se va via la corrente in un momento di attività intensa, ci sta.
Serve una analisi di integrità.
Poi compra un UPS.

fermat
Little John
Messaggi: 1072
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Re: Problema riavvio dopo spegnimento forzato

Messaggio da fermat » 10 febbraio 2021, 15:42

Dusty ha scritto:
10 febbraio 2021, 15:36
A me sembra che ci sia un problema di corruzione del file system.
Se va via la corrente in un momento di attività intensa, ci sta.
Serve una analisi di integrità.
Poi compra un UPS.
ok, quindi mi dici di riavviare da live e lanciare i classici:

Codice: Seleziona tutto

badblocks -sv /dev/sda
fsck -t ext4 -l bad-blocks-result /dev/sda1

fermat
Little John
Messaggi: 1072
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Re: Problema riavvio dopo spegnimento forzato

Messaggio da fermat » 10 febbraio 2021, 18:22

badblocks non ha trovato blocchi con errori.

ho cmq dato anche il comando:

Codice: Seleziona tutto

fsck -y /dev/sda1
ma ha fatto tutto subito senza indicare errori.

ora al riavvio si blocca qui:

Codice: Seleziona tutto

Loading Linux linux...
Loading initial ramdisk....

Avatar utente
TheSaint
Robin Hood
Messaggi: 8052
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Problema riavvio dopo spegnimento forzato

Messaggio da TheSaint » 11 febbraio 2021, 5:02

Matteo, ti devi rassegnare, reinstalla exnovo. Non penso che riesci a resuscitare lo zombie. Magari anche senza formattare, puoi provare a ripetere il pacstrap.
F the saint 14 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

fermat
Little John
Messaggi: 1072
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Re: Problema riavvio dopo spegnimento forzato

Messaggio da fermat » 11 febbraio 2021, 7:53

si mi sono già rassegnato.
ci speravo perchè è la terza volta che formatto dall'inizio dell'anno.....

Avatar utente
TheSaint
Robin Hood
Messaggi: 8052
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Problema riavvio dopo spegnimento forzato

Messaggio da TheSaint » 12 febbraio 2021, 3:42

Io penso che non è necessario formattare. Pacman potrebbe sovrascrivere senza formattare. Poi c'era anche l'installazione in differita, come hai scritto sopra con il -root /mnt. Non capisco per quale ragione non sei riuscito con quel metodo.
F the saint 14 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

fermat
Little John
Messaggi: 1072
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Re: Problema riavvio dopo spegnimento forzato

Messaggio da fermat » 12 febbraio 2021, 9:13

ci ho provato, ma mi dava errori.
qualcuno l'ho riportato sopra, sugli altri vi ho risparmiato.

cmq vabbè, in una giornata me la sono cavata.

Rispondi