blocco del sistema: random ma sempre durante navigazione in internet

Problemi e discussioni inerenti al kernel e al supporto hardware in ambiente Linux
Rispondi
magellano
Novello Arciere
Messaggi: 125
Iscritto il: 10 settembre 2016, 9:44

blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da magellano » 28 ottobre 2018, 11:18

ciao a tutti,
forse il titolo è vago e scorretto, suggeritemi, se è il caso, come modificarlo
Il problema:
succede saltuariamente ed apparentemente senza una regola, ma tipicamente con 5 o 6 schede aperte di firefox, una magari che si aggiorna continuamente
scaricando dati e aggiornando grafico ogni 5/6 secondi (tipo tradingview) ed una aperta su youtube: il sistema si blocca e devo spegnere e riavviare con tasto I/O
Posto dati sistema

Codice: Seleziona tutto

[angelo@angelo ~]$ inxi -b
System:    Host: angelo Kernel: 4.14.78-1-lts x86_64 bits: 64 Desktop: MATE 1.20.3 Distro: Arch Linux 
Machine:   Type: Desktop System: Hewlett-Packard product: HP Compaq dx2450 Microtower v: N/A 
           serial: <root required> 
           Mobo: PEGATRON model: 2A72h v: 3.02 serial: <root required> BIOS: Phoenix v: 5.60 date: 02/20/2009 
CPU:       Single Core: AMD Athlon 1640B type: UP speed: 1000 MHz min/max: 1000/2700 MHz 
Graphics:  Device-1: NVIDIA C61 [GeForce 6150SE nForce 430] driver: nouveau v: kernel 
           Display: server: X.Org 1.20.2 driver: nouveau resolution: 1920x1080_60.00~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Network:   Device-1: NVIDIA MCP61 Ethernet type: network bridge driver: forcedeth 
           Device-2: Realtek RTL8192CU 802.11n WLAN Adapter type: USB driver: rtl8192cu 
Drives:    Local Storage: total: 558.93 GiB used: 29.70 GiB (5.3%) 
Info:      Processes: 118 Uptime: 37m Memory: 3.73 GiB used: 1.20 GiB (32.2%) Shell: bash inxi: 3.0.26 
[angelo@angelo ~]$ inxi -F
System:    Host: angelo Kernel: 4.14.78-1-lts x86_64 bits: 64 Desktop: MATE 1.20.3 Distro: Arch Linux 
Machine:   Type: Desktop System: Hewlett-Packard product: HP Compaq dx2450 Microtower v: N/A 
           serial: <root required> 
           Mobo: PEGATRON model: 2A72h v: 3.02 serial: <root required> BIOS: Phoenix v: 5.60 date: 02/20/2009 
CPU:       Topology: Single Core model: AMD Athlon 1640B bits: 64 type: UP L2 cache: 512 KiB 
           Speed: 1800 MHz min/max: 1000/2700 MHz Core speed (MHz): 1: 1800 
Graphics:  Device-1: NVIDIA C61 [GeForce 6150SE nForce 430] driver: nouveau v: kernel 
           Display: server: X.Org 1.20.2 driver: nouveau resolution: 1920x1080_60.00~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: NVIDIA MCP61 High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.14.78-1-lts 
Network:   Device-1: NVIDIA MCP61 Ethernet type: network bridge driver: forcedeth 
           IF: enp0s7 state: down mac: 00:23:7d:c6:8c:2d 
           Device-2: Realtek RTL8192CU 802.11n WLAN Adapter type: USB driver: rtl8192cu 
           IF: enp0s2f1u2 state: up mac: c4:6e:1f:1d:7d:eb 
Drives:    Local Storage: total: 558.93 GiB used: 29.70 GiB (5.3%) 
           ID-1: /dev/sda vendor: Western Digital model: WD3200AAJS-60Z0A0 size: 298.09 GiB 
           ID-2: /dev/sdb vendor: Samsung model: HD161HJ size: 149.05 GiB 
           ID-3: /dev/sdc vendor: Kingston model: SV300S37A120G size: 111.79 GiB 
Partition: ID-1: / size: 81.86 GiB used: 29.70 GiB (36.3%) fs: ext4 dev: /dev/sdc3 
Sensors:   System Temperatures: cpu: 20.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 118 Uptime: 38m Memory: 3.73 GiB used: 1.20 GiB (32.2%) Shell: bash inxi: 3.0.26 


e journaling al momento del crash

Codice: Seleziona tutto

ott 28 10:07:15 angelo org.mate.atril.Daemon[449]: RegisterDocument process pending invocations for URI file:///home/angelo/Scrivania/AI19328316.pdf
ott 28 10:09:29 angelo org.mate.atril.Daemon[449]: UnregisterDocument URI 'file:///home/angelo/Scrivania/AI19328316.pdf'
ott 28 10:10:04 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 01140001 FAULT at 00b010
ott 28 10:10:04 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 00000000 FAULT at 00b010
ott 28 10:10:20 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 01140001 FAULT at 00b010
ott 28 10:10:20 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 00000000 FAULT at 00b010
ott 28 10:10:36 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 01140001 FAULT at 00b010
ott 28 10:10:36 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 00000000 FAULT at 00b010
ott 28 10:10:56 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 013c0001 FAULT at 00b010
ott 28 10:10:56 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 00000000 FAULT at 00b010
ott 28 10:11:21 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 013f0001 FAULT at 00b010
ott 28 10:11:21 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 00000000 FAULT at 00b010
ott 28 10:11:54 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 011c0001 FAULT at 00b010
ott 28 10:11:55 angelo kernel: nouveau 0000:00:0d.0: bus: MMIO write of 00000000 FAULT at 00b010
ott 28 10:20:25 angelo dhcpcd[919]: enp0s2f1u2: carrier lost
ott 28 10:20:25 angelo dhcpcd[977]: enp0s2f1u2: carrier lost
Chiedo forse troppo al mio macinino, è un problema di scheda grafica o ram?

Grazie

Avatar utente
Dusty
Arciere Provetto
Messaggi: 703
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da Dusty » 28 ottobre 2018, 12:53

Ma il sistema è aggiornato?
Io ho avuto questo problema qualche tempo fa, ma è un pezzo che non mi si manifesta più.
Credo che sia colpa dei drivers nouveau: l'unica alternativa è la sostituzione con quelli nvidia.
Per lo sblocco del sistema, si può ricorrere ai tasti Magic:
https://en.wikipedia.org/wiki/Magic_SysRq_key
SIGTERM (più volte), SIGKILL (più volte), sync, boot.
Serve comunque un riavvio, ma almeno si riesce a fare una chiusura del sistema meno disordinata e si limita il rischio di danni al file system.

Avatar utente
4javier
Moderatore
Messaggi: 9513
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da 4javier » 28 ottobre 2018, 13:05

I driver nvidia per la sua scheda non sono supportati da X.org.
Potrebbe provare ad utilizzare un kernel non LTS per vedere se dei nouveau più recenti non hanno il problema.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Avatar utente
Dusty
Arciere Provetto
Messaggi: 703
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da Dusty » 28 ottobre 2018, 18:10

4javier ha scritto:
28 ottobre 2018, 13:05
Potrebbe provare ad utilizzare un kernel non LTS per vedere se dei nouveau più recenti non hanno il problema.
Concordo.
Non avevo notato che il kernel è LTS.
LTS non vuol dire perfetto: visto che il bug è relativamente recente, potrebbe esserne afflitto.
Conviene provare l'ultimo kernel, che oltre tutto può tranquillamente convivere con LTS.
Ma i nouveau sono sempre quelli.

Avatar utente
4javier
Moderatore
Messaggi: 9513
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da 4javier » 28 ottobre 2018, 18:24

Sicuro che dal kernel 4.14.78 al 4.18.16 i nouveau non abbiano subito alcuna modifica? Mi pare strano...
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Avatar utente
Dusty
Arciere Provetto
Messaggi: 703
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da Dusty » 28 ottobre 2018, 20:43

Certo che hanno subito modifiche!
Il kernel 4.14 è di gennaio 2018 mentre la versione attuale dei nouveau è di maggio 2018.
Ma magellano ha installato il kernel LTS 4.14.78-1, che è l'ultimo disponibile.
Così come sta tenendo aggiornato il kernel LTS, immagino che sia tenendo aggiornato anche il resto del sistema, compreso il pacchetto nouveau.
Ma è una deduzione assolutamente personale.

Avatar utente
4javier
Moderatore
Messaggi: 9513
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da 4javier » 28 ottobre 2018, 21:14

Nouveau è parte del kernel, non è un pacchetto a parte.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Avatar utente
Dusty
Arciere Provetto
Messaggi: 703
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da Dusty » 28 ottobre 2018, 22:43

Sì, è vero.
Mi sono espresso male.
Ma il supporto 2D è separato e sta in xf86-video-nouveau; che non sono drivers ma sono in qualche modo un loro prolungamento.
E quando si usano programmi che fanno uso intensivo di grafica, come Firefox, non è facile individuare quale componente è usata.
Io, in particolare per questo problema specifico, non lo trascurerei.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7611
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da TheSaint » 29 ottobre 2018, 1:27

Prova lanciare firefox in una console. Mera speranza che scriva qualcosa in stderr.
Tipo

Codice: Seleziona tutto

$ firefox -MOZ_LOG_FILE
F the saint
11 anni da questo forum ;)

magellano
Novello Arciere
Messaggi: 125
Iscritto il: 10 settembre 2016, 9:44

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da magellano » 29 ottobre 2018, 11:33

ciao a tutti e grazie per i suggerimenti.
Preciso: è un problema che mi trascino su questa macchina da praticamente sempre, nel senso che ho recuperato il pc al lavoro ed ho cominciato ad installare linux, prima manjaro e dopo qualche mese arch ed ormai lo uso da 5 anni ca con mate. Sono passato al kernel LTS un anno fa circa per vedere di risolvere questo problema (ed a sensazione prima era più frequente) ed aggiorno il sistema almeno settimanalmente. Ad onor del vero, mi sono scordato di precisarlo, questi blocchi si verificano anche quando il sistema lo usa un altro utente, con proprio account, e che normalmente apre un paio di schede in firefox, in quanto utilizza quasi esclusivamente social, e nient'altro

Avatar utente
Dusty
Arciere Provetto
Messaggi: 703
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da Dusty » 29 ottobre 2018, 15:51

magellano ha scritto:
29 ottobre 2018, 11:33
Sono passato al kernel LTS un anno fa circa per vedere di risolvere questo problema (ed a sensazione prima era più frequente) ed aggiorno il sistema almeno settimanalmente.
LTS non vuol dire 'perfetto'.
Correggetemi se sbaglio, ma mi sembra che sui pacchetti LTS non siano applicate tutte le patch di correzione di errori, ma solo quelle relative alla sicurezza.
Quindi non è impossibile che il problema che descrivi non sia risolto nel pacchetto LTS ma lo sia in quello della linea 'normale'.
A me è capitato qualcosa di identico qualche anno fa.
Usavo il kernel standard ed è spuntato un errore grave (proprio sui drivers video).
Allora sono passato al kernel LTS, e sono andato avanti per un pezzo.
Poi l'errore è entrato anche nel kernel LTS ed il sistema è diventato inutilizzabile.
Dopo un po', quando avevo perso ogni speranza, è uscito un kernel standard corretto.
Dopo un altro po' di tempo è uscito un nuovo kernel LTS corretto.

magellano
Novello Arciere
Messaggi: 125
Iscritto il: 10 settembre 2016, 9:44

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da magellano » 29 ottobre 2018, 20:51

mi sembra di capire che sia da escludere l'inadeguatezza hw (ram, piuttosto he scheda video. etc), proverò sia l'avvio del browser da cli che l'aggiornamento del kernel non lts.
A proposito del kernel: siccome uso dkms per il corretto aggiornamento del modulo wifi (8192cu), possono convivere le due patch di entrambe i kernel?

Avatar utente
TheSaint
Robin Hood
Messaggi: 7611
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da TheSaint » 30 ottobre 2018, 2:25

magellano ha scritto:
29 ottobre 2018, 20:51
aggiornamento del modulo wifi (8192cu)
Ecco dove può esserci il problema. Con Realtek c'è sempre da tribolare.
F the saint
11 anni da questo forum ;)

magellano
Novello Arciere
Messaggi: 125
Iscritto il: 10 settembre 2016, 9:44

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da magellano » 30 ottobre 2018, 19:11

TheSaint ha scritto:
29 ottobre 2018, 1:27
Prova lanciare firefox in una console. Mera speranza che scriva qualcosa in stderr.
Tipo

Codice: Seleziona tutto

$ firefox -MOZ_LOG_FILE
ho "ricausato" il problema dopo aver aperto con il suddetto comando
dove trovo l'eventuale report?
(è una mezzoretta che vago a vuoto e cerco in rete)

Avatar utente
4javier
Moderatore
Messaggi: 9513
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da 4javier » 30 ottobre 2018, 19:24

Devi specificare un file di destinazione (-MOZ_LOG_FILE=/percorso/che/ti/pare.log), altrimenti te lo stampa nel terminale
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7611
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da TheSaint » 31 ottobre 2018, 4:54

C'è scritto che se non è specificato, allora viene diretto sullo stdout ;)
Provare con firefox -h :P
Se poi non si presentano alcuni errori, allora la probabilità diventa molto vaga chefirefox sia la causa. Direi che la ci può essere una correlazione tra l' accelerazione grafica di firefox e il modulo nouveau. Senonché crash del modulo realtek.
F the saint
11 anni da questo forum ;)

magellano
Novello Arciere
Messaggi: 125
Iscritto il: 10 settembre 2016, 9:44

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da magellano » 2 novembre 2018, 9:35

ho avviato firefox con
firefox -MOZ_LOG_FILE > /home/user/Scrivania/fire.log
ma dopo il crash il file è vuoto
ho notato che tutto si blocca dopo il movimento del mouse: l'audio comincia a singhiozzare, poi cessa del tutto e tutto si blocca

Avatar utente
TheSaint
Robin Hood
Messaggi: 7611
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da TheSaint » 2 novembre 2018, 13:45

Secondo me ci può essere che usi l' accelerazione hardware con il dirver nouveau, che fa il disastro.
F the saint
11 anni da questo forum ;)

magellano
Novello Arciere
Messaggi: 125
Iscritto il: 10 settembre 2016, 9:44

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da magellano » 2 novembre 2018, 18:00

TheSaint ha scritto:
2 novembre 2018, 13:45
Secondo me ci può essere che usi l' accelerazione hardware con il dirver nouveau, che fa il disastro.
cacchio! è vero!
l'avevo disabilitata qualche mese fa e invece adesso era abilitata come preferenza di default, mi sa che con i vari aggiornamenti di firefox.... può essere?
comunque ristresso il tutto e vediamo

Avatar utente
Dusty
Arciere Provetto
Messaggi: 703
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da Dusty » 3 novembre 2018, 17:41

magellano ha scritto:
29 ottobre 2018, 20:51
proverò sia l'avvio del browser da cli che l'aggiornamento del kernel non lts.
Ribadisco che potrebbe essere risolutivo.
Se c'è un errore in un driver, la correzione arriva sul kernel standard molto prima del LTS.
A proposito del kernel: siccome uso dkms per il corretto aggiornamento del modulo wifi (8192cu), possono convivere le due patch di entrambe i kernel?
Non ho esperienza diretta, ma mi sembra che dkms lavori sul kernel in esecuzione indipendentemente dall'origine.

Avatar utente
4javier
Moderatore
Messaggi: 9513
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: blocco del sistema: random ma sempre durante navigazione in internet

Messaggio da 4javier » 3 novembre 2018, 18:47

Purchè quello specifico modulo non abbia bisogno di alcuna patch per il kernel LTS (è di solito non è necessaria) e ti ricordi di installare i linux-headers per entrambi i kernel, non dovresti avere problemi.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Rispondi