nuovo repo multilib impossibile scaricare

Domande inerenti al gestore dei pacchetti di Arch Linux
Rispondi
axenx
Little John
Messaggi: 890
Iscritto il: 19 settembre 2008, 23:31

Messaggio da axenx » 28 agosto 2010, 16:41

salve ho letto la news e aggiunto il repo ma o questa risposta con molti server


errore: impossibile scaricare il pacchetto 'multilib.db.tar.gz' da mirrors.kernel.org : Not Found
errore: impossibile aggiornare multilib (Not Found)


cosa devo fare?
ciao e grazie

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 28 agosto 2010, 16:54

impossibile
http://mirrors.kernel.org/archlinux/multilib/os/x86_64/
controlla il tuo mirrorlist se è aggiornato
viewtopic.php?id=9638
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

axenx
Little John
Messaggi: 890
Iscritto il: 19 settembre 2008, 23:31

Messaggio da axenx » 28 agosto 2010, 17:01

credo abbia ragione, sto aggiornando dal repo che usi anche tu (lo hai consigliato in un post) e vedo un aggiornamento di mirrorlist e tutto kde 4.5

grazie e ciao

axenx
Little John
Messaggi: 890
Iscritto il: 19 settembre 2008, 23:31

Messaggio da axenx » 28 agosto 2010, 18:30

continua a non trovarlo neanche dopo l'aggiornamento!!!!

in mirrorliust ho decommentato il server italiano di garret e i due svizzeri
Ultima modifica di axenx il 28 agosto 2010, 18:32, modificato 1 volta in totale.

fgr
Arciere
Messaggi: 188
Iscritto il: 2 dicembre 2008, 18:31

Messaggio da fgr » 28 agosto 2010, 19:05

Aggiungi questa funzione a «.bashrc» o «.zshrc»:

Codice: Seleziona tutto

pac() {
    sudo reflector -l 6 -r -o /etc/pacman.d/mirrorlist
    sudo sed '/ ftp/d' /etc/pacman.d/mirrorlist > ${HOME}/mirrorlist
    sudo mv -f ${HOME}/mirrorlist /etc/pacman.d/
    sudo clyde -Syyu -a [sostituire con pacman eventualmente]
}
su come impostare 'sudo' e su 'reflector' vedi il wiki. Ho scelto di rimuovere tutti i mirror "ftp://" perché per me sono lenti.

axenx
Little John
Messaggi: 890
Iscritto il: 19 settembre 2008, 23:31

Messaggio da axenx » 28 agosto 2010, 19:22

ciao ho installato reflector e messo pacman al posto di clyde:
pac() {
sudo reflector -l 6 -r -o /etc/pacman.d/mirrorlist
sudo sed '/ ftp/d' /etc/pacman.d/mirrorlist > ${HOME}/mirrorlist
sudo mv -f ${HOME}/mirrorlist /etc/pacman.d/
sudo pacman -Syyu -a
}

mi da questo:

[axenx@axenx ~]$ pac
sudo: clyde: command not found
[axenx@axenx ~]$

e con il comando classico mi da:

Codice: Seleziona tutto

[axenx@axenx ~]$ sudo pacman -Syu
Password: 
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community è aggiornato
 archlinuxfr è aggiornato
errore: impossibile scaricare il pacchetto 'multilib.db.tar.gz' da ftp.iinet.net.au : Not Found
errore: impossibile scaricare il pacchetto 'multilib.db.tar.gz' da mirror.aarnet.edu.au : Not Found
errore: impossibile scaricare il pacchetto 'multilib.db.tar.gz' da mirrors.kernel.org : Not Found
errore: impossibile aggiornare multilib (Not Found)
:: Aggiornamento del sistema in corso...
ciao

morbin
Arciere Provetto
Messaggi: 546
Iscritto il: 20 gennaio 2010, 1:18
Località: Spagna

Messaggio da morbin » 28 agosto 2010, 19:24

axenx ha scritto:continua a non trovarlo neanche dopo l'aggiornamento!!!!

in mirrorliust ho decommentato il server italiano di garret e i due svizzeri
Quei 2 mirror sono deprecati al momento.
Vedi qui: viewtopic.php?id=9638

axenx
Little John
Messaggi: 890
Iscritto il: 19 settembre 2008, 23:31

Messaggio da axenx » 28 agosto 2010, 19:26

quale mi consigli?
ora ne ho una generate da reflector

Codice: Seleziona tutto

# 2010-08-28 19:20
# generated by reflector
# ranked by rankmirrors
Server = http://ftp.iinet.net.au/pub/archlinux/$repo/os/$arch
Server = http://mirror.aarnet.edu.au/pub/archlinux/$repo/os/$arch
Server = http://mirrors.kernel.org/archlinux/$repo/os/$arch

morbin
Arciere Provetto
Messaggi: 546
Iscritto il: 20 gennaio 2010, 1:18
Località: Spagna

Messaggio da morbin » 28 agosto 2010, 19:32

Attualmente uno tra i più raccomandati è

Codice: Seleziona tutto

Server = http://mirrors.kernel.org/archlinux/$repo/os/$arch

fgr
Arciere
Messaggi: 188
Iscritto il: 2 dicembre 2008, 18:31

Messaggio da fgr » 28 agosto 2010, 19:33

axenx ha scritto:ciao ho installato reflector e messo pacman al posto di clyde:
sudo pacman -Syyu -a
devi togliere l'opzione "-a", che è di clyde. Comunque strano che reflector aggiunga mirror deprecati perché prende solo i più sincronizzati di recente.

axenx
Little John
Messaggi: 890
Iscritto il: 19 settembre 2008, 23:31

Messaggio da axenx » 28 agosto 2010, 19:35

con la mirrorlist aggiornata il risultato non cambia:

[axenx@axenx ~]$ su
Password:
[root@axenx axenx]# nano /etc/pacman.d/mirrorlist
[root@axenx axenx]# nano /etc/pacman.d/mirrorlist
[root@axenx axenx]# pacman -Syy
:: Sincronizzazione dei database in corso...
core 35,5K 57,1K/s 00:00:01 [###############################] 100%
extra 461,7K 113,1K/s 00:00:04 [###############################] 100%
community 379,7K 112,1K/s 00:00:03 [###############################] 100%
archlinuxfr 15,5K 123,1K/s 00:00:00 [###############################] 100%
errore: impossibile scaricare il pacchetto 'multilib.db.tar.gz' da mirrors.kernel.org : Not Found
errore: impossibile aggiornare multilib (Not Found)
[root@axenx axenx]#

axenx
Little John
Messaggi: 890
Iscritto il: 19 settembre 2008, 23:31

Messaggio da axenx » 28 agosto 2010, 19:37

levata la -a il risultato:

Codice: Seleziona tutto

[axenx@axenx ~]$ pac
Password: 
:: Sincronizzazione dei database in corso...
 core                             35,5K   58,1K/s 00:00:01 [###############################] 100%
 extra                           461,7K  122,8K/s 00:00:04 [###############################] 100%
 community                       379,7K  135,0K/s 00:00:03 [###############################] 100%
 archlinuxfr                      15,5K  124,4K/s 00:00:00 [###############################] 100%
errore: impossibile scaricare il pacchetto 'multilib.db.tar.gz' da ftp.iinet.net.au : Not Found
errore: impossibile scaricare il pacchetto 'multilib.db.tar.gz' da mirror.aarnet.edu.au : Not Found
errore: impossibile scaricare il pacchetto 'multilib.db.tar.gz' da mirrors.kernel.org : Not Found
errore: impossibile aggiornare multilib (Not Found)
:: Aggiornamento del sistema in corso...
attenzione: qjson: la versione installata (0.7.1-2) è più recente di quella presente in extra (0.7.1-1)
Non c'è nulla da fare
[axenx@axenx ~]$
:(

morbin
Arciere Provetto
Messaggi: 546
Iscritto il: 20 gennaio 2010, 1:18
Località: Spagna

Messaggio da morbin » 28 agosto 2010, 19:53

/etc/pacman.conf è a posto? forse hai un pacman.conf.pacnew da verificare?
4-5 giorni fa ricevevo anch'io un errore, non sono sicuro sia uguale, ma quanto meno era molto simile a quello che hai appena scritto riguardo 'multilib.db.tar.gz'.
E oggi ho aggiornato senza errori.

axenx
Little John
Messaggi: 890
Iscritto il: 19 settembre 2008, 23:31

Messaggio da axenx » 28 agosto 2010, 19:58

ho solo il pacman.conf l'altro non c'è:

Codice: Seleziona tutto

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
HoldPkg     = pacman glibc
# If upgrades are available for these packages they will be asked for first
SyncFirst   = pacman
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#XferCommand = /usr/bin/curl -C - %u > %o
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options (all disabled by default)
#UseSyslog
#ShowSize
#UseDelta
#TotalDownload

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
## Add your preferred servers here, they will be used first
#Include = /etc/pacman.d/mirrorlist

[core]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist
#Server =  http://mirrors.kernel.org/archlinux/$repo/os/i686

[extra]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist
#Server =  http://mirrors.kernel.org/archlinux/$repo/os/i686

#[community-testing]
## Add your preferred servers here, they will be used first
#Include = /etc/pacman.d/mirrorlist

[community]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist
#Server =  http://mirrors.kernel.org/archlinux/$repo/os/i686

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#Server = file:///home/custompkgs

[archlinuxfr]
Server = http://repo.archlinux.fr/x86_64

[multilib] 
Include = /etc/pacman.d/mirrorlist 
#Server = http://mirrors.kernel.org/archlinux/$repo/os/$arch

morbin
Arciere Provetto
Messaggi: 546
Iscritto il: 20 gennaio 2010, 1:18
Località: Spagna

Messaggio da morbin » 28 agosto 2010, 20:08

Ma è normale che hai l'indirizzo dei server commentati sotto?
Il mio pacman.conf è così:

Codice: Seleziona tutto

[core]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[extra]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

#[community-testing]
## Add your preferred servers here, they will be used first
#Include = /etc/pacman.d/mirrorlist

[community]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[archlinuxfr]
Server = http://repo.archlinux.fr/i686

axenx
Little John
Messaggi: 890
Iscritto il: 19 settembre 2008, 23:31

Messaggio da axenx » 28 agosto 2010, 20:12

niente fare...aspetterò vediamo che succede!!!!
grazie di tutto

axenx
Little John
Messaggi: 890
Iscritto il: 19 settembre 2008, 23:31

Messaggio da axenx » 28 agosto 2010, 20:13

quali server hai decommentato nella mirrolist?

morbin
Arciere Provetto
Messaggi: 546
Iscritto il: 20 gennaio 2010, 1:18
Località: Spagna

Messaggio da morbin » 28 agosto 2010, 21:41

Su mirrorlist ho decommentato questi:

Codice: Seleziona tutto

# Arch Linux repository mirrorlist
# Generated on 2010-08-26

# Any
Server = ftp://mirrors.kernel.org/archlinux/$repo/os/$arch
Server = http://mirrors.kernel.org/archlinux/$repo/os/$arch
# Germany
Server = http://archlinux.limun.org/$repo/os/$arch
Server = ftp://ftp.spline.inf.fu-berlin.de/mirrors/archlinux/$repo/os/$arch
Server = http://ftp.spline.inf.fu-berlin.de/mirrors/archlinux/$repo/os/$arch
Comunque hai provato a rimuovere quelle righe da pacman.conf?
Che io sappia li non deve essere essere specificato nessun indirizzo server, a meno che non c'entri con reflector, clyde o altro, nel qual caso, non usandoli, come non detto.

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 29 agosto 2010, 0:34

te lo linkato io e te la linkato morbin viewtopic.php?id=9638 che diamine leggiamoli sti link e confrontiamo i file con i propri in fondo c'è anche il pacmna.conf di default
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

morbin
Arciere Provetto
Messaggi: 546
Iscritto il: 20 gennaio 2010, 1:18
Località: Spagna

Messaggio da morbin » 29 agosto 2010, 3:47

Scusa ho detto una fesseria, si possono specificare i mirror anche in pacman.conf, non lo sapevo.
Copiato dal wiki: http://wiki.archlinux.org/index.php/Mir ... fic_mirror

Codice: Seleziona tutto

To use the HostEurope mirror as a default mirror, add it before the Include line:

[core]
Server = ftp://ftp.hosteurope.de/mirror/ftp.archlinux.org/core/os/i686
Include = /etc/pacman.d/mirrorlist
L'unica cosa, è che spiegano di scrivere l'indirizzo del mirror prima della riga Include, mentre sul tuo file è alla rovescia. Anche se magari non è questo che ti genera l'errore. Al limite prova.

Rispondi