[Risolto] Nuovo xorg, non trovo xproto-7.0.14-1

Domande inerenti al gestore dei pacchetti di Arch Linux
Ubermensch
Little John
Messaggi: 994
Iscritto il: 27 maggio 2008, 14:28

Messaggio da Ubermensch » 30 novembre 2008, 19:01

Per tutti coloro che si apprestano a dare un bel

Codice: Seleziona tutto

# pacman -Syu
vi faccio presente che ci sono dei problemini : http://bbs.archlinux.org/viewtopic.php?id=59921:cool::cool:

Sawk
Arciere
Messaggi: 217
Iscritto il: 13 gennaio 2008, 17:27

Messaggio da Sawk » 30 novembre 2008, 19:08

a me si è aggiornato tutto senza alcun problema.

L'unica accortezza sta nel dover configurare synaptics con Xorg 7.4. Per il resto tutto ok

Babets
Arciere Provetto
Messaggi: 356
Iscritto il: 7 febbraio 2008, 19:44

Messaggio da Babets » 30 novembre 2008, 19:46

Quel problema e` gia` stato risolto.

deviantdark
Novello Arciere
Messaggi: 84
Iscritto il: 19 novembre 2008, 0:05
Contatta:

Messaggio da deviantdark » 30 novembre 2008, 21:04

Si può quindi aggiornare senza problemi?

Babets
Arciere Provetto
Messaggi: 356
Iscritto il: 7 febbraio 2008, 19:44

Messaggio da Babets » 30 novembre 2008, 21:06

Se non hai una nvidia che usa i driver legacy più vecchi (serie 71xx) allora sì. Ocio che però dovrai comunque ritoccare il file xorg.conf (leggi qui).

Babets
Arciere Provetto
Messaggi: 356
Iscritto il: 7 febbraio 2008, 19:44

Messaggio da Babets » 30 novembre 2008, 21:20

Anche le schede che usano la serie 96xx dei driver dopo l'aggiornamento si ritroveranno a non poter usare il modulo nvidia: http://bugs.archlinux.org/task/11360 :

Senseoflife
Arciere Provetto
Messaggi: 467
Iscritto il: 24 ottobre 2008, 9:42

Messaggio da Senseoflife » 30 novembre 2008, 21:31

Ehm.. io ora sono da console con elinks -.-
Mi ha fatto una marea di aggiornamenti compreso xorg...
Riavvio, e niente più X .. mi da 'no screens found'.
Inoltre, ovviamente ho pure un'instanza di slim che non compare da nessuna parte, visto che xorg ha deciso di non funzionare più -.- .. e ora???

P.S.: uso una ati..
Ultima modifica di Senseoflife il 30 novembre 2008, 21:38, modificato 1 volta in totale.
You can be anything you want to be, just turn yourself into anything you think that you could ever be

Babets
Arciere Provetto
Messaggi: 356
Iscritto il: 7 febbraio 2008, 19:44

Messaggio da Babets » 30 novembre 2008, 21:38

viewtopic.php?id=3269
E commenta la riga in xorg.conf "rgbpath"

Senseoflife
Arciere Provetto
Messaggi: 467
Iscritto il: 24 ottobre 2008, 9:42

Messaggio da Senseoflife » 30 novembre 2008, 21:48

Babets ha scritto:viewtopic.php?id=3269
E commenta la riga in xorg.conf "rgbpath"
Fatto.. ora sono da X normalmente.. mi chiedevo, che conseguenze porta modificare lo xorg.conf cosi?

Codice: Seleziona tutto

Section "ServerFlags"
    Option        "AutoAddDevices" "False"
EndSection
You can be anything you want to be, just turn yourself into anything you think that you could ever be

deviantdark
Novello Arciere
Messaggi: 84
Iscritto il: 19 novembre 2008, 0:05
Contatta:

Messaggio da deviantdark » 30 novembre 2008, 21:49

Senseoflife ha scritto:P.S.: uso una ati..
Uso ATI anche io...
Mi sa che me se sto buono buono ;)

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Messaggio da 4javier » 30 novembre 2008, 22:16

uso ati anch'io con fglrx, e sto xorg lo uso da un mese.
@ deviant
con le schede ati non c'è alcun problema.
@senseoflife
quella opzione disabilita una nuova feature di xorg (imho una vaccata colossale) che utilizza hal anche per identificare tastiera e mouse, e che quindi necessita di settaggi esterni a xorg.conf (e a sto punto mi vien da pensare, se comunque lo devo settare manualmente, che razza di auto-rilevamento è???-.-'''')
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Ubermensch
Little John
Messaggi: 994
Iscritto il: 27 maggio 2008, 14:28

Messaggio da Ubermensch » 30 novembre 2008, 22:24

Ragazzi scusate io uso i driver nvidia-173xx ancora non ho aggiornato mi dite cosa devo fare prima di aggiornare per non avere rogne???:cool::cool:

Avatar utente
Berseker
Amministratore
Messaggi: 4432
Iscritto il: 27 settembre 2007, 10:18
Architettura: x86_64 (64bit)
Località: Lecco (provincia)

Messaggio da Berseker » 30 novembre 2008, 22:55

i driver nvidia-173xx non sono stati toccati.
Leggete il Regolamento e cercate sempre su googleforumwiki prima di chiedere.
Tag x thread risolti: [Risolto] + Spazio messo all'inizio del titolo. Grazie

ArchWiki / Board Internazionale / Blog

maveloth
Arciere Provetto
Messaggi: 352
Iscritto il: 31 luglio 2008, 17:41
Località: Lucca

Messaggio da maveloth » 30 novembre 2008, 23:12

a me che ho una 615O non parte xorg nemmeno commentando RGBPath. sapete dirmi perche? ho un kernel ricompilato per il supporto per ext4 ed ho già provato a ricompilare i driver. nel log mi segala che non trova il modulo "nvidia.ko" che invece è presente.

Maveloth
Ultima modifica di maveloth il 30 novembre 2008, 23:24, modificato 1 volta in totale.

Senseoflife
Arciere Provetto
Messaggi: 467
Iscritto il: 24 ottobre 2008, 9:42

Messaggio da Senseoflife » 30 novembre 2008, 23:14

4javier ha scritto:uso ati anch'io con fglrx, e sto xorg lo uso da un mese.
@ deviant
con le schede ati non c'è alcun problema.
@senseoflife
quella opzione disabilita una nuova feature di xorg (imho una vaccata colossale) che utilizza hal anche per identificare tastiera e mouse, e che quindi necessita di settaggi esterni a xorg.conf (e a sto punto mi vien da pensare, se comunque lo devo settare manualmente, che razza di auto-rilevamento è???-.-'''')
Grazie per le info.
You can be anything you want to be, just turn yourself into anything you think that you could ever be

maveloth
Arciere Provetto
Messaggi: 352
Iscritto il: 31 luglio 2008, 17:41
Località: Lucca

Messaggio da maveloth » 1 dicembre 2008, 12:04

io ho risolto parzialmente installando i driver scaricandoli dal sito dato che con il kernel che ho non potevo usare i 177.82 ho quindi scaricato la versione 177.80 ma adesso mi ritrovo senza acellerazione grafica se provo a lanciare compiz mi da questo errore

Codice: Seleziona tutto

compiz: error while loading shared libraries: libGL.so.1: wrong ELF class: ELFCLASS32
niente di grave ma se avete idee..
ho provato ad installare il pacchetto lib32-nvidia-utils, ma non ho ottenuto nessun risultato...

Maveloth

EDIT:ho risolto ricompilando con abs le versioni 177.80 dei pacchetti nvidia ed nvidia-utils
il problema comunque deve essere relativo al fatto che ho un kernel ricompilato.
Ultima modifica di maveloth il 2 dicembre 2008, 14:05, modificato 1 volta in totale.

vingiul
Arciere Provetto
Messaggi: 647
Iscritto il: 28 gennaio 2008, 13:54
Località: Salerno

Messaggio da vingiul » 1 dicembre 2008, 12:16

Ciao,
@Ubermensch
ho anche io i drivers nvidia-173xx.
Nel tentativo di "farmi male" ho aggiornato: tutto OK per la parte video, senza nessun tipo di problemi, funziona perfettamente, ma non ho idea per 2D-3D, non li uso; per la tastiera, ho dovuto risolvere come suggerisce ugaciaka: http://ugaciaka.wordpress.com/2008/11/3 ... tplugging/ ma ancora non andavano la "@", il "#" ecc.: ho dovuto aggiungere nel file .fdi che avevo una tastiera tipo pc105, ho specificato nel centro di controllo di avere una tastiera italiana tipo evdev, ed e' andata a posto.
Altre ventuali note a seguire, per ora pare tutto a posto.
vingiul

psychoweb
Novello Arciere
Messaggi: 108
Iscritto il: 15 luglio 2008, 8:58

Messaggio da psychoweb » 1 dicembre 2008, 18:14

Appena aggiornato: niente video.

Ho una Mobility Radeon 9600, per aggiornare ho dovuto rinominare il file /usr/lib/libfglrx_tvout.so.1 che andava in conflitto con Catalyst-Utils, poi ho riavviato e mi dà un errore del tipo "error loading module [...]/fglrx.ko : cannot allocate memory".
Metterei volentieri i driver open, se non fosse che anche quelli vanno in conflitto con Catalyst che sembra essere una dipendenza di xorg-server (!!!!!).

Qualsiasi consiglio o suggerimento (magari una soluzione! :D) è ben accetto...

vingiul
Arciere Provetto
Messaggi: 647
Iscritto il: 28 gennaio 2008, 13:54
Località: Salerno

Messaggio da vingiul » 1 dicembre 2008, 19:41

Ciao,
mettere i vesa, tanto per smanettare un po'? Io avevo (quasi) paura, ma nell'aggiornamento e' andato tutto liscio (macchina con nvidia 173xx). Se credi, aspetta un giorno: domattina (verso le 08.00) "metto mano" ad un portatile con Ati m5xx (mi pare), e vedo che succede... oggi tra impegni di lavoro e varie, non ho avuto tempo.
vingiul

psychoweb
Novello Arciere
Messaggi: 108
Iscritto il: 15 luglio 2008, 8:58

Messaggio da psychoweb » 1 dicembre 2008, 20:22

sn riuscito a mettere i driver open, disinstallando i catalyst,resto in attesa di istruzioni.
non sono riuscito a capire pero` leggendo nel forum se il problema e` stato confermato, continuo a leggere che non ci sono problemi con le ati e che il problema riguarda solo le nVidia...

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Messaggio da 4javier » 1 dicembre 2008, 21:18

Infatti gli 8.11 sono fatti apposta per funzionare col nuovo xorg.
Le accortezze da tenere presente sono:
Eliminare (o commentare) la riga riferita ad rgbpath, e se non sbaglio c'era qualche problema con le modelines, per il resto basta usare lo stesso xorg.conf che si utilizzava prima.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

deviantdark
Novello Arciere
Messaggi: 84
Iscritto il: 19 novembre 2008, 0:05
Contatta:

Messaggio da deviantdark » 1 dicembre 2008, 23:22

Per chi usa i driver open [vesa] ci sono controindicazioni?

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Messaggio da 4javier » 1 dicembre 2008, 23:34

Per i vesa direi proprio di no, quelli stai sicuro che vanno sempre e comunque, gli ati open (radeon) non li ho provati con quest versione di xorg.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

deviantdark
Novello Arciere
Messaggi: 84
Iscritto il: 19 novembre 2008, 0:05
Contatta:

Messaggio da deviantdark » 2 dicembre 2008, 0:33

Grazie mille per la precisazione ;)

Ubermensch
Little John
Messaggi: 994
Iscritto il: 27 maggio 2008, 14:28

Messaggio da Ubermensch » 2 dicembre 2008, 9:21

Durante l'aggiornamento mi chiede se desidero passare da esd a esound e io ho accettato ma ora vorrei sapere, devo modificare la riga daemon in rc.conf ???
:rolleyes:

Rispondi