Downgrade bloccato

Domande inerenti al gestore dei pacchetti di Arch Linux
Rispondi
Avatar utente
vda
Arciere Provetto
Messaggi: 599
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Downgrade bloccato

Messaggio da vda » 16 gennaio 2021, 20:29

Ciao a tutti.

Mi accorgo solo ora che l'ultima versione di PulseAudio (la 14.1) ha introdotto un fastidioso problema (almeno in XFCE). Quando si sfilano gli auricolari dal pc, difatti, l'uscita audio non passa automaticamente agli speaker come atteso, ma bisogna agire manualmente sul mixer per ripristinare l'audio.

Il problema è noto e sul web si consiglia di effettuare il downgrade del pacchetto in attesa di nuovi rilasci che possano condurre a soluzione.

Questo, tuttavia, quel che avviene nel tentativo di tornare alla precedente release di PulseAudio:

Codice: Seleziona tutto

$ sudo pacman -U 'pulseaudio-13.99.3-1-x86_64.pkg.tar.zst' 
caricamento dei pacchetti in corso...
attenzione: installazione in corso di una versione meno recente del pacchetto pulseaudio (14.1-2 => 13.99.3-1)
risoluzione delle dipendenze in corso...
attenzione: impossibile risolvere "libpulse=13.99.3-1", una dipendenza di "pulseaudio"
:: Il seguente pacchetto non può essere aggiornato a causa di alcune dipendenze irrisolvibili:
      pulseaudio

:: Vuoi ignorare il seguente pacchetto per questo aggiornamento? [s/N] N
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: impossibile soddisfare la dipendenza 'libpulse=13.99.3-1' richiesta da pulseaudio
Se quindi si pensa di effettuare preventivamente il downgrade dell'incriminato libpulse la situazione si complica ulteriormente

Codice: Seleziona tutto

$ sudo pacman -U 'libpulse-13.99.3-1-x86_64.pkg.tar.zst' 
caricamento dei pacchetti in corso...
attenzione: installazione in corso di una versione meno recente del pacchetto libpulse (14.1-2 => 13.99.3-1)
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: l'installazione di libpulse (13.99.3-1) interrompe la dipendenza 'libpulse=14.1-2' richiesta da pulseaudio
In altri termini, non è possibile fare il downgrade di PulseAudio perchè manca il downgrade di libpulse. D'altra parte non è possibile il downgrade di libpulse se non si fa prima il downgrade di PulseAudio. Classico stallo.

Il problema è peraltro di carattere generale, riguardando tutte le situazioni nelle quali si verificano dipendenze "circolari" di questo tipo.

Qualche Idea? Grazie anticipatamente,

8)
Ultima modifica di vda il 17 gennaio 2021, 21:05, modificato 2 volte in totale.
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
vda
Arciere Provetto
Messaggi: 599
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Re: Downgrade bloccato

Messaggio da vda » 16 gennaio 2021, 23:34

[Edit] con l'ultimo aggiornamento di sistema sono stati aggiornati i pacchetti

Codice: Seleziona tutto

alsa-card-profiles (14.1-2 -> 14.2-1)
libpulse (14.1-2 -> 14.2-1)
pulseaudio (14.1-2 -> 14.2-1)
e di fatto il problema specifico di PulseAudio è stato risolto.

Rimane tuttavia valida la domanda di carattere generale (ragione questa per la quale non etichetto il post come "RISOLTO"): come effettuare il downgrade di un pacchetto in presenza di dipendenze circolari?

8)
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
TheSaint
Robin Hood
Messaggi: 8048
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Downgrade bloccato

Messaggio da TheSaint » 17 gennaio 2021, 6:12

Mi pare che alcuni pacchetti introducono anche librerie specifiche. A volte bisogna effettuare un downgrade multiplo.
Infatti in questo caso le parti in causa sono solo quelle specifiche al caso audio.
F the saint 14 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

enzolatina
Little John
Messaggi: 1154
Iscritto il: 6 ottobre 2007, 22:51
Architettura: x86_64 (64bit)
Località: belluno

Re: Downgrade bloccato

Messaggio da enzolatina » 17 gennaio 2021, 15:03

se il problema è installare la versione di un pacchetto precedente a quella attuale nei repo ti puoi rivolgere ad ARM:
https://wiki.archlinux.org/index.php/Arch_Linux_Archive
noi siamo arch linux, ogni resistenza è inutile, sarete assimilati

Avatar utente
vda
Arciere Provetto
Messaggi: 599
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Re: Downgrade bloccato

Messaggio da vda » 17 gennaio 2021, 17:21

TheSaint ha scritto:
17 gennaio 2021, 6:12
Mi pare che alcuni pacchetti introducono anche librerie specifiche. A volte bisogna effettuare un downgrade multiplo.
Infatti in questo caso le parti in causa sono solo quelle specifiche al caso audio.
enzolatina ha scritto:
17 gennaio 2021, 15:03
se il problema è installare la versione di un pacchetto precedente a quella attuale nei repo ti puoi rivolgere ad ARM:
https://wiki.archlinux.org/index.php/Arch_Linux_Archive
Grazie innanzitutto dei contributi.

Ho di fatto attinto proprio all'Arch Linux Archive poichè, per ragioni di spazio, avevo da poco cancellato la cache di Pacman. E lo ho fatto proprio nel tentativo di effettuare il downgrade sia di PulseAudio sia della sua libreria di riferimento libpulse.

Il problema, come già provavo a spiegare sopra, è che l'aggiornamento di PulseAudio ad una versione precedente non è possibile se non dopo aver effettuato l'analogo downgrade di libpulse; d'altra parte il downgrade di libpulse richiede il preventivo downgrade di PulseAudio.

In definitiva il cane che si morde la coda... da cui la mia domanda.

8)
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
TheSaint
Robin Hood
Messaggi: 8048
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Downgrade bloccato

Messaggio da TheSaint » 18 gennaio 2021, 7:39

vda ha scritto:
17 gennaio 2021, 17:21
d'altra parte il downgrade di libpulse richiede il preventivo downgrade di PulseAudio.

In definitiva il cane che si morde la coda... da cui la mia domanda.
Mi pare che rimuovendo entrambe e installando le versioni precedenti sia il compimento dell'opera. Chiaro che per escludere la lamentela delle dipendenze si usa -Rdd quel tanto che basta per ottenere il risultato.
Ma se non erro hanno sistemato il baco.
F the saint 14 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Rispondi