[risolto]IMPOSSIBILE AGGIORNARE mplayer-vaapi richiede libx264.so=144-64

Domande inerenti al gestore dei pacchetti di Arch Linux
Rispondi
Avatar utente
tano70
Arciere
Messaggi: 183
Iscritto il: 4 luglio 2013, 15:14

[risolto]IMPOSSIBILE AGGIORNARE mplayer-vaapi richiede libx264.so=144-64

Messaggio da tano70 » 19 luglio 2015, 15:10

Da ieri mattina quando tento di eseguire l'aggiornamento al sistema, con il classico comando

Codice: Seleziona tutto

# pacman -Syyu
:: Sincronizzazione dei database in corso...
 core                     121,7 KiB  1229K/s 00:00 [######################] 100%
 extra                   1743,7 KiB  1255K/s 00:01 [######################] 100%
 community                  2,7 MiB  1319K/s 00:02 [######################] 100%
 multilib                 125,9 KiB  1211K/s 00:00 [######################] 100%
 archlinuxfr               19,6 KiB   427K/s 00:00 [######################] 100%
 repo-ck                   50,9 KiB   264K/s 00:00 [######################] 100%
:: Aggiornamento del sistema in corso...
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: mplayer-vaapi: richiede libx264.so=144-64
ecco quello che ottengo!! a nulla è valso cercare di rimuovere mplayer-vaapi (che non mi fa disinstallare per tutto il discorso delle dipendenze da altri programmi) o aggiornare ffmpeg scaricando manualmente una versione apposita e tentando di installarla con Pacman .U
Soluzioni??
Ultima modifica di tano70 il 20 luglio 2015, 0:48, modificato 1 volta in totale.

Avatar utente
Dusty
Little John
Messaggi: 911
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: IMPOSSIBILE AGGIORNARE mplayer-vaapi richiede libx264.so=144-64

Messaggio da Dusty » 19 luglio 2015, 17:21

mplayer-vaapi è un pacchetto di AUR, orfano di mantainer.
libx264.so fa parte di libx264, che è ufficialmente supportato e dal 17/7 è alla versione 148.
Mi sa che non se ne esce, se non con la disinstallazione del primo.
Perchè scrivi che è impossibile disinstallarlo ?
Che messaggi di errore ricevi ?

Avatar utente
tano70
Arciere
Messaggi: 183
Iscritto il: 4 luglio 2013, 15:14

Re: IMPOSSIBILE AGGIORNARE mplayer-vaapi richiede libx264.so=144-64

Messaggio da tano70 » 20 luglio 2015, 0:47

si infatti, mi ero perso sul fatto che non mi permetteva di disinstallare mplayer-vaapi perchè era richiesto da gnome-mplayer... e a sua volta non mi permetteva di disinstallare gnome-mplayer perchè dipendeva da un altro programma...pensavo fosse una catena infinita di dipendenze, invece è bastato disinstallare anche il gecko-mediaplayer e cosi a ritroso ho potuto disinstallare tutti gli altri, incluso mplayer-vaapi. Adesso mi fa nuovamente aggiornare. Grazie !

Rispondi