[Risolto] pacman: "failed to update" (Raspberry-pi)

Domande inerenti al gestore dei pacchetti di Arch Linux
Rispondi
Pepppe
Arciere Provetto
Messaggi: 423
Iscritto il: 29 febbraio 2012, 21:55

[Risolto] pacman: "failed to update" (Raspberry-pi)

Messaggio da Pepppe » 26 gennaio 2015, 8:54

Ciao,
i problemi sono iniziati ieri sera quando, dopo aver aggiornato e riavviato il sistema (Raspberry-pi, che controllo con ssh), samba non e' piu ripartita

Codice: Seleziona tutto

~]$ sudo systemctl start smbd.service nmbd.service
Job for nmbd.service failed. See "systemctl status nmbd.service" and "journalctl -xe" for details.
Job for smbd.service failed. See "systemctl status smbd.service" and "journalctl -xe" for details.

Codice: Seleziona tutto

$ systemctl status smbd.service
* smbd.service - Samba SMB/CIFS server
   Loaded: loaded (/usr/lib/systemd/system/smbd.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 1970-01-01 00:25:41 UTC; 1min 24s ago
  Process: 228 ExecStart=/usr/bin/smbd -D (code=exited, status=1/FAILURE)
Poi oggi pacman non aggiorna piu' il sistema

Codice: Seleziona tutto

$ sudo pacman -Syu
:: Synchronizing package databases...
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update alarm (unable to lock database)
error: failed to update aur (unable to lock database)
error: failed to synchronize any databases
error: failed to init transaction (unable to lock database)
error: could not lock database: Read-only file system
questo e' il log di pacman e indica l'ultimo aggiornamento del sistema che ho fatto ieri 25

Codice: Seleziona tutto

[2015-01-24 00:23] [PACMAN] Running 'pacman -Syu'
[2015-01-24 00:23] [PACMAN] synchronizing package lists
[2015-01-24 00:23] [PACMAN] starting full system upgrade
[2015-01-24 00:23] [ALPM] transaction started
[2015-01-24 00:23] [ALPM] upgraded libdbus (1.8.12-1 -> 1.8.14-1)
[2015-01-24 00:23] [ALPM] upgraded dbus (1.8.12-1 -> 1.8.14-1)
[2015-01-24 00:23] [ALPM] upgraded openssl (1.0.1.k-1 -> 1.0.1.l-1)
[2015-01-24 00:23] [ALPM] upgraded python-setuptools (1:12.0.3-1 -> 1:12.0.4-1)
[2015-01-24 00:23] [ALPM] upgraded youtube-dl (2015.01.16-1 -> 2015.01.22-1)
[2015-01-24 00:23] [ALPM] transaction completed
[2015-01-25 21:58] [PACMAN] Running 'pacman -Syu'
[2015-01-25 21:58] [PACMAN] synchronizing package lists
[2015-01-25 21:58] [PACMAN] starting full system upgrade
[2015-01-25 21:59] [ALPM] transaction started
[2015-01-25 22:00] [ALPM] warning: /boot/config.txt installed as /boot/config.txt.pacnew
[2015-01-25 22:00] [ALPM] warning: /boot/cmdline.txt installed as /boot/cmdline.txt.pacnew
[2015-01-25 22:00] [ALPM] upgraded linux-raspberrypi (3.12.36-1 -> 3.18.3-1)
[2015-01-25 22:00] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2015-01-25 22:00] [ALPM-SCRIPTLET] ________________________________________________________________________________
[2015-01-25 22:00] [ALPM-SCRIPTLET] 
[2015-01-25 22:00] [ALPM-SCRIPTLET] WARNING: This kernel provides updated config.txt and cmdline.txt files.
[2015-01-25 22:00] [ALPM-SCRIPTLET]          Check for pacnew files in /boot and merge or replace the existing files
[2015-01-25 22:00] [ALPM-SCRIPTLET]          with the new versions.
[2015-01-25 22:00] [ALPM-SCRIPTLET] ________________________________________________________________________________
[2015-01-25 22:00] [ALPM-SCRIPTLET] 
[2015-01-25 22:00] [ALPM] upgraded openresolv (3.5.7-2 -> 3.6.1-1)
[2015-01-25 22:00] [ALPM] upgraded pacman (4.2.0-5 -> 4.2.0-6)
[2015-01-25 22:00] [ALPM] upgraded sqlite (3.8.8-1 -> 3.8.8.1-1)
[2015-01-25 22:00] [ALPM] upgraded youtube-dl (2015.01.22-1 -> 2015.01.23.4-1)
[2015-01-25 22:00] [ALPM] transaction completed
Inutile dire che ho tentato di risolvere leggendo sul forum dove ho trovato solo questo viewtopic.php?f=5&t=17889 ma purtroppo non ho avuto successo.

Grazie per l'aiuto
Ultima modifica di Pepppe il 26 gennaio 2015, 13:52, modificato 1 volta in totale.

Avatar utente
Superpiffer
Novello Arciere
Messaggi: 76
Iscritto il: 25 giugno 2011, 1:01
Architettura: x86_64 (64bit)

Re: pacman: "failed to update" (Raspberry-pi)

Messaggio da Superpiffer » 26 gennaio 2015, 10:47

C'è stato un aggiornamento del kernel e dovrai, come dice il warning, controllare il pacnew del file /boot/cmdline.txt che ora ha bisogno dell'opzione "rw" per poter montare la SD in lettura e scrittura.
Asus K52Jc - Intel Core i3 M 350 @2.27GHz - Arch x86_64 - linux-ck-nehalem - KDE

ro1900
Novello Arciere
Messaggi: 46
Iscritto il: 20 gennaio 2013, 1:30

Re: pacman: "failed to update" (Raspberry-pi)

Messaggio da ro1900 » 26 gennaio 2015, 11:06

io ho risolto eliminando /boot/config.txt e cmdline.txt e rinominando i nuovi

ro1900
Novello Arciere
Messaggi: 46
Iscritto il: 20 gennaio 2013, 1:30

Re: pacman: "failed to update" (Raspberry-pi)

Messaggio da ro1900 » 26 gennaio 2015, 11:23

Codice: Seleziona tutto

rm /boot/config.txt
rm /boot/cdmline.txt
mv /boot/config.txt.pacnew /boot/config.txt
mv /boot/cdmline.txt.pacnew /boot/cdmline.txt
da terminale ti riesci a connettere?

Avatar utente
TheSaint
Robin Hood
Messaggi: 7951
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: pacman: "failed to update" (Raspberry-pi)

Messaggio da TheSaint » 26 gennaio 2015, 13:07

Hai problemi con gli aggiornamenti, verifica che i nuovi files abbiano importanza con quello che contengono, fai il confronto dei files.
L' altro problema dovrebbe vedere che non hai il disco pieno.
Per pacman vedi qui e togli il /var/lib/pacman/db.lck
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Pepppe
Arciere Provetto
Messaggi: 423
Iscritto il: 29 febbraio 2012, 21:55

Re: pacman: "failed to update" (Raspberry-pi)

Messaggio da Pepppe » 26 gennaio 2015, 13:52

Ho risolto seguendo il consiglio di ro1900. Dovevo (ovviamente) fare più attenzione ai messaggi di pacman ed ai nuovi packnew. Non ho fatto il confronto tra i file (/boot/config.txt e /boot/cdmline.tx ed i nuovi introdotti con l'aggiornamento di pacman) solo perchè di solito uso meld con GUI, mentre in questo caso avevo il Raspberry senza interfaccia grafica e quindi ....

Ringrazio tutti di cuore e metto "Risolto"

Avatar utente
TheSaint
Robin Hood
Messaggi: 7951
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: pacman: "failed to update" (Raspberry-pi)

Messaggio da TheSaint » 26 gennaio 2015, 18:08

Pepppe ha scritto: perchè di solito uso meld con GUI, mentre in questo caso avevo il Raspberry senza interfaccia grafica e quindi
Scaricavi i files e li confrontavi ;) (Forse serviva di copiarli in una directory condivisa).
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

ro1900
Novello Arciere
Messaggi: 46
Iscritto il: 20 gennaio 2013, 1:30

Re: [Risolto] pacman: "failed to update" (Raspberry-pi)

Messaggio da ro1900 » 26 gennaio 2015, 18:38

Farai bene a dare un occhiata, nel nuovo config.txt ci sono state delle aggiunte... e se hai overcloccato in precedenza dovresti rifarlo

Pepppe
Arciere Provetto
Messaggi: 423
Iscritto il: 29 febbraio 2012, 21:55

Re: [Risolto] pacman: "failed to update" (Raspberry-pi)

Messaggio da Pepppe » 26 gennaio 2015, 21:48

ro1900 ha scritto:Farai bene a dare un occhiata, nel nuovo config.txt ci sono state delle aggiunte... e se hai overcloccato in precedenza dovresti rifarlo

si infatti lo avevio overcloccato, adesso ci rido' uno sguardo.
Grazie di nuovo :D

dax79
Novello Arciere
Messaggi: 48
Iscritto il: 28 gennaio 2013, 17:03

Re: [Risolto] pacman: "failed to update" (Raspberry-pi)

Messaggio da dax79 » 28 gennaio 2015, 9:55

@ro1900: i comndi esatti sono

Codice: Seleziona tutto

rm /boot/[b]cmd[/b]line.txt
mv /boot/[b]cmd[/b]line.txt.pacnew /boot/[b]cmd[/b]line.txt

:D

Rispondi