[Risolto] errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Domande inerenti al gestore dei pacchetti di Arch Linux
Bloccato
Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

[Risolto] errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da vda » 3 settembre 2014, 18:16

Ciao a tutti,

è da un po' che, non disponendo di una valida connessione ad Internet, non aggiornavo il sistema.

Sta di fatto che, quando oggi ho eseguito

Codice: Seleziona tutto

$ sudo pacman -Syu


ho ottenuto il seguente errore:

Codice: Seleziona tutto

errore: impossibile eseguire l'operazione richiesta (file in conflitto)
chromium: /usr/lib/chromium/libpdf.so è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
Ho anche provato a cercare il pacchetto di appartenenza del file incriminato

Codice: Seleziona tutto

$ pacman -Qo /usr/lib/chromium/libpdf.so 
ma ottengo in risposta il seguente messaggio;

Codice: Seleziona tutto

errore: Nessun pacchetto contiene /usr/lib/chromium/libpdf.so


Al momento ho tamponato aggiungendo a /etc/pacman.conf la riga

Codice: Seleziona tutto

IgnorePkg   = chromium


per evitare aggiornamenti di chromium, ma mi piacerebbe risolvere definitivamente il problema

8)
Ultima modifica di vda il 9 settembre 2014, 11:11, modificato 1 volta in totale.
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
smlb
Amministratore
Messaggi: 573
Iscritto il: 17 aprile 2013, 12:40
Architettura: x86_64 (64bit)
Località: /dev/null
Contatta:

Re: errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da smlb » 3 settembre 2014, 19:15

Prima di aprire thread ed effettuare altre azioni sul forum, leggere attentamente: forum etiquette

Consultare la wiki prima di postare sul forum - inserire sempre informazioni attinenti alle problematiche riscontrate

VenereNera
Little John
Messaggi: 952
Iscritto il: 20 dicembre 2012, 19:50

Re: errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da VenereNera » 3 settembre 2014, 19:17

Salve,
Non uso Chromium quindi chiedo:
Il lettore pdf è nativo di Chromium oppure hai installato da AUR un qualche pacchetto tipo chromium-stable-libpdf?
Hai provato aggiornare il sistema con yaourt o quel che usi per installare da AUR?
Perché Qui leggo che andrebbero aggiornati entrambi.

Bye ^_^

Avatar utente
smlb
Amministratore
Messaggi: 573
Iscritto il: 17 aprile 2013, 12:40
Architettura: x86_64 (64bit)
Località: /dev/null
Contatta:

Re: errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da smlb » 3 settembre 2014, 19:19

Non uso Chromium, indi per cui ho cercato una soluzione al tuo problema ed e` saltato fuori questa discussione.
Prima di aprire thread ed effettuare altre azioni sul forum, leggere attentamente: forum etiquette

Consultare la wiki prima di postare sul forum - inserire sempre informazioni attinenti alle problematiche riscontrate

Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Re: errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da vda » 4 settembre 2014, 14:50

Grazie innanzitutto delle risposte:

Per quanto riguarda la discussione citata da smlb
si riferisce all'indicazione fornita anche nel wiki all'indirizzo https://wiki.archlinux.org/index.php/chromium#libpdf.

Tuttavia, non risultano installati nè il pacchetto chromium-libpdf, nè chromium-libpdf-dev.

Quanto a quello che chiede VenereNera
VenereNera ha scritto:
Salve,
Non uso Chromium quindi chiedo:
Il lettore pdf è nativo di Chromium oppure hai installato da AUR un qualche pacchetto tipo chromium-stable-libpdf?
Hai provato aggiornare il sistema con yaourt o quel che usi per installare da AUR?
Perché Qui leggo che andrebbero aggiornati entrambi.

Bye ^_^
no! Non ho installato alcun pacchetto da AUR per file .pdf


Pensavo a questo punto di rinominare il file in libpdf.so.bck e forzare l'aggiornamento. Voi cosa ne pensate?

L'alternativa sarebbe disinstallare completamente Chromium ed installare direttamente la nuova versione.

8)
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da KleinerMann » 4 settembre 2014, 16:24

non forzare, fai come dice il wiki: rinomini il file e aggiorni. Se tutto funziona correttamente dopo (e non vedo perché non dovrebbe) potrai rimuovere il file rinominato
Arch Linux - AwesomeWM

Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Re: errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da vda » 4 settembre 2014, 17:14

KleinerMann ha scritto:
non forzare, fai come dice il wiki: rinomini il file e aggiorni. Se tutto funziona correttamente dopo (e non vedo perché non dovrebbe) potrai rimuovere il file rinominato
Grazie del contributo KleinerMann, anche se, in realtà, non è che questo lo dica esattamente il wiki: è solo una mia supposizione che, in mancanza di alternative valide, rinominare il file che dà problemi opponendosi all'aggiornamento di Chromium (questo intendevo per "forzare") non debba, in linea di principio, creare particolari problemi. Sarà realmente così? In ogni caso, credo che l'unica possibilità sia quella di provare...

Vi farò sapere,

8)
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da KleinerMann » 4 settembre 2014, 22:32

Se il file non è di proprietà di un altro pacchetto, rinominare il file che 'esiste nel filesystem' e rieseguire il comando di aggiornamento. Se tutto va bene, il file può essere rimosso.
cit da: pacman_(Italiano)
:D :D

Vedrai che non avrai problemi :D
Arch Linux - AwesomeWM

Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Re: errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da vda » 8 settembre 2014, 16:15

Incredibile, ma vero!

Rinominando il file, come anche suggerisce KleinerMann, è possibile procedere all'aggiornamento di Chromium (la versione 37 integra un proprio lettore pdf). Il problema sembrerebbe quindi risolto, se non fosse che, nel frattempo, si verifica un'altra incompatibilità analoga:

Codice: Seleziona tutto


sudo pacman -Syu
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community è aggiornato
 multilib è aggiornato
:: Aggiornamento del sistema in corso...
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...

Pacchetti (2): libexttextcat-3.4.4-1  pinot-1.08-1

Dimensione totale dei pacchetti da installare:   5,15 MiB
Dimensione netta dell'aggiornamento:             0,39 MiB

:: Vuoi procedere con l'installazione? [S/n] S
(2/2) verifica delle chiavi presenti nel porta...  [######################] 100%
(2/2) verifica dell'integrità dei pacchetti        [######################] 100%
(2/2) caricamento dei file dei pacchetti           [######################] 100%
(2/2) controllo dei conflitti in corso             [######################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
libexttextcat: /usr/bin/createfp è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

Questa volta:

Codice: Seleziona tutto


sudo pacman -Qo /usr/bin/createfp
/usr/bin/createfp è contenuto in libtextcat 2.2-9


Cosa faccio: anche in questo caso rinomino e procedo con l'aggiornamento?

8)
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da KleinerMann » 9 settembre 2014, 10:56

Risolvi allo stesso modo, anche se non capirò mai perché pacman si pianti su una sostituzione di file appartenente allo stesso pacchetto...
Arch Linux - AwesomeWM

Avatar utente
vda
Arciere Provetto
Messaggi: 596
Iscritto il: 13 febbraio 2011, 10:53
Architettura: x86_64 (64bit)

Re: errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da vda » 9 settembre 2014, 11:09

KleinerMann ha scritto:
Risolvi allo stesso modo, anche se non capirò mai perché pacman si pianti su una sostituzione di file appartenente allo stesso pacchetto...
Grazie ancora una volta KleinerMann. In realtà, quasi per caso, ho appena risolto disinstallando e reinstallando pinot

Codice: Seleziona tutto


sudo pacman -Rs pinot
sudo pacman -Sy pinot



In questo modo, di fatto è stato reinstallato anche libexttextcat (ma è una dipendenza di pinot?) ed il tutto sembra aver ripreso a funzionare.

8)
Soltanto quando siamo in grado di dare possediamo veramente.
Tutto ciò che non siamo in grado di dare ci possiede. [André Gide]

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: [Risolto] errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da KleinerMann » 9 settembre 2014, 12:04

Sì, libexttextcat è richiesto da pinot: https://www.archlinux.org/packages/comm ... xttextcat/
Arch Linux - AwesomeWM

Avatar utente
smlb
Amministratore
Messaggi: 573
Iscritto il: 17 aprile 2013, 12:40
Architettura: x86_64 (64bit)
Località: /dev/null
Contatta:

Re: [Risolto] errore: /usr/lib/chromium/libpdf.so è già presente nel filesystem

Messaggio da smlb » 9 settembre 2014, 12:08

Risolto. Chiudo il thread.
Prima di aprire thread ed effettuare altre azioni sul forum, leggere attentamente: forum etiquette

Consultare la wiki prima di postare sul forum - inserire sempre informazioni attinenti alle problematiche riscontrate

Bloccato