[Risolto] Problema aggiornamento xorg e driver catalyst

Domande inerenti al gestore dei pacchetti di Arch Linux
Rispondi
Avatar utente
Daniel.White
Novello Arciere
Messaggi: 42
Iscritto il: 24 marzo 2014, 18:48
Architettura: x86_64 (64bit)

[Risolto] Problema aggiornamento xorg e driver catalyst

Messaggio da Daniel.White » 29 luglio 2014, 14:23

Salve, ho installato la versione 14.4 di catalyst-total-pxp che è compatibile con X.Org 1.15 perciò ho deciso di aggiornarlo.
Ho aggiunto la repo xorg115 in pacman.conf e ho provato ad aggiornare ma ci sono degli errori con le dipendenze che non riesco a risolvere

Codice: Seleziona tutto

:: Sincronizzazione dei database in corso...
 xorg115 è aggiornato
 core è aggiornato
 extra è aggiornato
 community è aggiornato
 multilib è aggiornato
:: Aggiornamento del sistema in corso...
attenzione: gdm: l'aggiornamento del pacchetto è stato ignorato (3.10.0.1-2 => 3.12.2-1)
attenzione: glamor-egl: la versione installata (0.6.0-2) è più recente di quella presente in xorg115 (0.6.0-1)
:: Vuoi sostituire twisted con extra/python2-twisted? [S/n] n
attenzione: xf86-input-evdev: l'aggiornamento del pacchetto è stato ignorato (2.8.2-1 => 2.9.0-1)
attenzione: xorg-server: l'aggiornamento del pacchetto è stato ignorato (1.14.5-11 => 1.15.2-1)
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
:: xf86-video-intel e xorg-server vanno in conflitto. Vuoi rimuovere xorg-server? [s/N] s
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: catalyst-total-pxp: richiede xorg-server>=1.7.0
:: catalyst-total-pxp: richiede xorg-server<1.16.0
:: gdm: richiede xorg-server
Grazie in anticipo
Ultima modifica di Daniel.White il 29 luglio 2014, 19:42, modificato 1 volta in totale.

pineout
Little John
Messaggi: 1264
Iscritto il: 10 luglio 2014, 9:08

Re: [PROBLEMA] Problema aggiornmento xorg

Messaggio da pineout » 29 luglio 2014, 14:59

Cosi' non si capisce molto purtroppo, stai provando da terminale con interfaccia grafica spenta?

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: Problema aggiornmento xorg e driver catalyst

Messaggio da KleinerMann » 29 luglio 2014, 15:58

I driver catalyst purtroppo "rompono" ad ogni aggiornamento. Inoltre sembra che tu abbia molto cose in "IgnorePkg" di pacman.conf, mi sbaglio?
Arch Linux - AwesomeWM

Avatar utente
Daniel.White
Novello Arciere
Messaggi: 42
Iscritto il: 24 marzo 2014, 18:48
Architettura: x86_64 (64bit)

Re: Problema aggiornmento xorg e driver catalyst

Messaggio da Daniel.White » 29 luglio 2014, 19:18

No avevi ragione, in effetti xorg-server ed altri pacchetti erano ignorati, ma ora non lo sono più
Il problema sussiste ancora: in pratica se aggiorno xorg mi dice che glamor-egl è in confiltto con xorg e serve a xf86-video-intel; invece se aggiorno solo xf86-video-intel mi dice che devo rimuovere xorg-server

Avatar utente
Daniel.White
Novello Arciere
Messaggi: 42
Iscritto il: 24 marzo 2014, 18:48
Architettura: x86_64 (64bit)

Re: Problema aggiornamento xorg e driver catalyst

Messaggio da Daniel.White » 1 agosto 2014, 20:25

Ragazzi ho risolto disinstallando xf86-video-intel e poi aggiornando xorg.
Poi ho reinstallato xf86-video-intel :D

pineout
Little John
Messaggi: 1264
Iscritto il: 10 luglio 2014, 9:08

Re: [Risolto] Problema aggiornamento xorg e driver catalyst

Messaggio da pineout » 5 agosto 2014, 22:32

Tutto a caldo senza riavvi?

devil20
Newbie
Messaggi: 1
Iscritto il: 15 settembre 2014, 15:36
Architettura: x86 (32Bit)

Re: [Risolto] Problema aggiornamento xorg e driver catalyst

Messaggio da devil20 » 15 settembre 2014, 15:40

Il problema sussiste ancora: in pratica se aggiorno xorg mi dice che glamor-egl è in confiltto con xorg e serve a xf86-video-intel; invece se aggiorno solo xf86-video-intel mi dice che devo rimuovere xorg-server
Ultima modifica di devil20 il 30 settembre 2014, 6:25, modificato 1 volta in totale.

pineout
Little John
Messaggi: 1264
Iscritto il: 10 luglio 2014, 9:08

Re: [Risolto] Problema aggiornamento xorg e driver catalyst

Messaggio da pineout » 16 settembre 2014, 15:06

Scusa, la tua scheda necessita dei driver Intel o Ati? I driver opensource sono xf86-video-ati

Rispondi