[RISOLTO]errore installazione pacchetti pacman

Domande inerenti al gestore dei pacchetti di Arch Linux
Rispondi
tumbler
Newbie
Messaggi: 24
Iscritto il: 8 settembre 2012, 11:11

[RISOLTO]errore installazione pacchetti pacman

Messaggio da tumbler » 31 maggio 2014, 12:08

Buongiorno a tutti ... stamattina ho lanciato un aggiornamento ma non va a buon fine

Codice: Seleziona tutto

 readline-6.3.006-1-...   283,0 KiB   610K/s 00:00 [######################] 100%
 bash-4.3.018-1-x86_64   1236,8 KiB   831K/s 00:01 [######################] 100%
 cairo-1.12.16-2-x86_64   708,3 KiB   837K/s 00:01 [######################] 100%
 libtasn1-3.6-1-x86_64    102,7 KiB   828K/s 00:00 [######################] 100%
 gnutls-3.3.3-1-x86_64   1996,2 KiB   829K/s 00:02 [######################] 100%
 inputproto-2.3.1-1-any    76,9 KiB   663K/s 00:00 [######################] 100%
 libcups-1.7.3-2-x86_64   280,3 KiB   834K/s 00:00 [######################] 100%
 libx11-1.6.2-2-x86_64      2,0 MiB   828K/s 00:03 [######################] 100%
(8/8) verifica delle chiavi presenti nel porta...  [######################] 100%
(8/8) verifica dell'integrità dei pacchetti        [######################] 100%
errore: readline: signature from "Bartłomiej Stefan Piotrowski (Barthalion) <barthalion@gmail.com>" is invalid
:: Il file /var/cache/pacman/pkg/readline-6.3.006-1-x86_64.pkg.tar.xz è corrotto (il pacchetto non è valido oppure è corrotto (firma PGP)).
Vuoi eliminarlo? [S/n] 
mi segna tutti i pacchetti che mi scarica come corretti e mi suggerisce di cancellarli ... pulisco la cache?

lo fa con qualsiasi cosa cerchi di installare ... in piu ho trovato data ed ora sballati ... e non me li fa reimpostare e mi da una serie di errori ... provate a vedere

Codice: Seleziona tutto

[tumbler@tumbler ~]$ yaourt ntpdate
curl error: Peer certificate cannot be authenticated with given CA certificates
[tumbler@tumbler ~]$ date
mar  1 gen 2002, 17.31.26, CET
[tumbler@tumbler ~]$ date -s '31/05/2014 12:06:00'
date: data "31/05/2014 12:06:00" non valida
[tumbler@tumbler ~]$ sudo !!
sudo date -s '31/05/2014 12:06:00'
[sudo] password for tumbler: 
date: data "31/05/2014 12:06:00" non valida
[tumbler@tumbler ~]$ sudo date -s 31/05/2014 12:06:00
date: the argument "12:06:00" lacks a leading '+';
when using an option to specify date(s), any non-option
argument must be a format string beginning with '+'
Try 'date --help' for more information.
[tumbler@tumbler ~]$ hwclock --set --date='31/05/2014 12:06:00'
date: data "31/05/2014 12:06:00" non valida
hwclock: The date command issued by hwclock returned unexpected results.
The command was:
  date --date="31/05/2014 12:06:00" +seconds-into-epoch=%s
The response was:
  
hwclock: No usable set-to time.  Cannot set clock.
[tumbler@tumbler ~]$ sudo !!
sudo hwclock --set --date='31/05/2014 12:06:00'
date: data "31/05/2014 12:06:00" non valida
hwclock: The date command issued by hwclock returned unexpected results.
The command was:
  date --date="31/05/2014 12:06:00" +seconds-into-epoch=%s
The response was:
  
hwclock: No usable set-to time.  Cannot set clock.
[tumbler@tumbler ~]$ 
Ultima modifica di tumbler il 31 maggio 2014, 14:05, modificato 1 volta in totale.

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: errore installazione pacchetti pacman

Messaggio da KleinerMann » 31 maggio 2014, 12:12

Le due cose sono correlate, dai uno sguardo a https://wiki.archlinux.org/index.php/Pa ... invalid.22
Arch Linux - AwesomeWM

tumbler
Newbie
Messaggi: 24
Iscritto il: 8 settembre 2012, 11:11

Re: errore installazione pacchetti pacman

Messaggio da tumbler » 31 maggio 2014, 12:27

Perfetto ... è stato suffuciente

Codice: Seleziona tutto

# timedatectl set-time "yyyy-MM-dd hh:mm:ss"
Sai come posso fare in modo che l'orario si sincronizzi tramite rete internet??? ntpdate pare non supportato come pacchetto!

ho installato il pacchetto ntp ... va configurato o lo lascio così

Codice: Seleziona tutto

# With the default settings below, ntpd will only synchronize your clock.
#
# For details, see:
# - the ntp.conf man page
# - http://support.ntp.org/bin/view/Support/GettingStarted
# - https://wiki.archlinux.org/index.php/Network_Time_Protocol_daemon

# Associate to public NTP pool servers; see http://www.pool.ntp.org/
server 0.pool.ntp.org
server 1.pool.ntp.org
server 2.pool.ntp.org

# Only allow read-only access from localhost
restrict default noquery nopeer
restrict 127.0.0.1
restrict ::1

# Location of drift file
driftfile /var/lib/ntp/ntp.drift

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: errore installazione pacchetti pacman

Messaggio da KleinerMann » 31 maggio 2014, 13:02

Se non erro ntp va abilitato con il relativo servizio systemd

Codice: Seleziona tutto

# systemctl enable ntpd
Arch Linux - AwesomeWM

tumbler
Newbie
Messaggi: 24
Iscritto il: 8 settembre 2012, 11:11

Re: errore installazione pacchetti pacman

Messaggio da tumbler » 31 maggio 2014, 14:05

Perfetto grazie mille ... per me è risolto

Rispondi