Compilazione QT problema con qtwebkit

Domande inerenti al gestore dei pacchetti di Arch Linux
Rispondi
Avatar utente
Barone Rosso
Little John
Messaggi: 1249
Iscritto il: 30 agosto 2007, 9:36
Contatta:

Compilazione QT problema con qtwebkit

Messaggio da Barone Rosso » 27 settembre 2012, 18:46

Allora ho tentato di ricompilare QT con intel c++
Usando il PKGBUILD ufficiale.

https://projects.archlinux.org/svntogit ... ackages/qt

E ho rifatto il PKGBUILD in questo modo:

Codice: Seleziona tutto


pkgbase=qt
pkgname=('qt' 'qt-private-headers')
pkgver=4.8.3
pkgrel=4
arch=('i686' 'x86_64')
url='http://qt-project.org/'
license=('GPL3' 'LGPL')
makedepends=('libtiff' 'libpng' 'libmng' 'sqlite' 'ca-certificates' 'glib2' 'dbus'
    'fontconfig' 'libgl' 'libsm' 'libxrandr' 'libxv' 'libxi' 'alsa-lib'
    'xdg-utils' 'hicolor-icon-theme' 'desktop-file-utils' 'mesa' 'postgresql-libs'
    'mysql' 'unixodbc' 'cups' 'gtk2' 'libfbclient')
options=('!libtool')
_pkgfqn="${pkgbase}-everywhere-opensource-src-${pkgver}"
source=("http://releases.qt-project.org/qt4/source/${_pkgfqn}.tar.gz"
        'assistant.desktop' 'designer.desktop' 'linguist.desktop'
        'qtconfig.desktop'
        'improve-cups-support.patch'
        'fix-crash-in-assistant.patch'
        'undo-fix-jit-crash-on-x86_64.patch'
        'disable-ssl-compression.patch')
md5sums=('a663b6c875f8d7caa8ac9c30e4a4ec3b'
         'fc211414130ab2764132e7370f8e5caa'
         '85179f5e0437514f8639957e1d8baf62'
         'f11852b97583610f3dbb669ebc3e21bc'
         '6b771c8a81dd90b45e8a79afa0e5bbfd'
         'c439c7731c25387352d8453ca7574971'
         '57590084078b6379f0501f7728b02ae2'
         '094e5a4e30e52423c77daa4a9c782df5'
         'e74c7413de2a0d5ad3478c75f4095687')

build() {
  cd "${srcdir}"/${_pkgfqn}

  # (FS#28381) (KDEBUG#180051)
  patch -p1 -i "${srcdir}"/improve-cups-support.patch
                                                                                                                                                                                                                               
  # (FS#29469)                                                                                                                                                                                                                 
  patch -p1 -i "${srcdir}"/fix-crash-in-assistant.patch                                                                                                                                                                        
                                                                                                                                                                                                                               
  # (FS#31654)                                                                                                                                                                                                                 
  patch -Rp1 -i "${srcdir}"/undo-fix-jit-crash-on-x86_64.patch                                                                                                                                                                 
                                                                                                                                                                                                                               
  # Security fix                                                                                                                                                                                                               
  patch -p1 -i "${srcdir}"/disable-ssl-compression.patch                                                                                                                                                                       
                                                                                                                                                                                                                               
  export QT4DIR="${srcdir}"/${_pkgfqn}                                                                                                                                                                                         
  export LD_LIBRARY_PATH=${QT4DIR}/lib:${LD_LIBRARY_PATH}                                                                                                                                                                      
                                                                                                                                                                                                                               
  sed -i "s|-O2|${CXXFLAGS}|" mkspecs/common/{g++,gcc}-base.conf                                                                                                                                                               
  sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" mkspecs/common/gcc-base-unix.conf                                                                                                                                            
  sed -i "/^QMAKE_LFLAGS\s/s|+=|+= ${LDFLAGS}|g" mkspecs/common/gcc-base.conf                                                                                                                                                  
                                                                                                                                                                                                                               
  ./configure -confirm-license -opensource \                                                                                                                                                                                   
    -platform linux-icc-64 \                                                                                                                                                                                                   
    -prefix /usr \                                                                                                                                                                                                             
    -docdir /usr/share/doc/qt \
    -plugindir /usr/lib/qt/plugins \
    -importdir /usr/lib/qt/imports \
    -datadir /usr/share/qt \
    -translationdir /usr/share/qt/translations \
    -sysconfdir /etc/xdg \
    -examplesdir /usr/share/doc/qt/examples \
    -demosdir /usr/share/doc/qt/demos \
    -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
    -system-sqlite \
    -no-phonon \
    -no-phonon-backend \
    -no-webkit \
    -graphicssystem raster \
    -openssl-linked \
    -nomake demos \
    -nomake examples \
    -nomake docs \
    -silent \
    -no-rpath \
    -optimized-qmake \
    -reduce-relocations \
    -dbus-linked \
    -no-openvg
  make
}

package_qt() {
    pkgdesc='A cross-platform application and UI framework'
    depends=('libtiff' 'libpng' 'libmng' 'sqlite' 'ca-certificates' 'glib2' 'dbus'
      'fontconfig' 'libgl' 'libsm' 'libxrandr' 'libxv' 'libxi' 'alsa-lib'
      'xdg-utils' 'hicolor-icon-theme' 'desktop-file-utils')
    optdepends=('postgresql-libs: PostgreSQL driver'
                'libmysqlclient: MySQL driver'
                'unixodbc: ODBC driver'
                'libfbclient: Firebird/iBase driver'
                'libxinerama: Xinerama support'
                'libxcursor: Xcursor support'
                'libxfixes: Xfixes support')
    install='qt.install'

    cd "${srcdir}"/${_pkgfqn}
    make INSTALL_ROOT="${pkgdir}" install

    # install missing icons and desktop files
    for icon in tools/linguist/linguist/images/icons/linguist-*-32.png ; do
      size=$(echo $(basename ${icon}) | cut -d- -f2)
      install -p -D -m644 ${icon} \
        "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/linguist.png"
    done
    install -p -D -m644 src/gui/dialogs/images/qtlogo-64.png \
      "${pkgdir}/usr/share/icons/hicolor/64x64/apps/qtlogo.png"
    install -p -D -m644 tools/assistant/tools/assistant/images/assistant.png \
      "${pkgdir}/usr/share/icons/hicolor/32x32/apps/assistant.png"
    install -p -D -m644 tools/designer/src/designer/images/designer.png \
      "${pkgdir}/usr/share/icons/hicolor/128x128/apps/designer.png"
    install -d "${pkgdir}/usr/share/applications"
    install -m644 "${srcdir}"/{linguist,designer,assistant,qtconfig}.desktop \
      "${pkgdir}/usr/share/applications/"

    # install license addition
    install -D -m644 LGPL_EXCEPTION.txt \
      ${pkgdir}/usr/share/licenses/qt/LGPL_EXCEPTION.txt

    # Fix wrong path in pkgconfig files
    find "${pkgdir}/usr/lib/pkgconfig" -type f -name '*.pc' \
      -exec perl -pi -e "s, -L${srcdir}/?\S+,,g" {} \;

    # Fix wrong path in prl files
    find "${pkgdir}/usr/lib" -type f -name '*.prl' \
      -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
}

package_qt-private-headers(){
    pkgdesc="Qt private headers for development"
    depends=("qt=${pkgver}")

    install -d "${pkgdir}"/usr/include/{QtCore,QtDeclarative,QtGui,QtScript}
    install -d "${pkgdir}"/usr/src/{corelib,declarative,gui,script}
    
    for i in QtCore QtDeclarative QtGui QtScript; do
      cp -r "${srcdir}"/${_pkgfqn}/include/${i}/private/ \
        "${pkgdir}"/usr/include/${i}/
    done

    for i in corelib declarative gui script; do
      cp -r "${srcdir}"/${_pkgfqn}/src/${i} "${pkgdir}"/usr/src/
    done
}


Aggiungendo solo l'opzione relativa al compilatore nel configure

Ma il problema è webkit, ovvero c'è l'opzione per disattivare webkit, ma quando compila per qualche strano motivo va a compilare del files che
richiedono webkit, col risultato che si blocca.

Il pacchetto qtwebkit è installato nel mio sistema, quindi in teoria dovrebbe trovarlo.

Codice: Seleziona tutto

make[4]: Leaving directory `/opt/packages/qt/src/qt-everywhere-opensource-src-4.8.3/tools/assistant/tools/assistant'
make[4]: Entering directory `/opt/packages/qt/src/qt-everywhere-opensource-src-4.8.3/tools/assistant/tools/assistant'
compiling mainwindow.cpp
compiling .moc/release-shared/moc_bookmarkmanagerwidget.cpp
compiling helpviewer_qwv.cpp
compiling .moc/release-shared/moc_centralwidget.cpp
compiling .moc/release-shared/moc_bookmarkmodel.cpp
compiling .moc/release-shared/moc_findwidget.cpp
compiling .moc/release-shared/moc_contentwindow.cpp
compiling .moc/release-shared/moc_filternamedialog.cpp
compiling .moc/release-shared/moc_helpenginewrapper.cpp
compiling .moc/release-shared/moc_helpviewer.cpp
compiling .moc/release-shared/moc_helpviewer_p.cpp
compiling .moc/release-shared/moc_indexwindow.cpp
compiling .moc/release-shared/moc_installdialog.cpp
helpviewer_qwv.cpp(159): error: not a class or struct name
  class HelpPage : public QWebPage
                          ^

helpviewer_qwv.cpp(165): error: identifier "QWebPage" is undefined
      virtual QWebPage *createWindow(QWebPage::WebWindowType);
              ^

helpviewer_qwv.cpp(165): error: name followed by "::" must be a class or namespace name
      virtual QWebPage *createWindow(QWebPage::WebWindowType);
                                     ^

helpviewer_qwv.cpp(166): error: identifier "WebAction" is undefined
      virtual void triggerAction(WebAction action, bool checked = false);
                                 ^

helpviewer_qwv.cpp(168): error: identifier "QWebFrame" is undefined
      virtual bool acceptNavigationRequest(QWebFrame *frame,
                                           ^

helpviewer_qwv.cpp(169): error: identifier "NavigationType" is undefined
          const QNetworkRequest &request, NavigationType type);
                                          ^

helpviewer_qwv.cpp(181): error: "QWebPage" is not a nonstatic data member or base class of class "HelpPage"
      : QWebPage(parent)
        ^

helpviewer_qwv.cpp(189): error: identifier "QWebPage" is undefined
  QWebPage *HelpPage::createWindow(QWebPage::WebWindowType)
  ^

helpviewer_qwv.cpp(189): error: name followed by "::" must be a class or namespace name
  QWebPage *HelpPage::createWindow(QWebPage::WebWindowType)
                                   ^

helpviewer_qwv.cpp(193): error: class "HelpViewer" has no member "page"
          ->createPage()->page());

ecc... 
                          ^
Ci sono idee ....

Avatar utente
ilpianista
Amministratore
Messaggi: 2952
Iscritto il: 6 ottobre 2007, 0:41
Località: Lecce, Italy
Contatta:

Re: Compilazione QT problema con qtwebkit

Messaggio da ilpianista » 27 settembre 2012, 21:23

e` proprio quello il problema: il pacchetto qtwebkit.
Rimuovilo e poi reinstallalo.

Avatar utente
Barone Rosso
Little John
Messaggi: 1249
Iscritto il: 30 agosto 2007, 9:36
Contatta:

Re: Compilazione QT problema con qtwebkit

Messaggio da Barone Rosso » 27 settembre 2012, 21:33

ascarpino ha scritto:e` proprio quello il problema: il pacchetto qtwebkit.
Rimuovilo e poi reinstallalo.
Soluzione degna del peggiore windows ....

Ho appena provato e non funziona.
Sembra proprio che non trovi gli include ... dovrebbero esserci variabili d'ambite particolari ?

Il fatto è che in quel punto sta compilando assistant ... che è un applicazione che richiede webkit!

Avatar utente
Barone Rosso
Little John
Messaggi: 1249
Iscritto il: 30 agosto 2007, 9:36
Contatta:

Re: Compilazione QT problema con qtwebkit

Messaggio da Barone Rosso » 27 settembre 2012, 23:04

Alla fine ho risolto mettendo un provide e un conflict dentro al pachetto delle Qt.
Comunque non ho capito a cosa serve quel pacchetto separato delle qtwebkit visto che dipende dalle qt ed è fornito di base nelle qt.

Oltre al fatto che il team di sviluppo di qtwebkit non rilascia nessun pacchetto ufficiale.

Rispondi