Nuovo Pacman 4 : configurazione e problemi generici

Domande inerenti al gestore dei pacchetti di Arch Linux
Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Messaggio da KleinerMann » 4 febbraio 2012, 11:40

4javier ha scritto:La feature dei delta package a cui ti riferisci è implementata in pacman da molto tempo. La puoi abilitare dal pacman.conf, però devi impostare un mirror apposito che la sfrutti. Se cerchi nel forum internazionale ce ne era uno (non ufficiale) che sfruttava questa impostazione. Non so se sia ancora attivo.
dovrebbe essere http://delta.archlinux.fr/
Arch Linux - AwesomeWM

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 4 febbraio 2012, 11:51

la famosa opzione Delta di pacman, non so a quanti repo e pacchetti sia disponibile

EDIT: in stra-ritardo
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Messaggio da KleinerMann » 4 febbraio 2012, 11:54

veleno77 ha scritto:la famosa opzine Delta di pacman, non so a quanti repo e pacchetti sia disponible
personalmente credo sia utile solo in caso di connessioni lente... però se avessi una connessione così lenta da dover scegliere di sfruttare il delta package probabilmente non userei una rolling... (parere del tutto personale :) )
Arch Linux - AwesomeWM

Avatar utente
ambro
Robin Hood
Messaggi: 1933
Iscritto il: 27 agosto 2009, 21:37
Località: Verona

Messaggio da ambro » 6 febbraio 2012, 17:39

Oggi per la prima volta ricevo degli errori in aggiornamento:

Codice: Seleziona tutto

errore: libxml2: key "976AC6FA3B94FA10" is unknown
errore: key "976AC6FA3B94FA10" could not be looked up remotely
errore: pixman: key "976AC6FA3B94FA10" is unknown
errore: key "976AC6FA3B94FA10" could not be looked up remotely
errore: impossibile eseguire l'operazione richiesta (il pacchetto non è valido oppure è corrotto)
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
Il mio pacman.conf

Codice: Seleziona tutto

[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc
# If upgrades are available for these packages they will be asked for first
SyncFirst   = pacman
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#UseDelta
#TotalDownload
CheckSpace
#VerbosePkgLists

# PGP signature checking
# NOTE: None of this will work without running `pacman-key --init` first.
# The compiled in default is equivalent to the following line. This requires
# you to locally sign and trust packager keys using `pacman-key` for them to be
# considered valid.
#SigLevel = Optional TrustedOnly
# If you wish to check signatures but avoid local sign and trust issues, use
# the following line. This will treat any key imported into pacman's keyring as
# trusted.
#SigLevel = Optional TrustAll
# For now, off by default unless you read the above.
##SigLevel = Never
SigLevel = Optional TrustedOnly


#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[repo-ck]
Server = http://repo-ck.com/$arch

[core]
#SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
#SigLevel = PackageOptional
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[community]
#SigLevel = PackageOptional
Include = /etc/pacman.d/mirrorlist
PC: Amd FX-6100-Nvidia GT630-SSD- 64bit - kernel 4.3-ck - KDE Plasma 5
Mediacenter: Asrock Q2900 Itx - VGA Intel - 64bit - kernel 4.3-ck - lxde - Kodi - isengard
Netbook: Asus eeepc1001 - i686 - kernel 4.3 - lxde

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 6 febbraio 2012, 18:48

i pacchetti sono di Jan de Groot ,puoi tranquillamente aggiungere la chiave

Codice: Seleziona tutto

pacman-key -l 976AC6FA3B94FA10
gpg: NOTA: il trustdb non è scrivibile
pub   2048R/3B94FA10 2011-06-06
uid                  Jan de Groot <jgc@archlinux.org>
sub   2048R/0FBDDA6F 2011-06-06
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
ambro
Robin Hood
Messaggi: 1933
Iscritto il: 27 agosto 2009, 21:37
Località: Verona

Messaggio da ambro » 6 febbraio 2012, 23:58

Codice: Seleziona tutto

[root@arciere1 ambro]# pacman-key -l 976AC6FA3B94FA10
gpg: error reading key: chiave pubblica non trovata
[root@arciere1 ambro]# pacman-key -r 3B94FA10
gpg: requesting key 3B94FA10 from hkp server pgp.mit.edu
gpg: keyserver timed out
gpg: ricezione dal keyserver fallita: errore del keyserver
==> Aggiornamento del database in corso...
gpg: non è necessario un controllo del trustdb
[root@arciere1 ambro]# pacman-key --edit-key 3B94FA10
==> ERRORE: La chiave identificata da 3B94FA10 non esiste.

Dove sbaglio ? :/

Inoltre:

Codice: Seleziona tutto

[root@arciere1 pkg]# pacman-key --refresh-keys
gpg: refreshing 26 keys from hkp://pgp.mit.edu:11371
gpg: requesting key 21E9BBBA from hkp server pgp.mit.edu
gpg: requesting key FFF979E7 from hkp server pgp.mit.edu
gpg: requesting key CDFD6BB0 from hkp server pgp.mit.edu
gpg: requesting key 4C7EA887 from hkp server pgp.mit.edu
gpg: requesting key 6AC6A4C2 from hkp server pgp.mit.edu
gpg: requesting key 824B18E8 from hkp server pgp.mit.edu
gpg: requesting key D30DB0AD from hkp server pgp.mit.edu
gpg: requesting key 615137BC from hkp server pgp.mit.edu
gpg: requesting key A9999C34 from hkp server pgp.mit.edu
gpg: requesting key F56C0C53 from hkp server pgp.mit.edu
gpg: requesting key EA433FC7 from hkp server pgp.mit.edu
gpg: requesting key 9741E8AC from hkp server pgp.mit.edu
gpg: requesting key 6176ED4B from hkp server pgp.mit.edu
gpg: requesting key 06361833 from hkp server pgp.mit.edu
gpg: requesting key EAE999BD from hkp server pgp.mit.edu
gpg: requesting key 9205AC90 from hkp server pgp.mit.edu
gpg: requesting key 215B37AD from hkp server pgp.mit.edu
gpg: requesting key 0F2A092B from hkp server pgp.mit.edu
gpg: requesting key 7EDF681F from hkp server pgp.mit.edu
gpg: requesting key 8406FFF3 from hkp server pgp.mit.edu
gpg: requesting key AB441196 from hkp server pgp.mit.edu
gpg: requesting key 00F0D0F0 from hkp server pgp.mit.edu
gpg: requesting key 4FA415FA from hkp server pgp.mit.edu
gpg: requesting key F04569AE from hkp server pgp.mit.edu
gpg: requesting key C0711BF1 from hkp server pgp.mit.edu
gpg: requesting key 4CE1C13E from hkp server pgp.mit.edu
gpg: keyserver timed out
gpg: aggiornamento del keyserver fallito: errore del keyserver
Ultima modifica di ambro il 7 febbraio 2012, 0:09, modificato 1 volta in totale.
PC: Amd FX-6100-Nvidia GT630-SSD- 64bit - kernel 4.3-ck - KDE Plasma 5
Mediacenter: Asrock Q2900 Itx - VGA Intel - 64bit - kernel 4.3-ck - lxde - Kodi - isengard
Netbook: Asus eeepc1001 - i686 - kernel 4.3 - lxde

Avatar utente
ambro
Robin Hood
Messaggi: 1933
Iscritto il: 27 agosto 2009, 21:37
Località: Verona

Messaggio da ambro » 7 febbraio 2012, 0:19

Ho risolto con:

Codice: Seleziona tutto

pacman-key --refresh-keys --keyserver hkp://keys.gnupg.net
Mi ha aggiornato il database delle key e quindi con un nuovo pacman -Syu mi ha chiesto di importare la key di Jan de Groot finalmente riconosciuta :D
PC: Amd FX-6100-Nvidia GT630-SSD- 64bit - kernel 4.3-ck - KDE Plasma 5
Mediacenter: Asrock Q2900 Itx - VGA Intel - 64bit - kernel 4.3-ck - lxde - Kodi - isengard
Netbook: Asus eeepc1001 - i686 - kernel 4.3 - lxde

Avatar utente
Ninquitassar
Little John
Messaggi: 1085
Iscritto il: 16 settembre 2011, 21:07
Architettura: x86_64 (64bit)
Località: 127.0.0.1

Messaggio da Ninquitassar » 7 febbraio 2012, 13:42

ambro ha scritto:Ho risolto con:

Codice: Seleziona tutto

pacman-key --refresh-keys --keyserver hkp://keys.gnupg.net
Mi ha aggiornato il database delle key e quindi con un nuovo pacman -Syu mi ha chiesto di importare la key di Jan de Groot finalmente riconosciuta :D
Di solito combiare server o fare quello che hai fatto tu risolve questo genere di errori.
CPU: Intel Core i5-4460 (3.20GHz) Video: NVIDIA GeForce GT610 RAM: 8Gb Kingston DDR3
OS: Arch x86_64 + i3 + GTK+
My DeviantART

Avatar utente
nav
Arciere Provetto
Messaggi: 607
Iscritto il: 7 ottobre 2009, 22:53
Località: Monza

Re: Nuovo Pacman 4 : configurazione - delucidazioni - proble

Messaggio da nav » 5 marzo 2012, 18:35

dopo aver parzialmente risolto mi ritrovo da settimane ormai con lo stesso medesimo errore:

Codice: Seleziona tutto

errore: impossibile scaricare il pacchetto 'core.db' da mirrors.kernel.org : Connection time-out
errore: impossibile aggiornare core (si è verificato un errore della libreria di download)
solo con il repo [core] e con svariati mirror (kernel, limun, puzzle, devnull, prometeus...)
la cosa inizia a pesare quando ci sono pacchetti legati a [core], come ad esempio l'ultimo aggiornamento a nvidia-295 mi ha bloccato x, non avendo potuto aggiornare il kernel... per fortuna sono riuscito a risolvere facilmente, abilitando xfer curl da pacman.conf
vorrei risolvere questa cosa una volta per tutte:

pacman.conf

Codice: Seleziona tutto

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
ILoveCandy
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc
# If upgrades are available for these packages they will be asked for first
SyncFirst   = pacman
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = i686

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#UseDelta
#TotalDownload
CheckSpace
#VerbosePkgLists

# PGP signature checking
# NOTE: None of this will work without running `pacman-key --init` first.
# The compiled in default is equivalent to the following line. This requires
# you to locally sign and trust packager keys using `pacman-key` for them to be
# considered valid.
#SigLevel = Optional TrustedOnly

# If you wish to check signatures but avoid local sign and trust issues, use
# the following line. This will treat any key imported into pacman's keyring as
# trusted.
#SigLevel = Optional TrustAll

# For now, off by default unless you read the above.
#SigLevel = Never
SigLevel = Required DatabaseOptional TrustedOnly

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[core]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
SigLevel = PackageOptional
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[community]
SigLevel = PackageOptional
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs
rc.conf

Codice: Seleziona tutto

#
# /etc/rc.conf - Main Configuration for Arch Linux
#
# See 'man 5 rc.conf' for more details
#

# LOCALIZATION
# ------------
HARDWARECLOCK="UTC"
TIMEZONE="Europe/Rome"
KEYMAP="it"
CONSOLEFONT=
CONSOLEMAP=
LOCALE="it_IT.UTF-8"
DAEMON_LOCALE="yes"
USECOLOR="yes"

# HARDWARE
# --------
MODULES=()
USEDMRAID="no"
USEBTRFS="no"
USELVM="no"

# NETWORKING
# ----------
HOSTNAME="arch"

interface=wlan0
address=
netmask=
broadcast=
gateway=

NETWORK_PERSIST="no"

# DAEMONS
# -------
#
DAEMONS=(hwclock @syslog-ng @crond @klogd dbus ufw !iptables wicd @clamav)
lspci

Codice: Seleziona tutto

van@arch ~ $ sudo lspci | grep -i net
02:04.0 Ethernet controller: Atheros Communications Inc. AR5413/AR5414 Wireless Network Adapter [AR5006X(S) 802.11abg] (rev 01)
02:08.0 Ethernet controller: Intel Corporation N10/ICH 7 Family LAN Controller (rev 01)
uso wicd, ho disabilitato ipv6 come da wiki, pgp keys aggiornate...

grazie :oops:
Linux user #490716

Avatar utente
Hilinus
Moderatore
Messaggi: 5649
Iscritto il: 25 ottobre 2008, 19:28
Architettura: x86_64 (64bit)

Re: Nuovo Pacman 4 : configurazione - delucidazioni - proble

Messaggio da Hilinus » 5 marzo 2012, 18:39

Provato a controllare dmesg per eventuali messaggi dalla scheda di rete quando si verifica il timeout? Altro non mi viene in mente :/
Q6600 @ 3.2 Ghz + Thermalright Ultra 120 Extreme | 6 GB DDR2 Ocz Gold
Asus P5K | Sapphire HD7850 2GB | E ovviamente... Arch Linux :)

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: Nuovo Pacman 4 : configurazione - delucidazioni - proble

Messaggio da KleinerMann » 5 marzo 2012, 18:40

hai provato a cambiare mirror? :)
edit ho detto una minc****a :P
Arch Linux - AwesomeWM

Avatar utente
nav
Arciere Provetto
Messaggi: 607
Iscritto il: 7 ottobre 2009, 22:53
Località: Monza

Re: Nuovo Pacman 4 : configurazione - delucidazioni - proble

Messaggio da nav » 5 marzo 2012, 18:57

Hilinus ha scritto:Provato a controllare dmesg per eventuali messaggi dalla scheda di rete quando si verifica il timeout? Altro non mi viene in mente :/
avevo già controllato, ci sono dei blocchi di ufw (firewall) ma anche con iptables o senza nessun firewall non cambia nulla.
aggiorno la mirrorlist ogni settimana con mirrorlist updater...
Linux user #490716

Avatar utente
nav
Arciere Provetto
Messaggi: 607
Iscritto il: 7 ottobre 2009, 22:53
Località: Monza

Re: Nuovo Pacman 4 : configurazione - delucidazioni - proble

Messaggio da nav » 8 marzo 2012, 0:29

OpenDNS mi ha salvato :D
Linux user #490716

Avatar utente
Barone Rosso
Little John
Messaggi: 1249
Iscritto il: 30 agosto 2007, 9:36
Contatta:

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da Barone Rosso » 19 marzo 2012, 8:34

Codice: Seleziona tutto

(3/3) controllo dell'integrità del pacchetto                                                     [########################################################] 100%
errore: openntpd: key "FCF3C8CB5CF9C8D4" is unknown

errore: key "FCF3C8CB5CF9C8D4" could not be looked up remotely
errore: impossibile eseguire l'operazione richiesta (il pacchetto non è valido oppure è corrotto)
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
Mi è successo questo ..... pacchetto non valido

Avatar utente
ambro
Robin Hood
Messaggi: 1933
Iscritto il: 27 agosto 2009, 21:37
Località: Verona

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da ambro » 19 marzo 2012, 9:01

Prova dopo un "refresh-key" o cambiando mirror se si ripete l'errore
PC: Amd FX-6100-Nvidia GT630-SSD- 64bit - kernel 4.3-ck - KDE Plasma 5
Mediacenter: Asrock Q2900 Itx - VGA Intel - 64bit - kernel 4.3-ck - lxde - Kodi - isengard
Netbook: Asus eeepc1001 - i686 - kernel 4.3 - lxde

Avatar utente
Barone Rosso
Little John
Messaggi: 1249
Iscritto il: 30 agosto 2007, 9:36
Contatta:

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da Barone Rosso » 19 marzo 2012, 9:21

ambro ha scritto:Prova dopo un "refresh-key" o cambiando mirror se si ripete l'errore
Si ripete e quella chiave sembra non essere valida.
Visto che con altri pacchetti funziona.

[Conclusione: si è risolto da solo, era il server PGP che è stato down per qualche ora]

ziomarco
Novello Arciere
Messaggi: 132
Iscritto il: 27 giugno 2009, 18:53

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da ziomarco » 10 aprile 2012, 22:51

Ciao.
Ho provato oggi per la prima volta ad abilitare la gestione delle chiavi, e credo che qualcosa non mi funzioni a dovere.
Come da wiki ho importato le 5 masterkey, ma se tento un pacman -Syu non mi chiede di importare le chiavi relative ai pacchetti in aggiornamento e conseguentemente termina in errore.

Codice: Seleziona tutto

[root@ufficio marco]# pacman -Syu
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community è aggiornato
:: Aggiornamento del sistema in corso...
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
Pacchetti (8): akonadi-1.7.2-1  gparted-0.12.1-1  gpsd-3.4-3  libmtp-1.1.3-1  libpciaccess-0.13.1-1
               python2-httplib2-0.7.4-1  xorg-server-1.12.0.902-1  xorg-server-common-1.12.0.902-1
Dimensione totale dei pacchetti da installare:   14,32 MiB
Dimensione dell'aggiornamento di rete: -0,04 MiB
Vuoi procedere con l'installazione? [S/n] 
(8/8) controllo dell'integrità del pacchetto         [########################################] 100%
errore: libpciaccess: key "94657AB20F2A092B" is unknown
errore: key "94657AB20F2A092B" could not be looked up remotely
errore: python2-httplib2: key "7FB1A3800C84C0A5" is unknown
errore: key "7FB1A3800C84C0A5" could not be looked up remotely
errore: xorg-server-common: key "94657AB20F2A092B" is unknown
errore: key "94657AB20F2A092B" could not be looked up remotely
errore: xorg-server: key "94657AB20F2A092B" is unknown
errore: key "94657AB20F2A092B" could not be looked up remotely
errore: impossibile eseguire l'operazione richiesta (il pacchetto non è valido oppure è corrotto (firma PGP))
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
importo una delle due chiavi necessarie:

Codice: Seleziona tutto

 pacman-key -r 94657AB20F2A092B
gpg: requesting key 0F2A092B from hkp server pgp.mit.edu
gpg: key 0F2A092B: public key "Andreas Radke <andyrtr@archlinux.org>" imported
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   5  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   5  signed:   4  trust: 0-, 0q, 0n, 5m, 0f, 0u
gpg: depth: 2  valid:   4  signed:   0  trust: 4-, 0q, 0n, 0m, 0f, 0u
gpg: Numero totale esaminato: 1
gpg:              importate: 1  (RSA: 1)
==> Aggiornamento del database in corso...
gpg: non è necessario un controllo del trustdb

e riprovo:

Codice: Seleziona tutto

[root@ufficio marco]# pacman -Syu
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community è aggiornato
:: Aggiornamento del sistema in corso...
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
Pacchetti (8): akonadi-1.7.2-1  gparted-0.12.1-1  gpsd-3.4-3  libmtp-1.1.3-1  libpciaccess-0.13.1-1
               python2-httplib2-0.7.4-1  xorg-server-1.12.0.902-1  xorg-server-common-1.12.0.902-1
Dimensione totale dei pacchetti da installare:   14,32 MiB
Dimensione dell'aggiornamento di rete: -0,04 MiB
Vuoi procedere con l'installazione? [S/n] 
(8/8) controllo dell'integrità del pacchetto                [########################################] 100%
errore: python2-httplib2: key "7FB1A3800C84C0A5" is unknown
errore: key "7FB1A3800C84C0A5" could not be looked up remotely
errore: impossibile eseguire l'operazione richiesta (il pacchetto non è valido oppure è corrotto)
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
[root@ufficio marco]# 
Se avessi importato anche la seconda chiave sarebbe andato tutto a buon fine.
Ma perche devo importare le chiavi 'a mano'? non dovrebbe propormi automaticamente l'importazione delle chiavi necessarie?

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da veleno77 » 10 aprile 2012, 23:06

in teoria si ultimamente mi pare che più di un utente abbia dovuti importarli a mano... non so se dipenda dal tipo di livello impostato in pacman.conf
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

ziomarco
Novello Arciere
Messaggi: 132
Iscritto il: 27 giugno 2009, 18:53

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da ziomarco » 11 aprile 2012, 0:47

il mio pacman.conf e' cosi':

Codice: Seleziona tutto

 # /etc/pacman.conf
    #
    # GENERAL OPTIONS
    #
    [options]
    # The following paths are commented out with their default values listed.
    # If you wish to use different paths, uncomment and update the paths.
    #RootDir     = /
    #DBPath      = /var/lib/pacman/
    #CacheDir    = /var/cache/pacman/pkg/
    #LogFile     = /var/log/pacman.log
    #GPGDir      = /etc/pacman.d/gnupg/
    HoldPkg     = pacman glibc
    # If upgrades are available for these packages they will be asked for first
    SyncFirst   = pacman
    #XferCommand = /usr/bin/curl -C - -f %u > %o
    #XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
    #CleanMethod = KeepInstalled
    Architecture = auto

    # Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
    #IgnorePkg   =
    #IgnoreGroup =
    #NoUpgrade   =
    #NoExtract   =

    # Misc options
    #UseSyslog
    #UseDelta
    #TotalDownload
    CheckSpace
    #VerbosePkgLists

    # PGP signature checking
    #
    #SigLevel = Optional TrustedOnly

    # If you wish to check signatures but avoid local sign and trust issues, use the
    # following line. This will treat any key imported into pacman's keyring as trusted.
    #SigLevel = Optional TrustAll

    # For now, off by default unless you read the above.
    #SigLevel = Never

    #   REPOSITORIES
    [core]
    SigLevel = PackageRequired TrustedOnly
    Include = /etc/pacman.d/mirrorlist

    [extra]
    SigLevel = PackageOptional TrustAll
    Include = /etc/pacman.d/mirrorlist

    [community]
    SigLevel = PackageOptional TrustAll
    Include = /etc/pacman.d/mirrorlist



ziomarco
Novello Arciere
Messaggi: 132
Iscritto il: 27 giugno 2009, 18:53

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da ziomarco » 11 aprile 2012, 13:28

risolto: stamattina facendo il consueto pacman -Syu mi ha proposto l'aggiornamento di pacman, ho caricato a mano la chiave che chiedeva e dopo l'aggiornamento ha cominciato a propormi in automatico il caricamento delle chiavi. :D

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da veleno77 » 11 aprile 2012, 17:41

evidentemente qualche chiave bisogna importarla a mano va a capire,,,,
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

ArchGoat
Newbie
Messaggi: 10
Iscritto il: 25 aprile 2012, 20:02

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da ArchGoat » 25 aprile 2012, 22:10

Salve a tutti mi chiamo Vincenzo, sono appena arrivato in Arch dopo varie distro, ed "ovviamente" iniziano i primi problemi :D
Dunque, durante l'installazione sotto virtualbox, nel momento in cui dò un

Codice: Seleziona tutto

pacman-key --init
mi resta la riga

Codice: Seleziona tutto

gpg: generating pacman keychain master key
per troppo tempo, sarà passato un quarto d'ora, è normale?
grazie

Avatar utente
Hilinus
Moderatore
Messaggi: 5649
Iscritto il: 25 ottobre 2008, 19:28
Architettura: x86_64 (64bit)

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da Hilinus » 25 aprile 2012, 22:17

Devi raccogliere entropia affinchè la coppia di chiavi venga generata con sufficiente casualità:
https://wiki.archlinux.org/index.php/Pa ... chiesto.3F
Q6600 @ 3.2 Ghz + Thermalright Ultra 120 Extreme | 6 GB DDR2 Ocz Gold
Asus P5K | Sapphire HD7850 2GB | E ovviamente... Arch Linux :)

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da veleno77 » 25 aprile 2012, 23:38

sulla guida per principianti è stato aggiunto ultimamente un paragrafo a riguardo
https://wiki.archlinux.org/index.php/Gu ... me_Notizie
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

ArchGoat
Newbie
Messaggi: 10
Iscritto il: 25 aprile 2012, 20:02

Re: Nuovo Pacman 4 : configurazione e problemi generici

Messaggio da ArchGoat » 26 aprile 2012, 12:54

In effetti è bastato produrre un pò di entropia, ahahahah assurdo! :lol:
Anche se in realtà non mi era stato richiesto, s'era solo "bloccato" e basta, mah....vabbè.
grazie ragazzi

Rispondi