Nuovo Pacman 4 : configurazione e problemi generici

Domande inerenti al gestore dei pacchetti di Arch Linux
Avatar utente
Semedisenape
Arciere
Messaggi: 165
Iscritto il: 29 agosto 2011, 13:47
Località: Bastia di Rovolon PD

Messaggio da Semedisenape » 24 gennaio 2012, 10:58

Sto per dare tutto alle fiamme...

Ho ripetuto la procedura millemila volte e non ne vengo fuori.

Codice: Seleziona tutto

[da@myhost ~]$ sudo pacman-key -r 44D4A033 AC140143 927397D4 7EFD567D 4C7EA887
gpg: requesting key 44D4A033 from hkp server keys.gnupg.net
gpg: requesting key AC140143 from hkp server keys.gnupg.net
gpg: requesting key 927397D4 from hkp server keys.gnupg.net
gpg: requesting key 7EFD567D from hkp server keys.gnupg.net
gpg: requesting key 4C7EA887 from hkp server keys.gnupg.net
gpg: keyserver timed out
gpg: ricezione dal keyserver fallita: errore del keyserver
==> Aggiornamento del database in corso...
gpg: non è necessario un controllo del trustdb
[da@myhost ~]$ sudo nano /etc/pacman.d/gnupg/gpg.conf
[da@myhost ~]$ sudo pacman-key -r 44D4A033 AC140143 927397D4 7EFD567D 4C7EA887
gpg: requesting key 44D4A033 from hkp server pgp.mit.edu
gpg: requesting key AC140143 from hkp server pgp.mit.edu
gpg: requesting key 927397D4 from hkp server pgp.mit.edu
gpg: requesting key 7EFD567D from hkp server pgp.mit.edu
gpg: requesting key 4C7EA887 from hkp server pgp.mit.edu
gpgkeys: HTTP fetch error 7: couldn't connect to host
^C
gpg: Interrupt caught ... exiting
[da@myhost ~]$ sudo nano /etc/pacman.d/gnupg/gpg.conf
[da@myhost ~]$ sudo pacman-key -r 44D4A033 AC140143 927397D4 7EFD567D 4C7EA887
gpg: requesting key 44D4A033 from http server wwwkeys.it.pgp.net
gpg: requesting key AC140143 from http server wwwkeys.it.pgp.net
gpg: requesting key 927397D4 from http server wwwkeys.it.pgp.net
gpg: requesting key 7EFD567D from http server wwwkeys.it.pgp.net
gpg: requesting key 4C7EA887 from http server wwwkeys.it.pgp.net
gpgkeys: http fetch error 6: Could not resolve host: wwwkeys.it.pgp.net; Name or service not known
gpg: Non sono stati trovati dati OpenPGP validi.
gpg: Numero totale esaminato: 0
gpg: keyserver internal error
gpg: ricezione dal keyserver fallita: errore del keyserver
==> Aggiornamento del database in corso...
gpg: non è necessario un controllo del trustdb
Ho provato a cambiare chiave, a cambiare 4 keyserver e a commentare il timeout di gpg perchè se no non terminava l'operazione.

Codice: Seleziona tutto

no-greeting
no-permission-warning
lock-never
keyserver http://wwwkeys.it.pgp.net
#keyserver-options timeout=10
Che altro faccio?

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 24 gennaio 2012, 11:44

prima di ripetere tutta la procedura prova prima a cancellare le configurazioni e a riavviare pacman-key in modo che ti generi una nuova chiave

Codice: Seleziona tutto

rm  /etc/pacman.d/gnupg/*
pacman-key --init
poi cambi il server e cominci a scaricare e convalidare le chiavi master
viewtopic.php?pid=112575#p112575
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 24 gennaio 2012, 13:26

Ecco uno dei problemi a cui non saprei come procedere

Codice: Seleziona tutto

:: Download dei pacchetti da repo-ck...
 linux-ck-kx-3.2.1-4-i686                                                                                                 44,1 MiB   733K/s 01:02 [------------------------------------------------------------------------------------------] 100%
(2/2) controllo dell'integrità del pacchetto                                                                                                      [------------------------------------------------------------------------------------------] 100%
errore: linux-ck-kx: signature from "graysky <graysky@archlinux.us>" is unknown trust
errore: impossibile eseguire l'operazione richiesta (il pacchetto non è valido oppure è corrotto (firma PGP))
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
ho il repo CK abilitato

Codice: Seleziona tutto

[repo-ck]
SigLevel = PackageOptional
Server = http://repo-ck.com/$arch
in questo caso uno come deve operare?
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
Ninquitassar
Little John
Messaggi: 1085
Iscritto il: 16 settembre 2011, 21:07
Architettura: x86_64 (64bit)
Località: 127.0.0.1

Messaggio da Ninquitassar » 24 gennaio 2012, 13:52

Io ho importato la chiave dello sviluppatore del repo. In quel caso credo non ci siano alternative, se non fare questo... Io almeno ho fatto così.
CPU: Intel Core i5-4460 (3.20GHz) Video: NVIDIA GeForce GT610 RAM: 8Gb Kingston DDR3
OS: Arch x86_64 + i3 + GTK+
My DeviantART

Avatar utente
Hilinus
Moderatore
Messaggi: 5649
Iscritto il: 25 ottobre 2008, 19:28
Architettura: x86_64 (64bit)

Messaggio da Hilinus » 24 gennaio 2012, 18:49

@Chi ha problemi di timeout durante la richiesta delle chiavi: sicuri che il vostro provider o router non blocchi la relativa porta?
Q6600 @ 3.2 Ghz + Thermalright Ultra 120 Extreme | 6 GB DDR2 Ocz Gold
Asus P5K | Sapphire HD7850 2GB | E ovviamente... Arch Linux :)

Avatar utente
nav
Arciere Provetto
Messaggi: 607
Iscritto il: 7 ottobre 2009, 22:53
Località: Monza

Messaggio da nav » 24 gennaio 2012, 19:27

Io ho risolto la richiesta chiavi commentando

Codice: Seleziona tutto

#keyserver-options timeout=10
nel gpg.conf :)

ma continuo a ricevere errore anche cambiando server:

Codice: Seleziona tutto

van@arch ~ $ sudo pacman -Syu
Password: 
attenzione: database file for 'core' does not exist
:: Sincronizzazione dei database in corso...
errore: impossibile scaricare il pacchetto 'core.db' da archlinux.puzzle.ch : Connection time-out
errore: impossibile aggiornare core (si è verificato un errore della libreria di download)
 extra è aggiornato
 community è aggiornato
:: Aggiornamento del sistema in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile trovare il database)
Linux user #490716

Avatar utente
Hilinus
Moderatore
Messaggi: 5649
Iscritto il: 25 ottobre 2008, 19:28
Architettura: x86_64 (64bit)

Messaggio da Hilinus » 24 gennaio 2012, 19:32

Cambia mirror ad archlinux.limun.org, poi riprova:

Codice: Seleziona tutto

pacman -Syy
Quel "si è verificato un errore nella libreria di download" mi preoccupa però...
Q6600 @ 3.2 Ghz + Thermalright Ultra 120 Extreme | 6 GB DDR2 Ocz Gold
Asus P5K | Sapphire HD7850 2GB | E ovviamente... Arch Linux :)

Avatar utente
nav
Arciere Provetto
Messaggi: 607
Iscritto il: 7 ottobre 2009, 22:53
Località: Monza

Messaggio da nav » 24 gennaio 2012, 19:46

c'è un modo per recuperare core.db?
Linux user #490716

Emalele1688
Novello Arciere
Messaggi: 48
Iscritto il: 25 febbraio 2011, 15:47

Messaggio da Emalele1688 » 24 gennaio 2012, 21:26

Codice: Seleziona tutto

sudo pacman -Syu
:: Sincronizzazione dei database in corso...                                                                                                                                                                                                                                   
 core è aggiornato                                                                                                                                                                                                                                                             
 extra è aggiornato                                                                                                                                                                                                                                                            
 community è aggiornato                                                                                                                                                                                                                                                        
 multilib è aggiornato                                                                                                                                                                                                                                                         
:: I seguenti pacchetti dovrebbero essere aggiornati prima :                                                                                                                                                                                                                   
    pacman                               
Ho provato in 101 modi, non ci riesco... Qualcuno sa come si risolve?

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Messaggio da KleinerMann » 24 gennaio 2012, 21:28

Emalele1688 ha scritto:Ho provato in 101 modi, non ci riesco... Qualcuno sa come si risolve?
posta l'output completo :)
Arch Linux - AwesomeWM

antico
Novello Arciere
Messaggi: 73
Iscritto il: 9 marzo 2008, 7:55
Località: vicenza

Messaggio da antico » 24 gennaio 2012, 22:43

Per scaricare le chiavi dal keyserver io ho dovuto modificare (o aggiungere) una regola ad iptables per aprire la porta 11371 in uscita al traffico tcp
( e poi dare /etc/rc.d/iptables restart )
Ultima modifica di antico il 24 gennaio 2012, 22:45, modificato 1 volta in totale.
senso della misura

Emalele1688
Novello Arciere
Messaggi: 48
Iscritto il: 25 febbraio 2011, 15:47

Messaggio da Emalele1688 » 25 gennaio 2012, 0:51

Ecco cio che mi dice
(output con procedure comprese)

Codice: Seleziona tutto

sudo pacman -Syu
Password: 
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra                                                                                                                                  1182,3K  623,5K/s 00:00:02 [#####################################################################################################] 100%
 community                                                                                                                              1033,4K  630,2K/s 00:00:02 [#####################################################################################################] 100%
 multilib è aggiornato
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] s

risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: valgrind: richiede glibc<2.15

Avatar utente
Barone Rosso
Little John
Messaggi: 1249
Iscritto il: 30 agosto 2007, 9:36
Contatta:

Messaggio da Barone Rosso » 25 gennaio 2012, 8:48

Emalele1688 ha scritto:Ecco cio che mi dice
(output con procedure comprese)

Codice: Seleziona tutto

......
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: valgrind: richiede glibc<2.15

pacman -Sy valgrind

Nei repo sembra essere aggiornato.

Avatar utente
nav
Arciere Provetto
Messaggi: 607
Iscritto il: 7 ottobre 2009, 22:53
Località: Monza

Messaggio da nav » 25 gennaio 2012, 8:53

apparentemente risolto decommentando in pacman.conf

Codice: Seleziona tutto

XferCommand = /usr/bin/curl -C - -f %u > %o
leggendo sull'internazionale dovrebbe essere un bug legato a ipv6 che curl riesce ad aggirare.
nessuno ha avuto lo stesso problema?
Linux user #490716

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 25 gennaio 2012, 11:02

Ninquitassar ha scritto:Io ho importato la chiave dello sviluppatore del repo. In quel caso credo non ci siano alternative, se non fare questo... Io almeno ho fatto così.
ma per importare una chiave cosa hai fatto nello specifico....??
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
Ninquitassar
Little John
Messaggi: 1085
Iscritto il: 16 settembre 2011, 21:07
Architettura: x86_64 (64bit)
Località: 127.0.0.1

Messaggio da Ninquitassar » 25 gennaio 2012, 12:05

veleno77 ha scritto: ma per importare una chiave cosa hai fatto nello specifico....??

Codice: Seleziona tutto

pacman-key -r <keyid>
Per importarla.

Codice: Seleziona tutto

pacman-key --edit-key <keyid>
per editare e poi il solito

Codice: Seleziona tutto

gpg> lsign
...
 Primary key fingerprint: ...
...
Really sign? (y/N)

Really sign? (y/N) y
gpg> trust
...
Your decision? 3
gpg> q
Save changes? (y/N) y
Per renderle affidabili.
CPU: Intel Core i5-4460 (3.20GHz) Video: NVIDIA GeForce GT610 RAM: 8Gb Kingston DDR3
OS: Arch x86_64 + i3 + GTK+
My DeviantART

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 25 gennaio 2012, 12:31

si ma non trovo la sua chiave devo mettere quella che mi da errore durante l'aggiornamento?
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Messaggio da KleinerMann » 25 gennaio 2012, 12:53

veleno77 ha scritto:si ma non trovo la sua chiave devo mettere quella che mi da errore durante l'aggiornamento?
si... copiala poi dai

Codice: Seleziona tutto

# pacman-key -r <chiave che hai copiato>
:)
Arch Linux - AwesomeWM

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 25 gennaio 2012, 13:35

Argh non me la da più neanche se elimino il pacchetto e lo riscarico... inoltre non è presente nel log di pacman
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
crx
Arciere
Messaggi: 235
Iscritto il: 9 febbraio 2009, 14:33

Messaggio da crx » 25 gennaio 2012, 15:47

6176ED4B ?
S = k ln W
Il mio nome è Bond. Valence Bond. - Se non fai parte della soluzione, fai parte del precipitato.

Avatar utente
Semedisenape
Arciere
Messaggi: 165
Iscritto il: 29 agosto 2011, 13:47
Località: Bastia di Rovolon PD

Messaggio da Semedisenape » 25 gennaio 2012, 15:52

Cambia mirror ad archlinux.limun.org, poi riprova:
Fatto ma è lo stesso che con il mirror italiano:

Codice: Seleziona tutto

[da@myhost ~]$ sudo pacman -Syy
attenzione: database file for 'multilib' does not exist
:: Sincronizzazione dei database in corso...
--2012-01-25 15:33:11--  http://mirrors.prometeus.net/archlinux/core/os/i686/core.db
Risoluzione di mirrors.prometeus.net... 194.14.179.253
Connessione a mirrors.prometeus.net|194.14.179.253|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 200 OK
Lunghezza: 109566 (107K) [application/octet-stream]
Salvataggio in: "/var/lib/pacman/sync/core.db.part"

100%[======================================>] 109.566      239K/s   in 0,4s    

2012-01-25 15:33:17 (239 KB/s) - "/var/lib/pacman/sync/core.db.part" salvato [109566/109566]

--2012-01-25 15:33:17--  http://mirrors.prometeus.net/archlinux/core/os/i686/core.db.sig
Risoluzione di mirrors.prometeus.net... 194.14.179.253
Connessione a mirrors.prometeus.net|194.14.179.253|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 404 Not Found
2012-01-25 15:33:22 ERRORE 404: Not Found.

--2012-01-25 15:33:24--  http://mirrors.prometeus.net/archlinux/extra/os/i686/extra.db
Risoluzione di mirrors.prometeus.net... 194.14.179.253
Connessione a mirrors.prometeus.net|194.14.179.253|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 200 OK
Lunghezza: 1213704 (1,2M) [application/octet-stream]
Salvataggio in: "/var/lib/pacman/sync/extra.db.part"

100%[======================================>] 1.213.704    243K/s   in 4,9s    

2012-01-25 15:33:36 (244 KB/s) - "/var/lib/pacman/sync/extra.db.part" salvato [1213704/1213704]

--2012-01-25 15:33:36--  http://mirrors.prometeus.net/archlinux/extra/os/i686/extra.db.sig
Risoluzione di mirrors.prometeus.net... 194.14.179.253
Connessione a mirrors.prometeus.net|194.14.179.253|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 404 Not Found
2012-01-25 15:33:41 ERRORE 404: Not Found.

--2012-01-25 15:33:43--  http://mirrors.prometeus.net/archlinux/community/os/i686/community.db
Risoluzione di mirrors.prometeus.net... 194.14.179.253
Connessione a mirrors.prometeus.net|194.14.179.253|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 200 OK
Lunghezza: 1068639 (1,0M) [application/octet-stream]
Salvataggio in: "/var/lib/pacman/sync/community.db.part"

100%[======================================>] 1.068.639    243K/s   in 4,3s    

2012-01-25 15:33:53 (241 KB/s) - "/var/lib/pacman/sync/community.db.part" salvato [1068639/1068639]

--2012-01-25 15:33:53--  http://mirrors.prometeus.net/archlinux/community/os/i686/community.db.sig
Risoluzione di mirrors.prometeus.net... 194.14.179.253
Connessione a mirrors.prometeus.net|194.14.179.253|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 404 Not Found
2012-01-25 15:33:58 ERRORE 404: Not Found.

--2012-01-25 15:34:00--  http://mirrors.prometeus.net/archlinux/multilib/os/i686/multilib.db
Risoluzione di mirrors.prometeus.net... 194.14.179.253
Connessione a mirrors.prometeus.net|194.14.179.253|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 404 Not Found
2012-01-25 15:34:05 ERRORE 404: Not Found.

errore: impossibile aggiornare multilib (si è verificato un errore lanciando il downloader esterno)
--2012-01-25 15:34:07--  http://repo.archlinux.fr/x86_64/archlinuxfr.db
Risoluzione di repo.archlinux.fr... 91.121.141.57
Connessione a repo.archlinux.fr|91.121.141.57|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 200 OK
Lunghezza: 29030 (28K) [application/octet-stream]
Salvataggio in: "/var/lib/pacman/sync/archlinuxfr.db.part"

100%[======================================>] 29.030      --.-K/s   in 0,1s    

2012-01-25 15:34:13 (192 KB/s) - "/var/lib/pacman/sync/archlinuxfr.db.part" salvato [29030/29030]

--2012-01-25 15:34:13--  http://repo.archlinux.fr/x86_64/archlinuxfr.db.sig
Risoluzione di repo.archlinux.fr... 91.121.141.57
Connessione a repo.archlinux.fr|91.121.141.57|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 404 Not Found
2012-01-25 15:34:18 ERRORE 404: Not Found.
Per scaricare le chiavi dal keyserver io ho dovuto modificare (o aggiungere) una regola ad iptables per aprire la porta 11371 in uscita al traffico tcp
( e poi dare /etc/rc.d/iptables restart )
A questo punto non posso metterlo
apparentemente risolto decommentando in pacman.conf
XferCommand = /usr/bin/curl -C - -f %u > %o

leggendo sull'internazionale dovrebbe essere un bug legato a ipv6 che curl riesce ad aggirare.
nessuno ha avuto lo stesso problema?
Fatto ma non cambia niente.

Sono bloccato...

Avatar utente
Ninquitassar
Little John
Messaggi: 1085
Iscritto il: 16 settembre 2011, 21:07
Architettura: x86_64 (64bit)
Località: 127.0.0.1

Messaggio da Ninquitassar » 25 gennaio 2012, 15:53

Scherzi?? O_O
CPU: Intel Core i5-4460 (3.20GHz) Video: NVIDIA GeForce GT610 RAM: 8Gb Kingston DDR3
OS: Arch x86_64 + i3 + GTK+
My DeviantART

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 25 gennaio 2012, 16:48

crx ha scritto:6176ED4B
Perfetto grazie

@Semedisenape
prova a postare il tuo pacman.conf anche perchè io ipv6 mi pare che lo avevo disabilitato a tempo debito
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Avatar utente
Semedisenape
Arciere
Messaggi: 165
Iscritto il: 29 agosto 2011, 13:47
Località: Bastia di Rovolon PD

Messaggio da Semedisenape » 25 gennaio 2012, 17:17

Eccolo. ipv6 mai toccato.

Codice: Seleziona tutto

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc
# If upgrades are available for these packages they will be asked for first
SyncFirst   = pacman
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#UseDelta
#TotalDownload
CheckSpace
#VerbosePkgLists

# PGP signature checking
# NOTE: None of this will work without running `pacman-key --init` first.
# The compiled in default is equivalent to the following line. This requires
# you to locally sign and trust packager keys using `pacman-key` for them to be
# considered valid.
SigLevel = Required DatabaseOptional TrustedOnly
# If you wish to check signatures but avoid local sign and trust issues, use
# the following line. This will treat any key imported into pacman's keyring as
# trusted.
#SigLevel = Optional TrustAll
# For now, off by default unless you read the above.
#SigLevel = Never

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[core]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
SigLevel = PackageOptional
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[community]
SigLevel = PackageOptional
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

[archlinuxfr]
SigLevel = PackageOptional
Server = http://repo.archlinux.fr/i686

Avatar utente
veleno77
Moderatore
Messaggi: 6282
Iscritto il: 25 marzo 2008, 18:26
Architettura: x86 (32Bit)
Località: Torino
Contatta:

Messaggio da veleno77 » 25 gennaio 2012, 17:26

io siglivel lo ho impostasto così:

Codice: Seleziona tutto

SigLevel = Optional TrustedOnly

.. ma tu le chiavi master le hai impostate con successo?
Se avete risolto il vostro problema, editate il primo post aggiungendo [Risolto] al titolo.
Problemi con Arch ? 1°Metodo-2°Metodo-3°Metodo
ArchWiki Translation Team - Cerchiamo traduttori!

Rispondi