Alcuni problemi nati dopo l'aggiornamento a kde 4.3

Nuovo di Arch Linux? Nessun problema, fai qui le tue domande
Rispondi
known
Novello Arciere
Messaggi: 143
Iscritto il: 7 agosto 2009, 10:14

Messaggio da known » 7 agosto 2009, 10:52

Buon giorno a tutti :)

Vi racconto alcuni dei miei problemi, che ... ancora non sono riuscito a risolvere.
Diciamo che i problemi più gravi, che spero di risolvere al più presto, sono i primi due:


1) Il gestore degli archivi kdeutils-ark ha deciso di non funzionare più, cioè ogni volta che cerco di creare o di decomprimere un archivio ... ricevo sempre il seguente errore: "Impossibile localizzare il programma <zip> nel PATH"; tanto per approfondire, il problema si ripete per i rar zip 7zip (l'errore cambia solo nel punto <formato archivio>), ma non succede con il formato tar. Ho cercato in rete riportando l'errore, ma non sono venuto a capo del problema. Beh! l'unica cosa che posso pensare è la mancanza di qualche pacchetto, plugins ... ma è molto strano visto che ho reinstallato il gestore di pacchetti e teoricamente dovrebbe portarsi dietro tutte le dipendenze.

2) Ho un problema nel far caricare un lettore DVD ad hal, a voi l'errore: org.freedesktop.hal.device.volume.unknownfailure

Io non sono un intenditore di Arch Linux, sono passato da ubuntu/Fedora ad Arch da pochissimo tempo; quindi mi sono informato sul problema ... a quanto pare non sono il solo, ho provato molti suggerimenti che trovato in giro, ma non riesco a risolvere il problema ... anzi dopo vai tentativi il problema si evolveva con altri errori; quindi per cercare di non peggiorare la situazione ho ripristinato i file di configurazione precedentemente moddati. Ho visto che nel wiki il problema è trattato, ma malgrado tutto mi sono arreso, ho cambiato qualche settaggio come da guida, ma nulla ... tra l'altro, alcuni file citati dal wiki nel mio pc non esistono (... quindi non so dove mettere le mani). Non so se è utile, ma alcuni gestori multimediali (vlc, kaffeine, xine) rivolgono la loro attenzione verso il percorso /dev/sr0. Il problema è che in questa directory, non c'è traccia del lettore DVD. Non avevo nessun problema prima :( Ho anche un lettore DVD-RW, ma questo funziona.

3) Questo problema lo porto dietro da sempre: kdebluetooth non vuole funzionare; seguo il wiki e installo bluez e le altre dipendenze, malgrado tutto quando da terminale inizializzo il bluetooth e avvio l'applicazione ... ricevo l'erroe: "org.openobex.Error.NotFound"; ho provato ad installare openobex, ma nulla. Come da wiki, ho provato a montare manulamente il dispositivo, ma ricevo un errore che mi avverte dell'impossibilità dell'operazione. Avevo letto che molti hanno risolto il problema con le versioni unstable del kde 4.3 ma a me continua a non funzionare :(

Beh che dire, spero in un vostro aiuto :)

grazie in anticipo.

Ps: spero che la sezione sia giusta, non vorrei cannare al primo messaggio :rolleyes:
Ultima modifica di known il 7 agosto 2009, 10:56, modificato 1 volta in totale.

simo91
Arciere
Messaggi: 237
Iscritto il: 24 agosto 2008, 12:53
Località: Bologna
Contatta:

Messaggio da simo91 » 7 agosto 2009, 11:19

1)

Codice: Seleziona tutto

# pacman -Sy zip unrar p7zip
Arch Linux i686
Jabber, per chiunque: simo91@jabber.org - My blog

known
Novello Arciere
Messaggi: 143
Iscritto il: 7 agosto 2009, 10:14

Messaggio da known » 7 agosto 2009, 11:32

Ti ringrazio molto per la disponibilità :)

Già avevo installato unrar e p7zip; anche se reinstallo i pacchetti, il problema non cambia.

Non avevo pensato che fosse necessario installare zip, quindi ho provveduto; adesso il problema è cambiato:

"Impossibile localizzare il programma <zipinfo> nel PATH"

Ho appena provato a vedere se esiste un pacchetto zipinfo, ma nulla ... malgrado l'errore, adesso riesco a creare file zip.

Non cambia la situazione per i file rar e 7zip.

Grazie ancora ;)
Ultima modifica di known il 7 agosto 2009, 11:33, modificato 1 volta in totale.

simo91
Arciere
Messaggi: 237
Iscritto il: 24 agosto 2008, 12:53
Località: Bologna
Contatta:

Messaggio da simo91 » 7 agosto 2009, 11:39

prova ad installare rar da AUR

Codice: Seleziona tutto

# pacman -Rscn unrar
$ yaourt -Sy rar
per 7zip non so, è l'unico pacchetto che esce cercando 7zip..
Arch Linux i686
Jabber, per chiunque: simo91@jabber.org - My blog

simo91
Arciere
Messaggi: 237
Iscritto il: 24 agosto 2008, 12:53
Località: Bologna
Contatta:

Messaggio da simo91 » 7 agosto 2009, 11:45

known ha scritto:"Impossibile localizzare il programma <zipinfo> nel PATH"
prova a fare

Codice: Seleziona tutto

sudo updatedb && sudo locate zipinfo
dovresti avere

Codice: Seleziona tutto

/usr/bin/zipinfo
/usr/share/man/man1/zipinfo.1.gz
se è così e da ancora errore non so, prova a riavviare X o anche il pc!
Arch Linux i686
Jabber, per chiunque: simo91@jabber.org - My blog

known
Novello Arciere
Messaggi: 143
Iscritto il: 7 agosto 2009, 10:14

Messaggio da known » 7 agosto 2009, 11:49

ok, fatto con rar ... ma ho dovuto reinstallare anche unrar poichè generava un errore dovuto alla sua mancanza.
anche se non riesco a capire il motivo di questi cambiamenti :rolleyes:
per 7zip ho provato a cancellare il pack ed elimiare i file di configurazioni, adesso funziona. Punto 1 risolto, grazie mille simo91 :D
Ultima modifica di known il 7 agosto 2009, 11:50, modificato 1 volta in totale.

simo91
Arciere
Messaggi: 237
Iscritto il: 24 agosto 2008, 12:53
Località: Bologna
Contatta:

Messaggio da simo91 » 7 agosto 2009, 11:54

known ha scritto:ok, fatto con rar ... ma ho dovuto reinstallare anche unrar poichè generava un errore dovuto alla sua mancanza.
ops non sapevo che servisse :D
known ha scritto:anche se non riesco a capire il motivo di questi cambiamenti :rolleyes:
per 7zip ho provato a cancellare il pack ed elimiare i file di configurazioni, adesso funziona. Punto 1 risolto, grazie mille simo91 :D
figurati! ti da ancora quell'errore di zip? prova a fare come hai fatto con p7zip, ad eliminarlo completamente con -Rscn e reinstallarlo :)
Arch Linux i686
Jabber, per chiunque: simo91@jabber.org - My blog

known
Novello Arciere
Messaggi: 143
Iscritto il: 7 agosto 2009, 10:14

Messaggio da known » 7 agosto 2009, 12:00

L'errore zipinfo è sempre presente, ma visto che riesco ad utilizzare il zip; per adesso non mi preoccupo.
Ultima modifica di known il 7 agosto 2009, 12:01, modificato 1 volta in totale.

simo91
Arciere
Messaggi: 237
Iscritto il: 24 agosto 2008, 12:53
Località: Bologna
Contatta:

Messaggio da simo91 » 7 agosto 2009, 12:01

known ha scritto:L'errore con il formato zip è sempre presente, ma visto che mi consente di utilizzare il zip; per adesso non mi preoccupo.
bisogna raggiungere la perfezione! prova a fare quello che ti ho scritto sopra, poi se proprio proprio controlla in /etc/profile che nei path ci sia anche /usr/bin (ma ci sarà di sicuro)
Arch Linux i686
Jabber, per chiunque: simo91@jabber.org - My blog

known
Novello Arciere
Messaggi: 143
Iscritto il: 7 agosto 2009, 10:14

Messaggio da known » 7 agosto 2009, 12:09

Si, ho provato a rimuovere il pacchetto e ripulire, ma non si risolve; /etc/profile è tutto ok.

Ho serchato un po nel mio pc, non trovo nulla che riguarda zipinfo



EDIT: Ho installato unzip, funziona tutto :D
Adesso resta da risolvere il problema del mio lettore DVD e di kdebluetooth.


EDIT2: Ho avuto modo di testare meglio kdebluetooth, dopo alcune prove ... ho notato che l'errore org.openobex.Error.NotFound si presenta solo con i cellulari nokia (provati 3 cell di diverse serie), nessun problema con samsung, motorola e siemens. Probabilmente sarà qualche bug.


Non riesco a trovare soluzione al problema del mount del lettore DVD; se qualcuno mi può aiutare ben venga :)
Ultima modifica di known il 7 agosto 2009, 18:31, modificato 1 volta in totale.

Rispondi