Problemi fstab

Nuovo di Arch Linux? Nessun problema, fai qui le tue domande
Rispondi
giuseppe
Novello Arciere
Messaggi: 64
Iscritto il: 30 ottobre 2008, 13:28

Messaggio da giuseppe » 12 marzo 2009, 18:51

Ciao!!!

Ho dei problemi con fstab!!!
Ho un hard disk interno che uso come archivio, lo voglio far montare in automatico all'avvio con i diritti di scrittura e lettura per il mio utente ma ottengo ogni volta degli errori, o per il parametro umask, o gid e non so come risolverli...

Codice: Seleziona tutto

/dev/sdb1 	/media/Archivio 	ext3     rw,users,noatime,uid=1000,umask=002   0 2  #di solito aggiungo anche utf8=true

aleph
Robin Hood
Messaggi: 1530
Iscritto il: 12 febbraio 2008, 16:30
Contatta:

Messaggio da aleph » 12 marzo 2009, 19:32

magari se posti esattamente gli errori che hai ;) . . cmq non mi risulta che ext3 accetti come parametri uid=x e gid=x, se vuoi cambiare i permessi usa chmod e chown ;) anche il parametro users è relativo al montaggio e non ai permessi . .
ImmagineOutside of a dog, computers are a man's best friend, inside a dog it's too dark to type.

giuseppe
Novello Arciere
Messaggi: 64
Iscritto il: 30 ottobre 2008, 13:28

Messaggio da giuseppe » 12 marzo 2009, 19:47

Io di solito metto solo il paramtro default, pero come ho detto prima non mi permete di scrivere sul disco!!

Ho provato anche a dare un chmod -R +rw /archivio, ma non è cambiato niente!!!

Gli errori mi vengono dati uno per volta purtroppo, li ottengo tramite dmesg | tail

Codice: Seleziona tutto

EXT3-fs: Unrecognized mount option "umask=002" or missing value
Ho provato sia con umask=0002 che con umask= 002 ( non so che differenza ci sia )!!!

Avatar utente
ugaciaka
Little John
Messaggi: 1345
Iscritto il: 6 luglio 2008, 9:06
Località: Belluno
Contatta:

Messaggio da ugaciaka » 12 marzo 2009, 21:25

giuseppe ha scritto:Io di solito metto solo il paramtro default, pero come ho detto prima non mi permete di scrivere sul disco!!

Ho provato anche a dare un chmod -R +rw /archivio, ma non è cambiato niente!!!

Gli errori mi vengono dati uno per volta purtroppo, li ottengo tramite dmesg | tail

Codice: Seleziona tutto

EXT3-fs: Unrecognized mount option "umask=002" or missing value
Ho provato sia con umask=0002 che con umask= 002 ( non so che differenza ci sia )!!!

Codice: Seleziona tutto

man 8 mount
non mi pare che il fs ext3 supporti l'umask
non ho mai comprato su ebay, i macbook non mi piacciono, non ho bisogno di facebook né myspace né secondlife
non sono un nerd né lamer né troll né geek né cracker né hacker

Yagi858
Arciere
Messaggi: 246
Iscritto il: 3 novembre 2008, 18:14
Località: Salerno

Messaggio da Yagi858 » 12 marzo 2009, 21:28

basterebbe solo questo:

Codice: Seleziona tutto

UUID="quello-che-è" 	/media/Archivio	ext3	defaults,relatime	0	0
Se non ti fa scrivere dai il chown -R "tuo-username" /media/Archivio, ma basta farlo una sola volta.
Ultima modifica di Yagi858 il 12 marzo 2009, 21:39, modificato 1 volta in totale.

aleph
Robin Hood
Messaggi: 1530
Iscritto il: 12 febbraio 2008, 16:30
Contatta:

Messaggio da aleph » 12 marzo 2009, 23:37

giuseppe ha scritto:Ho provato anche a dare un chmod -R +rw /archivio, ma non è cambiato niente!!!
meglio chmod -R +rwX /archivio (o, come dice Yagi858, chown tuoutente ;) ) . . ovviamente entrambi da # ;)
Ultima modifica di aleph il 12 marzo 2009, 23:37, modificato 1 volta in totale.
ImmagineOutside of a dog, computers are a man's best friend, inside a dog it's too dark to type.

Rispondi