spotify

Nuovo di Arch Linux? Nessun problema, fai qui le tue domande
Rispondi
badir
Newbie
Messaggi: 8
Iscritto il: 8 novembre 2016, 21:14

spotify

Messaggio da badir » 26 aprile 2017, 16:52

Ciao ragazzi, un aiuto: non riesco ad installare spotify. Yaourt mi da sempre errore. Un grazie anticipato.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7937
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: spotify

Messaggio da TheSaint » 26 aprile 2017, 17:06

Mostraci l' errore, che così non si indovina.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

badir
Newbie
Messaggi: 8
Iscritto il: 8 novembre 2016, 21:14

Re: spotify

Messaggio da badir » 27 aprile 2017, 15:18

scusa ma non so come si fa, mi dice: ERRORE: una o più firme PGP non possono essere verificate
poi: ERRORE Makepk non è riuscito a compilare openssl098

zorro62
Arciere
Messaggi: 320
Iscritto il: 26 aprile 2011, 18:07

Re: spotify

Messaggio da zorro62 » 27 aprile 2017, 16:34

ma l'errore che dici,dove viene mostrato perchè provando ad installarlo manco esiste quel file?

Codice: Seleziona tutto

$ yaourt -S spotify

ReekyMarko commented on 2017-04-27 09:10			 
Please add libnghttp2 as a dependency, spotify won't lauch without that

runical commented on 2017-04-27 09:44			 
@ReekyMarco: Are you sure? It runs just fine on my system without that dependency.

ReekyMarko commented on 2017-04-27 11:06			 
@runical

$ spotify
/usr/share/spotify/spotify: error while loading shared libraries: libnghttp2.so.14: cannot open shared object file: No such file or directory

This is what I get when I try to run Spotify without libnghttp2

bol0bal4 commented on 2017-04-27 11:21			 
Hi @ReekyMarko,
When I check $ldd /usr/share/spotify/spotify I didn't see libnghttp2,
My spotify version is 1.0.53.758-2

spotify 1.0.53.758-2  (2017-04-25 14:38)
( Pacchetto non supportato: Potenzialmente pericoloso! )
==> Modificare PKGBUILD  [S/n] ("A" per annullare)
==> ----------------------------------------------
==> n

==> Dipendenze di spotify
 - alsa-lib>=1.0.14 (già installato)
 - gconf (già installato)
 - gtk2 (già installato)
 - glib2 (già installato)
 - nss (già installato)
 - libsystemd (già installato)
 - libxtst (già installato)
 - libx11 (già installato)
 - libxss (già installato)
 - desktop-file-utils (già installato)
 - rtmpdump (già installato)
 - libopenssl-1.0-compat (compilazione da AUR)
 - libcurl-openssl-1.0 (compilazione da AUR)


==> Continuare la compilazione di spotify [S/n]
==> -------------------------------------------
==> 
archlinux-xfce,archlinux.mate

Avatar utente
TheSaint
Robin Hood
Messaggi: 7937
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: spotify

Messaggio da TheSaint » 28 aprile 2017, 15:34

badir ha scritto:scusa ma non so come si fa,
Si fa che esegui il comando, poi quando sorte l' errore lo evidenzi e lo copi (dal comando in giù). Quindi lo incolli qui coi dovuti tags. In particolare quello che sta sopra alla finestra di un messaggio con scritto Code.
Altrimenti stiamo qui a cacciare le farfalle, nel periodo invernale :)
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

badir
Newbie
Messaggi: 8
Iscritto il: 8 novembre 2016, 21:14

Re: spotify

Messaggio da badir » 29 aprile 2017, 23:02

TheSaint ha scritto:
badir ha scritto:scusa ma non so come si fa,
Si fa che esegui il comando, poi quando sorte l' errore lo evidenzi e lo copi (dal comando in giù). Quindi lo incolli qui coi dovuti tags. In particolare quello che sta sopra alla finestra di un messaggio con scritto Code.
Altrimenti stiamo qui a cacciare le farfalle, nel periodo invernale :)
-> Download di openssl-0.9.8zh.tar.gz in corso...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 3729k 100 3729k 0 0 1019k 0 0:00:03 0:00:03 --:--:-- 1019k
-> Download di openssl-0.9.8zh.tar.gz.asc in corso...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 819 100 819 0 0 6109 0 --:--:-- --:--:-- --:--:-- 6157
-> È stato trovato no-rpath.patch
-> È stato trovato ca-dir.patch
==> Validazione di source file con sha256sums...
openssl-0.9.8zh.tar.gz ... Verificato
openssl-0.9.8zh.tar.gz.asc ... Ignorato
no-rpath.patch ... Verificato
ca-dir.patch ... Verificato
==> Validazione delle firme dei sorgenti con gpg in corso...
openssl-0.9.8zh.tar.gz ... NON RIUSCITO (chiave pubblica sconosciuta D5E9E43F7DF9EE8C)
==> ERRORE: Una o più firme PGP non possono essere verificate!
==> ERRORE: Makepkg non è riuscito a compilare openssl098.
==> Riavviare la compilazione di openssl098 [s/N]
==> ---------------------------------------------
==>

Avatar utente
TheSaint
Robin Hood
Messaggi: 7937
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: spotify

Messaggio da TheSaint » 30 aprile 2017, 22:09

Con unaricerca nel forum con pgp trovi la soluzione al tuo caso.
Per cortesia, edita il tuo messaggio con i dovuti tags.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Rispondi