Wlan0 non va senza ethernet

Nuovo di Arch Linux? Nessun problema, fai qui le tue domande
Rispondi
Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Wlan0 non va senza ethernet

Messaggio da Stelfex » 4 aprile 2016, 22:42

ho configurato il sistema per collegarsi alla wifi automaticamente con systemd,
ovviamente tramite porta ethernet, ora se non collego la ethernet il collegamento wifi
non funziona a priori, quindi devo collegarmi via ethernet + wlan?

Come faccio per renere soltanto la wlan0 autonoma?

Grazie

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Wlan0 non va senza ethernet

Messaggio da Stelfex » 4 aprile 2016, 22:55

che editor SSH mi consigliate di usare? Per winzozz?

Avatar utente
TheSaint
Robin Hood
Messaggi: 7844
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Wlan0 non va senza ethernet

Messaggio da TheSaint » 4 aprile 2016, 23:34

Stelfex ha scritto:che editor SSH mi consigliate di usare? Per winzozz?
Un topico alla volta
F the saint
13 anni da questo forum ;)

Avatar utente
TheSaint
Robin Hood
Messaggi: 7844
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Wlan0 non va senza ethernet

Messaggio da TheSaint » 4 aprile 2016, 23:36

Stelfex ha scritto:ho configurato il sistema per collegarsi alla wifi automaticamente con systemd,
ovviamente tramite porta ethernet
Secondo me non è chiaro.
Se penso come ho fatto io, hai un dispositivo AP collegato tramite ethernet. Descrivi il dispositivo o link al costruttore.
F the saint
13 anni da questo forum ;)

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Wlan0 non va senza ethernet

Messaggio da Stelfex » 5 aprile 2016, 10:10

lo sto configurando tramite LAN, adesso sono riuscito a collegarmi al router di casa tramite wpa_supplicant, quindi la porta LAN non mi serve +, però fa strani scherzetti, tipo non si associa al router WI-FI se prima non lo collego alla lan, per me e la porta da cambiare forse bisticciano se utilizzano la 22 entrambi no?

Avatar utente
TheSaint
Robin Hood
Messaggi: 7844
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Wlan0 non va senza ethernet

Messaggio da TheSaint » 5 aprile 2016, 10:50

Configurazioni automatiche possono creare questi problemi.
Se attivi la connessione al router con wpa_supplicant dovresti fissare l'IP, nel router, per collegarti.
Chi è il client della SSH?
F the saint
13 anni da questo forum ;)

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Wlan0 non va senza ethernet

Messaggio da Stelfex » 5 aprile 2016, 13:12

uso Putty, e possibile cambiare la porta di connessione wlan0 da 22 a chenesò 23?
Oppure metto nello script

Codice: Seleziona tutto

ifconfig eth0 down
se usano la stessa porta 22 wlan0 ed eth0, fanno a cazzotti no?

Avatar utente
TheSaint
Robin Hood
Messaggi: 7844
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Wlan0 non va senza ethernet

Messaggio da TheSaint » 5 aprile 2016, 17:34

La porta la configuri in /etc/ssh/sshd_config come l' indirizzo dove ascoltare.
F the saint
13 anni da questo forum ;)

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Wlan0 non va senza ethernet

Messaggio da Stelfex » 5 aprile 2016, 17:43

Ma e la porta di ascolto per wlan0?
Oppure eth0?

Perche ho 2 shell SSH una sul 192.168.1.12 che è la eth0 LAN...
ed una in wifi 192.168.1.20 che è la wlan0

Codice: Seleziona tutto


# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.

#Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

# The default requires explicit activation of protocol 1
#Protocol 2

Avatar utente
TheSaint
Robin Hood
Messaggi: 7844
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Wlan0 non va senza ethernet

Messaggio da TheSaint » 5 aprile 2016, 17:52

Allora modifichi /etc/ssh/sshd_config

Codice: Seleziona tutto

ListenAddress 192.168.1.20
Mi par anche semplice.
Oppure un

Codice: Seleziona tutto

$ man sshd_config
F the saint
13 anni da questo forum ;)

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Wlan0 non va senza ethernet

Messaggio da Stelfex » 5 aprile 2016, 20:38

quale può essere il motivo di tale comportamento?
Quando le chiamo assieme rispondono, quando chiamo il wifi singolarmente non risponde?
Sto impazzendo AIUTO!!!!

Avatar utente
TheSaint
Robin Hood
Messaggi: 7844
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Wlan0 non va senza ethernet

Messaggio da TheSaint » 6 aprile 2016, 0:03

Non capisco come stai effettuando l' accesso.
Se usassi ssh, il comando sarebbe

Codice: Seleziona tutto

$ ssh <utente>@IP -p 22
Poi con IP potrebbe essere anche un nome che hai registrato in hosts.
Ma se mi stai facendo gli accessi con putty, non ti so proprio aiutare.

Facciamo che scrivi i comandi eseguiti ed l' errore riportato, qui sul forum. Poi aggiungi l' opzione logging e/o debug del server ssh, in modo da postare quello che succede.
F the saint
13 anni da questo forum ;)

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Wlan0 non va senza ethernet

Messaggio da Stelfex » 6 aprile 2016, 10:30

non si tratta di errore, e il comportamento dei client windows SSH che non capisco, oppure è il rasp, credevo fosse un problema comune, ma in rete non ne ho trovato molti di simili.... i pratica quando tolgo fisicamente il cavetto LAN cade anche il collegamento wifi, come faccio a monitorere il problema?

Allego lo script della partenza per il collegamento wifi:

Codice: Seleziona tutto

#!/bin/bash
ifconfig wlan0 up
wpa_supplicant -Dwext -iwlan0 -c /etc/wpa_supplicant.conf -dd -B
dhcpcd wlan0

Codice: Seleziona tutto

[Unit]
Description=Lanciatore del mio programma
After=httpd.service mysql.service
[Service]
ExecStart=/usr/bin/partenza.sh
[Install]
WantedBy=multi-user.target
non ho fatto altro aparte cnfigurare il WPA:

Codice: Seleziona tutto

network={
        ssid="XXXXXXNET"
        #psk="bhhXXXXXXX"
        psk=3cb63290d15a1ecfXXXXXXXXXXXXXXXXXXXXXXXXXXXXX8e48579074ba2f
        key_mgmt=WPA-EAP WPA-PSK
        proto=RSN WPA
        pairwise=CCMP TKIP
}

pineout
Little John
Messaggi: 1264
Iscritto il: 10 luglio 2014, 9:08

Re: Wlan0 non va senza ethernet

Messaggio da pineout » 12 aprile 2016, 21:29

Non ti associa se non sei prima collegato tramite ethernet?
Per caso hai associato l'indirizzo con ARP

Rispondi