[GNOME] non si avvia

Nuovo di Arch Linux? Nessun problema, fai qui le tue domande
Rispondi
Nick
Newbie
Messaggi: 2
Iscritto il: 3 settembre 2015, 14:37
Architettura: x86_64 (64bit)

[GNOME] non si avvia

Messaggio da Nick » 3 settembre 2015, 15:05

Ciao a tutti, ho installato Arch in dual boot su un portatile..... installazione portata a termine senza problemi seguendo la BEGINNER'S GUIDE.
Quindi ho installato GNOME (# pacman -Syu # pacman -S gnome) come da guida: https://wiki.archlinux.org/index.php/GN ... taliano%29

Ora, non essendo la guida in italiano aggiornata i comandi successivi non funzionano (rc.d start dbus).....seguendo quella in inglese devo aggiungere "exec gnome-session" al file "~/.xinitrc" ma questo file NON esiste :|

Ho provato ad aggiungere

Codice: Seleziona tutto

[[ -z $DISPLAY && $XDG_VTNR -eq 1 ]] && exec startx
al file "~/.bash_profile" come indicato https://wiki.archlinux.org/index.php/St ... taliano%29 ma l'unica cosa che riesco ad ottenere dopo il login testuale sono delle finestre spartane con xorg-clock e un paio di terminali :roll:

Prima di fare altri tentativi ho preferito chiedere a voi.....mi sono anche un po' perso tra gnome,startx,xinitrc,.. eccetera :oops:
come faccio ad avviare GNOME all'avvio??
Grazie :wink:

EDIT: La riga che ho aggiunto al .bash_profile l'ho poi # commentata per avere il file come era all'inizio.
EDIT: Lanciando il comando "gnome-session" da tty1 l'unica risposta che ottengo è "Terminato" dopo qualche secondo.

Avatar utente
giupino
Novello Arciere
Messaggi: 25
Iscritto il: 20 giugno 2011, 16:30
Architettura: x86_64 (64bit)

Re: [GNOME] non si avvia

Messaggio da giupino » 3 settembre 2015, 15:19

devi avviare tramite systemd:

Codice: Seleziona tutto

sudo systemctl start gdm.service
per farlo partire quando sei da terminale e

Codice: Seleziona tutto

sudo systemctl enable gdm.service
(se non hai sudo basta loggarti da amministratore)
per farlo partire all'avvio.

Giupino

IlGab
Novello Arciere
Messaggi: 34
Iscritto il: 17 luglio 2015, 13:03
Architettura: x86_64 (64bit)

Re: [GNOME] non si avvia

Messaggio da IlGab » 3 settembre 2015, 15:30

Nick ha scritto:.....seguendo quella in inglese devo aggiungere "exec gnome-session" al file "~/.xinitrc" ma questo file NON esiste :|
Se non esiste (cosa abbastanza normale essendo la tua home nuova) puoi sempre crearlo.

Codice: Seleziona tutto

echo "exec gnome-session" >> ~/.xinitrc
Verifica di avere installato il pacchetto gnome-session, poi fai partire X

Codice: Seleziona tutto

startx
¸.·´ My Arch linux x86_64 Laptop `·.¸
Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz
8GB DDR3-1600 ram - 256GB SSD Samsung 850 Pro
GeForce GT 635M - 15" LCD 1080p

Nick
Newbie
Messaggi: 2
Iscritto il: 3 settembre 2015, 14:37
Architettura: x86_64 (64bit)

Re: [GNOME] non si avvia

Messaggio da Nick » 3 settembre 2015, 15:43

Ma guarda te se mi dovevo perdere in così poco :roll: :roll: :P
ho risolto con

Codice: Seleziona tutto

# systemctl enable gdm.service
e poi ho riavviato

Ero convinto che lo creasse in automatico durante l'installazione il file xinitrc...per quello poi mi sono un po' perso via :)

Ultima domanda: adesso xorg-twm xorg-clock e xterm posso anche rimuoverli tranquillamente no??

Grazie mille ragazzi!! siete stati più veloci della luce nel rispondere xD... adesso mi aggiungo ai sudoers e poi faccio le ultime personalizzazioni...

IlGab
Novello Arciere
Messaggi: 34
Iscritto il: 17 luglio 2015, 13:03
Architettura: x86_64 (64bit)

Re: [GNOME] non si avvia

Messaggio da IlGab » 4 settembre 2015, 9:51

Ottimo se tutto funziona !

Puoi rimuoverli, twm è un piccolo windows manager che non ti serve, così come il terminale e l'orologio, tanto hai gnome.
¸.·´ My Arch linux x86_64 Laptop `·.¸
Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz
8GB DDR3-1600 ram - 256GB SSD Samsung 850 Pro
GeForce GT 635M - 15" LCD 1080p

Rispondi