driver video intel - sfarfallio [Risolto]

Nuovo di Arch Linux? Nessun problema, fai qui le tue domande
Rispondi
allinone
Arciere
Messaggi: 176
Iscritto il: 5 aprile 2014, 12:16
Architettura: x86_64 (64bit)

driver video intel - sfarfallio [Risolto]

Messaggio da allinone » 21 luglio 2015, 18:49

Scusate la poca pazienza, ma la sensazione che ho è quella di avere una ferrari sotto il ...lo e di non saperla guidare, perdo aderenza in curva.
A parte le battute, anche se la sensazione è piuttosto verosimile, non sono ancora riuscito a conifgurare i driver video per benino.
Partiamo da qui:

Codice: Seleziona tutto

$ lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)                                                                                                                    
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)                                                                                                   
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)                                                                                                                   
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)                                                                                                         
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)                                                                                                 
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)                                                                                              
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)                                                                                                        
00:1c.1 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #2 (rev e3)                                                                                                        
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)                                                                                                        
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)                                                                                                        
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)                                                                                                         
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)                                                                                                                  
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)                                                                                                
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)                                                                                                                     
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)                                                                                       
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)                                                                 
09:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter      
Ora, se ho letto bene, questi driver hanno di default un'accelerazione sna
Questa mi porta uno sfarfallio in chiusura ed uno sfarfallio di glxgears.
Per glxgears ho risolto disabilitando la sincronizzazione verticale ( e non so se ho fatto bene)
ma resta comunque lo sfarfallio in chiusura.

Ho provato anche uxa
Questo risolve entrambi gli sfarfallii, e fino a qualche giorno fa andava anche bene.
Poi ho avuto un calo con vistosi rallentamenti del Desktop, tanto da dover rinunciare e tornare a sna

Con glamor ho piò o meno le stesse prestazioni di sna.

Ultimamente mi ritrovo anche questo errore (?)

Codice: Seleziona tutto

$ dmesg -w
...
[ 3161.886855] perf interrupt took too long (2520 > 2495), lowering kernel.perf_event_max_sample_rate to 50100
[ 3260.764520] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=106944 end=106945)
[ 4397.833170] ideapad_laptop: Unknown event: 1
e non so se sia collegabile al fatto in questione

Ho anche qualche altro piccolo problemuccio...

Grazie a tutti, Andrea.
Ultima modifica di allinone il 24 luglio 2015, 19:41, modificato 1 volta in totale.

allinone
Arciere
Messaggi: 176
Iscritto il: 5 aprile 2014, 12:16
Architettura: x86_64 (64bit)

Re: driver video intel

Messaggio da allinone » 22 luglio 2015, 18:33

Una differenza c'è, con glamor l'errore scompare.
Questo errore:

Codice: Seleziona tutto

[ 3260.764520] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=106944 end=106945)
Lo sfarfallio in chiusura rimane.
Questo è il miglior compromesso, per ora.
EDIT
COME NON DETTO
Certo che è strano, sono tornati.

Codice: Seleziona tutto

[  446.262811] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[ 1132.617317] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=68344 end=68345)
[ 1135.486968] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=68516 end=68517)
[ 1156.348566] cfg80211: Exceeded CRDA call max attempts. Not calling CRDA
[ 1862.444598] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=112088 end=112089)
[ 1928.046897] [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=116020 end=116021)
[ 2644.548309] snd_hda_intel 0000:00:1b.0: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.

allinone
Arciere
Messaggi: 176
Iscritto il: 5 aprile 2014, 12:16
Architettura: x86_64 (64bit)

Re: driver video intel

Messaggio da allinone » 24 luglio 2015, 18:16

ho trovato questo
http://forums.debian.net/viewtopic.php? ... 59#p585701
che mi sembra interessante e forse da provare, che ne dite?
Come si passa un parametro con syslinux?
Non vorrei ritrovrmi la macchina ferma.
Grazie, Andrea.

EDIT
ho trovato anche quest'altro articolo http://www.osside.net/?p=15237#more-15237
Sono riuscito a passare il parametro

Codice: Seleziona tutto

i915.enable_ips=0
al kernel ed effetivamente lo sfarfallio è svanito.
Non so cosa sia l'atro paramentro menzionato nel forum debian, intel_iommu=igfx_off e se va passato con la stessa sintassi.
Grazie, Andrea.

pineout
Little John
Messaggi: 1264
Iscritto il: 10 luglio 2014, 9:08

Re: driver video intel - sfarfallio [Risolto]

Messaggio da pineout » 25 luglio 2015, 1:49

Ciao, non dovresti avere paura di sperimentare nuove impostazioni :) al limite perdi un po' di tempo.

Forse riguardo iommu c'e' anche qualche post sul forum, comunque e' un sistema di accesso alla memoria (diretto), nel senso che la scheda puo' avere accesso diretto alla memoria.
Come fa a non andare in conflitto con gli indirizzi della CPU? Probabilmente ne ha di riservati o usa un altro sistema.

Parametri puoi aggiungerne finche' vuoi, la riga di start del kernel e' lunga lunga.

Al limite se dovesse presentarsi un kernel panic o qualche crash all'avvio, tieni pronta una chiavetta di boot per entrare e correggere il parametro sbagliato.

allinone
Arciere
Messaggi: 176
Iscritto il: 5 aprile 2014, 12:16
Architettura: x86_64 (64bit)

Re: driver video intel - sfarfallio [Risolto]

Messaggio da allinone » 25 luglio 2015, 12:49

Ciao Pineout, ma quale paura...fifa :)
Scherzi a parte, ci vado un po' cauto essendo questo il notebook che ha sostituito i miei pc da lavoro.
Quindi prima di trovarmi a dovere, magari, ributtare tutto giù, faccio qualche domanda aggiuntiva.
Anche se poi, effettivamente, il rischio è veramente limitato.

Per quanto riguarda intel_iommu=igfx_off l'ho passato così come l'ho scritto.
Noto una differenza: gli FPS di glxgears ora sono praticamente perfetti (60000 +/-), senza sbalzi.

Mi ripeto, ma la sensazione è proprio quella di avere una grande macchina dove ogni tanto perdo il retrotreno :)
Ciao Andrea.

Avatar utente
fabrixx
Arciere
Messaggi: 153
Iscritto il: 1 maggio 2015, 11:38
Architettura: x86_64 (64bit)
Contatta:

Re: driver video intel - sfarfallio [Risolto]

Messaggio da fabrixx » 30 luglio 2015, 22:17

Salve, ho scritto l'articolo su

Codice: Seleziona tutto

i915.enable_ips=0
e sono felice che anche per te la cosa abbia funzionato.

Non ho testato il parametro

Codice: Seleziona tutto

intel_iommu=igfx_off 
e mi sono messo a cercare informazioni..a te mi par di capire che ha migliorato le cose quindi?

allinone
Arciere
Messaggi: 176
Iscritto il: 5 aprile 2014, 12:16
Architettura: x86_64 (64bit)

Re: driver video intel - sfarfallio [Risolto]

Messaggio da allinone » 31 luglio 2015, 9:09

Ciao Fabrixx
premetto:
il parametro intel_iommu=igfx_off non so se va passato così.
Se così fosse, io non me ne intendo, comunue l'ho lasciato, a me sembra dare una stabilità di FPS in glxgears.

p.s. grazie per la dritta, allora.

Avatar utente
fabrixx
Arciere
Messaggi: 153
Iscritto il: 1 maggio 2015, 11:38
Architettura: x86_64 (64bit)
Contatta:

Re: driver video intel - sfarfallio [Risolto]

Messaggio da fabrixx » 31 luglio 2015, 13:56

Lo testero' con cautela allora..

Ciao e grazie.

allinone
Arciere
Messaggi: 176
Iscritto il: 5 aprile 2014, 12:16
Architettura: x86_64 (64bit)

Re: driver video intel - sfarfallio [Risolto]

Messaggio da allinone » 25 agosto 2015, 8:07

A seguito degli ultimi aggiornamenti ho potuto fare meno di tali parametri per eliminare lo sfarfallio in chiusura.
Resta un glxgears un po' altalenante.
Un saluto, Andrea.

Rispondi