Problema LightDM con multi monitor

Nuovo di Arch Linux? Nessun problema, fai qui le tue domande
Rispondi
JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Problema LightDM con multi monitor

Messaggio da JacopoMolteni » 10 aprile 2015, 15:13

Quando uso Arch usare più di un monitor non mi da problemi(con Xfce), mentre se eseguo il logout e passo a LightDM la schermata di quest'ultimo non compare ma rimane bianca con il cursore in risoluzione sbagliata (su tutti e due i monitor). Come posso fare?
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

erre
Arciere
Messaggi: 267
Iscritto il: 23 gennaio 2013, 23:12

Re: Problema LightDM con multi monitor

Messaggio da erre » 10 aprile 2015, 19:27

Log (X, Dmesg...)?

pineout
Little John
Messaggi: 1264
Iscritto il: 10 luglio 2014, 9:08

Re: Problema LightDM con multi monitor

Messaggio da pineout » 11 aprile 2015, 18:04

Il problema si presenta nella schermata di login?

Avatar utente
enricotognoni
Arciere Provetto
Messaggi: 668
Iscritto il: 19 settembre 2012, 1:31

Re: Problema LightDM con multi monitor

Messaggio da enricotognoni » 11 aprile 2015, 19:32

http://www.sudo-juice.com/lightdm-resolution/
se imposti lightdm.conf come descritto chiamando lo script dello schermo risoluzione che definisci in base alle caratteristiche volute, dovresti risolvere.

ciao :)

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Problema LightDM con multi monitor

Messaggio da JacopoMolteni » 11 aprile 2015, 21:36

Scusate se non rispondo subito, ma al momento non ho a disposizione il monitor esterno, appena riottengo il monitor vi faccio sapere :)
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Problema LightDM con multi monitor

Messaggio da JacopoMolteni » 14 aprile 2015, 17:11

Il problema si presenta in fase di login, con lightdm appunto, xfce non mi da problemi. I log dove li trovo? In più, non posso impostarlo in modo che si adatti a diverse risoluzioni?
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

pineout
Little John
Messaggi: 1264
Iscritto il: 10 luglio 2014, 9:08

Re: Problema LightDM con multi monitor

Messaggio da pineout » 18 aprile 2015, 16:43

nella directory /var/log/lightdm dovresti trovare tutto

io lightdm l'ho scartato uso startx o al limite userei lxdm
oltre ad xfce cosa usi?

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Problema LightDM con multi monitor

Messaggio da JacopoMolteni » 21 aprile 2015, 22:12

Oltre a Xfce uso KDE Plasma 5, ma LightDM mi soddisfa, è veloce e leggero e l'unico problema che mi da è quello con il monitor.

Codice: Seleziona tutto

totale 28
-rw------- 1 root root 4417 21 apr 17.42 lightdm.log
-rw------- 1 root root 6161 21 apr 15.57 lightdm.log.old
-rw------- 1 root root  598 21 apr 17.42 x-0-greeter.log
-rw------- 1 root root  598 21 apr 14.34 x-0-greeter.log.old
-rw------- 1 root root  990 21 apr 21.54 x-0.log
-rw------- 1 root root    0 21 apr 15.57 x-0.log.old


Questo è quello che ho in quella cartella, qual'è il file interessato?
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

pineout
Little John
Messaggi: 1264
Iscritto il: 10 luglio 2014, 9:08

Re: Problema LightDM con multi monitor

Messaggio da pineout » 21 aprile 2015, 23:29

Principalmente lightdm.log
Ottimo che lo trovi leggero, quando lo usavo, mi sembrava che di light avesse solo il nome :)

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Problema LightDM con multi monitor

Messaggio da JacopoMolteni » 26 aprile 2015, 0:11

Codice: Seleziona tutto

[+0.10s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.10s] DEBUG: Starting Light Display Manager 1.14.0, UID=0 PID=309
[+0.10s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.10s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.10s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.10s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.10s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.14s] DEBUG: Registered seat module xlocal
[+0.14s] DEBUG: Registered seat module xremote
[+0.14s] DEBUG: Registered seat module unity
[+0.56s] DEBUG: Monitoring logind for seats
[+0.56s] DEBUG: New seat added from logind: seat0
[+0.56s] DEBUG: Loading properties from config section SeatDefaults
[+0.56s] DEBUG: Seat seat0: Starting
[+0.56s] DEBUG: Seat seat0: Creating greeter session
[+0.67s] DEBUG: Seat seat0: Creating display server of type x
[+0.69s] DEBUG: Could not run plymouth --ping: Failed to execute child process "plymouth" (No such file or directory)
[+0.69s] DEBUG: Using VT 1
[+0.69s] DEBUG: Seat seat0: Starting local X display on VT 1
[+0.69s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+0.74s] DEBUG: DisplayServer x-0: Writing X server authority to /run/lightdm/root/:0
[+0.74s] DEBUG: DisplayServer x-0: Launching X Server
[+0.74s] DEBUG: Launching process 317: /usr/sbin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt1 -novtswitch
[+0.74s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+0.74s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.74s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+3.33s] DEBUG: Loading users from org.freedesktop.Accounts
[+3.33s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+5.59s] DEBUG: Got signal 10 from process 317
[+5.59s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+5.59s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+5.59s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+5.59s] DEBUG: Session pid=371: Started with service 'lightdm-greeter', username 'lightdm'
[+5.92s] DEBUG: Session pid=371: Authentication complete with return value 0: Success
[+5.92s] DEBUG: Seat seat0: Session authenticated, running command
[+5.92s] DEBUG: Session pid=371: Running command /usr/sbin/lightdm-gtk-greeter
[+5.92s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+5.92s] DEBUG: Session pid=371: Logging to /var/log/lightdm/x-0-greeter.log
[+6.11s] DEBUG: Activating VT 1
[+6.11s] DEBUG: Activating login1 session c1
[+6.11s] DEBUG: Seat seat0 changes active session to c1
[+6.11s] DEBUG: Session c1 is already active
[+7.46s] DEBUG: Session pid=371: Greeter connected version=1.14.0 resettable=false
[+11.44s] DEBUG: Session pid=371: Greeter start authentication for jacopo
[+11.44s] DEBUG: Session pid=394: Started with service 'lightdm', username 'jacopo'
[+11.61s] DEBUG: Session pid=394: Got 1 message(s) from PAM
[+11.61s] DEBUG: Session pid=371: Prompt greeter with 1 message(s)
[+29.99s] DEBUG: Session pid=371: Continue authentication
[+30.03s] DEBUG: Session pid=394: Authentication complete with return value 0: Success
[+30.03s] DEBUG: Session pid=371: Authenticate result for user jacopo: Success
[+30.03s] DEBUG: Session pid=371: User jacopo authorized
[+30.03s] DEBUG: Session pid=371: Greeter sets language it_IT.utf8
[+30.20s] DEBUG: Session pid=371: Greeter requests session xfce
[+30.54s] DEBUG: Writing /home/jacopo/.dmrc
[+30.66s] DEBUG: Seat seat0: Stopping greeter; display server will be re-used for user session
[+30.66s] DEBUG: Session pid=371: Sending SIGTERM
[+30.90s] DEBUG: Session pid=371: Greeter closed communication channel
[+30.90s] DEBUG: Session pid=371: Exited with return value 0
[+30.90s] DEBUG: Seat seat0: Session stopped
[+30.90s] DEBUG: Seat seat0: Greeter stopped, running session
[+30.90s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
[+30.91s] DEBUG: Session pid=394: Running command /etc/lightdm/Xsession startxfce4
[+30.91s] DEBUG: Creating shared data directory /var/lib/lightdm-data/jacopo
[+30.91s] DEBUG: Session pid=394: Logging to .xsession-errors
[+31.23s] DEBUG: Activating VT 1
[+31.23s] DEBUG: Activating login1 session c2
[+31.23s] DEBUG: Seat seat0 changes active session to c2
[+31.23s] DEBUG: Session c2 is already active
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

erre
Arciere
Messaggi: 267
Iscritto il: 23 gennaio 2013, 23:12

Re: Problema LightDM con multi monitor

Messaggio da erre » 28 aprile 2015, 11:30

Cosa contiene il file "x-0.log"?
Ed il log di Xorg in /var/log/?

JacopoMolteni
Arciere
Messaggi: 226
Iscritto il: 11 febbraio 2015, 16:53
Architettura: x86_64 (64bit)

Re: Problema LightDM con multi monitor

Messaggio da JacopoMolteni » 29 aprile 2015, 23:03

Ecco x-0.log:

Codice: Seleziona tutto

X.Org X Server 1.17.1
Release Date: 2015-02-10
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.19.2-1-ARCH x86_64 
Current Operating System: Linux archlaptop 4.0.1-1-ARCH #1 SMP PREEMPT Wed Apr 29 12:00:26 CEST 2015 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=fb110b7a-7122-45b0-adaa-06252f460cd8 rw
Build Date: 14 April 2015  10:34:18AM
 
Current version of pixman: 0.32.6
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 29 20:44:04 2015
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] Kernel modesetting enabled.
Di Xorg ci sono xorg.0.log, xorg.0.log.old e xorg.1.log, quale ti interessa?
Put the fun back into computing.

Arch 64bit con Cinnamon/Xfce4.12 su ASUS X52JB (Intel Pentium P6100, 4Gb RAM e ATI Mobility Radeon HD 5145)
Arch 64bit con Cinnamon (Intel Core i5-4690K e Asus nVidia GTX-970 Strix Direct CU II OC)

pineout
Little John
Messaggi: 1264
Iscritto il: 10 luglio 2014, 9:08

Re: Problema LightDM con multi monitor

Messaggio da pineout » 30 aprile 2015, 0:21

Scusa, purtroppo non me ne intendo molto.

Nel log tra le ultime righe c'e' questo:

Codice: Seleziona tutto

[+30.91s] DEBUG: Session pid=394: Running command /etc/lightdm/Xsession startxfce4
[+30.91s] DEBUG: Creating shared data directory /var/lib/lightdm-data/jacopo
[+30.91s] DEBUG: Session pid=394: Logging to .xsession-errors
Mi sembra piu' che altro l'avvio di xfce4.

Quando lo schermo diventa bianco, potresti accedere alla tty e vedere se in .xsession-errors c'e' qualcosa.

Rispondi