Pagina 1 di 1

Ancora Samba

Inviato: 14 marzo 2014, 18:46
da pagaiocontento
Ho installato samba, gvfs-smb su Raspberry.
Come client nessun problema.
Come server niente da fare.
Uso Thunar sia su Raspberry che sulle altre macchine ma, sia utilzzando l'opzione "Esplora la rete" di Thunar sia digitando ctrl+l e poi smb://indirizzo Ip, non riesco ad entrare. O meglio a volte proprio non vedo Raspberry, altre volte lo vedo ma poi, inesorabilmente: Recupero dell'elenco delle condivisioni dal server non riuscito: Connessione scaduta.
Questa è la mia smb.conf:

Codice: Seleziona tutto

$ cat /etc/samba/smb.conf
[global]
   workgroup = WORKGROUP
   server string = Samba Raspberry
   printcap name = /etc/printcap
   load printers = yes
   guest account = gianni
   log file = /var/log/samba/%m.log
   max log size = 50
   security = user
   encrypt passwords = yes
   include = /etc/samba/smb.conf.%m
   local master = yes
   os level = 3
   wins support = yes
   dns proxy = no
   netbiosname = raspberry
   map to guest = Bad User
#============================ Share Definitions ==============================
[printers]
   comment = All Printers
   path = /var/spool/samba
   browseable = no
# Set public = yes to allow user 'guest account' to print
   guest ok = no
   writable = no
   printable = yes
[Documenti]
   comment = Documenti
   path = /home/gianni/Documenti
   public = yes
   writable = yes
   browseable = yes 
   case sensitive = yes 
   strict locking = no 
   create mask = 0777
   directory mask = 0777
   vfs object = recycle
[Musica]
   comment = Musica
   path = /home/gianni/Musica
   public = yes
   writable = yes
   browseable = yes
   case sensitive = yes
   strict locking = no
   create mask = 0777
   directory mask = 0777
   vfs object = recycle
[Immagini]
   comment = Immagini 
   path = /home/gianni/Immagini
   public = yes
   writable = yes
   browseable = yes
   case sensitive = yes
   strict locking = no
   create mask = 0777
   directory mask = 0777
   vfs object = recycle
[Video]
   comment = Video
   path = /home/gianni/Video
   public = yes
   writable = yes
   browseable = yes
   case sensitive = yes
   strict locking = no
   create mask = 0777
   directory mask = 0777
   vfs object = recycle
[Scaricati]
   comment = Scaricati
   path = /home/gianni/Scaricati
   public = yes
   writable = yes
   browseable = yes
   case sensitive = yes
   strict locking = no
   create mask = 0777
   directory mask = 0777
   vfs object = recycle      
che ho editato identica, salvo netbiosname, su tutti i PC e che, tranne su Raspberry, non mi dà problemi.
Specifico che mentre per tutti gli altri PC ho impostato manualmente l'indirizzo IP con NetworkManager con Raspberry non l'ho fatto non avendo installato NM.
Uso un router con chiavetta inserita e nel router ho riservato un idirizzo ip associato all'indirizzo Mac di ciascuna macchina pur avendo abilitato DHCP.
I demoni smbd e nmbd sono attivati:

Codice: Seleziona tutto

# ls -l /etc/systemd/system/multi-user.target.wants
totale 0
lrwxrwxrwx 1 root root 38 13 ago  2013 cronie.service -> /usr/lib/systemd/system/cronie.service
lrwxrwxrwx 1 root root 39 13 ago  2013 haveged.service -> /usr/lib/systemd/system/haveged.service
lrwxrwxrwx 1 root root 47 13 ago  2013 netctl-ifplugd@eth0.service -> /usr/lib/systemd/system/netctl-ifplugd@.service
lrwxrwxrwx 1 root root 52  1 gen 01.04 netctl@wlan0\x2dcasa_mia.service -> /etc/systemd/system/netctl@wlan0\x2dcasa_mia.service
lrwxrwxrwx 1 root root 36  1 gen 01.09 nmbd.service -> /usr/lib/systemd/system/nmbd.service
lrwxrwxrwx 1 root root 36  1 gen 01.02 ntpd.service -> /usr/lib/systemd/system/ntpd.service
lrwxrwxrwx 1 root root 40  4 mar  2014 remote-fs.target -> /usr/lib/systemd/system/remote-fs.target
lrwxrwxrwx 1 root root 36 21 ago  2013 rngd.service -> /usr/lib/systemd/system/rngd.service
lrwxrwxrwx 1 root root 36  1 gen 01.09 smbd.service -> /usr/lib/systemd/system/smbd.service
lrwxrwxrwx 1 root root 36  7 mar  2014 sshd.service -> /usr/lib/systemd/system/sshd.service
lrwxrwxrwx 1 root root 46  1 gen 01.18 wpa_supplicant.service -> /usr/lib/systemd/system/wpa_supplicant.service
Ripeto tutte le altre macchine si vedono sia come client che come server. Raspberry non funziona come server.
Con SSH funziona tutto (sftp://indirizzo IP).
A proposito c'è un browser per connessioni SSH che mi elenchi i server connessi potendoli selezionare e accedervi?

Re: Ancora Samba

Inviato: 15 marzo 2014, 4:41
da TheSaint
Ho scritto un mio esperimento. Vedi se trovi degli spunti.
Poi ci sono dei limiti del router, se e' troppo carico non riesce a soddisfare la richiesta di aggiungere un nuovo MAC in DHCP. Quindi rifiuta per diverse volte. Da vedere se per una condizione di poco carico riesce meglio o meno.
Al limite prova escludere il DHCP ed assegnare solo IP fissi. Ovvio che smartphone di passaggio non son consentiti :)

Re: Ancora Samba

Inviato: 15 marzo 2014, 8:13
da pagaiocontento
Adesso ho provato con solo due PC in rete: un desktop e raspberry e ho provato ad attivare il collegamento del raspberry alla rete con wifi-menu e non in automatico. Funziona: il raspberry funziona da server e da client con accesso alle cartelle condivise.
Però devo dire che con Raspbian tutti questi problemi non ci sono e la connessione, con la stessa configurazione di samba (copiata e incollata), va come un treno.
Per quel che riguarda la possibilità di browser per SSH non hai una qualche idea? Ho provato con bssh e nss-mdns (Esploratore Avahi per server SSH) ma funziona solo con collegamento testuale e non grafico.

Re: Ancora Samba

Inviato: 15 marzo 2014, 8:27
da pagaiocontento
Uno scrupolo: io dico SSH ma non sono sicuro di usare i termini giusti vista la mia ignoranza.
A me sarebbe utile un browser che mi visualizzasse l'elenco degli server disponibili dal client quando specifico l'indirizzo sftp://indirizzoIP.
Ovviamente, visionato l'elenco, vorrei poter scegliere il collegamento e accedere al server selezionato.
Non so se c'è questa possibilità ma se ci fosse saluteri definitivamente Samba senza eccessivi rimpianti perchè ho visto che la connessione tramite sftp, che forse impropriamente ho definito "connessione SSH", mi da molti meno problemi.

Re: Ancora Samba

Inviato: 15 marzo 2014, 13:53
da TheSaint
Io uso ssh per collegarmi al server e fare dei lavoretti da shell. Non capisco cosa serve un browser ssh. Thunar/pcmanfm dovrebbe fare il lavoro.
In secondo piano se voglio usare la grafica allora uso vncserver, dal server. Questo è più veloce che via ssh e condivisione di X del remoto.

Re: Ancora Samba

Inviato: 15 marzo 2014, 20:34
da pagaiocontento
Ma mi servirebbe perchè con sftp:// accedo graficamente proprio come con Samba (con Samba digito smb://indirizzoIP) ma senza nessuno dei problemi che mi da Samba. Però mentre con Thunar posso visualizzare tutti i server samba (tasto: Esplora la rete), proprio come con Nautilus, non riesco a visualizzare tutti i server sftp e devo ricordarmi gli indirizzi IP per poter digitare nella finestra di ricerca di Thunar l'indirizzo che mi interessa (es.: sftp://192.168.0.107). Non sto parlando della connessione da terminale (ssh nome-utente@indirizzoIP o ssh -X nome-utente@indirizzoIP), sto parlando di sftp://indirizzoIP. Ripeto non so se è possibile fare quello che voglio, lo sto chiedendo. Se hai sshd attivo su server e client prova, dal file manager del client a connerterti al server digitando sftp://indirizzoIP del server e potrai accedere graficamente a tutto il file system del server previa richiesta di nome e password. Sarebbe comodissimo poter vedere l'intera lista dei server e poterli scegliere di volta in volta.

Re: Ancora Samba

Inviato: 16 marzo 2014, 2:21
da TheSaint
Credo che dovresti scrivere in /etc/hosts un nome per ogni computer col proprio IP assegnato. Almeno e' semplice da ricordare.
Magari hai una particolare necessita' con SFTP, io invece vedo, muovo, cancello tutti i file sul/da/per il server senza usarlo.
Sia con nautilus che pcmanfm. C'è un piccolo problema con nautilus che tende a cercare in NFS, quindi si deve mettere nella barra di ricerca smb:/ e dopo appare il gruppo e di seguito i severs.

Re: Ancora Samba

Inviato: 16 marzo 2014, 8:17
da pagaiocontento
Penso di esserci riuscito, ho provato il tutto da un solo PC che, con router acceso, sto utilizzando da client e da server.
Ho installato avahi e nss-mdns
Ho attivato avahi-daemon:

Codice: Seleziona tutto

systemctl enable avahi-daemon.service
Ho editato /etc/nsswitch.conf cambiando la riga
hosts: files myhostname dns
in
hosts: files myhostname mdns_minimal [NOTFOUND=return] dns
e ho riavviato. Questo il risultato che allego:
E' quello che vedo dopo aver schiacciato il pulsante Eplora rete di Thunar.
SPUTNIK è il server Samba (smb), sputnik è il server SSH (sftp). Ora mi aspetto che, disattivando smbd e nmbd, possa vedere solo il server SSH.
Le istruzioni le ho trovate qui:
https://wiki.archlinux.org/index.php/avahi

Re: Ancora Samba

Inviato: 16 marzo 2014, 20:02
da tvaltert
non ho letto ma occhio a una cosa ..
vedo 2 nomi identici sputnik e SPUTNIK e qualcosa potrebbe fare casino

Re: Ancora Samba

Inviato: 17 marzo 2014, 14:05
da TheSaint
pagaiocontento ha scritto:Penso di esserci riuscito, ho provato il tutto da un solo PC che, con router acceso, sto utilizzando da client e da server.
Ho installato avahi e nss-mdns
Ho attivato avahi-daemon:
Hai ragione, ho trovato anch' io che c' era da fare questo passo.