Pagina 1 di 1

[RISOLTO]youtube

Inviato: 3 ottobre 2013, 21:49
da pagaiocontento
Ciao a tutti,
ho appena istallato Arch e ho il primo problema che non riesco a risolvere da solo: non riesco a visualizzare i filmati Youtube.
Qui c'è la mia scheda video:

Codice: Seleziona tutto

$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8375 [KM266/KL266] Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
00:0a.0 Communication controller: Conexant Systems, Inc. HSF 56k HSFi Modem (rev 01)
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:10.0 USB controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
01:00.0 [u]VGA compatible controller: NVIDIA Corporation NV34 [GeForce FX 5500] (rev a1)[/u]
Questi sono i miei /usr/lib/mozilla/plugins:
libflashplayer.so

Mentre in /usr/lib/xorg/modules/drivers ho:
nouveau_drv.so e libdirectfb_nvidia.so

Interfaccia grafico: xfce4

Browser: Firefox

Sullo stesso vecchio Pc, ma su un altro HD, ho Puppy che mi visualizza normalmente i video youtube.

Ho installato i codec proprietari per cui vedo e sento correttamente DVD, mp3, mp4, flac, ecc.ecc.
Mi rendo conto che pur avendo cercato si possa cercare meglio ma non sono riuscito a trovare nulla che mi aiuti.
Mi potete dare una mano, non vorrei arrendermi subito.
Grazie

Re: youtube

Inviato: 3 ottobre 2013, 22:54
da Bubz
pacman -S flashplugin

Re: youtube

Inviato: 4 ottobre 2013, 0:22
da pagaiocontento
Grazie ma:

Codice: Seleziona tutto

pacman -S flashplugin
attenzione: flashplugin-11.2.202.310-1 è aggiornato ma sarà reinstallato
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
Comunque procedo.

Re: youtube

Inviato: 4 ottobre 2013, 2:17
da enricotognoni
prova a vedere se su chromium hai lo stesso problema, se vedi su chromium i filmati prova a cliccare su help trouble shooting informations [reset firefox].
Magari hai toccato qualche setting di firefox che non dovevi.

ciao e scusa se non è quello. :)

Re: youtube

Inviato: 4 ottobre 2013, 19:56
da pagaiocontento
Niente da fare:
ho installato chromium e mi dice "impossibile caricare Shockwave flash".
Ho resettato Firefox e quando avvio il filmato Youtube va in crash.
Ho installato gecko-mediaplayer.so in mozilla-plugin e non è cambiato niente.

Re: youtube

Inviato: 5 ottobre 2013, 20:34
da pagaiocontento
Proprio niente ?
Ho reinstallato Archlinux, ho installato firefox, con Pacman ho installato flashplugin.
Possibile naufragare su una scemata come questa ?

Re: youtube

Inviato: 5 ottobre 2013, 21:42
da crx
Scusa ma perché hai directfb?
Hai mica installato anche qualche alternativa a flash (tipo gnash o swfdec)?

Re: youtube

Inviato: 6 ottobre 2013, 7:51
da pagaiocontento
L'avevo caricato fra i tanti tentativi di far funzionare le cose ma ora. avendo reinstallato tutto, non c'è più: ho solp nouveau_drv.so e libflashplayer.so .

Re: youtube

Inviato: 6 ottobre 2013, 8:47
da pagaiocontento
Ecco:
contenuto /usr/lib/xorg/modules/drivers:

Codice: Seleziona tutto

-rwxr-xr-x 1 root root 200968 30 lug 23.13 nouveau_drv.so
contenuto /usr/lib/mozilla/plugins/:

Codice: Seleziona tutto

-rwxr-xr-x 1 root root 17422820 10 set 17.48 libflashplayer.so
Ripeto, il mio Archliux è nuovo di zecca, ho installato libdvdcss e vedo e sento i normali formati proprietari con VLC.

Re: youtube

Inviato: 6 ottobre 2013, 9:03
da pagaiocontento
Scusate l'insistenza ma ci terrei a capire e risolvere:
quando cerco di avviare il filmato firefox va in crash e tutto il sistema ha dei problemi.
Compare la finestra che allego. Spero di aver seguito la procedura giusta con l'allegato perchè non sono molto pratico.

Re: youtube

Inviato: 6 ottobre 2013, 9:40
da crx
Aspetta, ma quella finestra ti avverte che uno script javascript non sta funzionando, non c'entra niente con flash.
Dovresti cercare qualcosa tipo http://kb.mozillazine.org/Unresponsive_Script_Warning.

Re: youtube

Inviato: 6 ottobre 2013, 11:18
da danyf90
hai qualche estensione di firefox installata?

Re: youtube

Inviato: 6 ottobre 2013, 12:24
da pagaiocontento
Nessuna.

Re: youtube

Inviato: 6 ottobre 2013, 14:01
da danyf90
Sugli altri browser l'errore è lo stesso?

Re: youtube

Inviato: 6 ottobre 2013, 14:10
da pagaiocontento
Chromium mi dice che non cisono i plugins necessari ma tra un'installazione e l'altra e di archlinux non l'ho più reinstallato.

Re: youtube

Inviato: 6 ottobre 2013, 14:26
da danyf90
ma avevi controllato che in chrome://plugins/ il flash fosse abilitato?

Re: youtube

Inviato: 6 ottobre 2013, 15:08
da pagaiocontento
Ci rinuncio anche perchè nel frattempo wicd ha smesso di rilevarmi la rete che è perfettamente funzionante tant'è che sto postando (connessione avviata con wifi-menu ecc. ecc. da terminale), vlc, installato e ed eliminato 4 volte con pacman, con yaourt-gui , con yaourt senza gui, con badile e con martello) non ne vuole sapere di partire.
Tutto bellissimo ma non è per me.
Ciao, ciao.

Re: youtube

Inviato: 8 ottobre 2013, 2:29
da xpringo
Ciao, hai provato ad attivare la versione HTML5 di YouTube all'indirizzo http://www.youtube.com/html5 ?

Re: youtube

Inviato: 8 ottobre 2013, 20:39
da xyz
Io proverei con Chromium e con il chromium-pepper-flash installato da AUR.

Dopo averli installati entrambi, scrivi about:plugins nella barra degli indirizzi di Chromium e clicca su "Dettagli" in alto a destra. Cerca Adobe flash player.
Se in quel punto hai due file, lascia attivo solo quello che fa riferimento a pepper.

Visto che hai una nVidia, magari installando il pacchetto libvdpau si sblocca anche il Flash classico.

Re: youtube

Inviato: 10 ottobre 2013, 22:11
da pagaiocontento
libvdpau è già installato ma l'ho reinstallato.
Ho reinstallato chromium.
Ho controllato e allego il risultato di about:plugins
Ho cercato di installare chromium-pepper-flash e allego il risultato.
Ho installato Midori con glib 2.18 e gnash-gtk e disinstallato libflashplayer.so che poi ho reinstallato.
Ma cosa devo fare ?

Re: youtube

Inviato: 11 ottobre 2013, 10:04
da enricotognoni
se digito su chromium

Codice: Seleziona tutto

about:plugins
IcedTea-Web Plugin (using IcedTea-Web 1.4.1) - Versione: 1.4.1)
Adobe Flash player Shockwave Flash 11.2 r202
Mentre come flashplugin:

Codice: Seleziona tutto

aur/flashplugin-beta 11.2.202.297-1 [installed] (499)
    Adobe Flash Player 11 Beta
Immagino che tu abbia abilitato javascript da Impostazioni, Impostazioni avanzate.
Una soluzione proposta in un thread di arch bbs.archlinux:
https://chrome.google.com/webstore/deta ... bmndjpblei

qui un tentativo che puoi fare:
https://bbs.archlinux.org/viewtopic.php ... 2#p1321132
Questa idea sembra molto promettente e costa poco tentare :) :
https://bbs.archlinux.org/viewtopic.php ... 1#p1322731

Poi se gugoli, trovi di tutto di +.

Re: [RISOLTO]youtube

Inviato: 11 ottobre 2013, 18:52
da pagaiocontento
Ho risolto brutalmente così: ho copiato da Puppy, su cui funzionava tutto, i files Nouveau e libflashplayer.
Ho eliminato i loro omologhi su Arch e li ho sostituiti usando una chiavetta USB come vettore. Tutto da terminale e da root. Probabilmente la versione di Nouveau installata su Arch non funzionava con la mia scheda video ma non so verificare se esistano differenze di versione. Liblash l'ho sostituita sulla base del ragionamento "L'accoppiata che funziona da una parte dovrebbe funzionare anche dall'altra". Mi è andata bene.
Grazie a tutti e penso che ci risentiremo presto. Portate pazienza.
Ciao a tutti.

Re: [RISOLTO]youtube

Inviato: 12 ottobre 2013, 7:46
da enricotognoni
Rischi di ritrovarti nei guai al prossimo update, ti consiglio di guardare la wiki di pacman e mettere ignore ai pacchetti che hai cablato manualmente. Di modo che, al prossimo update non ti salti tutto, se hai NVIDIA potevi provare a installare bumblebee. Anche se anche Bumblebee ha qualche problemino di partenza del servizio.

ciao