Codecs

Nuovo di Arch Linux? Nessun problema, fai qui le tue domande
Rispondi
BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 9 maggio 2008, 2:10

Salve ragazzi, ho un problema che non riesco a risolvere per niente. Trattasi di Divx (video in generale: xvid, mpeg, divx, avi, ecc. ecc.).
Nei giorni a dietro quando guardavo in divx A TUTTO SCHERMO saltava, non era per niente fluido!!! Poi, dopo un bel "pacman -Suy", un giorno qualsiasi, mi accorgo che non saltano più, sono sufficientemente fluidi, ma solo per poco!

Con Kaffeine va a scatti in modo brutale;
Con Mplayer molto fluido e visibilissimo, ma si blocca tutto il sistema;
Con VLC dopo un pò inizia a dare qualche scattino (ma non è continuo);

Io credo di aver installato tutti i codec (pacman -Sy codecs)
Anche perchè se li guardo a dimensione originale, è tutto ok.

Potrebbe essere qualcosa di xorg?
Buh, mi da un fastidio 'sta cosa... enorme!

Grazie a tutti :):)

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 9 maggio 2008, 15:03

Qui il problema sembra esser abbastanza grave. Non credo sia problema di codec:

Mi diverto con GIMP e si blocca tutto;
Cerco di effettuare modifiche ad un mp3 con Audacity e si blocca tutto...

Ma cosa succede???

Avatar utente
Berseker
Amministratore
Messaggi: 4432
Iscritto il: 27 settembre 2007, 10:18
Architettura: x86_64 (64bit)
Località: Lecco (provincia)

Messaggio da Berseker » 9 maggio 2008, 15:10

a mio parere è probabile un problema hardware a questo punto..
Leggete il Regolamento e cercate sempre su googleforumwiki prima di chiedere.
Tag x thread risolti: [Risolto] + Spazio messo all'inizio del titolo. Grazie

ArchWiki / Board Internazionale / Blog

Avatar utente
ilpianista
Amministratore
Messaggi: 2952
Iscritto il: 6 ottobre 2007, 0:41
Località: Lecce, Italy
Contatta:

Messaggio da ilpianista » 9 maggio 2008, 15:34

BlackieLawless ha scritto:Potrebbe essere qualcosa di xorg?
uhm...forse i driver video?
che scheda hai?
usi arch64?

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 9 maggio 2008, 15:44

Arch i686
ATI 9600xt:
fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI RADEON 9600 Series
OpenGL version string: 2.1.7412 Release

glxgears
16639 frames in 5.0 seconds = 3327.672 FPS
18431 frames in 5.0 seconds = 3686.105 FPS
18617 frames in 5.0 seconds = 3723.281 FPS
18965 frames in 5.0 seconds = 3792.957 FPS

M/B Asus A8V-MX

ram 512mb Pc3200 (400mhz)

Eppure su Debian i386 (Lenny), andava tutto liscio :(:(

Se volete saper altro, chiedere pure :(:(
Se si dovesse bloccare tutto, ci sono tasti rapidi che mi permettano di vedere quale processi vanno in tilt?

Avatar utente
ilpianista
Amministratore
Messaggi: 2952
Iscritto il: 6 ottobre 2007, 0:41
Località: Lecce, Italy
Contatta:

Messaggio da ilpianista » 9 maggio 2008, 16:48

BlackieLawless ha scritto:Se si dovesse bloccare tutto, ci sono tasti rapidi che mi permettano di vedere quale processi vanno in tilt?
in quei casi io apro una nuova tty e do
$ top

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 9 maggio 2008, 17:59

tty? cos'è? come fai ad aprirla?

Demind
Little John
Messaggi: 816
Iscritto il: 6 settembre 2007, 19:37
Località: Massy

Messaggio da Demind » 9 maggio 2008, 18:16

BlackieLawless ha scritto:tty? cos'è? come fai ad aprirla?
Terminale in sostanza.
O ne apri uno oppure fai CTRL+ALT+F2 e esci da X senza fare un kill eseguendo la login in un'altra console puoi dare top da lì e vedere i processi che hanno problemi.
A mio avviso comunque la soluzione più comoda è aprire un terminale e dare top...
Linux User: #471778

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 9 maggio 2008, 18:31

su Mplayer/preferenze/video, ho 5 opzioni:
xv: mi da errore
x11: funziona perfetto, ma non vuol impostarsi a schermo intero.
gl: si blocca il pc dopo un pò
gl2: uguale al precedente
xvidix: mi da errore

Mi sono accorto che installando o rimuovendo codecs (pacman -R codecs; pacman -Sy codecs) non cambia nulla.
Kaffeine mi da l'opportunità di scegliere DUE motori di riproduzione: xine e gstreamer. Il primo mi da i soliti scatti, se metto gstreamer mi dice che sta controllando un driver simile a "alsasink", ma sul database non c'è "alsasink"... e non mi possibile provare gstreamer.

Volevo richiedere una cosa che nonostante la risp di qualcuno mi è ancora poco chiara.
Su Kaffeine, andando sui parametri di xine, c'è un voce "decoder" che indica: "external.real_codecs" nella directory "/usr/lib/codecs"; mentre in "external.win32_codecs" mi ritrovo la directory "/usr/lib/win32" che sul mio pc NON c'è. A me credo servirebbe proprio quella directory perché guardo un divx .Avi.

Qualche aiutino?
Ultima modifica di BlackieLawless il 10 maggio 2008, 3:06, modificato 1 volta in totale.

Avatar utente
ilpianista
Amministratore
Messaggi: 2952
Iscritto il: 6 ottobre 2007, 0:41
Località: Lecce, Italy
Contatta:

Messaggio da ilpianista » 10 maggio 2008, 16:49

BlackieLawless ha scritto:Su Kaffeine, andando sui parametri di xine, c'è un voce "decoder" che indica: "external.real_codecs" nella directory "/usr/lib/codecs"; mentre in "external.win32_codecs" mi ritrovo la directory "/usr/lib/win32" che sul mio pc NON c'è. A me credo servirebbe proprio quella directory perché guardo un divx .Avi.
i codec win32 sono contenuti in /usr/lib/codecs

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 11 maggio 2008, 1:30

Grazie :)

Cmq sia non ho ancora risolto. E' stranissima 'sta cosa!

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 20 maggio 2008, 0:50

Sul file config di mplayer ho aggiunto: zoom=yes. Funziona correttamente. Ma da due giorni smanetto su codec audio e video, e l'audio del video anticipa di molto la scena. Non c'è sincronismo...
Ultima modifica di BlackieLawless il 25 maggio 2008, 22:42, modificato 1 volta in totale.

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 27 maggio 2008, 14:18

Credo di aver capito il motivo degli "scattini" durante una riproduzione di un video a tutto schermo!!!
Abbassando la risoluzione a 1024x768 (solitamente e originariamente la tengo a 1280x1024) gli scattini diminuiscono DI MOLTO. Detto questo credo sia più che normale che il problema sono i driver ATI. Ho dato un'occhiata a xorg.conf, è normale che le seguenti voci siano commentate?

Section "Module"

# This loads the DBE extension module.
# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
# This loads the font modules
# Load "type1"
# This loads the GLX module
# Load "glx"
# This loads the DRI module
# Load "dri"
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "freetype"
# Load "xtt"
EndSection

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 6 giugno 2008, 18:51

Ragazzi perché quando metto un video a tutto schermo l'audio ed il video non riescono più a sincronizzarsi? Ho provato qualsiasi codec (audio e video). Con VLC i video vanno ancora a scatti...

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 8 giugno 2008, 23:16

Buh, sembra che impostando su xorg il bus agp a 4x (e ovviamente anke sulla bios), gli scattini siano diminuiti, e non da poco... però c'è ancora qualcosina che non mi convince. Credo che debba configurare meglio xorg. Non sarà facile. Avete qualcosa da consigliarmi per ottimizzare al meglio?

Ecco il mio xorg:

# File generated by xorgconfig.
#
# Copyright 2004 The X.Org Foundation
#
# Permission is hereby granted, free of charge, to any person obtaining a
# copy of this software and associated documentation files (the "Software"),
# to deal in the Software without restriction, including without limitation
# the rights to use, copy, modify, merge, publish, distribute, sublicense,
# and/or sell copies of the Software, and to permit persons to whom the
# Software is furnished to do so, subject to the following conditions:
#
# The above copyright notice and this permission notice shall be included in
# all copies or substantial portions of the Software.
#
# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
# The X.Org Foundation BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF
# OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
#
# Except as contained in this notice, the name of The X.Org Foundation shall
# not be used in advertising or otherwise to promote the sale, use or other
# dealings in this Software without prior written authorization from
# The X.Org Foundation.
#
# **********************************************************************
# Refer to the xorg.conf(5) man page for details about the format of
# this file.
# **********************************************************************
# **********************************************************************
# Module section -- this section is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
# **********************************************************************
# Files section. This allows default font and rgb paths to be set
# **********************************************************************
# **********************************************************************
# Server flags section.
# **********************************************************************
# **********************************************************************
# Input devices
# **********************************************************************
# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************
# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************
# **********************************************************************
# Other input device sections
# this is optional and is required only if you
# are using extended input devices. This is for example only. Refer
# to the xorg.conf man page for a description of the options.
# **********************************************************************
#
# Section "InputDevice"
# Identifier "Mouse2"
# Driver "mouse"
# Option "Protocol" "MouseMan"
# Option "Device" "/dev/mouse2"
# EndSection
#
# Section "InputDevice"
# Identifier "spaceball"
# Driver "magellan"
# Option "Device" "/dev/cua0"
# EndSection
#
# Section "InputDevice"
# Identifier "spaceball2"
# Driver "spaceorb"
# Option "Device" "/dev/cua0"
# EndSection
#
# Section "InputDevice"
# Identifier "touchscreen0"
# Driver "microtouch"
# Option "Device" "/dev/ttyS0"
# Option "MinX" "1412"
# Option "MaxX" "15184"
# Option "MinY" "15372"
# Option "MaxY" "1230"
# Option "ScreenNumber" "0"
# Option "ReportingMode" "Scaled"
# Option "ButtonNumber" "1"
# Option "SendCoreEvents"
# EndSection
#
# Section "InputDevice"
# Identifier "touchscreen1"
# Driver "elo2300"
# Option "Device" "/dev/ttyS0"
# Option "MinX" "231"
# Option "MaxX" "3868"
# Option "MinY" "3858"
# Option "MaxY" "272"
# Option "ScreenNumber" "0"
# Option "ReportingMode" "Scaled"
# Option "ButtonThreshold" "17"
# Option "ButtonNumber" "1"
# Option "SendCoreEvents"
# EndSection
# **********************************************************************
# Monitor section
# **********************************************************************
# Any number of monitor sections may be present
# **********************************************************************
# Graphics device section
# **********************************************************************
# Any number of graphics device sections may be present
# Standard VGA Device:
# Device configured by xorgconfig:
# **********************************************************************
# Screen sections
# **********************************************************************
# Any number of screen sections may be present. Each describes
# the configuration of a single screen. A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
# **********************************************************************
# ServerLayout sections.
# **********************************************************************
# Any number of ServerLayout sections may be present. Each describes
# the way multiple screens are organised. A specific ServerLayout
# section may be specified from the X server command line with the
# "-layout" option. In the absence of this, the first section is used.
# When now ServerLayout section is present, the first Screen section
# is used alone.
# Section "DRI"
# Mode 0666
# EndSection

Section "ServerLayout"

# The Identifier line must be present
# Each Screen line specifies a Screen section name, and optionally
# the relative position of other screens. The four names after
# primary screen name are the screens to the top, bottom, left and right
# of the primary screen. In this example, screen 2 is located to the
# right of screen 1.
# Each InputDevice line specifies an InputDevice section name and
# optionally some options to specify the way the device is to be
# used. Those options include "CorePointer", "CoreKeyboard" and
# "SendCoreEvents".
Identifier "Simple Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# RgbPath "/usr/share/X11/rgb"
# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
#
# FontPath "/usr/share/fonts/Type1"
# FontPath "/usr/lib/X11/fonts/local/"
# FontPath "/usr/lib/X11/fonts/misc/"
# FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
# FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
# FontPath "/usr/lib/X11/fonts/Speedo/"
# FontPath "/usr/lib/X11/fonts/Type1/"
# FontPath "/usr/lib/X11/fonts/TrueType/"
# FontPath "/usr/lib/X11/fonts/freefont/"
# FontPath "/usr/lib/X11/fonts/75dpi/"
# FontPath "/usr/lib/X11/fonts/100dpi/"
# The module search path. The default path is shown here.
# ModulePath "/usr/lib/modules"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/TTF"
EndSection

Section "Module"

# This loads the DBE extension module.
# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
# This loads the font modules
Load "type1"
# This loads the GLX module
Load "glx"
# This loads the DRI module
Load "dri"
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "freetype"
Load "xtt"
EndSection

Section "InputDevice"

# Option "Xleds" "1 2 3"
# Option "LeftAlt" "Meta"
# Option "RightAlt" "ModeShift"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc105"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# These are the default XKB settings for Xorg
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""
# Option "XkbDisable"
Identifier "Keyboard1"
Driver "kbd"
Option "AutoRepeat" "500 30"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "it"
Option "XkbVariant" "it"
EndSection

Section "InputDevice"

# Identifier and driver
# Option "Resolution" "256"
# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.
# Option "BaudRate" "9600"
# Option "SampleRate" "150"
# Mouse wheel mapping. Default is to map vertical wheel to buttons 4 & 5,
# horizontal wheel to buttons 6 & 7. Change if your mouse has more than
# 3 buttons and you need to map the wheel to different button ids to avoid
# conflicts.
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ImPS/2"
Option "Device" "/dev/input/mice"
# Mouse-speed setting for PS/2 mouse.
Option "ZAxisMapping" "4 5"
# Emulate3Buttons is an option for 2-button mice
Option "Emulate3Buttons" "no"
# Option "Emulate3Timeout" "50"
# ChordMiddle is an option for some 3-button Logitech mice
# Option "ChordMiddle"
EndSection

Section "Monitor"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
# HorizSync 30-64 # multisync
# HorizSync 31.5, 35.2 # multiple fixed sync frequencies
# HorizSync 15-25, 30-50 # multiple ranges of sync frequencies
# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
Identifier "My Monitor"
HorizSync 31.5 - 31.5
VertRefresh 50.0 - 70.0
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"

# The chipset line is optional in most cases. It can be used to override
# the driver's chipset detection, and should not normally be specified.
# Chipset "generic"
# The Driver line must be present. When using run-time loadable driver
# modules, this line instructs the server to load the specified driver
# module. Even when not using loadable driver modules, this line
# indicates which driver should interpret the information in this section.
# The BusID line is used to specify which of possibly multiple devices
# this section is intended for. When this line isn't present, a device
# section can only match up with the primary video device. For PCI
# devices a line like the following could be used. This line should not
# normally be included unless there is more than one video device
# intalled.
# BusID "PCI:0:10:0"
# VideoRam 256
# Clocks 25.2 28.3
Identifier "Standard VGA"
Driver "vga"
VendorName "Unknown"
BoardName "Unknown"
EndSection

Section "Device"

# unsupported card
#VideoRam 131072
# Insert Clocks lines here if appropriate
Identifier "My Video Card"
Driver "vga"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "XAANoOffscreenPixmaps" "true" #needed for aiglx
Option "AGPMode" "4"
Option "EnablePageFlip" "on"
EndSection

Section "Screen"
Identifier "Screen 1"
Device "My Video Card"
Monitor "My Monitor"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
Ultima modifica di BlackieLawless il 8 giugno 2008, 23:40, modificato 1 volta in totale.

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 26 giugno 2008, 18:53

Ragazzi, installando da NUDO i driver proprietari ATI, non cambia nulla. Com'è possibile che non riesco a guardare un dvd o un divx da secoli?! E' fastidiosissimo. Please.... help me!

aleph
Robin Hood
Messaggi: 1530
Iscritto il: 12 febbraio 2008, 16:30
Contatta:

Messaggio da aleph » 26 giugno 2008, 22:29

e andare di driver vesa? finche non ti servono giochi o composite dovrebebro andare bene . . .
ImmagineOutside of a dog, computers are a man's best friend, inside a dog it's too dark to type.

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 27 giugno 2008, 1:51

...KDE 4.0 arriva... :(!

raycon
Arciere
Messaggi: 193
Iscritto il: 8 febbraio 2008, 17:55
Località: ROMA

Messaggio da raycon » 27 giugno 2008, 2:34

prova configurarlo solo per i driver proprietari:

Codice: Seleziona tutto

Section "ServerLayout"
    Identifier     "Simple Layout"
    Screen      0  "aticonfig-Screen[0]" 0 0
    InputDevice    "Mouse1" "CorePointer"
    InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"  
    FontPath     "/usr/share/fonts/misc"
    FontPath     "/usr/share/fonts/100dpi:unscaled"
    FontPath     "/usr/share/fonts/75dpi:unscaled"
    FontPath     "/usr/share/fonts/TTF"
EndSection

Section "Module" 
    Load       "glx"
    Load       "dri"
    Load       "dbe"  
    Load       "freetype"
    Load       "xtt"
EndSection

Section "InputDevice" 
    Identifier     "Keyboard1"
    Driver         "kbd"
    Option        "AutoRepeat" "500 30" 
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc104"
    Option        "XkbLayout" "it"
    Option        "XkbVariant" "it"
EndSection

Section "InputDevice" 
    Identifier     "Mouse1"
    Driver         "mouse"
    Option        "Protocol" "ImPS/2"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5"
    Option        "Emulate3Buttons" "no"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]"
    Driver      "fglrx"
    Option    "XAANoOffscreenPixmaps" "true" #needed for aiglx
    Option    "AGPMode" "4"
    Option    "EnablePageFlip" "on"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device     "aticonfig-Device[0]"
    Monitor    "aticonfig-Monitor[0]"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "DRI"
    Mode 0666
EndSection

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 27 giugno 2008, 4:22

Fatto, ma non ho risolto nulla.

E' la prima volta che perdo la pazienza su una distribuzione... Se servisse spaccare tutto -.-! Calma, calma!!!!

BlackieLawless
Arciere Provetto
Messaggi: 625
Iscritto il: 23 aprile 2008, 15:37
Contatta:

Messaggio da BlackieLawless » 28 giugno 2008, 7:03

Stranezze in Arrivo.

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: P� (<- ca**o è?)
OpenGL version string: 2.0.6958 Release

Quando lancio il comando glxgears, il quadratino dove DOVREBBERO esserci le rotelline RIMANE TUTTO NERO; ma nella Konsole continua a darmi i frames, come se tutto fosse normale.

$ glxgears
17056 frames in 5.0 seconds = 3411.091 FPS
18539 frames in 5.0 seconds = 3707.670 FPS
18547 frames in 5.0 seconds = 3709.247 FPS
18557 frames in 5.0 seconds = 3711.365 FPS
18555 frames in 5.0 seconds = 3710.844 FPS

ldem quando lancio fgl_glxgears.

domanda O.T.: Scaricando versioni dei driver meno recenti dal sito ufficiali AMD/ATI, mi ritrovo il classico .run. Dopo averlo lanciato con ./nome file, e dato tutte le opzioni alla nuova finestra che mi appare, devo far altro (oltre che aggiungere fglrx nei moduli)?

Rispondi