[Risolto] Problema aggiornamento

Nuovo di Arch Linux? Nessun problema, fai qui le tue domande
Rispondi
Avatar utente
giupino
Novello Arciere
Messaggi: 25
Iscritto il: 20 giugno 2011, 16:30
Architettura: x86_64 (64bit)

[Risolto] Problema aggiornamento

Messaggio da giupino » 17 luglio 2012, 14:22

Ciao a tutti,

non davo un pacman -Syu da molto tempo e ora ho entrambi i problemi segnalati:

viewtopic.php?f=15&t=14723

viewtopic.php?f=15&t=14982

ora non so come procedere per l'aggiornamento se do il primo comando mi dà il problema sulla lib e se do il comando sulla lib mi da questo:

Codice: Seleziona tutto

[peppe@arch-giupino ~]$ sudo pacman -Syu --ignore glibc
Password: 
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community è aggiornato
:: Aggiornamento del sistema in corso...
:: Vuoi sostituire dbus-python con extra/python2-dbus? [S/n] s
attenzione: glibc: l'aggiornamento del pacchetto è stato ignorato (2.15-10 => 2.16.0-2)
:: Vuoi sostituire libusb con core/libusbx? [S/n] s
:: Vuoi sostituire procps con core/procps-ng? [S/n] s
:: Vuoi sostituire python-beautifulsoup con community/python2-beautifulsoup3? [S/n] s
:: Vuoi sostituire udev con core/systemd-tools? [S/n] s
risoluzione delle dipendenze in corso...
[..]
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
[...]
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
attenzione: il pacchetto glibc-2.16.0-2 è stato ignorato
attenzione: impossibile risolvere "glibc>=2.16", una dipendenza di "gcc-libs"
:: I seguenti pacchetti non possono essere aggiornati a causa di alcune dipendenze irrisolvibili:
      amarok  apr  ati-dri  attica  binutils  ca-certificates  ca-certificates-java  cairo  calibre  chromium  cifs-utils  cloog  colord  consolekit  coreutils  cronie
      cryptsetup  cups  curl  db  dbus  dbus-core  dbus-glib  python2-dbus  desktop-file-utils  device-mapper  e2fsprogs  faac  ffmpeg  filesystem  flashplugin
      foomatic-db  foomatic-db-engine  foomatic-filters  gcc  gcc-libs  glib-networking  glib2  gmp  gnutls  grep  gsettings-desktop-schemas  gstreamer0.10-bad-plugins
      gtk3  hplip  hyphen  icu  imagemagick  initscripts  iproute2  iputils  jre7-openjdk  jre7-openjdk-headless  k3b  kactivities  kdeaccessibility-jovie
      kdeaccessibility-kaccessible  kdeaccessibility-kmag  kdeaccessibility-kmousetool  kdeaccessibility-kmouth  kdeadmin-kcron  kdeadmin-ksystemlog  kdeadmin-kuser
      kdeadmin-system-config-printer-kde  kdeartwork-kscreensaver  kdeartwork-styles  kdebase-dolphin  kdebase-katepart  kdebase-kdepasswd  kdebase-kdialog
      kdebase-keditbookmarks  kdebase-kfind  kdebase-konq-plugins  kdebase-konqueror  kdebase-konsole  kdebase-kwrite  kdebase-lib  kdebase-plasma  kdebase-runtime
      kdebase-workspace  kdebindings-python2  kdeedu-analitza  kdeedu-blinken  kdeedu-cantor  kdeedu-kalgebra  kdeedu-kalzium  kdeedu-kanagram  kdeedu-kbruch
      kdeedu-kgeography  kdeedu-khangman  kdeedu-kig  kdeedu-kiten  kdeedu-klettres  kdeedu-kmplot  kdeedu-kstars  kdeedu-ktouch  kdeedu-kturtle  kdeedu-kwordquiz
      kdeedu-marble  kdeedu-parley  kdeedu-rocs  kdeedu-step  kdegames-bomber  kdegames-bovo  kdegames-granatier  kdegames-kajongg  kdegames-kapman  kdegames-katomic
      kdegames-kbattleship  kdegames-kblackbox  kdegames-kblocks  kdegames-kbounce  kdegames-kbreakout  kdegames-kdiamond  kdegames-kfourinline  kdegames-kgoldrunner
      kdegames-kigo  kdegames-killbots  kdegames-kiriki  kdegames-kjumpingcube  kdegames-klickety  kdegames-klines  kdegames-kmahjongg  kdegames-kmines  kdegames-knetwalk
      kdegames-kolf  kdegames-kollision  kdegames-konquest  kdegames-kpatience  kdegames-kreversi  kdegames-kshisen  kdegames-ksirk  kdegames-kspaceduel
      kdegames-ksquares  kdegames-ksudoku  kdegames-ktron  kdegames-ktuberling  kdegames-kubrick  kdegames-libkdegames  kdegames-libkmahjongg  kdegames-lskat
      kdegames-palapeli  kdegraphics-gwenview  kdegraphics-kamera  kdegraphics-kcolorchooser  kdegraphics-kgamma  kdegraphics-kolourpaint  kdegraphics-kruler
      kdegraphics-ksnapshot  kdegraphics-okular  kdelibs  kdemultimedia-dragonplayer  kdemultimedia-ffmpegthumbs  kdemultimedia-juk  kdemultimedia-kioslave
      kdemultimedia-kmix  kdemultimedia-kscd  kdemultimedia-mplayerthumbs  kdenetwork-filesharing  kdenetwork-kdnssd  kdenetwork-kget  kdenetwork-kopete  kdenetwork-kppp
      kdenetwork-krdc  kdenetwork-krfb  kdepim-akonadiconsole  kdepim-akregator  kdepim-blogilo  kdepim-console  kdepim-kaddressbook  kdepim-kalarm  kdepim-kjots
      kdepim-kleopatra  kdepim-kmail  kdepim-knode  kdepim-knotes  kdepim-kontact  kdepim-korganizer  kdepim-kresources  kdepim-ktimetracker  kdepim-libkdepim
      kdepim-runtime  kdepimlibs  kdeplasma-addons-applets-bball  kdeplasma-addons-applets-binary-clock  kdeplasma-addons-applets-blackboard
      kdeplasma-addons-applets-bookmarks  kdeplasma-addons-applets-bubblemon  kdeplasma-addons-applets-calculator  kdeplasma-addons-applets-charselect
      kdeplasma-addons-applets-comic  kdeplasma-addons-applets-community  kdeplasma-addons-applets-dict  kdeplasma-addons-applets-eyes
      kdeplasma-addons-applets-fifteenpuzzle  kdeplasma-addons-applets-filewatcher  kdeplasma-addons-applets-frame  kdeplasma-addons-applets-fuzzy-clock
      kdeplasma-addons-applets-icontasks  kdeplasma-addons-applets-incomingmsg  kdeplasma-addons-applets-kdeobservatory  kdeplasma-addons-applets-kimpanel
      kdeplasma-addons-applets-knowledgebase  kdeplasma-addons-applets-kolourpicker  kdeplasma-addons-applets-konqprofiles  kdeplasma-addons-applets-konsoleprofiles
      kdeplasma-addons-applets-lancelot  kdeplasma-addons-applets-leavenote  kdeplasma-addons-applets-life  kdeplasma-addons-applets-luna
      kdeplasma-addons-applets-magnifique  kdeplasma-addons-applets-mediaplayer  kdeplasma-addons-applets-microblog  kdeplasma-addons-applets-news
      kdeplasma-addons-applets-notes  kdeplasma-addons-applets-nowplaying  kdeplasma-addons-applets-paste  kdeplasma-addons-applets-pastebin
      kdeplasma-addons-applets-plasmaboard  kdeplasma-addons-applets-previewer  kdeplasma-addons-applets-qalculate  kdeplasma-addons-applets-rememberthemilk
      kdeplasma-addons-applets-rssnow  kdeplasma-addons-applets-showdashboard  kdeplasma-addons-applets-showdesktop  kdeplasma-addons-applets-social-news
      kdeplasma-addons-applets-spellcheck  kdeplasma-addons-applets-systemloadviewer  kdeplasma-addons-applets-timer  kdeplasma-addons-applets-unitconverter
      kdeplasma-addons-applets-weather  kdeplasma-addons-applets-weatherstation  kdeplasma-addons-applets-webslice  kdeplasma-addons-containments  kdeplasma-addons-libs
      kdeplasma-addons-runners-audioplayercontrol  kdeplasma-addons-runners-browserhistory  kdeplasma-addons-runners-characters  kdeplasma-addons-runners-contacts
      kdeplasma-addons-runners-converter  kdeplasma-addons-runners-datetime  kdeplasma-addons-runners-events  kdeplasma-addons-runners-katesessions
      kdeplasma-addons-runners-konquerorsessions  kdeplasma-addons-runners-konsolesessions  kdeplasma-addons-runners-kopete  kdeplasma-addons-runners-mediawiki
      kdeplasma-addons-runners-spellchecker  kdeplasma-addons-wallpapers-mandelbrot  kdeplasma-addons-wallpapers-marble  kdeplasma-addons-wallpapers-pattern
      kdeplasma-addons-wallpapers-potd  kdeplasma-addons-wallpapers-virus  kdeplasma-addons-wallpapers-weather  kdesdk-cervisia  kdesdk-dolphin-plugins
      kdesdk-kapptemplate  kdesdk-kate  kdesdk-kcachegrind  kdesdk-kdeaccounts-plugin  kdesdk-kioslave  kdesdk-kmtrace  kdesdk-kompare  kdesdk-kpartloader
      kdesdk-kstartperf  kdesdk-kuiviewer  kdesdk-lokalize  kdesdk-okteta  kdesdk-poxml  kdesdk-strigi-analyzer  kdesdk-umbrello  kdetoys-amor  kdetoys-kteatime
      kdetoys-ktux  kdeutils-ark  kdeutils-filelight  kdeutils-kcalc  kdeutils-kcharselect  kdeutils-kdf  kdeutils-kfloppy  kdeutils-kgpg  kdeutils-kremotecontrol
      kdeutils-ksecrets  kdeutils-ktimer  kdeutils-kwallet  kdeutils-printer-applet  kdeutils-superkaramba  kdeutils-sweeper  kdewebdev-kfilereplace
      kdewebdev-kimagemapeditor  kdewebdev-klinkstatus  kdewebdev-kommander  krb5  ktorrent  ldns  libatasmart  libcups  libegl  libevent  libgadu  libgl  libkdeedu
      libkexiv2  libkipi  libktorrent  libldap  liblrdf  libmp4v2  libmysqlclient  libproxy  libpulse  libreoffice-base  libreoffice-calc  libreoffice-common
      libreoffice-impress  libreoffice-kde4  libreoffice-math  libreoffice-writer  libssh2  libtool  libunrar  libva  libvncserver  linux  lm_sensors  logrotate  lvm2
      mediastreamer  mesa  mkinitcpio  mpfr  mplayer  mysql  mysql-clients  net-snmp  nettle  openssh  openssl  ortp  pam  pango  pcre  perl  polkit  poppler  poppler-qt
      ppl  pyqt  python2-gobject2  python2-pyqt  qscintilla  qt  qtwebkit  raptor  rasqal  rhino  samba  sane  shadow  smbclient  soprano  sudo  syslog-ng
      system-config-printer-common  sysvinit  taglib  systemd-tools  udisks  upower  util-linux  v4l-utils  virtuoso  vlc  vpnc  wpa_supplicant  xf86-video-ati  xfsprogs
      xorg-server

Vuoi ignorare i seguenti pacchetti per questo aggiornamento? [s/N] s
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: pyqt: richiede python-sip

Ultima modifica di giupino il 17 luglio 2012, 19:07, modificato 1 volta in totale.

nierro
Little John
Messaggi: 1019
Iscritto il: 19 novembre 2009, 17:51
Architettura: x86_64 (64bit)

Re: Problema aggiornamento

Messaggio da nierro » 17 luglio 2012, 16:10


Avatar utente
KleinerMann
Moderatore
Messaggi: 3784
Iscritto il: 8 gennaio 2011, 20:59
Architettura: x86_64 (64bit)

Re: Problema aggiornamento

Messaggio da KleinerMann » 17 luglio 2012, 18:09

hai la somma di due conflitti noti, oltre che a problemi di dipendenze, prova così:

Codice: Seleziona tutto

# pacman -Syu --ignore filesystem --ignore glibc 
# pacman -S filesystem --force
# pacman -S glibc
Arch Linux - AwesomeWM

Avatar utente
giupino
Novello Arciere
Messaggi: 25
Iscritto il: 20 giugno 2011, 16:30
Architettura: x86_64 (64bit)

Re: Problema aggiornamento

Messaggio da giupino » 17 luglio 2012, 18:12

ciao grazie per la risposta, però in pratica non riesce a continuare l'aggiornamento neanche se gli dico di skippare i pacchetti con la dipendenza...

muore con

Codice: Seleziona tutto

Vuoi ignorare i seguenti pacchetti per questo aggiornamento? [s/N] s
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: pyqt: richiede python-sip
:(

Avatar utente
ambro
Robin Hood
Messaggi: 1933
Iscritto il: 27 agosto 2009, 21:37
Località: Verona

Re: Problema aggiornamento

Messaggio da ambro » 17 luglio 2012, 18:17

Se dai

Codice: Seleziona tutto

pacman -Sy pyqt
ti ripete l'errore?
PC: Amd FX-6100-Nvidia GT630-SSD- 64bit - kernel 4.3-ck - KDE Plasma 5
Mediacenter: Asrock Q2900 Itx - VGA Intel - 64bit - kernel 4.3-ck - lxde - Kodi - isengard
Netbook: Asus eeepc1001 - i686 - kernel 4.3 - lxde

Avatar utente
giupino
Novello Arciere
Messaggi: 25
Iscritto il: 20 giugno 2011, 16:30
Architettura: x86_64 (64bit)

Re: Problema aggiornamento

Messaggio da giupino » 17 luglio 2012, 18:24

ambro ha scritto:Se dai

Codice: Seleziona tutto

pacman -Sy pyqt
ti ripete l'errore?

niente da fare...

Codice: Seleziona tutto

sudo pacman -Sy pyqt
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community è aggiornato
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
:: python-dbus-common e dbus-python vanno in conflitto. Vuoi rimuovere dbus-python? [s/N] s
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: python2-pyqt: richiede dbus-python
:: system-config-printer-common: richiede dbus-python
del codice di umby invece

Codice: Seleziona tutto

# pacman -Syu --ignore filesystem --ignore glibc 
# pacman -S filesystem --force
# pacman -S glibc
solo il secondo comando va a buon fine... mi sembra faccia un cambiamento di permessi su qualche cartella...
gli altri nada :( :(

Avatar utente
giupino
Novello Arciere
Messaggi: 25
Iscritto il: 20 giugno 2011, 16:30
Architettura: x86_64 (64bit)

Re: Problema aggiornamento

Messaggio da giupino » 17 luglio 2012, 18:59

sul forum internazionale ho trovato un sacco di persone con il mio stesso problema....

sembra che la soluzione sia qui:

http://allanmcrae.com/2012/07/updating- ... e-install/

ora stà aggiornando... vediamo se ho risolto :)

Avatar utente
giupino
Novello Arciere
Messaggi: 25
Iscritto il: 20 giugno 2011, 16:30
Architettura: x86_64 (64bit)

Re: [Risolto] Problema aggiornamento

Messaggio da giupino » 17 luglio 2012, 19:08

ha funzionato.
aggiunto [Risolto]

ciao a tutti

Rispondi