Come avviare manualmente un demone da utente?

Nuovo di Arch Linux? Nessun problema, fai qui le tue domande
Rispondi
zanardi84
Novello Arciere
Messaggi: 82
Iscritto il: 22 giugno 2011, 10:09

Messaggio da zanardi84 » 27 agosto 2011, 9:06

La domanda vi sembrerà banale, ma penso che sia l'unico workaround possibile per risolvere il mio problema con gnome 3.
La considerazione, riassunta brevemente è questa:
C'è qualcosa di gnome 3 che inibisce acpid che viene caricato correttamente sino alla finestra di login. Poi, dal login, acpi sembra smettere di funzionare, sembra attivo ma non lo è, tanto è vero che nei demoni in esecuzione non compare, ma stoppandolo da terminale si stoppa e si riavvia. E' SOLO un problema relativo a gnome, perchè con tutti ambienti funziona. In più. il demone è correttamente inserito nella lista di rc.conf.
Proprio questo stop e riavvia è necessario per renderlo nuovamente e correttamente operativo. Vorrei assolutamente automatizzare l'operazione in modo che
1) venga riavviato appena dopo il login di gnome
2) non sia necessario inserire di volta in volta la password di root.

Avatar utente
Berseker
Amministratore
Messaggi: 4431
Iscritto il: 27 settembre 2007, 10:18
Architettura: x86 (32Bit)
Località: Lecco (provincia)
Contatta:

Messaggio da Berseker » 27 agosto 2011, 10:16

metti in /etc/rc.local

sleep 30 && /etc/rc.d/acpid restart
Leggete il Regolamento e cercate sempre su googleforumwiki prima di chiedere.
Tag x thread risolti: [Risolto] + Spazio messo all'inizio del titolo. Grazie

ArchWiki / Board Internazionale / Blog

zanardi84
Novello Arciere
Messaggi: 82
Iscritto il: 22 giugno 2011, 10:09

Messaggio da zanardi84 » 27 agosto 2011, 10:50

Berseker ha scritto:metti in /etc/rc.local

sleep 30 && /etc/rc.d/acpid restart

Uff non sembra sortire alcun effetto!

fgr
Arciere
Messaggi: 188
Iscritto il: 2 dicembre 2008, 18:31

Messaggio da fgr » 27 agosto 2011, 10:54

e in /etc/gdm/Xsession? (se usi GNOME immagino usi pure gdm)

zanardi84
Novello Arciere
Messaggi: 82
Iscritto il: 22 giugno 2011, 10:09

Messaggio da zanardi84 » 27 agosto 2011, 11:37

Senza ben capire come, adesso se digito da terminale sudo /etc/rc.d/acpid restart NON mi chiede più la password.
Pertanto ho approfittato della situazione per creare uno script eseguibile che, messo in esecuzione all'avvio di gnome con un'entry in gnome-session-proprieties mi svolge il lavoro!!!

Quindi adesso effettivamente ho quello che volevo!

Si aggiunge un'altra questione però. Non so se è un problema conosciuto di gnome 3 o se c'è dell'altro, magari collegato al problema iniziale: NON va in sospensione. Gnome power manager è impostato per andarvici alla pressione del bottone d'accensione, ma in realtà non ci va e il bottone innesca il normale spegni computer (shutdown -h now insomma).

Rispondi