Pagina 1 di 1

Forzare frequenza a 50Hz su monitor

Inviato: 15 dicembre 2017, 14:13
da quellen
ciao,
avrei bisogno di impostare una frequenza di 50Hz (per emulare al meglio i giochi europei) sul mio monitor/TV 4:3 che a quanto pare non la supporta:

Codice: Seleziona tutto

$ xrandr 
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
VGA-1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 708mm x 398mm
   1280x720      50.00 +
   1024x768      75.03*   70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
(la risoluzione 1280x720 è fasulla e non funziona: se impostata da schermo nero e nell'OSD del monitor compare la scritta "OUT OF RANGE")

Codice: Seleziona tutto

$ xrandr -s 1024x768 -r 50
Rate 50.00 Hz not available for this size
Secondo voi c'è qualche trucchetto per forzare i 50Hz anche se non sono supportati?
Ho un GPU Intel integrata della CPU:

Codice: Seleziona tutto

$ lspci|grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)

Codice: Seleziona tutto

$ pacman -Q|grep xf86-video
xf86-video-vesa 2.3.4-4
ho provato a creare il file "/etc/X11/xorg.conf.d/90-monitor.conf" con dentro la riga "VertRefresh 50" ma così X non si avvia.

Re: Forzare frequenza a 50Hz su monitor

Inviato: 15 dicembre 2017, 22:39
da TheSaint
Mi pare evidente che le frequenze sono quelle che ti risponde Xorg. Se cerchi di cambiare, ti ritorna lo schermo nero.

Re: Forzare frequenza a 50Hz su monitor

Inviato: 16 dicembre 2017, 18:42
da quellen
però penso che questo monitor/TV supporti i 50Hz: se ci collego, tramite connettori RCA, una vecchia console PAL (tipo lo SNES) funziona perfettamente.
Cercando in giro ho letto che consigliano di seguire questa procedura:

Codice: Seleziona tutto

$ cvt 1024 768 50
# 1024x768 49.98 Hz (CVT 0.79M3) hsync: 39.63 kHz; pclk: 52.00 MHz
Modeline "1024x768_50.00"   52.00  1024 1072 1168 1312  768 771 775 793 -hsync +vsync

Codice: Seleziona tutto

$ xrandr --newmode  "1024x768_50.00"   52.00  1024 1072 1168 1312  768 771 775 793 -hsync +vsync

Codice: Seleziona tutto

$ xrandr --addmode VGA-1 "1024x768_50.00"

Codice: Seleziona tutto

$ xrandr --output VGA-1 --mode 1024x768_50.00
però avviando questo ultimo comando mi da schermo nero con scritta OUT OF RANGE (FUORI GAMMA se imposto la lingua italiana nel menu della TV).

Consigliano anche di modificare la configurazione di xorg. L'ho fatto ma si avvia lo stesso a 60Hz:

Codice: Seleziona tutto

$ cat /etc/X11/xorg.conf.d/10-monitor.conf
Section "Device"
        Identifier "Intel Graphics"
        Driver "intel"
        Option "TearFree" "true"
          Option "ModeValidation" "AllowNon60HzDFPModes"
  Option "FlatPanelProperties" "Scaling=Native"
  Option "UseEvents" "True"
EndSection

Section "Monitor"
        Identifier "Default Monitor"
        Option "UseEdidFreqs" "False"
        Option "ExactModeTimingsDVI" "True"
        # 1280x1024 @ 50.00 Hz (GTF) hsync: 52.70 kHz; pclk: 89.38 MHz
        Modeline "1024x768_50.00"   52.00  1024 1072 1168 1312  768 771 775 793 -hsync +vsync
        HorizSync 30-83
        VertRefresh 46-76
EndSection

Section "Screen"
        Identifier "Default Screen"
        Monitor "Default Monitor"
        Device "Intel Graphics"
        DefaultDepth 24
        Subsection "Display"
                Depth 24
                Modes "1024x768_50_0"
        EndSubsection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
EndSection