Errori di autenticazione dopo aggiornamento pambase

Problemi e discussioni inerenti al networking, ai server, backup dati e alla sicurezza in generale
Rispondi
Avatar utente
Dusty
Little John
Messaggi: 805
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Errori di autenticazione dopo aggiornamento pambase

Messaggio da Dusty » 10 febbraio 2019, 0:03

Segnalo a chi fosse interessato che l'ultimo aggiornamento del pacchetto pambase ha rafforzato i criteri di sicurezza ed impedisce l'autenticazione dei servizi non correttamente configurati.
Per esempio, il comando 'at' non funziona più:

Codice: Seleziona tutto

feb 09 17:20:00 PRIMO atd[5157]: pam_warn(atd:account): function=[pam_sm_acct_mgmt] flags=0x8000 service=[atd] terminal=[<unknown>] user=[beppe] ruser=[<unknown>] rhost=[<unknown>]
feb 09 17:20:00 PRIMO atd[5157]: Authentication failure
Chi lo usa, in attesa della correzione ufficiale può resuscitarlo aggiungendo in /etc/pam.d/ un file di nome atd e contenuto:

Codice: Seleziona tutto

#%PAM-1.0
auth            required        pam_unix.so
account         required        pam_unix.so
password        required        pam_unix.so
session         required        pam_unix.so

Avatar utente
TheSaint
Robin Hood
Messaggi: 7817
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Errori di autenticazione dopo aggiornamento pambase

Messaggio da TheSaint » 10 febbraio 2019, 11:53

Sto aggiornando e vedo se c'è ancora l' errore. Interessante la tua notifica.
Non ho notato alcun errore

Codice: Seleziona tutto

$ grep pambase /var/log/pacman.log 
[2017-10-11 16:36] [ALPM] upgraded pambase (20130928-1 -> 20171006-1)
[2019-02-10 18:51] [ALPM] upgraded pambase (20171006-1 -> 20190105.1-1)
[2019-02-10 18:53] [ALPM-SCRIPTLET] '/var/cache/pacman/pkg/pambase-20130928-1-any.pkg.tar.xz' rimosso
F the saint
12 anni da questo forum ;)

Avatar utente
Dusty
Little John
Messaggi: 805
Iscritto il: 12 agosto 2011, 13:15
Località: Firenze

Re: Errori di autenticazione dopo aggiornamento pambase

Messaggio da Dusty » 10 febbraio 2019, 14:43

L'errore non si verifica all'installazione di pambase, ma al successivo utilizzo di altri pacchetti che usano pam per autenticare gli utenti.
Fai una prova con 'at': vedrai che non funziona più.
Trovi altre segnalazioni analoghe per altri pacchetti sul forum internazionale.

Rispondi