Problema impostazioni vsftpd.conf

Problemi e discussioni inerenti al networking, ai server, backup dati e alla sicurezza in generale
Rispondi
Avatar utente
Astroarch
Novello Arciere
Messaggi: 72
Iscritto il: 28 marzo 2014, 13:42
Architettura: x86_64 (64bit)

Problema impostazioni vsftpd.conf

Messaggio da Astroarch » 20 aprile 2015, 19:28

Salve ragazzi,
voglio stabilire una connessione bidirezionale per scambiare file tra il mio notebook (connesso via wireless) ed il desktop (connesso via LAN).
Nel netbook ho installato vsftpd ed il file di configurazione è il seguente:

Codice: Seleziona tutto

write_enable=YES
local_enable=YES
anonymous_enable=YES
listen=YES
no_anon_password=YES
listen_port=2211
anon_root=/home
anon_mkdir_write_enable=YES
anon_upload_enable=YES
local_root=/home
dirlist_enable=YES


Nel desktop apro Filezilla con Host:192.168.1.10, Username=anonymous, Port=2211 e riesco a connettermi ma non vedo nessuna directory.

Questo è il log di Filezilla quando cerco di fare qualcosa

Codice: Seleziona tutto

Disconnected from server
Status:   Connecting to 192.168.1.10:2211...
Status:   Connection established, waiting for welcome message...
Status:   Insecure server, it does not support FTP over TLS.
Status:   Connected
Status:   Retrieving directory listing...
Status:   Directory listing of "/" successful
Status:   Creating directory '/New directory'...
Command:   MKD New directory
Response:   550 Create directory operation failed.
Command:   MKD /New directory
Response:   550 Create directory operation failed.
Status:   Retrieving directory listing of "/New directory"...


Non capisco dove sbaglio!

pineout
Little John
Messaggi: 1264
Iscritto il: 10 luglio 2014, 9:08

Re: Problema impostazioni vsftpd.conf

Messaggio da pineout » 21 aprile 2015, 16:57

Sicuramente hai creato l'utente ftp con la sua home, se non ricordo male anonymous ha accesso solo a /home/ftp, prova cosi'.
Non so se la restrizione sia aggirabile.

Avatar utente
Astroarch
Novello Arciere
Messaggi: 72
Iscritto il: 28 marzo 2014, 13:42
Architettura: x86_64 (64bit)

Re: Problema impostazioni vsftpd.conf

Messaggio da Astroarch » 21 aprile 2015, 19:15

Hai ragione, sono entrato con il mio account principale, elencato nel file degli utenti autorizzati, e tutto va bene.
Adesso provvedo con un account virtuale. Ti ringrazio per l'aiuto, tengo il post aperto se dovessi avere ancora problemi nel breve tempo.

Rispondi