[Risolto] Impostazioni per server casalingo (aggiornamento)

Problemi e discussioni inerenti al networking, ai server, backup dati e alla sicurezza in generale
Rispondi
Avatar utente
TheSaint
Robin Hood
Messaggi: 7866
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

[Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da TheSaint » 7 giugno 2013, 3:27

Ciao,
tempo indietro avevo sistemato samba per il desktop di casa a farmi da server per depositare files e stampare.
Dopo qualche aggiornamento, mi trovo che non posso accedere al server.
Prima usavo security= share, ora lo danno per deprecato. Ho cambiato, ma la maggior parte dei casi va in timeout, tramite browser dei files (nautilus, PCmanFM, dolphin). Quando provo =>

Codice: Seleziona tutto

smbclient -L 192.168.1.2
Enter user's password: 
Anonymous login successful
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 4.0.6]

        Sharename       Type      Comment
        ---------       ----      -------
        DeskJet_1050    Printer   Home printer
        tmp             Disk      Volatile space
        public          Disk      Public
        IPC$            IPC       IPC Service (Samba Desktop)[
Anonymous login successful
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 4.0.6]

        Server               Comment
        ---------            -------
        DESKTOP              Samba Desktop

        Workgroup            Master
        ---------            -------
        WORKGROUP            DESKTOP
appare subito la richiesta di password, che non serve e vedo la lista del server. Di seguito se volessi aggiungere il listato di una cartella di share, comunque non appare e va in timeout.

Codice: Seleziona tutto

$ samba -V
Version 4.0.6
Ho guardato in rete per alcune impostazioni di smb.conf, ma in generale sono vecchie e non conta il fatto della security.
La mia smb.conf =
#======================= Global Settings =====================================
[global]
server string = Laptop Asus75
log file = /var/log/samba/%m.log
max log size = 50
idmap config * : backend = tdb
hosts allow = 192.168.1., 192.168.2., 127.

[homes]
comment = Home Directories
browseable = no
writable = yes

[tmp]
comment = Temporary file space
path = /tmp
read only = no
public = yes
La stranezza è che con android del mio smartphone riesco perfettamente accedere anche alla home, tramite total commander/plugin SMB. Se qualcuno vuol postare la sua smb.conf che funziona, ne sarei grato.
Approp.... Ho attivo anche miniDLNA.

EDIT
Ho letto questo thread e sembra la maggior causa. Intanto anche apportando le modifiche, non riesco ancora a vedere gli shares. Mentre con Android si fa subito.
Riassumendo samba 4 porta un maggior livello di sicurezza che forse per uso domestico non vale la pena aggiornare.

EDIT2
Alcune prove hanno dato risultato positivo, ma si tratta di operazioni da console. A me serve che in famiglia lo facciano in maniera il più semplice possibile. Quello di cliccare nel browser dei files è quello che mi aspetterei, purtroppo non ho ancora capito quale problema ci sia dietro a queste operazioni.
Purtroppo non posso adottare NFSv4 visto che ho anche 2 Android che potrebbero aver accesso alla stampante, una volta risolto.

EDIT3
Ora posso usare dolphin e trovare i files del server :mrgreen: :mrgreen:
Le modifiche
/etc/fuse.conf
user_allow_other
/etc/samba/smb.conf [solo la parte rilevante]
usershare path = /var/lib/samba/usershares # Vedere questo wiki
usershare max shares = 100
usershare allow guests = yes
usershare owner only = False

# lanman fix
client lanman auth = yes
client ntlmv2 auth = no
/etc/hosts

Codice: Seleziona tutto

#<ip-address>	<hostname.domain.org>	<hostname>
127.0.0.1	localhost.localdomain	localhost
::1		localhost.localdomain	localhost
# di seguito un esempio
#192.168.1.2	localhost.localdomain	desktop
# End of file
Bisognerà impostare il router che assegni l' IP fisso al server, se si una DHCP
Ho anche operato l' aggiunta delle passwords per gli utenti dal lato server e quello che dice questo wiki
PcmanFM non accetta il link smb:///, forse manca qualche plugin. Io l' ho solo provato dentro KDE.
Devo verificare per altri tipi di browsers e come si potrà usare la stampante

EDIT FINALE
  • Per PCmanFM serve gvfs-smb installato
  • Per la stampante ho sbagliato a mettere il nome in smb.conf.
  • Tal nome deve rispecchiare quello che si assegna nella configurazione di CUPS. Io non avevo capito quel passaggio e pensavo fosse il nome che appare da smbclient -L
Un fatto strano che da Android stampa comunque anche se il nome era sbagliato. Forse usa l' opzione raw che salta il caricamento del driver di CUPS.
Ultima modifica di TheSaint il 12 marzo 2014, 8:23, modificato 3 volte in totale.
F the saint
13 anni da questo forum ;)

Avatar utente
francesco_dem
Arciere
Messaggi: 234
Iscritto il: 17 maggio 2013, 17:05
Architettura: x86_64 (64bit)

Re: [Risolto] Impostazioni per server casalingo

Messaggio da francesco_dem » 12 luglio 2013, 14:27

Ciao TheSaint,
anch'io ho il problema del timeout
Queste le mie configurazioni:

Codice: Seleziona tutto

[francesco@francescopc ~]$ smbclient -L 192.168.0.3
Enter francesco's password: 
Domain=[MYGROUP] OS=[Unix] Server=[Samba 4.0.7]

	Sharename       Type      Comment
	---------       ----      -------
	IPC$            IPC       IPC Service (Samba Server)
	Epson Stylus SX235 Printer   Epson Stylus SX235
	public          Disk      public
	homes           Disk      Home Directories
	francesco       Disk      Home Directories
Domain=[MYGROUP] OS=[Unix] Server=[Samba 4.0.7]

	Server               Comment
	---------            -------
	FRANCESCOPC          Samba Server
	MACBOOK-40EB4B       MacBook di Maria 

	Workgroup            Master
	---------            -------
	MYGROUP              FRANCESCOPC

Codice: Seleziona tutto

# Samba config file created using SWAT
# from UNKNOWN (127.0.0.1)
# Date: 2013/07/12 13:43:00

[global]
        workgroup = MYGROUP
        server string = Samba Server
        map to guest = Bad User
        obey pam restrictions = Yes
        guest account = francesco
        username map = /etc/samba/smbusers
        log file = /var/log/samba/%m.log
        max log size = 50
        client max protocol = SMB2
        client min protocol = SMB2
        printcap name = /etc/printcap
        dns proxy = No
        idmap config * : range =
        idmap config * : backend = tdb
         invalid users = root
[homes]
        comment = Home Directories
        read only = No
        guest ok = Yes

[printers]
        comment = All Printers
        path = /var/spool/samba
         guest ok = Yes
        printable = Yes
        print ok = Yes
        use client driver = Yes
        browseable = No
[public]
        comment = public
        path = /home/francesco/public/
        read only = No
        guest ok = Yes

[Epson Stylus SX235]
        comment = Epson Stylus SX235
        path = /var/spool/samba
        guest ok = Yes
        printable = Yes
        print ok = Yes
        printer name = Epson Stylus SX235
        use client driver = Yes
ho aggiunto user_allow_other in /etc/fuse.conf

Codice: Seleziona tutto

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#
#mount_max = 1000

# Allow non-root users to specify the 'allow_other' or 'allow_root'
# mount options.
#
user_allow_other

Per quanto riguarda /etc/samba/smb.conf, hai suggerito di vedere questa parte del wiki:
https://wiki.archlinux.org/index.php/Sa ... share_path

se ho ben capito, devo seguire pari pari i passaggi e solo qui:
# usermod -a -G ${USERSHARES_GROUP} your_username, devo sostituire your_username con francesco

non mi sono chiare invece queste 3 righe:
# lanman fix
client lanman auth = yes
client ntlmv2 auth = no

per la stampante ti ho gia chiesto qui:
viewtopic.php?f=25&t=17631

Avatar utente
TheSaint
Robin Hood
Messaggi: 7866
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: [Risolto] Impostazioni per server casalingo

Messaggio da TheSaint » 12 luglio 2013, 17:44

Vedo una configurazione con molte opzione che non ti so dire. Partiamo con le condizioni che lavorano, poi si prova ad aggiungere e provar altre opzioni, una alla volta. di questo passo si riesce a capire quale opzione ritoccare.
Io ho una smb.conf

Codice: Seleziona tutto

[global]
        server role = STANDALONE
        server string = DESKTOP
        usershare path = /var/lib/samba/usershares
        usershare max shares = 100
        usershare allow guests = yes
        usershare owner only = False
        map to guest = Bad User
        log file = /var/log/samba/log.%U
        max log size = 50
        unix extensions = No
        socket options = IPTOS_LOWDELAY TCP_NODELAY SO_KEEPALIVE
        dns proxy = No
        idmap config * : backend = tdb
        guest ok = Yes
        hosts allow = 192.168.1.
        use sendfile = Yes
        write cache size = 2097152
        load printers = yes
;       printer admin = root, @ntadmins, @smbprintadm
        printcap = cups
        printcap name = cups

#============================ Printer Settings ==============================

[DeskJet_1050]
        comment = Home printer
        path = /var/spool/samba
        create mask = 0700
        printable = Yes
        printer name = Deskjet_1050
        lpq command = /usr/bin/lpq -P'%p'
        lprm command = lprm -P'%p' %j

#============================ Share Definitions ==============================
[homes]
        comment = Home Directories
        read only = No
        browseable = No

[tmp]
        comment = Volatile space
        path = /tmp
        read only = No
Poi ho aggiunto la password degli utenti che vogliono accedere alla propria /home =>> smbpasswd -a nomeutente, con la password uguale che si usa per accedere direttamente dalla macchina server.
Il client che accede al server dovrebbe aver un file /etc/samba/smb.conf anche posticcio. In questo modo non genera errori, basta anche un

Codice: Seleziona tutto

touch /etc/samba/smb.conf
Non ti resta che provare con questo stile, poi vedi cosa ti serve modificare.
francesco_dem ha scritto:

Codice: Seleziona tutto

# usermod -a -G ${USERSHARES_GROUP} your_username, devo sostituire your_username con francesco
Credo che sia quello, son io che non ricordo bene. Aspetta...

Codice: Seleziona tutto

$ groups
lp optical scanner users myself sambashare
. Questo e' scritto sul server e son entrato col mio account normale.

Un particolare, la cartella condivisa deve avere i permessi giusti fino la livello più alto. Quindi quelle fatte in /home non dovrebbero dare problemi (ma questo rientra nella possibilità di accedere con il proprio login). Non so se altri utenti possono avere tali permessi.
Al mio scopo uso partizioni in NTFS ed i permessi non sono più controllabili. Volendo condividere sotto una cartella di linux, io son riuscito solo a dare /tmp, per altri percorsi bisogna sperimentare.
F the saint
13 anni da questo forum ;)

Avatar utente
francesco_dem
Arciere
Messaggi: 234
Iscritto il: 17 maggio 2013, 17:05
Architettura: x86_64 (64bit)

Re: [Risolto] Impostazioni per server casalingo

Messaggio da francesco_dem » 12 luglio 2013, 21:50

la configurazione lavora, nel senso che posso accedere da altro pc alle cartelle condivise di arch.
il fatto strano invece e che se vado in thunar/esplora la rete/rete windows/mygroup(che è il nome della mia condivisione) ricevo il seguente messaggio di errore:
Recupero dell'elenco delle condivisioni dal server non riuscito: Connessione scaduta
e se do smbclient -L francescopc -U%

Codice: Seleziona tutto

Connection to francescopc failed (Error NT_STATUS_IO_TIMEOUT)
comunque appena tornerò dalle vacanze :D :D :D , seguirò le tue indicazioni e ti saprò dire.
grazie intanto delle risposte

Avatar utente
TheSaint
Robin Hood
Messaggi: 7866
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: [Risolto] Impostazioni per server casalingo

Messaggio da TheSaint » 13 luglio 2013, 9:44

Hai provato ha dare smb://192.168.0.3/cartella_condivisa e se la vede?
Da thunar, di preciso non so. So che thunar/pcmanfm usano gvfs-smb. l' accesso quindi si fa con smb://francescopc/cartella_condivisa
In altre parole se cerchi per nome devi dire al (od ai) computer(s) che quell' IP ha quel nome. E questo vale per tutti i clients che lo cercano.
Quindi il francescopc deve avere un IP in /etc/hosts. Per esempio
192.168.0.3 localhost.localdomain francescopc
Ammesso che 192.168.0.3 sia il server.

E buone vacanze
F the saint
13 anni da questo forum ;)

Avatar utente
francesco_dem
Arciere
Messaggi: 234
Iscritto il: 17 maggio 2013, 17:05
Architettura: x86_64 (64bit)

Re: [Risolto] Impostazioni per server casalingo

Messaggio da francesco_dem » 13 luglio 2013, 11:52

si, in effetti per accedere al macbook da arch utilizzavo smb://192.168.0.4.
Nn ci avevo pensato di dare smb://192.168.0.3 dal server stesso per poter vedere le cartelle condivise.
quello che invece non riesco ad aprire è la cartella mygroup in "esplora rete/rete windows/MYGROUP ".
diciamo che con questo sistema ho risolto in parte e mi va bene.
grazie di tutto.
per la stampante sull'altro topic, controllerò al rientro dalle vcanze. :mrgreen: :mrgreen:
ciaooooo

Avatar utente
TheSaint
Robin Hood
Messaggi: 7866
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: [Risolto] Impostazioni per server casalingo

Messaggio da TheSaint » 14 luglio 2013, 9:56

La risposta te la lascio ora, in Iran non so se potrò accedere al forum. Si vedrà quando sarò la.
Non capisco "esplora rete/rete windows/MYGROUP ". Che sia da windows o da linux, i problemi sono entrambe dalla dichiarazione in hosts, che contiene la conversione dell' IP in un nome di comodo.
Il file hosts in linux lo troviamo in /etc e c'è in windows nella cartella windows o sotto. [dipende dalla versione (piccola ricerca Win+F), c'è anche l' equivalente lmhost.sam, non so quale abbia la precedenza].
Non avendo delle certezze, direi:
  • Se MYGROUP non e' il gruppo del client, sarà facile che fallisce.
  • Di solito la ricerca e' solo nel gruppo di appartenenza o magari quello che compare nella lista di hosts, suppongo.
  • Non credo che gvfs faccia lo scandaglio di tutta la rete locale per trovare altri gruppi.
  • Con nautilus, non mi riesce esplorare cliccando col mouse, bisogna che do CTRL+L e scrivo l' indirizzo nella barra dei medesimi. Potrebbe esser un difetto e continua a cercare in NFS, non CIFS
Per esplorare le proprie cartelle condivise, si può fare come suddetto (con l' IP) oppure smb://localhost . Il discorso segue la logica della conversione in nome di comodo in hosts.
Magari può servire uno strumento come SWAT
F the saint
13 anni da questo forum ;)

Avatar utente
francesco_dem
Arciere
Messaggi: 234
Iscritto il: 17 maggio 2013, 17:05
Architettura: x86_64 (64bit)

Re: [Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da francesco_dem » 7 agosto 2013, 10:57

Ciao iraniano :-) ; ti faccio il punto:
Ho aggiunto in hosts 192.168.0.3 localhost.localdomain francescopc
192.168.0.4 localhost.localdomain macbook
adesso accedo in esplora rete/rete windows/MYGROUP/francescopc :-))
non è lo stesso per rete/rete windows/MYGROUP/macbook, credo sia dovuto a problemi di permessi; infatto se do smb:// 192.168.0.4 si apre una schermata di accesso dove inserendo le credenziali, acceddo poi alle cartelle condivise del macbook.
dovrei quindi aggiungere la password degli utenti che vogliono accedere alla propria /home =>> smbpasswd -a nomeutente(utente macbook), con la password uguale che si usa per accedere direttamente dalla macchina server??
e poi dare
# usermod -a -G ${USERSHARES_GROUP} your_username, devo sostituire your_username con l'amministratore del macbook ??

Avatar utente
TheSaint
Robin Hood
Messaggi: 7866
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: [Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da TheSaint » 7 agosto 2013, 17:43

Per le password ho usato quelle che si usa come utente normale per accedere alla propria /home.
La diversità che io ho, è che ho solo linux nella rete. Qualche volta Android del mio smartphone. Non ho provato con Win.
Forse col macbook potrebbe essere un problema di permessi, della cartella superiore.
Io accedo al desktop (il server) semplicemente con smb://desktop. Non capisco perché appare anche il MYGROUP nel percorso
Non ho altre risorse visto che il desktop è a casa ed io no, faccio fatica a verificare tutte le condizioni.
F the saint
13 anni da questo forum ;)

Avatar utente
francesco_dem
Arciere
Messaggi: 234
Iscritto il: 17 maggio 2013, 17:05
Architettura: x86_64 (64bit)

Re: [Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da francesco_dem » 16 agosto 2013, 20:35

Ciao thesaint, non mi spiego perchè, ma in esplora rete trovo i PC host (senza passare per mygroup) ed accedo quindi alle cartelle condivise senza l'uilizzo del percorso smb//192.168.0.*.
Ottimo direi :D :D :D
posso dire che ho risolto anche questo.
In samba non ho modificato alcunchè, suppongo sia dovuto o all' aggiornamento di samba o all'avvio del demone avahi, come ti dicevo qui viewtopic.php?f=25&t=17631
Grazie per le tue risposte e disponibilità, sebbene tu fossi nell'antica Persia

Avatar utente
TheSaint
Robin Hood
Messaggi: 7866
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: [Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da TheSaint » 17 agosto 2013, 14:45

Se hai messo i nomi in /etc/hosts, i numeri vengono convertiti.
Perpocosiano :D :D Spero che la prossima la scrivo da casa :P
EDIT
Ora scrivo dal server e confermo di aver avahi-deamon attivato

Codice: Seleziona tutto

#sytemctl status avahi-daemon
avahi-daemon.service - Avahi mDNS/DNS-SD Stack
   Loaded: loaded (/usr/lib/systemd/system/avahi-daemon.service; enabled)
   Active: active (running) since mar 2013-07-16 14:28:33 MYT; 1 months 4 days ago
 Main PID: 235 (avahi-daemon)
   Status: "Server startup complete. Host name is Desktop.local. Local service cookie is 2814149465."
   CGroup: name=systemd:/system/avahi-daemon.service
           ├─235 avahi-daemon: running [Desktop.local]
           └─261 avahi-daemon: chroot helper
F the saint
13 anni da questo forum ;)

Avatar utente
francesco_dem
Arciere
Messaggi: 234
Iscritto il: 17 maggio 2013, 17:05
Architettura: x86_64 (64bit)

Re: [Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da francesco_dem » 29 ottobre 2013, 21:06

Sono costretto a riesumare il post.
Dopo l'aggiornamento di samba alla versione 4.1.0 noto con dispiacere che la rete ha smesso di funzionare in parte.
Riesco da altri pc ad accedere ad Arch, ma non a fare il contrario.
In particolare faccio rilevare che con il comando smbclient -L 192.168.0.3 ci sono alcune differenze nei risultati

Codice: Seleziona tutto

[francesco@francescopc ~]$ smbclient -L 192.168.0.3
Enter francesco's password: 
Domain=[FRANCESCOPC] OS=[] Server=[]

	Sharename       Type      Comment
	---------       ----      -------
	homes           Disk      Home Directories
	public          Disk      public
	Epson_Stylus_SX235 Printer   Epson_Stylus_SX235
	IPC$            IPC       IPC Service (Samba Server)
	francesco       Disk      Home Directories
Domain=[FRANCESCOPC] OS=[] Server=[]

	Server               Comment
	---------            -------

	Workgroup            Master
	---------            -------
Notate che in OS e Server, nella parentesi quadre, non c'è scritto nulla, mentre con la vecchia versione di samba appariva cosi:
Domain=[MYGROUP] OS=[Unix] Server=[Samba 4.0.7]
La configurazione del file smb.conf è la stessa postata in precedenza

Codice: Seleziona tutto

# Samba config file created using SWAT
# from UNKNOWN (127.0.0.1)
# Date: 2013/08/07 11:18:07

[global]
        workgroup = MYGROUP
        server string = Samba Server
        map to guest = Bad User
        obey pam restrictions = Yes
        guest account = francesco
        username map = /etc/samba/smbusers
        log file = /var/log/samba/%m.log
        max log size = 50
        client max protocol = SMB2
        client min protocol = SMB2
        printcap name = /etc/printcap
        dns proxy = No
        idmap config * : range =
        idmap config * : backend = tdb
        username map = /etc/samba/smbusers
        log file = /var/log/samba/%m.log
        max log size = 50
        client max protocol = SMB2
        client min protocol = SMB2
        printcap name = /etc/printcap
        dns proxy = No
        idmap config * : range =
        idmap config * : backend = tdb
        invalid users = root

[homes]
        comment = Home Directories
        path = /home/francesco/
        read only = No
        guest ok = Yes

[printers]
        comment = All Printers
        path = /var/spool/samba
        browseable = yes
        # to allow user 'guest account' to print.
        guest ok = Yes
        writable = no
        printable = Yes
        create mode = 0700
        use client driver = Yes
        write list = @adm root francesco mariacalabria
[/quote]
Questo il file hosts
[quote]#
# /etc/hosts: static lookup table for host names
#

#<ip-address>   <hostname.domain.org>   <hostname>
127.0.0.1       localhost.localdomain   localhost
::1             localhost.localdomain   localhost
205.204.88.154 kat.ph
66.90.101.200 kastatic.com
205.204.88.154 kickasstorrents.com
130.185.105.68 torcache.net
178.73.210.219 thepiratebay.org
178.73.210.219 www.thepiratebay.org
178.73.210.219 thepiratebay.se
178.73.210.219 www.thepiratebay.se
192.168.0.3 localhost.localdomain francescopc
192.168.0.4 localhost.localdomain mariacalabria
# End of file

Dove appunto avevo aggiunto i domini dei pc accedendo direttamente da thunar (esplora rete)

Infine non mi funziona più swat

Avatar utente
TheSaint
Robin Hood
Messaggi: 7866
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: [Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da TheSaint » 30 ottobre 2013, 17:28

è un po che non traffico col desktop. L' ultimo aggiornamento non ho verificato se c' eran problemi.
Dovrai leggerti il change.log per vedere cosa hanno portato i cambiamenti. Magari esiste un smb.conf.example con i commenti per usare come guida,
Fino a Natale non son a casa, mi dispiace ma non son di molto aiuto. Il server è a casa.
F the saint
13 anni da questo forum ;)

Avatar utente
francesco_dem
Arciere
Messaggi: 234
Iscritto il: 17 maggio 2013, 17:05
Architettura: x86_64 (64bit)

Re: [Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da francesco_dem » 31 ottobre 2013, 20:14

Ma figurati!grazie per l'interessamento, proverò intanto a leggere quanto mi consigli.
Buon rientro a casa (anche se manca ancora un po' di tempo).


Questo il messaggio di errore accedendo da thunar:

Codice: Seleziona tutto

Recupero dell'elenco delle condivisioni dal server non riuscito: Connessione scaduta.

Avatar utente
francesco_dem
Arciere
Messaggi: 234
Iscritto il: 17 maggio 2013, 17:05
Architettura: x86_64 (64bit)

Re: [Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da francesco_dem » 17 novembre 2013, 14:33

dopo l'ulteriore aggiornamento di samba alla versione 4.1.1,
ho modificato il file smb.conf:

Codice: Seleziona tutto

[global]
        workgroup = MYGROUP
        server string = Samba Server
        map to guest = Bad User
        log file = /var/log/samba/%m.log
        max log size = 50
        dns proxy = no
        create mask = 0664
        directory mask = 0775
        force create mode = 0664
        force directory mode = 0775
        usershare path = /var/lib/samba/usershares
        usershare max shares = 100
        usershare allow guests = yes
           guest ok = Yes
        guest account = francesco

[public]
        comment = public
        path = /home/francesco/public/
        read only = No
        guest ok = Yes
posto: smbclient -L 192.168.0.3

Codice: Seleziona tutto

Domain=[MYGROUP] OS=[Unix] Server=[Samba 4.1.1]

	Sharename       Type      Comment
	---------       ----      -------
	homes           Disk      Home Directories
	public          Disk      public
	Epson_Stylus_SX235 Printer   Epson_Stylus_SX235
	IPC$            IPC       IPC Service (Samba Server)
	francesco       Disk      Home Directories
Domain=[MYGROUP] OS=[Unix] Server=[Samba 4.1.1]

	Server               Comment
	---------            -------
	FRANCESCOPC          Samba Server
	MACBOOK-40EB4B       MacBook di Maria 

	Workgroup            Master
	---------            -------
	MYGROUP              FRANCESCOPC
la condivisione è tornata a funzionare!! :) :)
saluti a thesaint :wink:

Avatar utente
TheSaint
Robin Hood
Messaggi: 7866
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: [Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da TheSaint » 21 dicembre 2013, 6:20

Francesco sono a casa!!
Scrivo per aggiornare una cosa.
Nel caso si avesse a che fare con una doppia rete, bisogna impostare gli IP a mano per i computer collegati.
ESEMPIO
Notebook = ifconfig 192.168.0.2 netmask 255.255.255.0 eth0 #notare la specifica del dispositivo dal comando ifconfig, prima
Desktop = ifconfig 192.168.0.3 netmask 255.255.255.0 eth0 #notare la specifica del dispositivo dal comando ifconfig, prima

Assunto che il server samba si trova sul desktop si puo' verificare con un ping -c4 192.168.0.3. Anche con smbclient -L 192.168.0.3
A questo punto se il lavoro non e' permanente si puo' vedere gli shares sotto smb:/192.168.0.3/nome_share.
In caso di una configurazione permanente si dovra' modificare /etc/hosts del client(s).
Se avete bloccato gli accessi ad un livello del tipo hosts allow = 192.168. ricordarsi di modificarlo
Intanto il desktop ha samba versione 4.1.0-1 ed il Notebook versione 4.1.3-1 e sto scaricando 40 Gb :P
F the saint
13 anni da questo forum ;)

Avatar utente
francesco_dem
Arciere
Messaggi: 234
Iscritto il: 17 maggio 2013, 17:05
Architettura: x86_64 (64bit)

Re: [Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da francesco_dem » 30 dicembre 2013, 11:32

TheSaint ha scritto:Francesco sono a casa!!
Scrivo per aggiornare una cosa.
Bentornato e buone feste!!! :D :D :D


Gli IP li avevo già impostati come statici in entrambi i computers dal network manager

Avatar utente
TheSaint
Robin Hood
Messaggi: 7866
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: [Risolto] Impostazioni per server casalingo (aggiornamento)

Messaggio da TheSaint » 31 dicembre 2013, 7:39

;) ;)
Si ma la storia continua, al 5 Gennaio si riparte :P
Un altro punto che forse non ho evidenziato, riguarda il fatto che d' uso corrente il traffico passa dal router di casa via etere.
In questo caso ho collegato con un cavetto CAT5-cross (magari non serve e le NIC si auto-configurano) e trasferito un volume elevato a velocità 40 volte superiore.
F the saint
13 anni da questo forum ;)

Rispondi