Nvidia - Regolazione Luminosità

Problemi e discussioni inerenti ai PC portatili e ai loro accessori
Rispondi
Avatar utente
Odak
Novello Arciere
Messaggi: 101
Iscritto il: 20 febbraio 2008, 12:52
Architettura: x86_64 (64bit)
Località: Caserta

Nvidia - Regolazione Luminosità

Messaggio da Odak » 29 dicembre 2017, 16:58

Ciao a tutti,
ho dovuto reinstallare la distro sul nuovo hd ssd. Il portatile monta una GPU Nvidia 410M ed ho installato come prima i driver proprietari. Purtroppo non riesco più a far funzionare i tasti Fn per la regolazione della luminosità. Plasma mostra la sovrimpressione corretta ma la luminosità non varia. Da riga di comando, xbacklight -dec 20 non produce risultati.
Ho provato a variare acpi_backlight con valori video e none ma non compaiono più le sovrimpressioni di Plasma.
Allego un po' di info.

etc/default/grub

Codice: Seleziona tutto

GRUB_CMDLINE_LINUX_DEFAULT="quiet nvidia-drm.modeset=1"
Moduli /etc/mkinitcpio.conf

Codice: Seleziona tutto

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)
xorg.conf

Codice: Seleziona tutto

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Xorg.0.log

Codice: Seleziona tutto

[   367.655] (--) Log file renamed from "/var/log/Xorg.pid-1251.log" to "/var/log/Xorg.0.log"
[   367.655] 
X.Org X Server 1.19.6
Release Date: 2017-12-20
[   367.655] X Protocol Version 11, Revision 0
[   367.655] Build Operating System: Linux 4.9.71-1-lts x86_64 
[   367.655] Current Operating System: Linux ippotux 4.14.8-1-ARCH #1 SMP PREEMPT Wed Dec 20 21:27:44 UTC 2017 x86_64
[   367.655] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=9a479819-56c3-4867-82d2-b1a111998684 rw quiet nvidia-drm.modeset=1
[   367.655] Build Date: 25 December 2017  02:02:38PM
[   367.655]  
[   367.655] Current version of pixman: 0.34.0
[   367.655]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   367.655] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   367.655] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Dec 29 16:42:46 2017
[   367.655] (==) Using config file: "/etc/X11/xorg.conf"
[   367.655] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   367.655] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   367.656] (==) ServerLayout "Layout0"
[   367.656] (**) |-->Screen "Screen0" (0)
[   367.656] (**) |   |-->Monitor "Monitor0"
[   367.656] (**) |   |-->Device "Device0"
[   367.656] (**) |-->Input Device "Keyboard0"
[   367.656] (**) |-->Input Device "Mouse0"
[   367.656] (==) Automatically adding devices
[   367.656] (==) Automatically enabling devices
[   367.656] (==) Automatically adding GPU devices
[   367.656] (==) Automatically binding GPU devices
[   367.656] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   367.656] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   367.656]    Entry deleted from font path.
[   367.656] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/share/fonts/OTF/,
        /usr/share/fonts/100dpi/,
        /usr/share/fonts/75dpi/
[   367.656] (==) ModulePath set to "/usr/lib/xorg/modules"
[   367.656] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   367.656] (WW) Disabling Keyboard0
[   367.656] (WW) Disabling Mouse0
[   367.656] (II) Loader magic: 0x555c58780d60
[   367.656] (II) Module ABI versions:
[   367.656]    X.Org ANSI C Emulation: 0.4
[   367.656]    X.Org Video Driver: 23.0
[   367.656]    X.Org XInput driver : 24.1
[   367.656]    X.Org Server Extension : 10.0
[   367.656] (++) using VT number 1

[   367.656] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   367.657] (II) xfree86: Adding drm device (/dev/dri/card0)
[   368.919] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules"
[   368.919] (**) OutputClass "nvidia" setting /dev/dri/card0 as PrimaryGPU
[   368.919] (--) PCI:*(0:1:0:0) 10de:1055:104d:908b rev 161, Mem @ 0xd2000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/131072
[   368.919] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   368.919] (II) LoadModule: "glx"
[   368.919] (II) Loading /usr/lib/nvidia/xorg/libglx.so
[   368.922] (II) Module glx: vendor="NVIDIA Corporation"
[   368.922]    compiled for 4.0.2, module version = 1.0.0
[   368.922]    Module class: X.Org Server Extension
[   368.922] (II) NVIDIA GLX Module  387.34  Tue Nov 21 02:04:31 PST 2017
[   368.922] (II) LoadModule: "nvidia"
[   368.923] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   368.923] (II) Module nvidia: vendor="NVIDIA Corporation"
[   368.923]    compiled for 4.0.2, module version = 1.0.0
[   368.923]    Module class: X.Org Video Driver
[   368.923] (II) NVIDIA dlloader X Driver  387.34  Tue Nov 21 01:38:22 PST 2017
[   368.923] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   368.923] (II) Loading sub module "fb"
[   368.923] (II) LoadModule: "fb"
[   368.923] (II) Loading /usr/lib/xorg/modules/libfb.so
[   368.923] (II) Module fb: vendor="X.Org Foundation"
[   368.923]    compiled for 1.19.6, module version = 1.0.0
[   368.923]    ABI class: X.Org ANSI C Emulation, version 0.4
[   368.923] (II) Loading sub module "wfb"
[   368.923] (II) LoadModule: "wfb"
[   368.923] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   368.923] (II) Module wfb: vendor="X.Org Foundation"
[   368.923]    compiled for 1.19.6, module version = 1.0.0
[   368.923]    ABI class: X.Org ANSI C Emulation, version 0.4
[   368.923] (II) Loading sub module "ramdac"
[   368.923] (II) LoadModule: "ramdac"
[   368.923] (II) Module "ramdac" already built-in
[   368.924] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[   368.924] (==) NVIDIA(0): RGB weight 888
[   368.924] (==) NVIDIA(0): Default visual is TrueColor
[   368.924] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   368.924] (II) Applying OutputClass "nvidia" options to /dev/dri/card0
[   368.924] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[   368.924] (**) NVIDIA(0): Option "RegistryDwords" "EnableBrightnessControl=1"
[   368.924] (**) NVIDIA(0): Enabling 2D acceleration
[   368.926] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[   368.926] (--) NVIDIA(0):     CRT-0
[   368.926] (--) NVIDIA(0):     DFP-0 (boot)
[   368.926] (--) NVIDIA(0):     DFP-1
[   368.927] (II) NVIDIA(0): NVIDIA GPU GeForce 410M (GF119) at PCI:1:0:0 (GPU-0)
[   368.927] (--) NVIDIA(0): Memory: 1048576 kBytes
[   368.927] (--) NVIDIA(0): VideoBIOS: 75.19.0c.00.03
[   368.927] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   368.928] (--) NVIDIA(GPU-0): CRT-0: disconnected
[   368.928] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[   368.928] (--) NVIDIA(GPU-0): 
[   368.929] (--) NVIDIA(GPU-0): cPATH (DFP-0): connected
[   368.929] (--) NVIDIA(GPU-0): cPATH (DFP-0): Internal LVDS
[   368.929] (--) NVIDIA(GPU-0): cPATH (DFP-0): 330.0 MHz maximum pixel clock
[   368.929] (--) NVIDIA(GPU-0): 
[   368.929] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   368.929] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[   368.929] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[   368.929] (--) NVIDIA(GPU-0): 
[   368.929] (==) NVIDIA(0): 
[   368.929] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[   368.929] (==) NVIDIA(0):     will be used as the requested mode.
[   368.929] (==) NVIDIA(0): 
[   368.930] (II) NVIDIA(0): Validated MetaModes:
[   368.930] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[   368.930] (II) NVIDIA(0): Virtual screen size determined to be 1366 x 768
[   368.932] (--) NVIDIA(0): DPI set to (102, 102); computed from "UseEdidDpi" X config
[   368.932] (--) NVIDIA(0):     option
[   368.932] (--) Depth 24 pixmap format is 32 bpp
[   368.932] (II) NVIDIA: Using 6144.00 MB of virtual memory for indirect memory
[   368.932] (II) NVIDIA:     access.
[   368.944] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[   368.944] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[   368.944] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[   368.944] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[   368.944] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[   368.944] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[   368.944] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[   368.944] (II) NVIDIA(0):     Config Options in the README.
[   368.953] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[   370.011] (==) NVIDIA(0): Disabling shared memory pixmaps
[   370.011] (==) NVIDIA(0): Backing store enabled
[   370.011] (==) NVIDIA(0): Silken mouse enabled
[   370.011] (**) NVIDIA(0): DPMS enabled
[   370.011] (WW) NVIDIA(0): Option "PrimaryGPU" is not used
[   370.011] (II) Loading sub module "dri2"
[   370.011] (II) LoadModule: "dri2"
[   370.011] (II) Module "dri2" already built-in
[   370.011] (II) NVIDIA(0): [DRI2] Setup complete
[   370.011] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   370.011] (--) RandR disabled
[   370.014] (II) Initializing extension GLX
[   370.014] (II) Indirect GLX disabled.
[   370.095] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[   370.095] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[   370.095] (**) Power Button: Applying InputClass "system-keyboard"
[   370.095] (II) LoadModule: "libinput"
[   370.095] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   370.096] (II) Module libinput: vendor="X.Org Foundation"
[   370.096]    compiled for 1.19.3, module version = 0.26.0
[   370.096]    Module class: X.Org XInput Driver
[   370.096]    ABI class: X.Org XInput driver, version 24.1
[   370.096] (II) Using input driver 'libinput' for 'Power Button'
[   370.096] (**) Power Button: always reports core events
[   370.096] (**) Option "Device" "/dev/input/event3"
[   370.096] (**) Option "_source" "server/udev"
[   370.096] (II) event3  - (II) Power Button: (II) is tagged by udev as: Keyboard
[   370.096] (II) event3  - (II) Power Button: (II) device is a keyboard
[   370.096] (II) event3  - (II) Power Button: (II) device removed
[   370.123] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input4/event3"
[   370.123] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[   370.123] (**) Option "xkb_layout" "it"
[   370.151] (II) event3  - (II) Power Button: (II) is tagged by udev as: Keyboard
[   370.151] (II) event3  - (II) Power Button: (II) device is a keyboard
[   370.152] (II) config/udev: Adding input device Sony Vaio Keys (/dev/input/event5)
[   370.152] (**) Sony Vaio Keys: Applying InputClass "libinput keyboard catchall"
[   370.152] (**) Sony Vaio Keys: Applying InputClass "system-keyboard"
[   370.152] (II) Using input driver 'libinput' for 'Sony Vaio Keys'
[   370.152] (**) Sony Vaio Keys: always reports core events
[   370.152] (**) Option "Device" "/dev/input/event5"
[   370.152] (**) Option "_source" "server/udev"
[   370.152] (II) event5  - (II) Sony Vaio Keys: (II) is tagged by udev as: Keyboard Joystick
[   370.152] (II) event5  - (II) Sony Vaio Keys: (II) device is a keyboard
[   370.152] (II) event5  - (II) Sony Vaio Keys: (II) device removed
[   370.173] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:01/SNY5001:00/input/input6/event5"
[   370.173] (II) XINPUT: Adding extended input device "Sony Vaio Keys" (type: KEYBOARD, id 7)
[   370.173] (**) Option "xkb_layout" "it"
[   370.175] (II) event5  - (II) Sony Vaio Keys: (II) is tagged by udev as: Keyboard Joystick
[   370.175] (II) event5  - (II) Sony Vaio Keys: (II) device is a keyboard
[   370.176] (II) config/udev: Adding input device Sony Vaio Jogdial (/dev/input/event6)
[   370.176] (**) Sony Vaio Jogdial: Applying InputClass "libinput pointer catchall"
[   370.176] (II) Using input driver 'libinput' for 'Sony Vaio Jogdial'
[   370.176] (**) Sony Vaio Jogdial: always reports core events
[   370.176] (**) Option "Device" "/dev/input/event6"
[   370.176] (**) Option "_source" "server/udev"
[   370.177] (II) event6  - (II) Sony Vaio Jogdial: (II) is tagged by udev as: Mouse
[   370.177] (II) event6  - (II) Sony Vaio Jogdial: (II) device is a pointer
[   370.177] (II) event6  - (II) Sony Vaio Jogdial: (II) device removed
[   370.223] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:01/SNY5001:00/input/input7/event6"
[   370.223] (II) XINPUT: Adding extended input device "Sony Vaio Jogdial" (type: MOUSE, id 8)
[   370.223] (**) Option "AccelerationScheme" "none"
[   370.223] (**) Sony Vaio Jogdial: (accel) selected scheme none/0
[   370.223] (**) Sony Vaio Jogdial: (accel) acceleration factor: 2.000
[   370.223] (**) Sony Vaio Jogdial: (accel) acceleration threshold: 4
[   370.224] (II) event6  - (II) Sony Vaio Jogdial: (II) is tagged by udev as: Mouse
[   370.224] (II) event6  - (II) Sony Vaio Jogdial: (II) device is a pointer
[   370.225] (II) config/udev: Adding input device Sony Vaio Jogdial (/dev/input/mouse0)
[   370.225] (II) No input driver specified, ignoring this device.
[   370.225] (II) This device may have been added with another device file.
[   370.226] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[   370.226] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[   370.226] (**) Video Bus: Applying InputClass "system-keyboard"
[   370.226] (II) Using input driver 'libinput' for 'Video Bus'
[   370.226] (**) Video Bus: always reports core events
[   370.226] (**) Option "Device" "/dev/input/event4"
[   370.226] (**) Option "_source" "server/udev"
[   370.227] (II) event4  - (II) Video Bus: (II) is tagged by udev as: Keyboard
[   370.227] (II) event4  - (II) Video Bus: (II) device is a keyboard
[   370.227] (II) event4  - (II) Video Bus: (II) device removed
[   370.273] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:20/LNXVIDEO:00/input/input5/event4"
[   370.273] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 9)
[   370.273] (**) Option "xkb_layout" "it"
[   370.275] (II) event4  - (II) Video Bus: (II) is tagged by udev as: Keyboard
[   370.275] (II) event4  - (II) Video Bus: (II) device is a keyboard
[   370.275] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[   370.275] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[   370.275] (**) Power Button: Applying InputClass "system-keyboard"
[   370.275] (II) Using input driver 'libinput' for 'Power Button'
[   370.276] (**) Power Button: always reports core events
[   370.276] (**) Option "Device" "/dev/input/event1"
[   370.276] (**) Option "_source" "server/udev"
[   370.276] (II) event1  - (II) Power Button: (II) is tagged by udev as: Keyboard
[   370.276] (II) event1  - (II) Power Button: (II) device is a keyboard
[   370.276] (II) event1  - (II) Power Button: (II) device removed
[   370.303] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input2/event1"
[   370.303] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 10)
[   370.303] (**) Option "xkb_layout" "it"
[   370.305] (II) event1  - (II) Power Button: (II) is tagged by udev as: Keyboard
[   370.305] (II) event1  - (II) Power Button: (II) device is a keyboard
[   370.305] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[   370.305] (II) No input driver specified, ignoring this device.
[   370.305] (II) This device may have been added with another device file.
[   370.307] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event13)
[   370.307] (II) No input driver specified, ignoring this device.
[   370.307] (II) This device may have been added with another device file.
[   370.308] (II) config/udev: Adding input device Sony Visual Communication Camer (/dev/input/event12)
[   370.308] (**) Sony Visual Communication Camer: Applying InputClass "libinput keyboard catchall"
[   370.308] (**) Sony Visual Communication Camer: Applying InputClass "system-keyboard"
[   370.308] (II) Using input driver 'libinput' for 'Sony Visual Communication Camer'
[   370.308] (**) Sony Visual Communication Camer: always reports core events
[   370.308] (**) Option "Device" "/dev/input/event12"
[   370.308] (**) Option "_source" "server/udev"
[   370.309] (II) event12 - (II) Sony Visual Communication Camer: (II) is tagged by udev as: Keyboard
[   370.309] (II) event12 - (II) Sony Visual Communication Camer: (II) device is a keyboard
[   370.309] (II) event12 - (II) Sony Visual Communication Camer: (II) device removed
[   370.353] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/input/input14/event12"
[   370.353] (II) XINPUT: Adding extended input device "Sony Visual Communication Camer" (type: KEYBOARD, id 11)
[   370.353] (**) Option "xkb_layout" "it"
[   370.355] (II) event12 - (II) Sony Visual Communication Camer: (II) is tagged by udev as: Keyboard
[   370.355] (II) event12 - (II) Sony Visual Communication Camer: (II) device is a keyboard
[   370.356] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event9)
[   370.356] (II) No input driver specified, ignoring this device.
[   370.356] (II) This device may have been added with another device file.
[   370.356] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event7)
[   370.356] (II) No input driver specified, ignoring this device.
[   370.356] (II) This device may have been added with another device file.
[   370.357] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event8)
[   370.357] (II) No input driver specified, ignoring this device.
[   370.357] (II) This device may have been added with another device file.
[   370.358] (II) config/udev: Adding input device Logitech USB Laser Mouse (/dev/input/event11)
[   370.358] (**) Logitech USB Laser Mouse: Applying InputClass "libinput pointer catchall"
[   370.358] (II) Using input driver 'libinput' for 'Logitech USB Laser Mouse'
[   370.358] (**) Logitech USB Laser Mouse: always reports core events
[   370.358] (**) Option "Device" "/dev/input/event11"
[   370.358] (**) Option "_source" "server/udev"
[   370.414] (II) event11 - (II) Logitech USB Laser Mouse: (II) is tagged by udev as: Mouse
[   370.414] (II) event11 - (II) Logitech USB Laser Mouse: (II) device set to 1200 DPI
[   370.414] (II) event11 - (II) Logitech USB Laser Mouse: (II) device is a pointer
[   370.414] (II) event11 - (II) Logitech USB Laser Mouse: (II) device removed
[   370.450] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3/2-1.3:1.0/0003:046D:C062.0001/input/input13/event11"
[   370.450] (II) XINPUT: Adding extended input device "Logitech USB Laser Mouse" (type: MOUSE, id 12)
[   370.450] (**) Option "AccelerationScheme" "none"
[   370.450] (**) Logitech USB Laser Mouse: (accel) selected scheme none/0
[   370.450] (**) Logitech USB Laser Mouse: (accel) acceleration factor: 2.000
[   370.450] (**) Logitech USB Laser Mouse: (accel) acceleration threshold: 4
[   370.507] (II) event11 - (II) Logitech USB Laser Mouse: (II) is tagged by udev as: Mouse
[   370.507] (II) event11 - (II) Logitech USB Laser Mouse: (II) device set to 1200 DPI
[   370.507] (II) event11 - (II) Logitech USB Laser Mouse: (II) device is a pointer
[   370.508] (II) config/udev: Adding input device Logitech USB Laser Mouse (/dev/input/mouse1)
[   370.508] (II) No input driver specified, ignoring this device.
[   370.508] (II) This device may have been added with another device file.
[   370.509] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[   370.509] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[   370.509] (**) AT Translated Set 2 keyboard: Applying InputClass "system-keyboard"
[   370.509] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[   370.509] (**) AT Translated Set 2 keyboard: always reports core events
[   370.509] (**) Option "Device" "/dev/input/event0"
[   370.509] (**) Option "_source" "server/udev"
[   370.510] (II) event0  - (II) AT Translated Set 2 keyboard: (II) is tagged by udev as: Keyboard
[   370.510] (II) event0  - (II) AT Translated Set 2 keyboard: (II) device is a keyboard
[   370.510] (II) event0  - (II) AT Translated Set 2 keyboard: (II) device removed
[   370.533] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[   370.533] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 13)
[   370.533] (**) Option "xkb_layout" "it"
[   370.535] (II) event0  - (II) AT Translated Set 2 keyboard: (II) is tagged by udev as: Keyboard
[   370.535] (II) event0  - (II) AT Translated Set 2 keyboard: (II) device is a keyboard
[   370.536] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/event14)
[   370.536] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "libinput touchpad catchall"
[   370.536] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "touchpad"
[   370.536] (II) LoadModule: "synaptics"
[   370.536] (WW) Warning, couldn't open module synaptics
[   370.536] (II) UnloadModule: "synaptics"
[   370.536] (II) Unloading synaptics
[   370.536] (EE) Failed to load module "synaptics" (module does not exist, 0)
[   370.536] (EE) No input driver matching `synaptics'
[   370.536] (II) Falling back to input driver `libinput'
[   370.536] (II) Using input driver 'libinput' for 'AlpsPS/2 ALPS GlidePoint'
[   370.536] (**) AlpsPS/2 ALPS GlidePoint: always reports core events
[   370.536] (**) Option "Device" "/dev/input/event14"
[   370.536] (**) Option "_source" "server/udev"
[   370.537] (II) event14 - (II) AlpsPS/2 ALPS GlidePoint: (II) is tagged by udev as: Touchpad
[   370.537] (II) event14 - (II) AlpsPS/2 ALPS GlidePoint: (II) no resolution or size hints, assuming a size of 69x50mm
[   370.537] (II) event14 - (II) AlpsPS/2 ALPS GlidePoint: (II) device is a touchpad
[   370.537] (II) event14 - (II) AlpsPS/2 ALPS GlidePoint: (II) device removed
[   370.583] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input12/event14"
[   370.583] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS GlidePoint" (type: TOUCHPAD, id 14)
[   370.584] (**) Option "AccelerationScheme" "none"
[   370.584] (**) AlpsPS/2 ALPS GlidePoint: (accel) selected scheme none/0
[   370.584] (**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration factor: 2.000
[   370.584] (**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration threshold: 4
[   370.585] (II) event14 - (II) AlpsPS/2 ALPS GlidePoint: (II) is tagged by udev as: Touchpad
[   370.585] (II) event14 - (II) AlpsPS/2 ALPS GlidePoint: (II) no resolution or size hints, assuming a size of 69x50mm
[   370.585] (II) event14 - (II) AlpsPS/2 ALPS GlidePoint: (II) device is a touchpad
[   370.585] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse2)
[   370.585] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "touchpad"
[   370.585] (II) LoadModule: "synaptics"
[   370.586] (WW) Warning, couldn't open module synaptics
[   370.586] (II) UnloadModule: "synaptics"
[   370.586] (II) Unloading synaptics
[   370.586] (EE) Failed to load module "synaptics" (module does not exist, 0)
[   370.586] (EE) No input driver matching `synaptics'
[   370.586] (II) Falling back to input driver `libinput'
[   370.586] (II) Using input driver 'libinput' for 'AlpsPS/2 ALPS GlidePoint'
[   370.586] (**) AlpsPS/2 ALPS GlidePoint: always reports core events
[   370.586] (**) Option "Device" "/dev/input/mouse2"
[   370.586] (**) Option "_source" "server/udev"
[   370.633] (II) mouse2  - failed to create input device '/dev/input/mouse2'.
[   370.633] (EE) libinput: AlpsPS/2 ALPS GlidePoint: Failed to create a device for /dev/input/mouse2
[   370.633] (EE) PreInit returned 2 for "AlpsPS/2 ALPS GlidePoint"
[   370.633] (II) UnloadModule: "libinput"
[   370.634] (II) config/udev: Adding input device PC Speaker (/dev/input/event10)
[   370.634] (II) No input driver specified, ignoring this device.
[   370.634] (II) This device may have been added with another device file.
[   374.529] (--) NVIDIA(GPU-0): CRT-0: disconnected
[   374.529] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[   374.529] (--) NVIDIA(GPU-0): 
[   374.529] (--) NVIDIA(GPU-0): cPATH (DFP-0): connected
[   374.529] (--) NVIDIA(GPU-0): cPATH (DFP-0): Internal LVDS
[   374.529] (--) NVIDIA(GPU-0): cPATH (DFP-0): 330.0 MHz maximum pixel clock
[   374.529] (--) NVIDIA(GPU-0): 
[   374.529] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   374.529] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[   374.529] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[   374.529] (--) NVIDIA(GPU-0): 
[   375.163] (--) NVIDIA(GPU-0): CRT-0: disconnected
[   375.163] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[   375.163] (--) NVIDIA(GPU-0): 
[   375.163] (--) NVIDIA(GPU-0): cPATH (DFP-0): connected
[   375.163] (--) NVIDIA(GPU-0): cPATH (DFP-0): Internal LVDS
[   375.163] (--) NVIDIA(GPU-0): cPATH (DFP-0): 330.0 MHz maximum pixel clock
[   375.163] (--) NVIDIA(GPU-0): 
[   375.163] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   375.163] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[   375.163] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[   375.163] (--) NVIDIA(GPU-0): 
[   377.655] (II) event14 - (II) AlpsPS/2 ALPS GlidePoint: (II) device removed
[   395.549] (--) NVIDIA(GPU-0): CRT-0: disconnected
[   395.549] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[   395.549] (--) NVIDIA(GPU-0): 
[   395.549] (--) NVIDIA(GPU-0): cPATH (DFP-0): connected
[   395.549] (--) NVIDIA(GPU-0): cPATH (DFP-0): Internal LVDS
[   395.549] (--) NVIDIA(GPU-0): cPATH (DFP-0): 330.0 MHz maximum pixel clock
[   395.549] (--) NVIDIA(GPU-0): 
[   395.549] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   395.549] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[   395.549] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[   395.549] (--) NVIDIA(GPU-0): 
[   401.741] (--) NVIDIA(GPU-0): CRT-0: disconnected
[   401.741] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[   401.741] (--) NVIDIA(GPU-0): 
[   401.741] (--) NVIDIA(GPU-0): cPATH (DFP-0): connected
[   401.741] (--) NVIDIA(GPU-0): cPATH (DFP-0): Internal LVDS
[   401.741] (--) NVIDIA(GPU-0): cPATH (DFP-0): 330.0 MHz maximum pixel clock
[   401.741] (--) NVIDIA(GPU-0): 
[   401.741] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   401.741] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[   401.741] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[   401.741] (--) NVIDIA(GPU-0):

Avatar utente
TheSaint
Robin Hood
Messaggi: 7814
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Nvidia - Regolazione Luminosità

Messaggio da TheSaint » 30 dicembre 2017, 2:13

Per Nvidia è da molto che non posso usare i tasti funzione. C'era un periodo che con KDE4 funzionavano quelli della tastiera, ma non per il display. Comunque io riesco ad ovviare la luminosità con xbacklight
Siccome sono driver proprietari, l' unica è scrivere alla Nvidia. Qualcosa poi risolvono, come nel caso che non si poteva uscire su TTY quando avviavo Xorg.
F the saint
12 anni da questo forum ;)

Avatar utente
Odak
Novello Arciere
Messaggi: 101
Iscritto il: 20 febbraio 2008, 12:52
Architettura: x86_64 (64bit)
Località: Caserta

Re: Nvidia - Regolazione Luminosità

Messaggio da Odak » 30 dicembre 2017, 13:47

Ciao Saint, grazie della risposta.
xbacklight non funziona, potrebbe essere un problema di configurazione? Nemmeno dal pannello Risparmio Energetico riesco a cambiare la luminosità dello schermo. Nella vecchia installazione avevo configurato i driver con il framebuffer v86d (quindi non KMS) e nella lista moduli di mkinitcpio.conf caricavo solo nvidia, quindi senza nvidia_modeset, nvidia_uvm, nvidia_drm.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7814
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Nvidia - Regolazione Luminosità

Messaggio da TheSaint » 30 dicembre 2017, 16:34

Purtroppo, non posso andare oltre. Pensavo ci potesse essere una correlazione con il mio sistema.
Comunque non c'è interfaccia grafica che possa risolverti il problema, in genere si va a pescare in /sys/class. Quindi prova a vedere anche questo e altri messaggi sul forum a riguardo la luminosità.
Possiamo vedere

Codice: Seleziona tutto

$ ls /sys/class/backlight/*
e andare dentro a vedere se si può modificare i parametri del file brightness.

Codice: Seleziona tutto

$ lsmod |grep asus
Per capire quali moduli vanno a caricarsi per il controllo acpi. Ma il più importante sarebbe asus_nb_wmi
F the saint
12 anni da questo forum ;)

Zar Marco
Arciere Provetto
Messaggi: 618
Iscritto il: 29 dicembre 2015, 11:34
Architettura: x86_64 (64bit)

Re: Nvidia - Regolazione Luminosità

Messaggio da Zar Marco » 29 gennaio 2018, 21:44

Avevo un problema simile su un macbook, con i3wm come desktop. Avevo risolto installando brightnessctl
Lenovo Legion Y520 Intel i7 7700HQ 8Gb ram arch(x86_64)+plasma5+i3wm
Macbook pro intel core 2duo 8gb di ram arch(x86_64)+i3wm

Avatar utente
TheSaint
Robin Hood
Messaggi: 7814
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Nvidia - Regolazione Luminosità

Messaggio da TheSaint » 30 gennaio 2018, 6:48

Zar Marco ha scritto:
29 gennaio 2018, 21:44
Avevo risolto installando brightnessctl
Provato, ma non mi fuziona. Attualmente non funziona più anche per la tastiera. Solo xbacklight per lo schermo.
F the saint
12 anni da questo forum ;)

Rispondi