[Risolto] aur/avant-window-navigator-bzr

Problemi e discussioni inerenti ad Archlinux su architetture non ufficialmente supportate
Rispondi
enigma39139
Novello Arciere
Messaggi: 28
Iscritto il: 13 settembre 2007, 18:31

Messaggio da enigma39139 » 27 dicembre 2007, 14:00

Attualmente ho installato avant-window-navigator-bzr 108-1 su un Arch64,
ho provato ad aggiornare alla vers 154-1 ma il make mi fallisce sempre con "configure: exit 77", ho provato ad andare in /var/abs/local/yaourtbuild/avant-window-navigator-bzr/src/avant-window-navigator-build/ e lanciare un configure && make && make install e funziona, quindi non capisco dove possa essere il problema, allego gli output di yaourt e il config.log

Codice: Seleziona tutto

[root@Mokoto ~]# yaourt avant
1 community/agsync 0.2_pre-2
    AvantGo sync plugin
2 aur/avant-window-navigator 0.2.1-10
    Fully customisable dock-like window navigator for GNOME
3 aur/avant-window-navigator-bzr 130-1 [108-1 installed]
    Fully customisable dock-like window navigator for GNOME (AKA awn)
4 aur/awn-extras-bzr 282-1
    Extra Applets for Avant Window Navigator - Development Version
5 aur/gmpc-awn-git 20071025-1
    A plugin for gmpc interfaces with the avant window navigator
6 aur/sudoku-savant 1.1-8
    A simple GUI-driven application to solve and generate sudoku puzzles through logical means
==>  Enter n° (separated by blanks, or a range) of packages to be installed
     Example:   '1 6 7 8 9'   or   '1 6-9'
==>   ----------------------------------------------
==>3
==> WARNING: Building unsupported package as root is dangerous.
 Please run yaourt as a non-privileged user.
==> Resuming previous build

==> Downloading avant-window-navigator-bzr PKGBUILD from AUR...


Comment by: BlSabbatH on 20071226 [12:06:45]
triex is right!! fantastic!

Comment by: triex on 20071216 [10:55:09]
If you change the bzr url in http://bazaar.launchpad.net/~awn-curves-team/awn/awn-curves
you can build avant-window-navigator with the curves style:
http://www.abload.de/img/screensawi.png

Comment by: thesilent on 20071205 [12:11:28]
Grazie Molok!

Comment by: keerthi on 20071121 [04:25:04]
Build fails.
==> Entering fakeroot environment
==> Making package: avant-window-navigator-bzr 130-1 (Wed Nov 21 09:40:59 IST 2007)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==> Validating source files with md5sums
==> Extracting Sources...
==> Removing existing pkg/ directory...
==> Starting build()...
==> Connecting to the server....
bzr: ERROR: Connection error: while sending GET /%7Eawn-core/awn/trunk/.bzr/branch-format: (110, 'Connection timed out')
cp: cannot stat `./avant-window-navigator': No such file or directory
./PKGBUILD: line 35: cd: ./avant-window-navigator-build: No such file or directory

Comment by: RoobZ on 20071117 [11:18:26]
What I needed as dependencies:
autoconf, automake, libtool, libgtop and make.
After that, everything went just fine.
Thank you! It's a great dock.

Comment by: berbez on 20071116 [15:29:41]
I fixed the last error with:
pacman -S autoconf

Comment by: berbez on 20071116 [14:53:03]
Checking for required M4 macros...
Checking for forbidden M4 macros...
make: aurpage avant-window-navigator.install pkg PKGBUILD src No targets specified and no makefile found. Stop.
==> ERROR: Build Failed. Aborting...
Error: Makepkg was unable to build avant-window-navigator-bzr package.

Comment by: luk156 on 20071113 [14:49:20]
you have to install also autoconf

Comment by: dmn on 20071111 [02:43:52]
pacman -S automake
fixed this problem for me

Comment by: Don-DiZzLe on 20071026 [16:03:08]
I'm also getting that error message.

Comment by: killajoe on 20071017 [13:20:59]
Checking for required M4 macros...
libtool.m4 not found
glib-gettext.m4 not found
intltool.m4 not found
pkg.m4 not found
***Error***: some autoconf macros required to build avant-panel-menu
were not found in your aclocal path, or some forbidden
macros were found. Perhaps you need to adjust your
ACLOCAL_FLAGS?
make: aurpage avant-window-navigator.install pkg PKGBUILD src No targets specified and no makefile found. Stop.

Comment by: mOLOk on 20071016 [23:01:03]
update

Comment by: teo on 20071006 [11:22:43]
Please add gnome-python-desktop as dependency, if this is not installed the awn preferences panel doesn't load and throws
Traceback (most recent call last):
File "/usr/bin/awn-manager", line 40, in <module>
import gnomedesktop
ImportError: No module named gnomedesktop

Comment by: Matzyx on 20070914 [20:12:09]
ooooppppssssssssss
i did it!!!!!!!!
libgtop's dep is in extra package.
sorry

Comment by: Matzyx on 20070914 [20:02:41]
hi, i found libgtop as dep,
thanx for pkgbuild.

Comment by: mOLOk on 20070912 [23:11:05]
minor fix

Comment by: hdoria on 20070905 [01:11:50]
Im having problems trying to build this package. My problem can be found here:
http://bbs.archlinux.org/viewtopic.php?pid=278856
Any suggestions?

Comment by: mOLOk on 20070822 [00:50:05]
fixed problem with some applets

Comment by: mOLOk on 20070821 [01:36:26]
note for myself:
http://www.planetblur.org/hosted/awnforum/index.php?shard=forum&action=g_reply&ID=257&page=1&isLive=true

Comment by: mOLOk on 20070819 [15:54:01]
Thanks decaturguy, it is in the AUR now (awn-extras-bzr)

Comment by: mOLOk on 20070810 [00:05:20]
please use versionpkg instead of makepkg to build this package!

Comment by: mOLOk on 20070802 [01:44:16]
moved from svn to bzr
Version 1.4.1

  First Submitted: Thu, 02 Aug 2007 01:44:16 +0000
      Last Updated: Tue, 16 Oct 2007 23:01:03 +0000
avant-window-navigator-bzr 130-1 (SAFE): Fully customisable dock-like window navigator for GNOME (AKA awn)

==> avant-window-navigator-bzr dependencies:
 - libwnck (already installed)
 - gconf (already installed)
 - gnome-desktop (already installed)
 - gnome-python (already installed)
 - gnome-common (already installed)
 - gnome-python-desktop (already installed)
 - libxcomposite (already installed)
 - libxdamage (already installed)
 - intltool (already installed)
 - bzr (already installed)
==>  Edit the PKGBUILD ? [y/N] ("A" to abort)
==>   ----------------------------------------------
==>y


==> avant-window-navigator-bzr dependencies:
 - libwnck (already installed)
 - gconf (already installed)
 - gnome-desktop (already installed)
 - gnome-python (already installed)
 - gnome-common (already installed)
 - gnome-python-desktop (already installed)
 - libxcomposite (already installed)
 - libxdamage (already installed)
 - intltool (already installed)
 - bzr (already installed)
==>  Continue the building of 'avant-window-navigator-bzr'? [Y/n] 
==>   ----------------------------------------------
==>y



==> Building and installing package
cp: directory `./pkg' omessa
cp: directory `./src' omessa
==> Searching new CVS/SVN/GIT revision for avant-window-navigator-bzr
==> retrieving latest revision number from bzr... 154
==> newer revision detected: 154
==> modifying PKGBUILD to pkgver=154... 
==> Making package: avant-window-navigator-bzr 154-1 (gio dic 27 14:50:36 CET 2007)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==> Validating source files with md5sums
==> Extracting Sources...
==> Starting build()...
==> Connecting to the server....
==> Checkout done or server timeout                                            
==> Starting make...
/usr/bin/gnome-autogen.sh
checking for autoconf >= 2.53...
  testing autoconf2.50... not found.
  testing autoconf... found 2.61
checking for automake >= 1.9...
  testing automake-1.10... found 1.10
checking for libtool >= 1.4.3...
  testing libtoolize... found 1.5.24
checking for glib-gettext >= 2.2.0...
  testing glib-gettextize... found 2.14.4
checking for intltool >= 0.25...
  testing intltoolize... found 0.36.3
checking for pkg-config >= 0.14.0...
  testing pkg-config... found 0.22
Checking for required M4 macros...
Checking for forbidden M4 macros...
Processing ./configure.in
Running libtoolize...
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
Running glib-gettextize... Ignore non-fatal messages.
Copying file mkinstalldirs
Copying file po/Makefile.in.in

Please add the files
  codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
  progtest.m4
from the /aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can get from
ftp://ftp.gnu.org/pub/gnu/config/.

Running intltoolize...
Running aclocal-1.10...
Running autoconf...
Running autoheader...
Running automake-1.10...
configure.in:9: installing `./missing'
configure.in:9: installing `./install-sh'
awn-applet-activation/Makefile.am: installing `./depcomp'
pyawn/Makefile.am:10: installing `./py-compile'
Running ./configure --enable-maintainer-mode --prefix=/usr --sysconfdir=/etc ...
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... 
configure: error: C compiler cannot create executables
See `config.log' for more details.
make: *** No targets specified and no makefile found.  Stop.
==> ERROR: Build Failed.  Aborting...
Error: Makepkg was unable to build avant-window-navigator-bzr package.

[root@Mokoto ~]#

Codice: Seleziona tutto

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by avant-window-navigator configure 0.2.1, which was
generated by GNU Autoconf 2.61.  Invocation command line was

  $ ./configure --enable-maintainer-mode --prefix=/usr --sysconfdir=/etc

## --------- ##
## Platform. ##
## --------- ##

hostname = Mokoto
uname -m = x86_64
uname -r = 2.6.23-ARCH
uname -s = Linux
uname -v = #1 SMP PREEMPT Fri Dec 21 20:26:31 CET 2007

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = x86_64
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /bin
PATH: /usr/bin
PATH: /sbin
PATH: /usr/sbin
PATH: /usr/X11R6/bin
PATH: /opt/bin
PATH: /opt/java/jre/bin
PATH: /opt/kde/bin
PATH: /opt/mozilla/bin
PATH: /opt/qt/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2085: checking for a BSD-compatible install
configure:2141: result: /bin/install -c
configure:2152: checking whether build environment is sane
configure:2195: result: yes
configure:2223: checking for a thread-safe mkdir -p
configure:2262: result: /bin/mkdir -p
configure:2275: checking for gawk
configure:2291: found /bin/gawk
configure:2302: result: gawk
configure:2313: checking whether make sets $(MAKE)
configure:2334: result: yes
configure:2522: checking whether to enable maintainer-specific portions of Makefiles
configure:2531: result: yes
configure:2560: checking for style of include used by make
configure:2588: result: GNU
configure:2658: checking for gcc
configure:2674: found /usr/bin/gcc
configure:2685: result: gcc
configure:2923: checking for C compiler version
configure:2930: gcc --version >&5
gcc (GCC) 4.2.2
Copyright (C) 2007 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2933: $? = 0
configure:2940: gcc -v >&5
Using built-in specs.
Target: x86_64-unknown-linux-gnu
Configured with: ../configure --prefix=/usr --enable-shared --enable-languages=c,c++,objc --enable-threads=posix --enable-__cxa_atexit --disable-multilib --libdir=/usr/lib --libexecdir=/usr/lib --enable-clocale=gnu --disable-libstdcxx-pch --with-tune=generic
Thread model: posix
gcc version 4.2.2
configure:2943: $? = 0
configure:2950: gcc -V >&5
gcc: '-V' option must have argument
configure:2953: $? = 1
configure:2976: checking for C compiler default output file name
configure:3003: gcc -march=i686 -mtune=generic -O2 -pipe   conftest.c  >&5
conftest.c:1: error: CPU you selected does not support x86-64 instruction set
configure:3006: $? = 1
configure:3044: result: 
configure: failed program was:
| /* confdefs.h.  */
| #define PACKAGE_NAME "avant-window-navigator"
| #define PACKAGE_TARNAME "avant-window-navigator"
| #define PACKAGE_VERSION "0.2.1"
| #define PACKAGE_STRING "avant-window-navigator 0.2.1"
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "avant-window-navigator"
| #define VERSION "0.2.1"
| /* end confdefs.h.  */
| 
| int
| main ()
| {
| 
|   ;
|   return 0;
| }
configure:3051: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_AWN_CFLAGS_set=
ac_cv_env_AWN_CFLAGS_value=
ac_cv_env_AWN_LIBS_set=
ac_cv_env_AWN_LIBS_value=
ac_cv_env_CCC_set=
ac_cv_env_CCC_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-march=i686 -mtune=generic -O2 -pipe'
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=set
ac_cv_env_CXXFLAGS_value='-march=i686 -mtune=generic -O2 -pipe'
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_F77_set=
ac_cv_env_F77_value=
ac_cv_env_FFLAGS_set=
ac_cv_env_FFLAGS_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_PKG_CONFIG_set=
ac_cv_env_PKG_CONFIG_value=
ac_cv_env_PYCAIRO_CFLAGS_set=
ac_cv_env_PYCAIRO_CFLAGS_value=
ac_cv_env_PYCAIRO_LIBS_set=
ac_cv_env_PYCAIRO_LIBS_value=
ac_cv_env_PYGTK_CFLAGS_set=
ac_cv_env_PYGTK_CFLAGS_value=
ac_cv_env_PYGTK_LIBS_set=
ac_cv_env_PYGTK_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_path_install='/bin/install -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK=gawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /var/abs/local/yaourtbuild/avant-window-navigator-bzr/src/avant-window-navigator-build/missing --run aclocal-1.10'
ACLOCAL_AMFLAGS='${ACLOCAL_FLAGS}'
ALL_LINGUAS=''
AMDEPBACKSLASH=''
AMDEP_FALSE='#'
AMDEP_TRUE=''
AMTAR='${SHELL} /var/abs/local/yaourtbuild/avant-window-navigator-bzr/src/avant-window-navigator-build/missing --run tar'
AR=''
AUTOCONF='${SHELL} /var/abs/local/yaourtbuild/avant-window-navigator-bzr/src/avant-window-navigator-build/missing --run autoconf'
AUTOHEADER='${SHELL} /var/abs/local/yaourtbuild/avant-window-navigator-bzr/src/avant-window-navigator-build/missing --run autoheader'
AUTOMAKE='${SHELL} /var/abs/local/yaourtbuild/avant-window-navigator-bzr/src/avant-window-navigator-build/missing --run automake-1.10'
AWK='gawk'
AWN_CFLAGS=''
AWN_LIBS=''
CATALOGS=''
CATOBJEXT=''
CC='gcc'
CCDEPMODE=''
CFLAGS='-march=i686 -mtune=generic -O2 -pipe'
CPP=''
CPPFLAGS=''
CXX=''
CXXCPP=''
CXXDEPMODE=''
CXXFLAGS='-march=i686 -mtune=generic -O2 -pipe'
CYGPATH_W='echo'
DATADIRNAME=''
DBUS_GLIB_BIN=''
DEFS=''
DEPDIR='.deps'
ECHO='echo'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
F77=''
FFLAGS=''
GCONFTOOL=''
GCONF_SCHEMAS_INSTALL_FALSE=''
GCONF_SCHEMAS_INSTALL_TRUE=''
GCONF_SCHEMA_CONFIG_SOURCE=''
GCONF_SCHEMA_FILE_DIR=''
GETTEXT_PACKAGE=''
GLIB_CFLAGS=''
GLIB_GENMARSHAL=''
GLIB_LIBS=''
GLIB_MKENUMS=''
GMOFILES=''
GMSGFMT=''
GOBJECT_QUERY=''
GREP=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
INSTOBJEXT=''
INTLLIBS=''
INTLTOOL_CAVES_RULE=''
INTLTOOL_DESKTOP_RULE=''
INTLTOOL_DIRECTORY_RULE=''
INTLTOOL_EXTRACT=''
INTLTOOL_KBD_RULE=''
INTLTOOL_KEYS_RULE=''
INTLTOOL_MERGE=''
INTLTOOL_OAF_RULE=''
INTLTOOL_PERL=''
INTLTOOL_POLICY_RULE=''
INTLTOOL_PONG_RULE=''
INTLTOOL_PROP_RULE=''
INTLTOOL_SCHEMAS_RULE=''
INTLTOOL_SERVER_RULE=''
INTLTOOL_SERVICE_RULE=''
INTLTOOL_SHEET_RULE=''
INTLTOOL_SOUNDLIST_RULE=''
INTLTOOL_THEME_RULE=''
INTLTOOL_UI_RULE=''
INTLTOOL_UPDATE=''
INTLTOOL_XAM_RULE=''
INTLTOOL_XML_NOMERGE_RULE=''
INTLTOOL_XML_RULE=''
LDFLAGS=''
LIBOBJS=''
LIBS=''
LIBTOOL=''
LN_S=''
LTLIBOBJS=''
MAINT=''
MAINTAINER_MODE_FALSE='#'
MAINTAINER_MODE_TRUE=''
MAKEINFO='${SHELL} /var/abs/local/yaourtbuild/avant-window-navigator-bzr/src/avant-window-navigator-build/missing --run makeinfo'
MKINSTALLDIRS=''
MSGFMT=''
MSGFMT_OPTS=''
MSGMERGE=''
OBJEXT=''
PACKAGE='avant-window-navigator'
PACKAGE_BUGREPORT=''
PACKAGE_NAME='avant-window-navigator'
PACKAGE_STRING='avant-window-navigator 0.2.1'
PACKAGE_TARNAME='avant-window-navigator'
PACKAGE_VERSION='0.2.1'
PATH_SEPARATOR=':'
PKG_CONFIG=''
PLATFORM=''
POFILES=''
POSUB=''
PO_IN_DATADIR_FALSE=''
PO_IN_DATADIR_TRUE=''
PYCAIRO_CFLAGS=''
PYCAIRO_LIBS=''
PYGTK_CFLAGS=''
PYGTK_CODEGEN=''
PYGTK_DEFSDIR=''
PYGTK_LIBS=''
PYTHON=''
PYTHON_EXEC_PREFIX=''
PYTHON_INCLUDES=''
PYTHON_PLATFORM=''
PYTHON_PREFIX=''
PYTHON_VERSION=''
RANLIB=''
SED=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
USE_NLS=''
VERSION='0.2.1'
XGETTEXT=''
ac_ct_CC='gcc'
ac_ct_CXX=''
ac_ct_F77=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__fastdepCXX_FALSE=''
am__fastdepCXX_TRUE=''
am__include='include'
am__isrc=''
am__leading_dot='.'
am__quote=''
am__tar='${AMTAR} chof - "$$tardir"'
am__untar='${AMTAR} xf -'
bindir='${exec_prefix}/bin'
build=''
build_alias=''
build_cpu=''
build_os=''
build_vendor=''
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host=''
host_alias=''
host_cpu=''
host_os=''
host_vendor=''
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='$(SHELL) /var/abs/local/yaourtbuild/avant-window-navigator-bzr/src/avant-window-navigator-build/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='${datarootdir}/man'
mkdir_p='/bin/mkdir -p'
oldincludedir='/usr/include'
pdfdir='${docdir}'
pkgpyexecdir=''
pkgpythondir=''
prefix='/usr'
program_transform_name='s,x,x,'
psdir='${docdir}'
pyexecdir=''
pythondir=''
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
slicelocaledir=''
sysconfdir='/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME "avant-window-navigator"
#define PACKAGE_TARNAME "avant-window-navigator"
#define PACKAGE_VERSION "0.2.1"
#define PACKAGE_STRING "avant-window-navigator 0.2.1"
#define PACKAGE_BUGREPORT ""
#define PACKAGE "avant-window-navigator"
#define VERSION "0.2.1"

configure: exit 77
qualcuno ha qualche idea?
tnx[



un consiglio, mai modificare makepkg.conf senza controllare quello che si è scritto -.-'
Ultima modifica di enigma39139 il 29 dicembre 2007, 20:45, modificato 1 volta in totale.
Linux Registered User #453411

Rispondi