Raspberry PI 3

Problemi e discussioni inerenti ad Archlinux su architetture non ufficialmente supportate
Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Raspberry PI 3

Messaggio da Stelfex » 25 aprile 2016, 18:40

no... sembra che lo script non parta.... oppure lo lancia troppo presto, oppur bisogna fare il login?

BOHH

Avatar utente
4javier
Moderatore
Messaggi: 9367
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Raspberry PI 3

Messaggio da 4javier » 25 aprile 2016, 18:58

Prova a modificarlo così

Codice: Seleziona tutto

[Unit]
Description=Connect to wireless disabling powersave
After=network.target

[Service]
Type=oneshot
ExecStart=/percorso/a/partenza.sh

[Install]
WantedBy=multi-user.target
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Raspberry PI 3

Messaggio da Stelfex » 25 aprile 2016, 20:11

ninte provato..... quando provo a dirle di fare partire in automatico alla partenza non cè verso...

Quando mi loggo e lo do a mano, funziona benissimo...

Cihedo troppo se ti và di raggiungerlo in ssh?

Ti do l'indirizzo ip? OK?

Avatar utente
4javier
Moderatore
Messaggi: 9367
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Raspberry PI 3

Messaggio da 4javier » 25 aprile 2016, 21:25

Ok, ma metti una password temporanea, o passamela in messaggio privato.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Raspberry PI 3

Messaggio da Stelfex » 26 aprile 2016, 11:48

Il rasp e pronto per la connessione in PM i dettagli, grazie

Avatar utente
4javier
Moderatore
Messaggi: 9367
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Raspberry PI 3

Messaggio da 4javier » 26 aprile 2016, 15:41

Dovrebbe essere tutto a posto. La "magia" dovrebbero averla fatta questi tre file

Codice: Seleziona tutto

[root@alarmpi ~]# cat /etc/systemd/system/disable_wlan0_powersave.service 
[Unit]
Description=Disable power_save for wlan0 interface
After=systemd-networkd.service

[Service]
Type=oneshot
ExecStart=/usr/bin/iw dev wlan0 set power_save off

[Install]
WantedBy=multi-user.target

Codice: Seleziona tutto

[root@alarmpi ~]# cat /etc/systemd/system/multi-user.target.wants/wpa_supplicant\@wlan0.service   
[Unit]
Description=WPA supplicant daemon (interface-specific version)
Requires=sys-subsystem-net-devices-%i.device
After=sys-subsystem-net-devices-%i.device
Before=network.target
Wants=network.target

# NetworkManager users will probably want the dbus version instead.

[Service]
Type=simple
ExecStart=/usr/bin/wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant-%I.conf -i%I

[Install]
Alias=multi-user.target.wants/wpa_supplicant@%i.service

Codice: Seleziona tutto

[root@alarmpi ~]# cat /etc/systemd/network/wireless.network 
[Match]
Name=wlan0

[Network]
DHCP=ipv4
Fai qualche verifica, e nel caso avessi bisogno di spiegazioni, chiedi pure.
Modifica la tua chiave wpa, perchè l'ho visualizzata.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Raspberry PI 3

Messaggio da Stelfex » 26 aprile 2016, 15:48

hai mandato i comandi in 3 demoni separati?
giusto?

Avatar utente
4javier
Moderatore
Messaggi: 9367
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Raspberry PI 3

Messaggio da 4javier » 26 aprile 2016, 16:03

Partiamo dal terzo: é un file .network, cioé un file di configurazione del service systemd-networkd.

Il secondo è un service parametrico fornito da wpa-supplicant.

Il primo è un service scritto da me che disabilita il pwer_save aspettando che networkd abbia acceso l'interfaccia.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Raspberry PI 3

Messaggio da Stelfex » 26 aprile 2016, 18:25

ok questi file riesco a generarli facilmente, ma se ho cpito bene li hai abilitati alla partenza...
se si.... con quale comando? No così se dovessi ripartire da zero riesco a destreggiarmi...
grazie la wi-fi parte all'avvio e non si scollega mai

Avatar utente
4javier
Moderatore
Messaggi: 9367
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Raspberry PI 3

Messaggio da 4javier » 26 aprile 2016, 18:39

Networkd in realtà era già abilitato, ed una volta creato quel file .network nella giusta directory, lo legge da solo.
Il service di wpa_supplicant esiste già ed è parametrico, quindi lo abiliti specificandone l'interfaccia.

Codice: Seleziona tutto

systemctl enable wpa_supplicant@wlan0
Devi anche creare il file di configurazione di WPA col giusto nome nella giusta directory.
Il service creato a mano lo abiliti con

Codice: Seleziona tutto

systemctl enable nome_del_service
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Raspberry PI 3

Messaggio da Stelfex » 27 aprile 2016, 20:47

puoi spiegarmi i passi che hai fatto per sistemare tutto?
Grazie e scusa la testardaggine :DD

Avatar utente
4javier
Moderatore
Messaggi: 9367
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Raspberry PI 3

Messaggio da 4javier » 27 aprile 2016, 21:41

???
È nell'ultimo messaggio cosa ho fatto, scusa?
Quale passaggio non ti è chiaro?
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Stelfex
Novello Arciere
Messaggi: 64
Iscritto il: 1 aprile 2016, 22:49

Re: Raspberry PI 3

Messaggio da Stelfex » 28 aprile 2016, 10:21

e qui dentro cosa hai messo?

Codice: Seleziona tutto

wpa_supplicant@wlan0

questo..??

Codice: Seleziona tutto

network={
        ssid="XXXXXXNET"
        #psk="xxxxxxna"
        psk=3cb63290d15a1eZZZZZZZZZZZZZZZZZZZZZZZZc25c21ba28e48579074ba2f
}

Giusto? Poi hai mandato questo?

Codice: Seleziona tutto

systemctl enable wpa_supplicant@wlan0
Poi per il DHCP? Che demone hai creato?

Ma poi quel era il problema? Hai impostato il tutto alla partenza OK,
io ho fatto lo stesso, perche il miei script non funzionavano?

Avatar utente
4javier
Moderatore
Messaggi: 9367
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Raspberry PI 3

Messaggio da 4javier » 28 aprile 2016, 13:12

Partiamo dal basso:
il tuo script non funzionava perchè non si prendeva carico di aspettare che i dispositivi ed i sottosistemi su cui andava a lavorare, fossero già avviati completamente al momento della sua esecuzione. Usando l'approccio che prevede l'utilizzo delle unità di systemd, questo problema non si pone, perchè sarà systemd stesso a prendersi carico di tutte quelle faccende.

Passiamo ai file:

1) wpa_supplicant@wlan0 non esiste. Come ti spiegavo, esiste (lo installa il pacchetto wpa_supplicant, non lo devi creare tu.)il service parametrico wpa_supplicant@.service, che accetta in input un nome di interfaccia. Non lo devi creare tu, devi semplicemente specificare l'interfaccia che ti interessa, al momento dell'abilitazione del service. Quindi per abilitare quel service passandogli wlan0 come parametro userai

Codice: Seleziona tutto

systemctl enable wpa_supplicant@wlan0
Questo service si aspetta anche che nella directory /etc/wpa_supplicant/ esista un file di nome wpa_supplicant-nome_dell_interfaccia.conf, che abbia al suo interno i classici parametri di configurazione di wpa_supplicant.

2) Il DHCP è specificato nell'unità di configurazione di networkd /etc/systemd/network/wireless.network. Anche questa te l'ho mostrata prima.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Rispondi