Gnome 3

Aiutaci a localizzare la nostra Arch Wiki
Rispondi
TheREAL1

Messaggio da TheREAL1 » 13 maggio 2011, 11:06

Salve,
ho riscontrato dei problemi nel montaggio delle periferiche usb con gnome 3. Il problema può essere legato al login manager (utilizzo slim), ma credo che persista anche per chi utilizzi gdm. La cosa è stata risolta modificando .xinitrc in questo modo:

Codice: Seleziona tutto

exec ck-launch-session dbus-launch gnome-session
Mi sono iscritto al wiki da poco e mi chiedevo se si poteva aggiungere sulla guida all'installazione, visto che può essere utile a molti. :D

PS: ho trovato questa modifica nel forum in inglese di arch...
Ultima modifica di TheREAL1 il 13 maggio 2011, 11:07, modificato 1 volta in totale.

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Messaggio da 4javier » 13 maggio 2011, 13:18

non uso gdm da parecchio, ma che mi risulti ignora totalmente .xinitrc.
Quel metodo che hai usato in realtà è piuttosto comune a chi non usa i due maggiori de perchè essenziale per lanciare qualsiasi sessione che non sia kdm o gnome tramite i loro display manager. Credo che piuttosto andrebbe aggiunto il lancio di dbus alla riga di avvio nella pagina di slim,dove è menzionato solo consolekit. Parlo della versione inglese, quella italiana la metterò nel prossimo bando del gruppo traduzioni.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

TheREAL1

Messaggio da TheREAL1 » 13 maggio 2011, 15:56

Benissimo!!! Visto che ci sono volevo segnalare anche un altro problema che riguarda lo screensaver durante la visualizzazione di un video a tutto schermo. Di norma dovrebbe essere disabilitato dal programma in esecuzione, infatti con Gnome Mplayer va tutto bene, mentre con vlc lo schermo va in "blocco" (nel senso che si oscura) dopo pochi minuti. Un piccolo fix che ho trovato su altri forum è il seguente:

Codice: Seleziona tutto

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

Codice: Seleziona tutto

xset -dpms
Si deve però effettuare questa operazione ad ogni login, aggiungendo quindi xset -dpms in gnome-session-properties. Per riattivare la configurazione basta sostituire false con true e -dpms con +dpms. Purtroppo è solo un metodo per aggirare al momento la cosa, visto che si disattiva il risparmio energetico automatico e lo screensaver, spero che più avanti si risolva anche questo :D.

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Messaggio da 4javier » 13 maggio 2011, 19:28

questo se non sbaglio è un bug che vlc si porta dietro da un paio d'anni.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

TheREAL1

Messaggio da TheREAL1 » 13 maggio 2011, 21:47

OK, non lo sapevo :D . Grazie mille per le risposte!!!

Rispondi