Problema mail con EMESENE

Problemi e suggerimenti legati al software e ai pacchetti problematici.
Rispondi
CaptainHook8
Novello Arciere
Messaggi: 131
Iscritto il: 22 ottobre 2008, 11:30

Messaggio da CaptainHook8 » 30 giugno 2009, 13:27

Ciao a tutti!
Ho un problema con Emesene...il client di messaggistica funziona senza problemi, ma quando clicco sulla busta in alto a destra per aprire la mia posta di hotmail, mi riporta sulla pagina di login di Hotmail dicendomi che la mia password è sbagliata. Poi inserisco la mia password manualmente e mi riconduce alla mia mailbox regolarmente, quindi il problema non sta su Hotmail, ma probabilmente in qlk file di configureazione di Emesene che conserva la mia password.

Potete aiutarmi?

Grazie.
Ultima modifica di CaptainHook8 il 30 giugno 2009, 13:29, modificato 1 volta in totale.
«Perchè i geeks amano i computer? "Unzip, strip, touch, finger, grep, mount, fsck, more, yes, fsck, fsck, fsck, unmount, sleep."»

psychoweb
Novello Arciere
Messaggi: 108
Iscritto il: 15 luglio 2008, 8:58

Messaggio da psychoweb » 30 giugno 2009, 20:45

Ciao!
che versione di eMeSeNe usi? la password è memorizzata per l'accesso o ogni volta devi inserirla?
Giusto per avere un confronto: io uso il pacchetto emesene-svn, faccio memorizzare la password del mio account e la mail funziona senza problemi.
Se hai bisogno i file di configurazione si trovano in ".config/emesene1.0/".
:)

CaptainHook8
Novello Arciere
Messaggi: 131
Iscritto il: 22 ottobre 2008, 11:30

Messaggio da CaptainHook8 » 1 luglio 2009, 10:35

Grzie mille per la risposta!!
Io uso la versione Emesene 1.0.1-1 scaricata da pacman. Ho memorizzato sia username sia password, infatti all'avvio di emesene basta che clicco "Connetti" e si connette senza problemi!
Magari potrei passare alla versione svn? Sai come fare per aggiornare alla versione svn?
«Perchè i geeks amano i computer? "Unzip, strip, touch, finger, grep, mount, fsck, more, yes, fsck, fsck, fsck, unmount, sleep."»

Biagio
Arciere Provetto
Messaggi: 730
Iscritto il: 26 febbraio 2008, 17:21
Località: Firenze

Messaggio da Biagio » 1 luglio 2009, 11:09

$ sudo pacman -Rsn emesene
$ yaourt -S emesene-svn
(oppure http://aur.archlinux.org/packages.php?ID=7930)

Kaos
Novello Arciere
Messaggi: 99
Iscritto il: 5 ottobre 2008, 14:34
Architettura: x86_64 (64bit)
Località: /dev/null

Messaggio da Kaos » 1 luglio 2009, 12:06

Se devi usare emesene-svn, credo sia meglio emesene-crazy a questo punto :)
Immagine
Immagine

CaptainHook8
Novello Arciere
Messaggi: 131
Iscritto il: 22 ottobre 2008, 11:30

Messaggio da CaptainHook8 » 1 luglio 2009, 12:37

Kaos ha scritto:Se devi usare emesene-svn, credo sia meglio emesene-crazy a questo punto :)
Quali sono le differenze di emesene-crazy rispetto ad Emesene(ufficiale) e rispetto alla versione svn?

Grazie.

EDIT: Mi sembra di capire che hanno interrotto lo sviluppo di emesene-crazy... http://forum.emesene.org/index.php/topic,2052.0.html
Potreste dare un'occhiata al link?


A questo punto cosa mi consigliate?
Ultima modifica di CaptainHook8 il 1 luglio 2009, 12:55, modificato 1 volta in totale.
«Perchè i geeks amano i computer? "Unzip, strip, touch, finger, grep, mount, fsck, more, yes, fsck, fsck, fsck, unmount, sleep."»

Kaos
Novello Arciere
Messaggi: 99
Iscritto il: 5 ottobre 2008, 14:34
Architettura: x86_64 (64bit)
Località: /dev/null

Messaggio da Kaos » 1 luglio 2009, 13:06

CaptainHook8 ha scritto:Quali sono le differenze di emesene-crazy rispetto ad Emesene(ufficiale) e rispetto alla versione svn?

Grazie.
Allora, da quello che so io, hanno interrotto lo sviluppo di emesene per dedicarsi a emesene2 (scritto da zero). Quindi c'è un "fork" chiamato appunto emesene-crazy che lo continua a sviluppare con correzioni, patch e anche l'aggiunta di script/plugin degli utenti.

Dal tuo link sembra però che non ci sia più questa differenza :/.

Il pkgbuild emesene-svn sarebbe da aggiornare (mi sembra), modificando _svnmod="emesene" in _svnmod="emesene_1.5-beta" (e magari richiede altre cose, ci ho buttato solo un occhio).
Immagine
Immagine

CaptainHook8
Novello Arciere
Messaggi: 131
Iscritto il: 22 ottobre 2008, 11:30

Messaggio da CaptainHook8 » 1 luglio 2009, 13:12

Kaos ha scritto:
CaptainHook8 ha scritto:Quali sono le differenze di emesene-crazy rispetto ad Emesene(ufficiale) e rispetto alla versione svn?

Grazie.
Allora, da quello che so io, hanno interrotto lo sviluppo di emesene per dedicarsi a emesene2 (scritto da zero). Quindi c'è un "fork" chiamato appunto emesene-crazy che lo continua a sviluppare con correzioni, patch e anche l'aggiunta di script/plugin degli utenti.

Dal tuo link sembra però che non ci sia più questa differenza :/.

Il pkgbuild emesene-svn sarebbe da aggiornare (mi sembra), modificando _svnmod="emesene" in _svnmod="emesene_1.5-beta" (e magari richiede altre cose, ci ho buttato solo un occhio).
Infatti a quel link dice che emesene-crazy è stato trasferito nel trunk principale ed è diventato emesene 1.5.
La mia domanda ora è questa....installando emesene-svn ottengo la versione 1.5?
«Perchè i geeks amano i computer? "Unzip, strip, touch, finger, grep, mount, fsck, more, yes, fsck, fsck, fsck, unmount, sleep."»

Biagio
Arciere Provetto
Messaggi: 730
Iscritto il: 26 febbraio 2008, 17:21
Località: Firenze

Messaggio da Biagio » 1 luglio 2009, 13:26

ottieni emesene 1.5 beta

CaptainHook8
Novello Arciere
Messaggi: 131
Iscritto il: 22 ottobre 2008, 11:30

Messaggio da CaptainHook8 » 1 luglio 2009, 13:51

Biagio ha scritto:$ sudo pacman -Rsn emesene
$ yaourt -S emesene-svn
(oppure http://aur.archlinux.org/packages.php?ID=7930)
Sto provando ad installare emesene-svn da AUR, ma alla fine mi da questo errorre:

Codice: Seleziona tutto

errore: './emesene-svn-1701-1-i686.pkg.tar.gz': impossibile aprire il pacchetto
==> WARNING: Il pacchetto è stato salvato in /tmp/yaourt-tmp-root/emesene-svn-1701-1-i686.pkg.tar.gz
cp: impossibile fare stat di `./emesene-svn-1701-1-i686.pkg.tar.gz': No such file or directory
==> WARNING: Impossibile copiare emesene-svn-1-i686.pkg.tar.gz nella directory /tmp/yaourt-tmp-root
Che faccio?
«Perchè i geeks amano i computer? "Unzip, strip, touch, finger, grep, mount, fsck, more, yes, fsck, fsck, fsck, unmount, sleep."»

Biagio
Arciere Provetto
Messaggi: 730
Iscritto il: 26 febbraio 2008, 17:21
Località: Firenze

Messaggio da Biagio » 1 luglio 2009, 14:08

Sembra che yaourt abbia creato il pacchetto compilato ma che non lo abbia effettivamente installato credo a causa di permessi sbagliati su /var/abs/local.
Il messaggio dice che trovi il pacchetto compilato in /tmp/yaourt-tmp-root, quindi (se non hai riavviato e /tmp non è stata quindi ancora svuotata):

$ cd /tmp/yaourt-tmp-root
$ sudo pacman -U emesene-svn-1701-1-i686.pkg.tar.gz

CaptainHook8
Novello Arciere
Messaggi: 131
Iscritto il: 22 ottobre 2008, 11:30

Messaggio da CaptainHook8 » 1 luglio 2009, 14:21

Biagio ha scritto:Sembra che yaourt abbia creato il pacchetto compilato ma che non lo abbia effettivamente installato credo a causa di permessi sbagliati su /var/abs/local.
Il messaggio dice che trovi il pacchetto compilato in /tmp/yaourt-tmp-root, quindi (se non hai riavviato e /tmp non è stata quindi ancora svuotata):

$ cd /tmp/yaourt-tmp-root
$ sudo pacman -U emesene-svn-1701-1-i686.pkg.tar.gz
Il problema è che nel .PKGINFO del pacchetto è impostato:

Codice: Seleziona tutto

pkgver = 1702
Mentre nel PKGBUILD c'è:

Codice: Seleziona tutto

pkgver=1701
consigli?
«Perchè i geeks amano i computer? "Unzip, strip, touch, finger, grep, mount, fsck, more, yes, fsck, fsck, fsck, unmount, sleep."»

Biagio
Arciere Provetto
Messaggi: 730
Iscritto il: 26 febbraio 2008, 17:21
Località: Firenze

Messaggio da Biagio » 1 luglio 2009, 14:52

Anche se sul PKGBUILD c'è pkgver=1701, vedo che yaourt intercetta comunque la versione 1702, infatti (senza aver modificato il PKGBUILD):
yaourt -S emesene-svn ha scritto:==> Compilazione e installazione del pacchetto
==> Determinazione dell'ultima revisione svn in corso...
-> Versione trovata: 1702
==> Creazione del pacchetto: emesene-svn 1702-1 i686 (mer lug 1 14:39:59 CEST 2009)

CaptainHook8
Novello Arciere
Messaggi: 131
Iscritto il: 22 ottobre 2008, 11:30

Messaggio da CaptainHook8 » 1 luglio 2009, 15:04

Biagio ha scritto:Anche se sul PKGBUILD c'è pkgver=1701, vedo che yaourt intercetta comunque la versione 1702, infatti (senza aver modificato il PKGBUILD):
yaourt -S emesene-svn ha scritto:==> Compilazione e installazione del pacchetto
==> Determinazione dell'ultima revisione svn in corso...
-> Versione trovata: 1702
==> Creazione del pacchetto: emesene-svn 1702-1 i686 (mer lug 1 14:39:59 CEST 2009)
Si infatti.... però poi continuando con l'installazione cerca il pacchetto "emesene-svn-1701-1-i686.pkg.tar.gz" che ovviamente non c'è perchè c'è la versione 1702, cioè il pacchetto "emesene-svn-1702-1-i686.pkg.tar.gz".

Codice: Seleziona tutto

==>  Continuare installando emesene-svn? [S/n]
==>  [v]edi il contenuto del pacchetto [c]ontrolla il pacchetto con namcap
==>   ----------------------------------------------
==>


caricamento dei dati in corso...
errore: './emesene-svn-1701-1-i686.pkg.tar.gz': impossibile aprire il pacchetto
==> WARNING: Il pacchetto è stato salvato in /tmp/yaourt-tmp-root/emesene-svn-1701-1-i686.pkg.tar.gz
cp: impossibile fare stat di `./emesene-svn-1701-1-i686.pkg.tar.gz': No such file or directory
==> WARNING: Impossibile copiare emesene-svn-1-i686.pkg.tar.gz nella directory /tmp/yaourt-tmp-root
Se ti piace questo pacchetto, per favore installa aurvote
e vota per la sua inclusione/mantenimento in [community]

[captainhook8@archlinux:yaourtbuild]$
Ovviamente modificando il PKGBUILD l'installazione dovrebbe andare a buon fine (1702). Ma è corretto fare ciò?
Tu che revisione hai?
Puoi provare ad installarlo e vedere se ti dà lo stesso problema?

Grazie mille.
«Perchè i geeks amano i computer? "Unzip, strip, touch, finger, grep, mount, fsck, more, yes, fsck, fsck, fsck, unmount, sleep."»

Biagio
Arciere Provetto
Messaggi: 730
Iscritto il: 26 febbraio 2008, 17:21
Località: Firenze

Messaggio da Biagio » 1 luglio 2009, 15:58

Senza toccare il PKGBUILD, yaourt mi da questo output (un po' ripulito) e installa tranquillamente il pacchetto compilato, chiamato emesene-svn-1703-1-i686.pkg.tar.gz (ora è disponibile la versione 1703)

Codice: Seleziona tutto

k@salterium ~
> yaourt -S emesene-svn

...
...


==>  Modificare il PKGBUILD (altamente raccomandato per ragioni di sicurezza) ? [S/n]("A" per annullare)
==>   ----------------------------------------------
==>n


==> Dipendenze di emesene-svn
 - python (già  installato)
 - pygtk (già  installato)
 - subversion (già  installato)
==>  Continuare la compilazione di emesene-svn? [S/n]
==>   ----------------------------------------------
==>S


==> Compilazione e installazione del pacchetto
==> Determinazione dell'ultima revisione svn in corso...
  -> Versione trovata: 1703
==> Creazione del pacchetto: emesene-svn 1703-1 i686 (mer lug  1 15:37:31 CEST 2009)
==> Controllo delle dipendenze per l'esecuzione in corso...
==> Controllo delle dipendenze per la compilazione in corso...
==> Download dei sorgenti in corso...
  -> Trovato emesene.run nella directory di compilazione
==> Validazione dei file sorgenti con md5sums in corso...
    emesene.run ... Verificato
==> Estrazione dei sorgenti in corso...
==> Entrata nell'ambiente di fakeroot in corso...
==> Avvio di build() in corso...
==> Getting sources...

...
...


Estratta revisione 1703.

...
...


==> Compilazione terminata: emesene-svn 1703-1 i686 (mer lug  1 15:42:18 CEST 2009)

==>  Continuare installando emesene-svn? [S/n]
==>  [v]edi il contenuto del pacchetto [c]ontrolla il pacchetto con namcap
==>   ----------------------------------------------
==>S

caricamento dei dati in corso...
controllo delle dipendenze in corso...
(1/1) installazione in corso di emesene-svn         [##################################################################################################] 100%
Dipendenze opzionali di emesene-svn
    gnome-python-extras: for spell-check plugin
    gtkspell: for spell-check plugin
    cabextract: for Wink preview plugin
    gnash-common: for Wink preview plugin
    gstreamer0.10-python: for webcam support
Se ti piace questo pacchetto, per favore installa aurvote
e vota per la sua inclusione/mantenimento in [community]

CaptainHook8
Novello Arciere
Messaggi: 131
Iscritto il: 22 ottobre 2008, 11:30

Messaggio da CaptainHook8 » 1 luglio 2009, 16:10

Biagio ha scritto:Senza toccare il PKGBUILD, yaourt mi da questo output (un po' ripulito) e installa tranquillamente il pacchetto compilato, chiamato emesene-svn-1703-1-i686.pkg.tar.gz (ora è disponibile la versione 1703)

Codice: Seleziona tutto

[captainhook8@archlinux:local]$ yaourt -S emesene-svn

...
...


==>  Modificare il PKGBUILD (altamente raccomandato per ragioni di sicurezza) ? [S/n]("A" per annullare)
==>   ----------------------------------------------
==>n


==> Dipendenze di emesene-svn
 - python (già  installato)
 - pygtk (già  installato)
 - subversion (già  installato)
==>  Continuare la compilazione di emesene-svn? [S/n]
==>   ----------------------------------------------
==>S


==> Compilazione e installazione del pacchetto
==> Determinazione dell'ultima revisione svn in corso...
  -> Versione trovata: 1703
==> Creazione del pacchetto: emesene-svn 1703-1 i686 (mer lug  1 15:37:31 CEST 2009)
==> Controllo delle dipendenze per l'esecuzione in corso...
==> Controllo delle dipendenze per la compilazione in corso...
==> Download dei sorgenti in corso...
  -> Trovato emesene.run nella directory di compilazione
==> Validazione dei file sorgenti con md5sums in corso...
    emesene.run ... Verificato
==> Estrazione dei sorgenti in corso...
==> Entrata nell'ambiente di fakeroot in corso...
==> Avvio di build() in corso...
==> Getting sources...

...
...


Estratta revisione 1703.

...
...


==> Compilazione terminata: emesene-svn 1703-1 i686 (mer lug  1 15:42:18 CEST 2009)

==>  Continuare installando emesene-svn? [S/n]
==>  [v]edi il contenuto del pacchetto [c]ontrolla il pacchetto con namcap
==>   ----------------------------------------------
==>S

caricamento dei dati in corso...
controllo delle dipendenze in corso...
(1/1) installazione in corso di emesene-svn         [##################################################################################################] 100%
Dipendenze opzionali di emesene-svn
    gnome-python-extras: for spell-check plugin
    gtkspell: for spell-check plugin
    cabextract: for Wink preview plugin
    gnash-common: for Wink preview plugin
    gstreamer0.10-python: for webcam support
Se ti piace questo pacchetto, per favore installa aurvote
e vota per la sua inclusione/mantenimento in [community]
A me dà sempre lo stesso errore...a questo punto è un mio problema!!

Codice: Seleziona tutto

> yaourt -S emesene-svn

...
...


==>  Modificare il PKGBUILD (altamente raccomandato per ragioni di sicurezza) ? [S/n]("A" per annullare)
==>   ----------------------------------------------
==>n


==> Dipendenze di emesene-svn
 - python (già  installato)
 - pygtk (già  installato)
 - subversion (già  installato)
==>  Continuare la compilazione di emesene-svn? [S/n]
==>   ----------------------------------------------
==>S


==> Compilazione e installazione del pacchetto
==> Determinazione dell'ultima revisione svn in corso...
  -> Versione trovata: 1703
==> Creazione del pacchetto: emesene-svn 1703-1 i686 (mer lug  1 15:37:31 CEST 2009)
==> Controllo delle dipendenze per l'esecuzione in corso...
==> Controllo delle dipendenze per la compilazione in corso...
==> Download dei sorgenti in corso...
  -> Trovato emesene.run nella directory di compilazione
==> Validazione dei file sorgenti con md5sums in corso...
    emesene.run ... Verificato
==> Estrazione dei sorgenti in corso...
==> Entrata nell'ambiente di fakeroot in corso...
==> Avvio di build() in corso...
==> Getting sources...

...
...


Estratta revisione 1703.

...
...


==> Compilazione terminata: emesene-svn 1703-1 i686 (mer lug  1 15:42:18 CEST 2009)

==>  Continuare installando emesene-svn? [S/n]
==>  [v]edi il contenuto del pacchetto [c]ontrolla il pacchetto con namcap
==>   ----------------------------------------------
==>S

caricamento dei dati in corso...
errore: './emesene-svn-1701-1-i686.pkg.tar.gz': impossibile aprire il pacchetto
==> WARNING: Il pacchetto è stato salvato in /tmp/yaourt-tmp-root/emesene-svn-1701-1-i686.pkg.tar.gz
cp: impossibile fare stat di `./emesene-svn-1701-1-i686.pkg.tar.gz': No such file or directory
==> WARNING: Impossibile copiare emesene-svn-1-i686.pkg.tar.gz nella directory /tmp/yaourt-tmp-root
Se ti piace questo pacchetto, per favore installa aurvote
e vota per la sua inclusione/mantenimento in [community]
A provato anche a reinstallare yaourt ma mi dà sempre lo stesso problema, hai qualche consiglio su come fixare questo che mi sembra un problema di yaourt? Tu oltre yaourt hai installato qualche altro software come dipendenza opzionale?
Comunque il PKGBUILD che scarica da qui http://aur.archlinux.org/packages.php?ID=7930 ha la reviosone 1701.


Grazie
Ultima modifica di CaptainHook8 il 1 luglio 2009, 16:41, modificato 1 volta in totale.
«Perchè i geeks amano i computer? "Unzip, strip, touch, finger, grep, mount, fsck, more, yes, fsck, fsck, fsck, unmount, sleep."»

hutch
Novello Arciere
Messaggi: 142
Iscritto il: 6 dicembre 2007, 22:59

Messaggio da hutch » 1 luglio 2009, 16:47

ad occhi otu lanci yaourt come root

hai provato a farlo con il tuo utente normale ?

CaptainHook8
Novello Arciere
Messaggi: 131
Iscritto il: 22 ottobre 2008, 11:30

Messaggio da CaptainHook8 » 1 luglio 2009, 17:11

hutch ha scritto:ad occhi otu lanci yaourt come root

hai provato a farlo con il tuo utente normale ?
YESSSSS!!!!
Era proprio quello il problema!!!! Dando yaourt come utente normale, si usa la tmp e il pacchetto prende solo in nome emesene-svn.tar.gz .
Grazie mille, ma mi potresti spiegare perchè come utente privilegiato non funziona?
«Perchè i geeks amano i computer? "Unzip, strip, touch, finger, grep, mount, fsck, more, yes, fsck, fsck, fsck, unmount, sleep."»

Biagio
Arciere Provetto
Messaggi: 730
Iscritto il: 26 febbraio 2008, 17:21
Località: Firenze

Messaggio da Biagio » 1 luglio 2009, 17:43

CaptainHook8 ha scritto:
hutch ha scritto:ad occhi otu lanci yaourt come root

hai provato a farlo con il tuo utente normale ?
YESSSSS!!!!
Era proprio quello il problema!!!! Dando yaourt come utente normale, si usa la tmp e il pacchetto prende solo in nome emesene-svn.tar.gz .
Questo però non è il pacchetto finale compilato ma il sorgente scaricato.
( viewtopic.php?pid=40131#p40131 )

CaptainHook8 ha scritto:Grazie mille, ma mi potresti spiegare perchè come utente privilegiato non funziona?
Per questioni di sicurezza. Un PKGBUILD alla fine è uno script che potrebbe contenere anche istruzioni pericolose, specialmente se dato da root.

marlock
Newbie
Messaggi: 4
Iscritto il: 19 luglio 2009, 15:46

Messaggio da marlock » 19 luglio 2009, 16:49

ciao a tutti....sto usando emesene-svn installato da AUR e non mi funziona il bottone per aprire la posta di hotmail....
avviando emesene da terminale noto che quando premo il bottone mi restituisce questo:

Codice: Seleziona tutto

[marlock@ArchBox ~]$ emesene
If you are reading this, you may want to enable debug
It's the first option in the connection tab in preferences
Thread-1 start
File /home/marlock/.config/emesene1.0/marlock87_hotmail_com/custom_emoticons/map does not exist, skipping
/usr/share/emesene/UserList.py:463: GtkWarning: gtk_tree_model_row_has_child_toggled: assertion `path != NULL' failed
  return self.model.append(iterator, values)
Errore nel mostrare l'URL: Esecuzione del processo figlio "wine" non riuscita (No such file or directory)
qualcuno mi può dire se è un problema solo mio oppure capita anche a voi?
mi sembra strano che emesene richieda wine...

EDIT:

ho risolto, il problema non era legato ad emesene ma al programma di default per aprire i file .htm (che va ad aprire emesene per entrare su hotmail)....
non so perchè ma li apriva con winebrowser.

mi scuso per l'inutile post :P
Ultima modifica di marlock il 19 luglio 2009, 20:50, modificato 1 volta in totale.
DON'T PANIC

Rispondi