Pagina 1 di 1

[Risolto] Aggiornamento Samba letale per Mplayer

Inviato: 29 marzo 2020, 20:33
da kens
Ave.

L'aggiornamento lanciato ieri comprendeva Samba:

Codice: Seleziona tutto

[2020-03-28T21:57:21+0100] [ALPM] upgraded samba (4.10.10-2 -> 4.11.3-3)
da quel momento Mplayer non vuol più saperne di andare; non trova una libreria che c'era nella vecchia versione di Samba ed ora non c'è più, almeno così pare:

Codice: Seleziona tutto

mplayer: error while loading shared libraries: libroken-samba4.so.19: cannot open shared object file: No such file or directory
In rete non mi pare ci sia -ancora?- nulla; qualcuno ha lo stesso problema?

Grazie... :)

n.

Re: Aggiornamento Samba letale per Mplayer

Inviato: 30 marzo 2020, 1:07
da TheSaint
Direi che il caso sia che hai i file da prendere con le condivisioni samba.
Ma se apri il file con un browser, facile che ti succede la stessa cosa. Forse il file system delle condivisioni è da cambiare.
Dovrebbe arrivare la versione 4.12 forse ci sono cambiamenti. Verifica se hai qualche *.pacnew in /etc..

Re: Aggiornamento Samba letale per Mplayer

Inviato: 30 marzo 2020, 11:46
da kens
In verità no, sai?
Stavo cercando di accedere a banali clip video depositate nella mia home.
Non vorrei sbagliare ma Mplayer considera smbclient una dipendenza "a prescindere".
Aspetterò l'aggiornamento che giudico probabile anch'io.
Grazie 1000! :)

n.

Re: Aggiornamento Samba letale per Mplayer

Inviato: 1 aprile 2020, 15:01
da kens
Però ho notato che, sotto /usr/lib, oltre la directory "samba", è comparsa una directory "samba.save".
uhm...

Re: Aggiornamento Samba letale per Mplayer

Inviato: 3 aprile 2020, 4:32
da TheSaint
Ho fatto una prova con un mp4 nella mia home, ma niente che mi risulti difettoso. (anche con samba attivato).
Ci possono essere delle strane correlazioni che forse non è proprio mplayer la causa principale.
Prova mplayer e attiva il debug con -msglevel 7. Tanto da cercare di trovare cosa succede.

Re: Aggiornamento Samba letale per Mplayer

Inviato: 5 aprile 2020, 10:49
da kens
Ho risolto, grazie comunque dell'aiuto :)
Durante l'ultimo aggiornamento di Samba c'era stato un problema col pacchetto libwbclient.
Ora va.