[Risolto] Problemi installazione monodevelop

Problemi e suggerimenti legati al software e ai pacchetti problematici.
Rispondi
fermat
Little John
Messaggi: 1046
Iscritto il: 9 maggio 2009, 18:28
Contatta:

[Risolto] Problemi installazione monodevelop

Messaggio da fermat » 16 ottobre 2018, 15:07

ciao!

vorrei installare monodevelop, ma ottengo sempre questo errore:

Codice: Seleziona tutto

$ aurman -S monodevelop-stable
~~ initializing aurman...
~~ the following packages are neither in known repos nor in the aur
:: pcmciautils-018-8
~~ calculating solutions...

:: The following 14 package(s) are getting installed:
   extra/cmake                   /  ->  3.12.3-1
   aur-archlinux/fsharp          /  ->  1:4.5.0-3
   extra/gtk-sharp-2             /  ->  2.12.45-1
   extra/jsoncpp                 /  ->  1.8.4-2
   extra/libgdiplus              /  ->  5.6-1
   extra/mono                    /  ->  5.14.0.177-1
   extra/mono-addins             /  ->  1.3.3-2
   aur/monodevelop-stable        /  ->  7.8.0.338-1
   aur-archlinux/msbuild-stable  /  ->  15.8_xamarinxplat.2018.07.31.22.43_0xamarin5_ubuntu1404b1-3
   extra/nuget                   /  ->  2.14-2
   extra/rhash                   /  ->  1.3.6-1
   extra/xbitmaps                /  ->  1.1.2-1
   extra/xorg-luit               /  ->  1.1.1-3
   extra/xterm                   /  ->  337-1

?? Do you want to continue? Y/n: 
~~ looking for new pkgbuilds and fetching them...
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...

Pacchetti (13) cmake-3.12.3-1  fsharp-1:4.5.0-3  gtk-sharp-2-2.12.45-1  jsoncpp-1.8.4-2  libgdiplus-5.6-1  mono-5.14.0.177-1  mono-addins-1.3.3-2
               msbuild-stable-15.8_xamarinxplat.2018.07.31.22.43_0xamarin5_ubuntu1404b1-3  nuget-2.14-2  rhash-1.3.6-1  xbitmaps-1.1.2-1  xorg-luit-1.1.1-3  xterm-337-1

Dimensione totale dei pacchetti da installare:  374,38 MiB

:: Vuoi procedere con l'installazione? [S/n] s
(13/13) verifica delle chiavi presenti nel portachiavi                                                         [##################################################################] 100%
(13/13) verifica dell'integrità dei pacchetti                                                                  [##################################################################] 100%
errore: msbuild-stable: signature from "builds.itmettke.de <builds@itmettke.de>" is unknown trust
:: Il file /var/cache/pacman/pkg/msbuild-stable-15.8_xamarinxplat.2018.07.31.22.43_0xamarin5_ubuntu1404b1-3-x86_64.pkg.tar.xz è corrotto (il pacchetto non è valido oppure è corrotto (firma PGP)).
come posso risolvere??

PS: ma anni fa era nei repo ufficiali o sbaglio??
Ultima modifica di fermat il 17 ottobre 2018, 10:00, modificato 1 volta in totale.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Problemi installazione monodevelop

Messaggio da TheSaint » 16 ottobre 2018, 17:59

Questo l' hai letto ?
Mi sa che dovresti disabilitare il controllo della firma.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: Problemi installazione monodevelop

Messaggio da 4javier » 16 ottobre 2018, 19:20

Non so perchè tu abbia aggiunto questo repo non ufficiale che fornisce pacchetti compilati da AUR: repo.itmettke.de
Se lo togli e compili in locale non dovresti avere problemi.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: Problemi installazione monodevelop

Messaggio da TheSaint » 16 ottobre 2018, 19:39

Io l' ho compilato. Solo che con pikaur non mi ha lasciato i pacchetti di pacman. Per installare si deve copiare il contenuto e non rimane la possibilità di rimuovere con pacman.
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

fermat
Little John
Messaggi: 1046
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Re: Problemi installazione monodevelop

Messaggio da fermat » 17 ottobre 2018, 9:49

ciao!
4javier ha scritto:
16 ottobre 2018, 19:20
Non so perchè tu abbia aggiunto questo repo non ufficiale che fornisce pacchetti compilati da AUR: repo.itmettke.de
Se lo togli e compili in locale non dovresti avere problemi.
quel repo l'ho messo per installare ed avere aurman sempre aggiornato.
disabilitandolo, sono riuscito ad installare monodevelop senza problemi (sempre tramite aurman).

ci ha messo parecchio, spero che prima o poi lo mettano nei repo ufficiali :mrgreen:

grazie per le dritte!

Avatar utente
4javier
Moderatore
Messaggi: 9541
Iscritto il: 5 ottobre 2008, 17:19
Architettura: x86_64 (64bit)

Re: [Risolto] Problemi installazione monodevelop

Messaggio da 4javier » 17 ottobre 2018, 13:23

Tieni a mente che Aurman non viene più sviluppato per il pubblico ma solo a scopo personale dell'autore, che comunque continua ad aggiornarlo secondo le sue necessità. Io penso che darò una chance a yay per sostituire yaourt.
Offertissima: Mi Vendo!!! Cercasi lavoro o corso di formazione finanziato in tutta italia da Roma in su, oppure in provincia di Catanzaro.
In particolare sono interessato ad opportunità su Roma.

fermat
Little John
Messaggi: 1046
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Re: [Risolto] Problemi installazione monodevelop

Messaggio da fermat » 17 ottobre 2018, 13:39

4javier ha scritto:
17 ottobre 2018, 13:23
Tieni a mente che Aurman non viene più sviluppato per il pubblico ma solo a scopo personale dell'autore, che comunque continua ad aggiornarlo secondo le sue necessità. Io penso che darò una chance a yay per sostituire yaourt.
ok grazie!
mi do uno sguardo anche io a yay.

Avatar utente
TheSaint
Robin Hood
Messaggi: 7930
Iscritto il: 8 settembre 2007, 7:43
Architettura: x86_64 (64bit)
Località: davanti al computer

Re: [Risolto] Problemi installazione monodevelop

Messaggio da TheSaint » 17 ottobre 2018, 14:01

Cavolo!, dopo 3 Gb di sorgenti, non l' hai neanche guardato ? :(
F the saint 13 anni da questo forum ;)
Gli uomini consumano il pianeta, almeno due di queste cose si possono ridurre.

fermat
Little John
Messaggi: 1046
Iscritto il: 9 maggio 2009, 18:28
Contatta:

Re: [Risolto] Problemi installazione monodevelop

Messaggio da fermat » 17 ottobre 2018, 14:58

TheSaint ha scritto:
17 ottobre 2018, 14:01
Cavolo!, dopo 3 Gb di sorgenti, non l' hai neanche guardato ? :(
intendi monodevelop??
si si ci ho già smanettato!!

Rispondi